Josh Triplett | 1 Sep 08:15 2010

Bug#595108: Please depend on system-config-printer-udev rather than recommending it

Package: system-config-printer
Version: 1.2.3-1
Severity: normal

I can somewhat understand not depending on cups-pk-helper, though it
seems harmless to do so for simplicity.  However, I don't see any reason
to not depend on system-config-printer-udev.  system-config-printer-udev
introduces minimal additional dependencies, and these days libudev0 does
not depend on udev, so it doesn't even require the use of udev.
Furthermore, the package itself has negligible size compared to
system-config-printer.  Recommending it rather than depending on it
seems error-prone and doesn't seem to gain anything, and it makes life
harder for people who install recommends selectively.

- Josh Triplett
Josh Triplett | 1 Sep 09:13 2010

Bug#595117: file-roller: Unpacking tools scattered in Depends, Recommends, and Suggests

Package: file-roller
Version: 2.30.2-1
Severity: normal

file-roller seems to have various unpacking tools scattered through
Depends, Recommends, and Suggests with no obvious pattern.

file-roller:

- Depends on tar (Essential anyway) and p7zip-full (a
  relatively uncommon format, unless file-roller uses its support for
  other archive formats),
- Recommends lzma (obsolete in favor of xz-utils) and rpm2cpio (by no
  means a more common thing to extract than most of the Suggests), and
- Suggests all other unpackers (including things like zip/unzip which
  seem common enough to include in Recommends or Depends if *anything*
  qualifies).

- Josh Triplett

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.35-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

(Continue reading)

Debian Bug Tracking System | 1 Sep 16:46 2010
Picon

Bug#545869: marked as done (the printer havn't been removed)

Your message dated Wed, 1 Sep 2010 16:40:02 +0200
with message-id <20100901144002.GB12469 <at> melusine.alphascorpii.net>
and subject line Package got removed
has caused the Debian Bug report #545869,
regarding the printer havn't been removed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner <at> bugs.debian.org
immediately.)

--

-- 
545869: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=545869
Debian Bug Tracking System
Contact owner <at> bugs.debian.org with problems
Picon
From: Dmitry Baryshev <ksquirrel.iv <at> gmail.com>
Subject: the printer havn't been removed
Date: 2009-09-09 17:21:28 GMT
(Continue reading)

Debian Bug Tracking System | 1 Sep 22:09 2010
Picon

Bug#574637: marked as done (python-cupsutils: Problem parsing PPD attributes : UnicodeDecodeError: 'utf8' codec can't decode)

Your message dated Wed, 1 Sep 2010 22:04:24 +0200
with message-id <20100901200424.GA18661 <at> bogon.sigxcpu.org>
and subject line Fixed in 1.2.3-1
has caused the Debian Bug report #574637,
regarding python-cupsutils: Problem parsing PPD attributes : UnicodeDecodeError: 'utf8' codec can't decode
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner <at> bugs.debian.org
immediately.)

--

-- 
574637: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=574637
Debian Bug Tracking System
Contact owner <at> bugs.debian.org with problems
Picon
From: Olivier Berger <olivier.berger <at> it-sudparis.eu>
Subject: python-cupsutils: Problem parsing PPD attributes : UnicodeDecodeError: 'utf8' codec can't decode
Date: 2010-03-19 15:41:08 GMT
(Continue reading)

Anders Boström | 2 Sep 00:06 2010
Picon

Bug#595199: gdm: face browser removed me

Package: gdm
Version: 2.20.11-1
Severity: normal

A few days ago, I was removed from the face-browser in gdm. No
re-configuration of gdm had been performed and no new version of dgm
was installed. However, I run Debian testing and regulary update to
current testing.

The user-configuration in gdm is set to /etc/passwd . But I also tried
to change to not use /etc/passwd, and added myself to the include
list. The result is the same, I'm excluded from the face-browser, and
I don't get any error-message from gdm. I can however remove and add
other users.

Also, I can login by writing my login-name in gdm.

/ Andere

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing'), (50, 'unstable'), (40, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32.15 (SMP w/2 CPU cores)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to sv_SE.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gdm depends on:
(Continue reading)

Mayer K?roly | 2 Sep 15:03 2010
Picon

Bug#595250: Freeze at startup, I must use 'killall gnome-panel' every time, then it works great

Package: gnome-panel
Version: 2.30.2-1
Severity: important
Tags: squeeze

At every startup, the gnome-panel, and sometimes the nautilus freeze out. I do
the following then:

1. Alt+F2(The Run Application dialog appears, but the widgets are invisible, so
I type the 'killall gnome-panel' text blind)
2. Then the gnome-panel restarts, appears and run properly. Then I kill the
nautilus.
3. Then the nautilus is ok.
4. Then I must stop the dbus, and the start again, because the udisks-daemon
eats up my CPU.
5. After I did this steps, I can work on my PC, for hours, days, weeks...
without any trouble.

In the logs I can't found anything about the gnome panel error. When I install
a new Squeeze on another machine, the problem comes again. I tried to make a
new, clean user account, but it freeze out again. I have this problem for 2-3
months.. :/

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.33.2 (SMP w/1 CPU core)
(Continue reading)

Gonéri Le Bouder | 2 Sep 16:49 2010

Bug#594898: gnome-system-tools: In kfreebsd Network Administration Tool says the platform is not supported.

On Mon, Aug 30, 2010 at 03:09:53PM +0100, Michael Dorrington wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 
> 
> Package: gnome-system-tools
> Version: 2.30.2-1
> Severity: normal
> User: debian-bsd <at> lists.debian.org
> Usertags: kfreebsd
> X-Debbugs-CC: debian-bsd <at> lists.debian.org
> 
> 
> In kfreebsd, launching the Gnome Network Administration Tool by going to
> System->Administration->Network pops up a message saying:
> 
>  Unsupported platform

Hi,

I reasigned the bug to system-tools-backends.
I attached the patch.

Best regards,

     Gonéri
Attachment (kfreebsd.diff): text/x-diff, 1218 bytes
_______________________________________________
(Continue reading)

Mathieu Malaterre | 2 Sep 18:20 2010
Picon

Bug#595271: gedit crash when saving empty file

Package: gedit
Version: 2.22.3-1+lenny1
Severity: important

hi

gedit crashes when user click save with default empty file.

steps to reproduce:
$ gedit
click save

this should lead to:
#0  0x00007ffff7de4dcc in open_path (name=<value optimized out>, namelen=<value optimized out>,
preloaded=<value optimized out>, sps=<value optimized out>, 
    realname=<value optimized out>, fbp=<value optimized out>, loader=0x7ffff7ff49b8, whatcode=2,
found_other_class=0x7fffffffc37f) at dl-load.c:1946
#1  0x00007ffff7de66fb in _dl_map_object (loader=0x7ffff7ffce20, name=0x9d3570
"libtracker-client-0.7.so.0", preloaded=<value optimized out>, type=<value optimized out>, 
    trace_mode=<value optimized out>, mode=-1879048191, nsid=0) at dl-load.c:2082
#2  0x00007ffff7df0bbf in dl_open_worker (a=<value optimized out>) at dl-open.c:254
#3  0x00007ffff7dec5b6 in _dl_catch_error (objname=<value optimized out>, errstring=<value
optimized out>, mallocedp=<value optimized out>, operate=<value optimized out>, 
    args=<value optimized out>) at dl-error.c:178
#4  0x00007ffff7df05da in _dl_open (file=0x9d3570 "libtracker-client-0.7.so.0", mode=-2147483647,
caller_dlopen=0x7ffff50fab79, nsid=-2, argc=1, argv=0x0, 
    env=0x7fffffffe7b8) at dl-open.c:583
#5  0x00007ffff4132f66 in dlopen_doit (a=<value optimized out>) at dlopen.c:67
#6  0x00007ffff7dec5b6 in _dl_catch_error (objname=<value optimized out>, errstring=<value
optimized out>, mallocedp=<value optimized out>, operate=<value optimized out>, 
(Continue reading)

Debian Bug Tracking System | 2 Sep 20:57 2010
Picon

Bug#580139: marked as done ((inkscape:25344): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed)

Your message dated Thu, 2 Sep 2010 19:54:11 +0100
with message-id <AANLkTinovE7FLTiLTOO1L=Qz6EEeB=fonTh4=M9wniau <at> mail.gmail.com>
and subject line Fixed upstream in gtk+2.0 version 2.20.1
has caused the Debian Bug report #580139,
regarding (inkscape:25344): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC
(misc)' failed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner <at> bugs.debian.org
immediately.)

--

-- 
580139: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580139
Debian Bug Tracking System
Contact owner <at> bugs.debian.org with problems
Picon
From: Daniel Kahn Gillmor <dkg <at> fifthhorseman.net>
Subject: (inkscape:25344): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed
Date: 2010-05-03 20:35:26 GMT
(Continue reading)

Picon

brasero: New upstream version available

Hello,

The Debian External Health Status system (a.k.a. DEHS) has found a new
 upstream version of the package brasero in the unstable distribution.
The current package version is 2.30.2-1 and latest by upstream is 2.30.3.

If you are the maintainer or a co-maintainer of the package
 please consider updating the package.

The source code of version 2.30.3 by upstream can be found at:
http://ftp.gnome.org/pub/GNOME/sources/brasero/2.30/brasero-2.30.3.tar.gz

For more information please refer to the DEHS report of brasero at:
http://dehs.alioth.debian.org/report.php?package=brasero

If you believe this message can be improved in any way don't hesitate
 to contact me by replying to this message.
Note that the latest version by upstream is found thanks to the debian/watch
 file provided by the package, in case this message is a false positive please
 review the watch file before reporting.

Sincerely,
Raphael Geissert

Gmane