Paolo Ornati | 1 Jan 13:55 2007
Picon

Bug#319837: Not really a BUG...

This is not really a BUG of GRUB... it's just that BIOS tables are
getting bigger!

Memtest86(+) uses the "standard" linux kernel image format, so it it can
be loaded easily by boot loaders such as Lilo and Grub...

The format is:
	512 byte of boot sector
	512 * X bytes of setup (where X is usually 4)
	Y bytes of kernel image

A zImage kernel will be loaded at address 0x10000 (64k) while a bzImage
will be loaded at 0x10000 (1MB).

Memtest uses the old format.

The boot loader also loads a copy of boot sector and setup sectors at
0x90000 (and then execute the setup code):

        |                        |
0A0000  +------------------------+
        |  Reserved for BIOS     |      Do not use.  Reserved for BIOS EBDA.
09A000  +------------------------+
        |  Stack/heap/cmdline    |      For use by the kernel real-mode code.
098000  +------------------------+
        |  Kernel setup          |      The kernel real-mode code.
090200  +------------------------+
        |  Kernel boot sector    |      The kernel legacy boot sector.
090000  +------------------------+
        |  Protected-mode kernel |      The bulk of the kernel image.
(Continue reading)

Paolo Ornati | 1 Jan 14:35 2007
Picon

Bug#319837: Workaround

As a workaround for the memory-testers that cannot wait, just boot it
from a floppy:

1) insert a Floppy
2) cat /boot/memtest86/memtest.bin > /dev/fd0
3) boot from floppy

This will bypass GRUB and overwrite a bit of these "reserved" memory
regions... I don't think this is a problem (it isn't on my machine).

Another source that tells that some of these regions can be overwritten
without problems is the memtest86 README:
	zless /usr/share/doc/memtest86-3.2/README.gz

Probably these tables (etc) are only used by an OS... but since we only
run memtest there's no problem at all.

--

-- 
	Paolo Ornati
	Linux 2.6.20-rc2 on x86_64

Martin-Éric Racine | 1 Jan 01:26 2007
Picon
Picon

Bug#405152: myspell-lv: patch to generate aspell-lv

Package: myspell-lv
Version: 0.6.5.1-1
Severity: wishlist
Tags: patch

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Sveiki!

I made a preliminary patch to generate the Aspell wordlist from the MySpell one:

dget http://q-funk.iki.fi/debian/pool/m/myspell-lv/myspell-lv_0.6.5.1-1.1.dsc

There is one error (similar in nature to the one that previously plagued the 
Russian wordlists that I maintain) that appears at installation time. However, 
because I'm not (yet) too familiar with Latvian, I'm not sure how to fix the 
word that triggers the bug.

Anyhow, if the above looks like something that you would consider a good starting 
point to generate proper Aspell wordlists for Latvian, feel free to use it.

- -- System Information:
Debian Release: 4.0
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/dash
Kernel: Linux 2.6.18-imac
Locale: LANG=fi_FI.UTF-8, LC_CTYPE=fi_FI.UTF-8 (charmap=UTF-8)

Versions of packages myspell-lv depends on:
(Continue reading)

Brian White | 1 Jan 01:39 2007
Picon

Bug#364167: missing sound drivers (were in 2.6.8 but gone in 2.6.17 and above)

> this is an obsolote sound module and oss is superseded by alsa.
> there is an equivalent sound driver for your sound card available.
> make sure you have the alsa userland installed aka alsa-utils
> and run alsaconf it will load the apprioriate sound driver.

Okay, I got it.  It was found and loaded by "discover" but there was a 
USB webcam that somehow took first position so everything tried to play 
through that.

                                           Brian
                                   ( bcwhite <at> pobox.com )

-------------------------------------------------------------------------------
         If it weren't for the last minute, nothing would ever get done.

Kevin Locke | 1 Jan 02:02 2007
Picon

Bug#405154: libsdl-gfx1.2-4: unchecked surface allocation results in segfault

Package: libsdl-gfx1.2-4
Version: 2.0.13-2+b1
Severity: normal
Tags: patch

In SDL_rotozoom.c there are several calls to SDL_CreateRGBSurface()
where the return value is passed unchecked to subsequent functions
where it is dereferenced (such as zoomSurfaceRGBA()) which results in
segfaults.  The attached patch bails out and returns NULL if
allocation fails (since SDL_Error is already set by CreateSurface()
upon failure).

There may be more elegant ways to handle this (is there a way to
recover from failed allocations?) but at least this will allow the
user to call SDL_GetError() on failure.

Hope you find it useful,
Kevin

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/dash
Kernel: Linux 2.6.18.20061209a
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages libsdl-gfx1.2-4 depends on:
ii  libc6                        2.3.6.ds1-8 GNU C Library: Shared libraries
(Continue reading)

Vermont | 1 Jan 01:58 2007

Bug#405153: amarok: Amarok orphaning mp3s; likely libgpod incompatibility

Package: amarok
Version: 1.4.4-2
Severity: important

I am experiencing the problem reported here
http://bugs.kde.org/show_bug.cgi?id=138733

I haven't yet tried building with the exact version of libgpod0 on my 
system to see if that fixes it; the kde build dependencies are large.

If the solution for this bug is what Martin Aumueller recommends, then 
I suppose the fix could be to require the exact version of libgpod0 
that amarok was built with or perhaps link to it statically.

-- System Information:
Debian Release: 2.2
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.19.1
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages amarok depends on:
ii  amarok-engines         1.4.4-2           output engines for the Amarok audi
ii  amarok-xine [amarok-en 1.4.4-2           xine engine for the Amarok audio p
ii  kdelibs4c2a            4:3.5.5a.dfsg.1-5 core libraries and binaries for al
ii  libart-2.0-2           2.3.17-1          Library of functions for 2D graphi
ii  libaudio2              1.7-9             The Network Audio System (NAS). (s
ii  libc6                  2.3.6-9           GNU C Library: Shared libraries
(Continue reading)

Modestas Vainius | 1 Jan 01:47 2007

Bug#405114: konqueror: special characters not displayed

tags 405114 unreproducible
thanks

Hi,

2006 m. gruodis 31 d., sekmadienis 14:49, Marcus Better rašė:
> konqueror fails to display glyphs from the International Phonetic
> Alphabet (IPA) in web pages (in Unicode), for example on Wikipedia:
>   http://en.wikipedia.org/wiki/International_Phonetic_Alphabet
>
> In the above page, most phonetic characters display as empty
> boxes. The same page displays correctly in Iceweasel, so I am sure
> that I have the necessary fonts.
Not the case here. Konqueror displays[1] the same set of characters as 
Iceweasel[2].

1. http://alioth.debian.org/~modax-guest/konqueror-phonetic.png
2. http://alioth.debian.org/~modax-guest/iceweasel-phonetic.png

Please upgrade to libqt3-mt 3.3.7-2 (from unstable) and test again.
Harald Geyer | 1 Jan 02:52 2007
Picon
Picon

Bug#405155: abiword-gnome: crashes on spell checking

Package: abiword-gnome
Version: 2.4.6-1
Severity: important

Whenever abiword tries to check a word (i.e. I select spell checking from the
menu or I have auto spell checking enabled an type a word of at least
two characters) it crashes with the following message:

abiword: common/convert.cpp:391:
acommon::PosibErr<acommon::NormTable<T>*>
acommon::create_norm_table(acommon::IStream&, acommon::String&) [with T
= acommon::ToUniNormEntry]: Zusicherung »cur - d == size« nicht erfüllt.

This happens with a newly created account.

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/dash
Kernel: Linux 2.6.8-1-386
Locale: LANG=de_AT <at> euro, LC_CTYPE=de_AT <at> euro (charmap=ISO-8859-15)

Versions of packages abiword-gnome depends on:
ii  abiword-common            2.4.6-1        WYSIWYG word processor based on GT
ii  libart-2.0-2              2.3.17-1       Library of functions for 2D graphi
ii  libatk1.0-0               1.12.3-1       The ATK accessibility toolkit
ii  libbonobo2-0              2.14.0-3       Bonobo CORBA interfaces library
ii  libbonoboui2-0            2.8.1-2        The Bonobo UI library
(Continue reading)

Hendrik Sattler | 1 Jan 03:09 2007
Picon

Bug#384379: [Pkg-bluetooth-maintainers] Bug#384379: WORK-AROUND for "iscan not set"

Happy New Year 2007.

Am Sonntag 31 Dezember 2006 16:22 schrieb Marcel Holtmann:
> > * plugging the dongle in and then chaning to "connectable" may be too
> > late Practically the same thing as the default from above.
>
> This is why we go back to non-discoverable after 180 seconds by default.
>
> Supporting these kind of strange setting would also mean that you know
> the address of the adapter you are gonna plug in up-front. In general
> you don't. Except you really know what you are doing and then no
> interface will fully suit you at all.

Well, it is a special case, I agree. But since you already plugged it in once, 
you can already know the address (ls /var/lib/bluetooth).

> > > > So is there an easy command line tool for all those dbus options
> > > > (except using raw dbus command)?: no == very bad usibility (and an
> > > > awful lot to type for one option)
> > > >
> > > > So how can you solve this problem with your input:
> > > > * ship the dbus API documenation in the binary packages
> > >
> > > Definitely.
> > >
> > > > * give the user and root a shell tool to make use of the things in
> > > > the bluez dbus API without getting bloody hands by using dbus-send
> > >
> > > Since we wanna avoid a Python dependency,
> >
(Continue reading)

Steve Langasek | 1 Jan 03:31 2007
Picon

Bug#401668: depends on initrd-tools, which will go away

tags 401668 etch-ignore
thanks

This bug is no longer RC for etch, initrd-tools will be reintroduced in
response to upgrade concerns.

It will be dropped after etch anyway, so the bug still needs to be fixed for
lenny.

Cheers,
--

-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon <at> debian.org                                   http://www.debian.org/


Gmane