Picon

Pyatspi

Greetings,

When I try to install python-pyatspi typing apt-get install 
python-pyatspi, I get the following message:

INFO: using old version '/usr/bin/python2.3'
Compiling /usr/lib/python2.3/site-packages/pyatspi/constants.py ...
   File "/usr/lib/python2.3/site-packages/pyatspi/constants.py", line 195
     values = ((name, value) for name, value in acc_dict.items()
                               ^
SyntaxError: invalid syntax

pycentral: pycentral pkginstall: error byte-compiling files (6)
pycentral pkginstall: error byte-compiling files (6)
dpkg: error processing python-pyatspi (--configure):
  subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
  python-pyatspi
E: Sub-process /usr/bin/dpkg returned an error code (1)

What could be the problem?

Bertil

Milan Zamazal | 12 Nov 10:31 2007

Re: Pyatspi

>>>>> "JaBSN" == Jan and Bertil Smark Nilsson <jbsn <at> tpg.com.au> writes:

    JaBSN> Compiling /usr/lib/python2.3/site-packages/pyatspi/constants.py ...
    JaBSN>   File "/usr/lib/python2.3/site-packages/pyatspi/constants.py", line 195
    JaBSN>     values = ((name, value) for name, value in acc_dict.items()
    JaBSN>                               ^
    JaBSN> SyntaxError: invalid syntax

[...]

    JaBSN> What could be the problem?

It doesn't work with Python 2.3, Python 2.4 is needed.  If you use
Python 2.4 as the default Python interpreter, the cited message is
probably harmless.

Regards,

Milan Zamazal

Mario Lang | 14 Nov 16:54 2007
Picon

Re: Pyatspi

Jan and Bertil Smark Nilsson <jbsn <at> tpg.com.au> writes:

> When I try to install python-pyatspi typing apt-get install
> python-pyatspi, I get the following message:
>
> INFO: using old version '/usr/bin/python2.3'
> Compiling /usr/lib/python2.3/site-packages/pyatspi/constants.py ...
>   File "/usr/lib/python2.3/site-packages/pyatspi/constants.py", line 195
>     values = ((name, value) for name, value in acc_dict.items()
>                               ^
> SyntaxError: invalid syntax
>
> pycentral: pycentral pkginstall: error byte-compiling files (6)
> pycentral pkginstall: error byte-compiling files (6)
> dpkg: error processing python-pyatspi (--configure):
>  subprocess post-installation script returned error exit status 1
> Errors were encountered while processing:
>  python-pyatspi
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> What could be the problem?

If you do not use the old version of python (2.3) for anything,
try removing it with apt-get remove python2.3.

pyatspi does not work with python 2.3, only with 2.4 (and hopefully aboe).

--

-- 
CYa,
  Mario | Debian Developer <URL:http://debian.org/>
(Continue reading)

Mario Lang | 29 Nov 17:38 2007
Picon

Gnopernicus is obsolete, use gnome-orca

Hi.

This is just a reminder to anyone who might still have gnopernicus
installed on their Debian system.  gnome-orca does a much better
job these days and gnopernicus has been removed from Debian.

According to popcon[1] there are still approx. 1000 installations
of gnopernicus around.

[1] http://popcon.debian.org/by_inst.gz

--

-- 
CYa,
  Mario | Debian Developer <URL:http://debian.org/>
  .''`. | Get my public key via finger mlang <at> db.debian.org
 : :' : | 1024D/7FC1A0854909BCCDBE6C102DDFFC022A6B113E44
 `. `'
   `-      <URL:http://delysid.org/>  <URL:http://www.staff.tugraz.at/mlang/>


Gmane