Alexander Farber | 1 May 08:45 2011
Picon

Re: Switching to php53

Hello Dave, this really works -
I run Drupal 7 at my CentOS 5.6 machine with
the "native" php53 and postgresql84 packages.

Just remove the older php packages first.

Regards
Alex
Alexander Farber | 1 May 08:52 2011

please help to repair software RAID

Hello Mark and others,

On Thu, Apr 28, 2011 at 10:21 PM,  <m.roth@...> wrote:
> At this point, I'd run the long test on each drive, and (after coming back
> an hour or two later, see the results.

I have that dreadly warning again -

        /etc/cron.weekly/99-raid-check:
       WARNING: mismatch_cnt is not 0 on /dev/md0

By the "long tests" do you mean some Linux command
I could run while booted in "rescue mode"?

Or do you mean inserting Seagate/WD/whatever CD?

(Because Strato.de people refuse to do the latter -
I only pay EUR 29 + 59/month, locked until Dec.,
why would they do anything for me /sarcasm)

Regards
Alex

PS: below my disk info:

# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sdb1[1] sda1[0]
      1023936 blocks [2/2] [UU]

(Continue reading)

Dave Cross | 1 May 09:03 2011
Picon

Re: Switching to php53

On 30 April 2011 07:35, Eero Volotinen <eero.volotinen@...> wrote:
> 2011/4/30 Dave Cross <davorg@...>:
>> I have a Centos 5.6 server which is using the default php packages.
>> These currently contain PHP 5.1.6.
>>
>> My main use of PHP on the server is to support an installation of
>> WordPress. I currently had WP 3.1.2 installed, but the WP developers
>> have announced that from WP 3.2 they will only support PHP 5. and
>> greater.
>>
>> So I investigated and found that the Centos repo contains a series of
>> php53 packages. I tried to install php53 using yum but got the
>> following error:
>>
>>  Resolving Dependencies
>>  --> Running transaction check
>>  ---> Package php53.x86_64 0:5.3.3-1.el5_6.1 set to be updated
>>  --> Processing Dependency: php53-cli = 5.3.3-1.el5_6.1 for package: php53
>>  --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53
>>  --> Running transaction check
>>  ---> Package php53-cli.x86_64 0:5.3.3-1.el5_6.1 set to be updated
>>  ---> Package php53-common.x86_64 0:5.3.3-1.el5_6.1 set to be updated
>>  --> Processing Conflict: php53-common conflicts php-common
>>  --> Finished Dependency Resolution
>>  php53-common-5.3.3-1.el5_6.1.x86_64 from updates has depsolving problems
>>    --> php53-common conflicts with php-common
>>  Error: php53-common conflicts with php-common
>>   You could try using --skip-broken to work around the problem
>>   You could try running: package-cleanup --problems
>>                          package-cleanup --dupes
(Continue reading)

Lucian | 1 May 09:19 2011

Re: Switching to php53

On Sun, May 1, 2011 at 8:03 AM, Dave Cross <davorg@...> wrote:
> On 30 April 2011 07:35, Eero Volotinen <eero.volotinen@...> wrote:
>> 2011/4/30 Dave Cross <davorg@...>:
>>> I have a Centos 5.6 server which is using the default php packages.
>>> These currently contain PHP 5.1.6.
>>>
>>> My main use of PHP on the server is to support an installation of
>>> WordPress. I currently had WP 3.1.2 installed, but the WP developers
>>> have announced that from WP 3.2 they will only support PHP 5. and
>>> greater.
>>>
>>> So I investigated and found that the Centos repo contains a series of
>>> php53 packages. I tried to install php53 using yum but got the
>>> following error:
>>>
>>>  Resolving Dependencies
>>>  --> Running transaction check
>>>  ---> Package php53.x86_64 0:5.3.3-1.el5_6.1 set to be updated
>>>  --> Processing Dependency: php53-cli = 5.3.3-1.el5_6.1 for package: php53
>>>  --> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53
>>>  --> Running transaction check
>>>  ---> Package php53-cli.x86_64 0:5.3.3-1.el5_6.1 set to be updated
>>>  ---> Package php53-common.x86_64 0:5.3.3-1.el5_6.1 set to be updated
>>>  --> Processing Conflict: php53-common conflicts php-common
>>>  --> Finished Dependency Resolution
>>>  php53-common-5.3.3-1.el5_6.1.x86_64 from updates has depsolving problems
>>>    --> php53-common conflicts with php-common
>>>  Error: php53-common conflicts with php-common
>>>   You could try using --skip-broken to work around the problem
>>>   You could try running: package-cleanup --problems
(Continue reading)

Dotan Cohen | 1 May 09:21 2011
Picon

Re: I have RHel6. How does that turn into Centos 6?

On Sun, May 1, 2011 at 01:48, Les Mikesell <lesmikesell <at> gmail.com> wrote:
> On 4/30/11 4:31 PM, Kai Schaetzl wrote:
>> Les, I don't understand you, sorry. You talk about something that I didn't
>> ask for. You seem to make something of this thread that it isn't.
>
> You asked for something 'centos-y'.  And there really is nothing specific to
> centos other than it's differences from upstream., most of which aren't technical.
>

Might I suggest to investigate Scientific Linux as well?

SL is also RHEL-based, but I do believe that some other packages are
added. SL has had a 6.0 release, as well as 4.9. I don't know about
5.6, though.

--

-- 
Dotan Cohen

http://gibberish.co.il
http://what-is-what.com
_______________________________________________
CentOS mailing list
CentOS <at> centos.org
http://lists.centos.org/mailman/listinfo/centos
John R. Dennison | 1 May 09:50 2011

Re: Switching to php53

On Sun, May 01, 2011 at 08:19:49AM +0100, Lucian wrote:
> 
> It's not really that risky, just rpm -e --nodeps and then yum install
> php53 packages.

Do not follow this advice at all; it will most likely wreck your server.

Contact Plesk support or your hosting provider's support department and
ask them about upgrading php.  Plesk, like most control panels,
integrates quite tightly into your system; replacing the system default
php-5.1.6 with the php53 optional package may not be supported for your
environment.

							John
--

-- 
The truth is, when all is said and done, one does not teach a subject, one
teaches a student how to learn it.  Teaching may look like administering a
dose, but even a dose must be worked on by the body if it is to cure.  Each
individual must cure his or her own ignorance.

-- Jacques Barzun (30 November 1907-), French-born American scholar,
   historian, critic and teacher, "Reasons to De-Test the Schools,"
   New York Times, 11 October 1988
_______________________________________________
CentOS mailing list
CentOS@...
http://lists.centos.org/mailman/listinfo/centos
(Continue reading)

Dave Cross | 1 May 10:40 2011
Picon

Re: Switching to php53

On 1 May 2011 08:50, John R. Dennison <jrd@...> wrote:
> On Sun, May 01, 2011 at 08:19:49AM +0100, Lucian wrote:
>>
>> It's not really that risky, just rpm -e --nodeps and then yum install
>> php53 packages.
>
> Do not follow this advice at all; it will most likely wreck your server.
>
> Contact Plesk support or your hosting provider's support department and
> ask them about upgrading php.  Plesk, like most control panels,
> integrates quite tightly into your system; replacing the system default
> php-5.1.6 with the php53 optional package may not be supported for your
> environment.

This is exactly what worried me. Thanks for confirming my fears.

Dave...

--

-- 
Dave Cross :: dave@...
http://dave.org.uk/
 <at> davorg
John R. Dennison | 1 May 10:55 2011

Re: Switching to php53

On Sun, May 01, 2011 at 09:40:13AM +0100, Dave Cross wrote:
> 
> This is exactly what worried me. Thanks for confirming my fears.

Something else I should have pointed out earlier is that the php53
package from TUV does _not_ have a Provide: php in effect; meaning that
this is not a fully drop-in replacement for the default version and will
cause issues if you try to use it with packages that require "php" to be
provided for - squirrelmail is one such example of a package that CentOS
provides that will not work with php53 but there are many others.

There are some other issues present with php53 as well.  People needing
php53 support may very well be happier with the package as provided by
the IUS repository; it's more complete and more compatible than the one
that TUV is supplying.  More information on IUS is available at:

http://wiki.centos.org/AdditionalResources/Repositories

Please take a few moments and read the IUS web page that's linked off
the CentOS wiki article in its entirety to understand how IUS works.

							John
--

-- 
In view of the fact that God limited the intelligence of man, it seems
unfair that he did not also limit his stupidity.

-- Konrad Hermann Josef Adenauer (1876-1967), West German Chancellor from
   1949-1963, as quoted in Through Russian Eyes: President Kennedy's 1036
   Days (1973) by Anatoli-Andreevich Gromyko 
(Continue reading)

Markus Falb | 1 May 11:33 2011

please help to repair software RAID

On 1.5.2011 08:52, Alexander Farber wrote:
> Hello Mark and others,
> 
> On Thu, Apr 28, 2011 at 10:21 PM,  <m.roth@...> wrote:
>> At this point, I'd run the long test on each drive, and (after coming back
>> an hour or two later, see the results.
> 
> I have that dreadly warning again -
> 
>         /etc/cron.weekly/99-raid-check:
>        WARNING: mismatch_cnt is not 0 on /dev/md0

This does not mean necessarily mean that something is wrong.
Writes are not occuring at exactly the same time, there is a short
timespan where data is written to disk A but not yet to disk B. So it is
possible that 2 mirrored blocks hold different data.

http://marc.info/?l=linux-raid&m=117555829807542&w=2
http://marc.info/?l=linux-raid&m=117304688617916&w=2
https://bugzilla.redhat.com/show_bug.cgi?id=566828

> By the "long tests" do you mean some Linux command
> I could run while booted in "rescue mode"?

$ smartctl -t long /dev/sdX

No need for rescue mode.

--

-- 
Kind Regards, Markus Falb
(Continue reading)

Dave Cross | 1 May 12:47 2011
Picon

Re: Switching to php53

On 1 May 2011 09:40, Dave Cross <davorg@...> wrote:
> On 1 May 2011 08:50, John R. Dennison <jrd@...> wrote:
>> On Sun, May 01, 2011 at 08:19:49AM +0100, Lucian wrote:
>>>
>>> It's not really that risky, just rpm -e --nodeps and then yum install
>>> php53 packages.
>>
>> Do not follow this advice at all; it will most likely wreck your server.
>>
>> Contact Plesk support or your hosting provider's support department and
>> ask them about upgrading php.  Plesk, like most control panels,
>> integrates quite tightly into your system; replacing the system default
>> php-5.1.6 with the php53 optional package may not be supported for your
>> environment.
>
> This is exactly what worried me. Thanks for confirming my fears.

Some quick research reveals that it's likely to break Plesk horribly.

  http://forum.parallels.com/printthread.php?t=109479

I think I'll wait for Centos 6 (and for Plesk to certify it).

Thanks for all the help.

Dave...

--

-- 
Dave Cross :: dave@...
http://dave.org.uk/
(Continue reading)


Gmane