saravanan | 12 Oct 13:45 2005
Picon

CUPS to use Print server's filters for remote jobs

Dear all, 

 We got a HP 9050 printer with a right driver
installed in CUPS running on RHEL 3
 We have a requirement to add watermark for all the
printouts that go through the printserver.

 What happens is that, only local jobs that goes
directly from the Print server have the watermark. I
have shared this printer through SAMBA. Any job coming
from a Windows  client or other Linux clients do not
have Watermark, though the job goes through the print
server.

My requirements is here:

 How to enforce the print server to apply watermarks
for any job (remote/Local) ? 
 I'd like to do Filtering via the Linux Print Server. 
and Apply watermark over the jobs that come from
remote machine.

Please Advice.

Regards,
saravanan

Possibilities are Infinite !

	
(Continue reading)

linux | 28 Sep 21:50 2005

missing space on RAID-0 volume

Hello,

I've got a RAID-0 volume (yes, I know the implications re. data loss), and it 
seems to be smaller than it should be.

The physical disks are 2x80GB (actually, 2x74.5GB, for powers of 1024b, not
marketing-GB w. powers of 1000). There's ~7.5GB taken from /dev/sda to create /
(4GB) and swap (3.5GB). The md driver is supposed to be able to create RAID0
volumes that are pure concatenations--ie., volumes of different sizes simply
added together.

-------------------------------------
	Disk /dev/sda: 80.0 GB, 80000000000 bytes
	255 heads, 63 sectors/track, 9726 cylinders
	Units = cylinders of 16065 * 512 = 8225280 bytes

	Disk /dev/sdb: 80.0 GB, 80000000000 bytes
	255 heads, 63 sectors/track, 9726 cylinders
	Units = cylinders of 16065 * 512 = 8225280 bytes
-------------------------------------

The /dev/md0 volume is composed of two partitions:

   Device Boot    Start       End    Blocks   Id  System
/dev/sda3           914      9726  70790422+  fd  Linux raid autodetect
/dev/sdb1   *         1      9726  78124063+  fd  Linux raid autodetect

So, the total should be 148914485 blocks. Actually, tune2fs reports that the 
md0 device has 148914177 1KB blocks (an insignificant difference of 308 blocks).
The ext3fs filesystem is configured with 1% reserved, so there should be 
(Continue reading)

Picon

MPI build on 64bit rhel4

Can anyone help me with building the mpich-1.2.5.2 on a rhel4-64 system.
I can't see a config flag for 64 bit, but it doesn't create
/usr/lib64/mpi* libraries.

What i have done is:

configure --prefix=/usr/local
make
make install
make clean

I do get these errors at the end of the make process:

make[7]: *** [prog] Error 1
make[6]: *** [sloglib] Error 2
make[5]: *** [libslog.a] Error 2
make[4]: *** [default] Error 2
make[3]: *** [build_libs_progs] Error 2
make[2]: *** [mpelib] Error 1
make[1]: *** [mpi-addons] Error 2
make: *** [mpi] Error 2

Thank you,
Rick.
_______________________________________________
LinuxManagers mailing list - http://www.linuxmanagers.org
submissions: LinuxManagers@...
subscribe/unsubscribe: http://www.linuxmanagers.org/mailman/listinfo/linuxmanagers

(Continue reading)

Chris Lee | 6 Sep 10:24 2005
Picon

Process Monitor

Hi,

Is there any program tahn can monitor process (e.g. java / postmaster) CPU
and Memory Usages and plot graph like MRTG?

Many thanks in advance.

Regards,
Chris Lee

This message and its attachment (if any) are strictly confidential and sent
to the designated recipient(s) only. If you are not the intended recipient,
please notify the sender by e-mail and delete this message and its
attachment (if any) from your computer system immediately . Century City
International Holdings Limited, Paliburg Holdings Limited, Regal Hotels
International Holdings Limited, its respective related subsidiaries,
associated companies and affiliates do not guarantee this message and its
attachment (if any) are free of computer virus and would not accept any
liability whatsoever arising from Internet transmission. 
_______________________________________________
LinuxManagers mailing list - http://www.linuxmanagers.org
submissions: LinuxManagers@...
subscribe/unsubscribe: http://www.linuxmanagers.org/mailman/listinfo/linuxmanagers
Marcos Resendiz | 29 Aug 23:12 2005
Picon

RAID 1 conversion

Hi all,

I am converting an existing RHEL3 system to RAID1 I have setup
everything that I need to do but I ran into booting errors.  For some
reason I am getting:

mount error 6 mounting
error 2 mounting none
switching to new root
switch root mount failed 22

I have been doin some googling and it appears that it may be the
kernel.  The only problem is that I am not sure why that should be.
This is what I did

uname -a 2.6.9-5.EL
rpm -q kernel
mkinitrd -v --preload=raid1 /root/initrd--2.6.9-EL 2.6.9-EL

then I copied this file to the /boot/ directory
of course I renamed the original xxxx.orig

I edited the grub.conf to use hd1,0 and boot from that kernel
kernel /vmlinuz-2.6.9x-5.EL    ro root=/dev/md0 panic=10
initrd /initrd-2.6.9-5.EL

This all seems right to me, but I am obviously no expert.

Please help

(Continue reading)

Dave Filchak | 29 Aug 02:13 2005
Picon

Stats

Anyone out there still using FunnelWeb stats at all? If there is, I
would be interested in having a chat about how you use them. By that I
do not mean that I need someone to teach me how to use the package. I am
referring to how people are setting up the use of the extended database
feature. For one of my clients alone this database has well in excess of
a million entries and it is taking longer and longer to produce the
stats and the file size is getting larger and larger.

Just curious.

Dave
_______________________________________________
LinuxManagers mailing list - http://www.linuxmanagers.org
submissions: LinuxManagers@...
subscribe/unsubscribe: http://www.linuxmanagers.org/mailman/listinfo/linuxmanagers

Dave Filchak | 23 Aug 16:48 2005
Picon

DNS on CentOS box:

SUMMARY of DNS on CentOS box:

Well after much head scratching and yes .. cursing, and with the help of
a couple of people, namely Darrell and Jesse, I managed to figure out
what was happening on my CentOS box. Not having used this OS too much in
the past, and not being familiar with SELinux, I did not realize that
unless named was add to an ACL to include named, which appears not to be
added by default. So I was getting permission errors when I created new
directories and zone files because of this. Anyway, I basically turned
SELinux off for the moment while I research how to properly configure it
for my setup and it appears, for the most part ( but not all parts ) to
be functioning. Once I figure out the configuration, I will post an update.

Thanks all.

Dave
_______________________________________________
LinuxManagers mailing list - http://www.linuxmanagers.org
submissions: LinuxManagers@...
subscribe/unsubscribe: http://www.linuxmanagers.org/mailman/listinfo/linuxmanagers

Lucio Chiappetti | 22 Aug 14:37 2005
Picon

mounting ISO9660 non-Rock Ridge CD on Suse 9.2

I have to mount a CD containing satellite data (ISO9660 without Rock Ridge 
extension, see ref. [1]) onto the DVD drive of a new HP Compaq dc7100 
running Linux Suse 9.2.

I used the CD in the past on other systems (Alphas with OSF, and Suns with 
Solaris) with no particular problems, however now I'm incurring in a 
case-sensitivity problem.

The problem is as follows :

  - if I mount the CD by default (inserting it into the drive) using the
    default fstab entry [see ref. 2] I get lowercase filenames like
    odf/0519_0065760201_m1s00100aux.fit  

  - if I mount the CD manually using 
    mount -t iso9660 -o map=off /dev/dvd /media/dvd 
    I obtain uppercase filenames with version number like
    ODF/0519_0065760201_M1S00100AUX.FIT;1       

  - the software which is supplied to analyse such satellite data expects
    instead uppercase FILE names WITHOUT version number e.g.
    anypath/0519_0065760201_M1S00100AUX.FIT       
    and therefore fails on internal consistency checks

  - using map=off,check=r (relaxed check as implied by man mount) does not
    work (gives uppercase names with version)

  - using ONLY check=r (as suggested by ref. 1) does not work (gives 
    lowercase names as the default, but the checks seem not to be ignored
    as ref. 1 seems to tell)
(Continue reading)

Dave Filchak | 21 Aug 11:02 2005
Picon

DNS on CentOS box

Hello all,

Any CentOS people out there with DNS experience?

I am having a hell of an issue configuring dns on a CentOS 4 box which
was installed clean after a drive failure. It is installed in a chroot
and the issues are twofold at this point. It will not do lookups for
anything outside of the domains it is authoritive for, which is a
problem because it is also my secondary mail server. We are getting a
lot of senders address does not resolve errors in the logs for addresses
that I know are good. It is talking and updating the secondary servers
as well. There could be network issues I suppose as it is also flaky.
Most times it will respond if I force it to do a query for something
like ford.ca but then sometimes right after a successful query, I will
get a server can't be reached error. It isn't a network at large error
because I can still get the web sites that are hosted on the same box.

The other, and perhaps even more puzzling issue is one of permissions. I
made a backup of the primary domain file folder and renamed it to
something else. I then created a new folder and copied in my zone files
from the backup. They had the same permissions as the files in the
backup folder but I kept getting startup errors saying could not load
zone file .. permission denied. When I restored the backup folder again,
the permissions went away. Very curious and very frustrating.

There is no difference in the actual Bind program between a caching
server and a primary name server is there?

I will summarize if I can get this straightened out.

(Continue reading)

Picon

User can't print from certain apps on rhel4-64

Hello all,
    This is kind of convoluted so please bear with me.

User on a dell precision box loaded with rhel4-64 can't print from
firefox or openoffice.  I have the printer (hp color laserjet) added to
the system as a JetDirect printer and all the print test work from the
printer config interface.
    I can print as root from the same applications that she can't.
    I can print from the applications if I su - user  from a remote box.
    She can print from the command line.

ARRRRGGGGGGHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!

Rick
_______________________________________________
LinuxManagers mailing list - http://www.linuxmanagers.org
submissions: LinuxManagers@...
subscribe/unsubscribe: http://www.linuxmanagers.org/mailman/listinfo/linuxmanagers

Dave Filchak | 14 Aug 21:38 2005
Picon

With regards to strange server behavior

Hello all,

Well I managed to get the server back up again. There where issues with
the /var partition and so I was able to run fsck.ext3 and it fixed the
errors in the drive. I am now in the process of backing up the files and
ordering a new drive ;-( Or, has it been anyone's experience that the
drive might still be OK and it was simply a file corruption? There were
a ton of errors in the /var partition but the rest of the partitions
were clean.

Dave
_______________________________________________
LinuxManagers mailing list - http://www.linuxmanagers.org
submissions: LinuxManagers@...
subscribe/unsubscribe: http://www.linuxmanagers.org/mailman/listinfo/linuxmanagers


Gmane