TSUCHIYA Masatoshi | 3 Oct 12:10 2004

[emacs-w3m:07118] Re: google での文字化け

>> On Thu, 30 Sep 2004 22:48:04 +0900
>> yoichi <at> geiin.org (Yoichi NAKAYAMA) said as follows:

>Google で日本語 query で検索するといろいろうまく表示されないのですが、
>何が原因でしょうか。

「Google で」と言うのは,

  (1) C-u M-x w3m-search RET google RET query RET という手順で検索した.
  (2) M-x w3m RET http://www.google.com/ RET で Google のページに移動
      して,そこから検索した.

のどちらでしょうか? 少なくとも私のところでは,どちらの手順でも普通に検
索できますし,表示もできています.

あと,問題の発生する具体的な URI を示して頂けるとありがたいです[*].そ
れとも,全ての日本語 query で問題が発生するのでしょうか?

[*] サンプル画像から query を手でコピーしてチェックしました….

>画像を http://yoichi.geiin.org/tmp/emacs-w3m.png に置きました。

確かに,これは致命的に使いにくそうな様子ですが.

>現在の環境は:
>emacs-w3m (cvs の最新版を 3日ほど前にインストール)
>emacs-21.3.50 (cvs の最新版を 3日ほど前にインストール)
>% w3m-m17n -V                               
>w3m version w3m/0.4.2-m17n-20030308, options lang=en,m17n,image,color,ansi-color,mouse,gpm,menu,cookie,ssl,ssl-verify,external-uri-loader,w3mmailer,nntp,ipv6,alarm,mark

(Continue reading)

Yoichi NAKAYAMA | 3 Oct 12:27 2004
X-Face

[emacs-w3m:07119] Re: google での文字化け

At Sun, 03 Oct 2004 19:10:29 +0900,
TSUCHIYA Masatoshi wrote:
> 「Google で」と言うのは,
> 
>   (1) C-u M-x w3m-search RET google RET query RET という手順で検索した.
>   (2) M-x w3m RET http://www.google.com/ RET で Google のページに移動
>       して,そこから検索した.

両方とも同じで、全ての日本語 query で発生していました。
(フォームのボタンの部分は最初からおかしかった)

> とりあえず w3m を入れ換えてみられてはどうでしょうか.w3m-0.5.1 
> には w3m-m17n も merge されていますから,置き換えてしまっても特に問題
> は発生しないはずです.

w3m を入れ換えてみたところ、完全に解決しました。
w3m version w3m/0.5.1, options lang=ja,m17n,image,color,ansi-color,mouse,gpm,menu,cookie,ssl,ssl-verify,external-uri-loader,w3mmailer,nntp,ipv6,alarm,mark

ありがとうございます。

;; > しばらく前からこんな感じになってました。特にタブの部分が致命的で、
;; > タブが増えてくると左にはみ出してしまいます。
;; 放置しておかずにさっさと聞いてみるべきでした…
--

-- 
Yoichi NAKAYAMA

ARISAWA Akihiro | 3 Oct 14:15 2004
Picon

[emacs-w3m:07120] utf-translate-cjk-mode

Emacs-21.3.50 の utf-translate-cjk モードを用いて UTF-8 でエンコードされた
ページの閲覧に関する問題点と対策についておしらせします。
(mew-dist で書いたことのまとめです。)

○問題点

Emacs-21.3.50 では utf-translate-cjk モードがあるので、Mule-UCS なしでも
日本語を含む UTF-8 でエンコードされたページを emacs-w3m で閲覧できることが
期待されます。しかし、デフォルトの状態では多くの記号が化けてしまいます。

○原因

utf-translate-cjk モードで UTF-8 をデコードすると、U+0100 - U+2E7F は
mule-unicode-* の文字セットを使って表現されます。その文字セットを
iso-2022-7bit-ss2 (w3m-input-coding-system のデフォルト値) で
エンコードして w3m に渡すと、w3m が解せないために文字化けします。
(参考 [emacs-w3m:06969])

○対策

1. Mule-UCS を使う。
   - 個人的には最もおすすめな手です:-)

2. w3m-input-coding-system / w3m-output-coding-system を utf-8 にする。
   - mule-unicode-* を表示できる必要があります。
   - テーブルがずれる場合などは w3m-use-symbol を nil にしてみてください。

3. UTF-8 のデコード時に、記号が japanese-jisx0208 となるようにする。
   - あまりおすすめしません。参考までに私の設定です。
     http://www.nijino.com/ari/emacs/utf-cjk.html#subst-ari
(Continue reading)

Katsumi Yamaoka | 5 Oct 07:32 2004
X-Face

[emacs-w3m:07121] Re: Gnus w/ w3m stoped working

I Cc this message to the emacs-w3m mailing list.  You can read
the list in the gmane.emacs.w3m newsgroup as well.

>>>>> In <ubrfij8dp.fsf <at> raytheon.com>
>>>>>	Sarir Khamsi <sarir.khamsi <at> raytheon.com> wrote:

> OK, I did something I can't figure out. For some reason, starting
> today, I can't seem to read some email w/ Gnus. The stack trace is
> listed below. I've diff'ed my .emacs & .gnus files and can't seem to
> figure out what the heck I did wrong/different. I'm running with Gnus
> 5.10.6, w3m 0.4, GNUS Emacs 21.3.50.1, on WinXP SP1.

> Any help would be appreciated since I am getting pretty frustrated
> with this problem and can't seem to debug the problem from the trace
> below. I've tried to get w3m 0.5, but that won't build w/ Cygwin
> (missing ja.gmo, & I had to get gc.h and build that) and I can't seem
> to get any install info off the net. Thanks.

> Sarir

I'm not familiar with Cygwin and don't know how to build w3m 0.5
in that environment.  Anyone?

The error you encountered is the case where the w3m executable
is not found in the directories which is specified by the
`exec-path' Lisp variable.  It normally inherits the value of
the PATH environment variable when Emacs starts.  So, you may
want to check the value, or to specify the `w3m-command'
variable explicitly in the ~/.emacs file with the absolute path
name of the w3m executable as follows:
(Continue reading)

Andreas Seltenreich | 10 Oct 04:24 2004
X-Face
Picon
Picon

[emacs-w3m:07122] sb-laut-de.el

Hi,

attached is a shimbun backend for the rss feeds of
<http://www.laut.de> and an attempt of the appropriate documentation
update. Content is music news and reviews in german.

Thanks
Andreas

;;; sb-laut-de.el --- shimbun backend for <http://www.laut.de/>

;; Copyright (C) 2004 Andreas Seltenreich <seltenreich <at> gmx.de>

;; Author: Andreas Seltenreich <seltenreich <at> gmx.de>
;; Keywords: news
;; Created: May 23, 2004

;; This program is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
;; the Free Software Foundation; either version 2, or (at your option)
;; any later version.

;; This program is distributed in the hope that it will be useful,
;; but WITHOUT ANY WARRANTY; without even the implied warranty of
;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;; GNU General Public License for more details.

;; You should have received a copy of the GNU General Public License
(Continue reading)

Katsumi Yamaoka | 11 Oct 01:14 2004
X-Face

[emacs-w3m:07123] Re: sb-laut-de.el

>>>>> In [emacs-w3m : No.07122] 
>>>>>	Andreas Seltenreich <seltenreich <at> gmx.de> wrote:

> attached is a shimbun backend for the rss feeds of
> <http://www.laut.de> and an attempt of the appropriate documentation
> update. Content is music news and reviews in german.

Thanks for your contribution.  I've installed it.

Joakim Verona | 12 Oct 17:08 2004
Picon

[emacs-w3m:07124] [Q] download file synchronously?

Hello list, 

I'm trying to use the function w3m-download
to download a file synchronously. This file will then be used after
its been downloaded.

I only get it to do an asynchronous download however.

My call looks like this:

(w3m-download url  "/tmp/x.torrent" nil nil) ;it apears this runs asynchronously, although it says synch
when handler nil

Any hints?

Cheers,
/Joakim

Matt Hodges | 12 Oct 20:44 2004
Picon

[emacs-w3m:07125] Re: [Q] download file synchronously?

>>>>> Joakim Verona writes:

 > I'm trying to use the function w3m-download to download a file
 > synchronously. This file will then be used after its been
 > downloaded.

 > I only get it to do an asynchronous download however.

 > My call looks like this:

 > (w3m-download url "/tmp/x.torrent" nil nil) ;it apears this runs
 > asynchronously, although it says synch when handler nil

 > Any hints?

Maybe something like:

    (let ((w3m-async-exec nil))
      (w3m-download ...))

Matt

Joakim Verona | 14 Oct 16:08 2004
Picon

[emacs-w3m:07126] [Q] does w3m sometimes download garbage?

Hello,

Im writing a little interface around w3m.el.
It uses w3m to download torrent files and submitts them to
mldonkey.el.

This has worked nicely a long time. Suddenly w3m sometimes downloads
garbage instead of the real file! what can be the problem?

I tried w3m.el and w3m standalone.
w3m 0.3.2.2 (the latest packaged for rh9) and
w3m 0.5.1.

here is a url that consistently fails for me:

http://zcultfm4.no-ip.org:6969/torrent.html?info_hash=4034a05a962f4b9b470e197417753f87d4cae046

w3m does download something, but im not shure what it is.

I tried removing files in ~/.w3m that might be cache files, but im not shure.

wget handles the url.

Regards,
/Joakim

Katsumi Yamaoka | 15 Oct 03:34 2004
X-Face

[emacs-w3m:07127] Re: [Q] does w3m sometimes download garbage?

Hi,

I have no idea how we should fix this problem, but I noticed what
is bad at least.  You will be able to fix it temporarily modifying
the w3m-download function as follows:

< (w3m-retrieve url t no-cache...
> (w3m-retrieve url nil no-cache...

>>>>> In [emacs-w3m : No.07126] Joakim Verona wrote:

> here is a url that consistently fails for me:

> http://zcultfm4.no-ip.org:6969/torrent.html?info_hash=4034a05a962f4b9b470e197417753f87d4cae046

> w3m does download something, but im not shure what it is.

w3m-download specifies the second argument `no-decode' as t to
the w3m-retrieve function so that it should not decode the
contents.  However, the contents of that url has been encoded
with `deflate'.  Here's the header information:

W3m-current-url: http://zcultfm4.no-ip.org:6969/torrent.html?info_hash=4034a05a962f4b9b470e197417753f87d4cae046
W3m-document-charset: US-ASCII
HTTP/1.1 200 OK
Connection: close
Content-Disposition:: attachment; filename="dcp 10-14-04.torrent"
Content-Encoding: deflate
Content-Length: 22722
Content-Type: application/x-bittorrent; name="dcp 10-14-04.torrent"
(Continue reading)


Gmane