SXEmacs Issue Tracking | 7 Oct 12:12 2008

[Bug 83] New: Core dump during start of gnuclient with X Error

http://issues.sxemacs.org/show_bug.cgi?id=83

           Summary: Core dump during start of gnuclient with X Error
           Product: SXEmacs
           Version: 22.1.9
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P3
         Component: General
        AssignedTo: steve <at> sxemacs.org
        ReportedBy: e.taumberger <at> centersystems.com
         QAContact: sxemacs-devel <at> sxemacs.org

Created an attachment (id=78)
 --> (http://issues.sxemacs.org/attachment.cgi?id=78)
Installation report

SXEmacs died with leaving the following message:

X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  40 (X_TranslateCoords)
  Resource id in failed request:  0xef180e
  Serial number of failed request:  885142
  Current serial number in output stream:  885142
sxemacs: ../../src/xcb_io.c:182: process_responses: Assertion `((int)
(((dpy->last_request_read)) - ((dpy->request))) <= 0)' failed.

[1]+  Segmentation fault      (core dumped) sxemacs
(Continue reading)

SXEmacs Issue Tracking | 7 Oct 12:15 2008

[Bug 83] Core dump during start of gnuclient with X Error

http://issues.sxemacs.org/show_bug.cgi?id=83

--- Comment #1 from Ernst Taumberger <e.taumberger <at> centersystems.com>  2008-10-07 20:14:45 EST ---
Created an attachment (id=79)
 --> (http://issues.sxemacs.org/attachment.cgi?id=79)
backtrace generated from the core dump

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

SXEmacs Issue Tracking | 7 Oct 12:24 2008

[Bug 83] Core dump during start of gnuclient with X Error

http://issues.sxemacs.org/show_bug.cgi?id=83

Ernst Taumberger <e.taumberger <at> centersystems.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
     Attachment #78|application/octet-stream    |text/plain
          mime type|                            |

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

SXEmacs Issue Tracking | 7 Oct 12:26 2008

[Bug 83] Core dump during start of gnuclient with X Error

http://issues.sxemacs.org/show_bug.cgi?id=83

Ernst Taumberger <e.taumberger <at> centersystems.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
     Attachment #79|application/octet-stream    |text/plain
          mime type|                            |

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

SXEmacs Issue Tracking | 7 Oct 12:46 2008

[Bug 83] Core dump during start of gnuclient with X Error

http://issues.sxemacs.org/show_bug.cgi?id=83

Sebastian Freundt <hroptatyr <at> sxemacs.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED
         AssignedTo|steve <at> sxemacs.org           |hroptatyr <at> sxemacs.org
                 CC|                            |hroptatyr <at> sxemacs.org

--- Comment #2 from Sebastian Freundt <hroptatyr <at> sxemacs.org>  2008-10-07 20:45:10 EST ---
Ah, xcb issue. I'll dig into it.

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

SXEmacs Issue Tracking | 9 Oct 17:04 2008

[Bug 84] New: cl modules does not compile with bison 1.35

http://issues.sxemacs.org/show_bug.cgi?id=84

          Revision: sxemacs--main--22.1.10--patch-24
          Mainline: sxemacs--main--22.1.10--patch-24
           Summary: cl modules does not compile with bison 1.35
           Product: SXEmacs
           Version: 22.1.10
          Platform: PC
        OS/Version: Other
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Compile/Install
        AssignedTo: njsf <at> sxemacs.org
        ReportedBy: njsf <at> sxemacs.org
         QAContact: sxemacs-devel <at> sxemacs.org

Bison is detected, but at least version 1.35 cannot deal with %parse-param,
%lex-parm and %name-prefix.

Recommended action: configure automatically disable cl if bison <= 1.35

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

SXEmacs Issue Tracking | 9 Oct 22:26 2008

[Bug 85] New: SXEmacs tries and fails miserably to find out if HPPA has MMX extensions

http://issues.sxemacs.org/show_bug.cgi?id=85

          Revision: sxemacs--main--22.1.10--patch-24
          Mainline: sxemacs--main--22.1.10--patch-24
           Summary: SXEmacs tries and fails miserably to find out if HPPA
                    has MMX extensions
           Product: SXEmacs
           Version: 22.1.10
          Platform: Other
        OS/Version: Unix
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Compile/Install
        AssignedTo: hroptatyr <at> sxemacs.org
        ReportedBy: njsf <at> sxemacs.org
         QAContact: sxemacs-devel <at> sxemacs.org

It does not, nor it ever will :-)
Configure stops with:
checking for MMX extensions... ../configure[20869]: 0x >> 23 & 1: The specified
number is not valid for this command.

We should really only make this check on x86 architectures [ie ix86, x86_64,
amd, etc]

Last good output on config.log:
configure:20788: checking for processor flags
configure:20806: result: no
configure:20816: checking for MMX extensions
(Continue reading)

SXEmacs Issue Tracking | 9 Oct 22:54 2008

[Bug 85] SXEmacs tries and fails miserably to find out if HPPA has MMX extensions

http://issues.sxemacs.org/show_bug.cgi?id=85

Sebastian Freundt <hroptatyr <at> sxemacs.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED

--- Comment #1 from Sebastian Freundt <hroptatyr <at> sxemacs.org>  2008-10-10 06:53:19 EST ---
Yepp, easy ... I'll do it slightly differently from what you propose, I don't
want dependencies a la `this only works on x86' in the detection routines,
instead I'd rather fire off the cpuid macro and if that fails any code
depending on it will be skipped, is that okay?

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

SXEmacs Issue Tracking | 10 Oct 00:08 2008

[Bug 84] cl modules does not compile with bison 1.35

http://issues.sxemacs.org/show_bug.cgi?id=84

Sebastian Freundt <hroptatyr <at> sxemacs.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED
         AssignedTo|njsf <at> sxemacs.org            |hroptatyr <at> sxemacs.org
                 CC|                            |hroptatyr <at> sxemacs.org

--- Comment #1 from Sebastian Freundt <hroptatyr <at> sxemacs.org>  2008-10-10 08:07:06 EST ---
sorry to nick your bug :)
Also, I'd say we require at least bison 1.875

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

SXEmacs Issue Tracking | 10 Oct 02:23 2008

[Bug 85] SXEmacs tries and fails miserably to find out if HPPA has MMX extensions

http://issues.sxemacs.org/show_bug.cgi?id=85

--- Comment #2 from Nelson Ferreira <njsf <at> sxemacs.org>  2008-10-10 10:22:35 EST ---
Ok, as long as that check does cramp configure under other archs, which I think
it will not.

--

-- 
Configure bugmail: http://issues.sxemacs.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


Gmane