ayiiq180 | 14 Jan 08:09 2005
Picon

latex found no preview images

hi:
I install the preview-latex and try it,I text a samll tex doc,that's
noly one line in documnet.But when I try C-c C-p C-d,that's show me
latex found no preview images.
this is the log:
This is e-TeXk, Version 3.141592-2.1 (Web2C 7.5.2) (format=prv_new
2005.1.14) 14 JAN 2005 14:56
entering extended mode
%&-line parsing enabled.
(/usr/TeX/texmf/web2c/cp8bit.tcx)
**&prv_new new.tex
(./new.tex
LaTeX2e <2001/06/01>
Babel <v3.7j> and hyphenation patterns for english, dumylang,
nohyphenation, ba
sque, czech, slovak, german, ngerman, spanish, catalan, french,
ukenglish, ital
ian, dutch, polish, portuguese, loaded.
CUSTOMISED FORMAT. Preloaded files:
.
new.tex
article.cls 2001/04/21 v1.4e Standard LaTeX document class
size10.clo 2001/04/21 v1.4e Standard LaTeX file (size option)
.
No file new.aux.
\openout1 = `new.aux'.

LaTeX Font Info: Checking defaults for OML/cmm/m/it on input line 2.
LaTeX Font Info: ... okay on input line 2.
LaTeX Font Info: Checking defaults for T1/cmr/m/n on input line 2.
(Continue reading)

Jan-Ake Larsson | 14 Jan 12:08 2005
Picon
Picon

Re: latex found no preview images

ayiiq180 wrote:
> hi:
> I install the preview-latex and try it,I text a samll tex doc,that's
> noly one line in documnet.But when I try C-c C-p C-d,that's show me
> latex found no preview images.

What is the content of the document?
/JÅ

--

-- 
Some people, when confronted with a problem, think "I know, I'll use
regular expressions." Now they have two problems.

-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
_______________________________________________
preview-latex-bugs mailing list
preview-latex-bugs <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/preview-latex-bugs

-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
David Kastrup | 14 Jan 15:22 2005
Picon
Picon

Re: [preview-latex-devel] latex found no preview images

ayiiq180 <ayiiq180 <at> gmail.com> writes:

> hi:
> I install the preview-latex and try it,I text a samll tex doc,that's
> noly one line in documnet.But when I try C-c C-p C-d,that's show me
> latex found no preview images.
> this is the log:

The log is an absolutely perfect log for a document containing no
preview images.

preview-latex only previews certain constructs, the default being
included graphics, text math, display math, tables and figures, and
footnote marks.

If your document contains nothing like that, generating previews will
give just that message.

What happens if you try C-c C-p C-d on the document circ.tex coming
with preview-latex?

--

-- 
David Kastrup, Kriemhildstr. 15, 44793 Bochum

-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
Jan-Ake Larsson | 14 Jan 15:43 2005
Picon
Picon

Re: [preview-latex-devel] latex found no preview images

Jan-Ake Larsson wrote:
> ayiiq180 wrote:
> > hi:
> > I install the preview-latex and try it,I text a samll tex doc,that's
> > noly one line in documnet.But when I try C-c C-p C-d,that's show me
> > latex found no preview images.
> 
> What is the content of the document?

I got a response off-list. I believe the issue is resolved now.
/JÅ

--

-- 
UNIX _is_ user friendly. It's just selective about who its friends are.

-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
Thomas Unternaehrer | 16 Jan 11:55 2005
Picon
Picon

preview-latex make install problem (WinXP)


Dear List,

I tried to install PreviewLatex with XEmacs on Windows XP but failed
(Following the file INSTALL.windows and the online docs of preview-latex).

Until now I've done the following:

(Install without any problems)
- MinGW (some times ago)
- MSYS (as far as I can remember there was a message which sounds like:
    oh man, you don't have ... makeVar or make installed) ???
- MikTeX  2.4.1545
- XEmacs 21.4.13
- Ghostscript/Ghostview 8.14/4.6
(all tested with other programs and packages and they seems to work)

PreviewLatex 0.8.1 - Installation:
- I unpacked the preview-latex...tar.gz to c:\temp and unpacked the
preview-latex-prebuilt-docs-...tar.gz to its doc directory.
- in MSYS I typed:

./configure --with-xemacs=/c/XEmacs/XEmacs-21.4.13/i586-pc-win32/xemacs.exe
--with-texmf-dir=/c/texmf --with-packagedir=/c/XEmacs/xemacs-packages

and

make

make install
(Continue reading)

David Kastrup | 16 Jan 16:56 2005
Picon
Picon

Re: [preview-latex-devel] preview-latex make install problem (WinXP)

Thomas Unternaehrer <t.unternaehrer <at> gmx.ch> writes:

> I tried to install PreviewLatex with XEmacs on Windows XP but failed
> (Following the file INSTALL.windows and the online docs of
> preview-latex).

The XEmacs/Windows combination has a problem in Makefile.in.  Please
get
<URL:http://cvs.sourceforge.net/viewcvs.py/*checkout*/preview-latex/preview/Makefile.in?rev=1.48>
which does not show this problem.  It will be fixed with the next
release.

> ./configure and make seems to be ok (no warning or error message).
> make install gives me the following error after I comile the
> prv-xemacs.el manually:

> But I can't compile the other file preview.el.
> It gives me the following error message:
>
> While compiling toplevel forms:
> !! File error (("Image not installed" "prevwork.xpm"))

Looks like a chicken-and-egg problem.  Nick, are you following this?
I think there are tests in prv-xemacs.el to check that the image files
are installed, and obviously this can't work before installing them.

Since we don't have something like this in prv-emacs.el, I'll probably
throw the tests out completely [Checking].  Uh oh.  This is not as
simple as I thought: the filenames are actually used for initializing
stuff and are probably evaluated at compile time...
(Continue reading)

Thomas Unternaehrer | 16 Jan 17:23 2005
Picon
Picon

Re: [preview-latex-devel] preview-latex make install problem (WinXP)

> Try doing something like
> 
> make install-icons
> 
> _before_ compiling things.

YES! Everything works just fine now!

The following steps were required on my machine:

./configure
make
make install-icons
"compile the files manually"
make install

Thanks a lot David Kastrup

Thomas

-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
David Kastrup | 16 Jan 20:07 2005
Picon
Picon

Re: [preview-latex-devel] preview-latex make install problem (WinXP)

Thomas Unternaehrer <t.unternaehrer <at> gmx.ch> writes:

>> Try doing something like
>> make install-icons
>> _before_ compiling things.
>
>
> YES! Everything works just fine now!
>
> The following steps were required on my machine:
>
> ./configure
> make
> make install-icons
> "compile the files manually"

With a newer Makefile.in, this manual compilation step should not be
necessary.  And we have to do something about make install-icons here.
We can't ask people to do things in that order.

Thanks for bringing this to our attention.  Nick?

> make install

Well, at least something that appears as expected.

--

-- 
David Kastrup, Kriemhildstr. 15, 44793 Bochum

-------------------------------------------------------
(Continue reading)


Gmane