joakim | 7 Feb 16:13 2016
Picon
Gravatar

Did anyone try the jdk 9 repl?

I tried the jdk 9 repl briefly, and it appeared to work as advertized.

Maybe it could be used in place of bsh, or maybe the Clojure idea is
better, I'm not sure. 

--

-- 
Joakim Verona

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
Hoffmann, Jobst | 23 Dec 21:40 2015
Picon

jdee-server

Hi,

I've installed jdee from melpa and jdee-server from github and
configured jdee-server-dir accordingly.

Then I've loaded a small Java example and stumbled across the below
mentioned error.

My Messages buffer looks like this - I've cut the relevant lines:

-------8<--------------------------------------------------------------
For information about GNU Emacs and the GNU system, type C-h C-a.
jdee-font-lock: building names cache...empty
rebind key again
using my-c-mode
Setting customized JDEE variables to startup values...
Starting the BeanShell. Please wait...
using my-c-mode
Symbol's function definition is void: jdee-load-additional-functions
Error in menu-bar-update-hook (imenu-update-menubar): (void-function
semantic-sort-tokens-by-name-increasing-ci)
-------8<--------------------------------------------------------------

I can compile and execute the Java example by short key cuts but I don't
get a JDE-entry in the menu bar. What went wrong or what can I do to
make the JDE-entry appear?

Many thanks for your answer in advance and many thanks for supporting
JDEE again!

(Continue reading)

Stephen Leake | 14 Dec 19:01 2015

jdee-live can't find nrepl-current-dir

I'm trying to use

https://github.com/phillord/jde-with-clojure-backend

I'm using Emacs master, on Windows 8.1 with Cygwin.

I got leiningen, maven, cask installed.

Running:

$ cd java-live
$ cask package

doesn't do anything; no files are created in dst/

So I tried: (package-install-file ".../java-live/java-live.el")

That seems to have succeeded; it installed cider from MELPA, etc.

However, doing "M-x java-live-jack-in" gives an error:

jdee-live-jack-in: Symbol’s function definition is void:
nrepl-current-dir

nrepl-client.el is part of cider; I have version 0.11.0-cvs.

Any clues?

looking at the code, it seems "(nrepl-current-dir)" can be replaced by
"default-directory".
(Continue reading)

Troy Daniels | 7 Dec 02:36 2015
Picon

Using the correct cider connection

I have made some progress on using cider to get values for JDEE.  At the moment, I am running into a problem when I have a directory structures like this

root/
-pom.xml
-prj1/
--src/main/java/...
--pom.xml
-prj2/
--pom.xml
--src/main/java/...

If I have an nrepl running for all three pom.xml, then cider-connections lists the last one that I started first.  So if I start the nrepl for prj1, then root, then prj2 and call cider from prj1, I get a timeout because it uses the nrepl for prj2, even though I am in prj1.

Probably, I just need to call some cider function to say "use the nrepl associated with this directory", but I am not sure what that function is.  Does anybody know that?

Thanks,
Troy

------------------------------------------------------------------------------
Go from Idea to Many App Stores Faster with Intel(R) XDK
Give your users amazing mobile app experiences with Intel(R) XDK.
Use one codebase in this all-in-one HTML5 development environment.
Design, debug & build mobile apps & 2D/3D high-impact games for multiple OSs.
http://pubads.g.doubleclick.net/gampad/clk?id=254741911&iu=/4140
_______________________________________________
jdee-devel mailing list
jdee-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/jdee-devel
richard | 4 Sep 20:33 2015

Trying out the new JDEE


Hi,

I've just grabbed this from git with a few to trying it out
and possibly contributing subject to need / time / whatever.

I've noticed a few glitches:

1. Line 71 in jdee-imenu.el contains the following:
    ("static"        . ?§)              ; §

When I load JDEE on my system, it fails with the error 
load-with-code-conversion: Invalid read syntax: "?" I think it's
a charset problem but I'm not sure what's supposed to be here.
Commenting it out makes JDEE load file

2. Cask isn't listed as a dependency. Since the makefile doesn't
work without it, I'm guessing it should be.

3. If I open a simple Java file from my home dir it tries sucking
up the entire tree as a classpath. This takes forever and seems a
bit silly. I tried adding some system.out/err messages to the code
to troubleshoot it but the messages didn't appear in the *Messages*
buffer. I can't see where in the code is the bit that makes this
work. Any pointers?

Regards,

Richard

------------------------------------------------------------------------------
Sudong Lei | 3 Sep 03:51 2015
Picon

about bsh classpath

sorry for my poor english.
when I use jdee git version, copy jdee-bundle.jar to my jdee-server-dir, M-x jdee-compile,it poped a message "java.lang.ClassNotFoundException: com.sun.tools.javac.Main", then I copy tools.jar from jdk lib dir to jdee-server-dir, it work fine; but I compare the "jdee-bsh.el" file between version 2.4.1 and git version, I found out that in version 2.4.1, method bsh-launch set jdee-global-classpath and several paths to cp and git version just set the jar files in jdee-server-dir to cp.
now, I don't know which way is better(modify jdee-bsh.el to add more paths to cp or just copy tools.jar to jdee-server-dir)
------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140
_______________________________________________
jdee-devel mailing list
jdee-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/jdee-devel
Przemysław Wojnowski | 24 Aug 21:24 2015

Purpose of which.el

Hello everybody,

Anyone knows what is the purpose of which.el?

AFAIK it is not used and can be removed.

Thanks,
Przemysław

------------------------------------------------------------------------------
_______________________________________________
jdee-devel mailing list
jdee-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/jdee-devel
Przemysław Wojnowski | 24 Aug 11:49 2015

Recent changes

Hello everybody,

Recently I did a couple of updates to move JDEE to MELPA:
1. Renamed every "jde" to "jdee" match project name and packaging naming 
conventions (rules?).
This means that if you've got an old config with "jde" vars you'll have 
to rename them to "jdee".
Nobody has implemented auto conversion. Sorry. :-)

2. jdee-server-dir is required to have support from JVM side.
The jar from jdee/jdee-server have to be copied to some directory and 
jdee-server-dir should point to it (the dir).
If it is unset then user will see a message on the first call to JVM 
part.

3. Since we're on melpa, we can use other packages.

4. We can work on other things in parallel.

Cheers,
Przemysław

------------------------------------------------------------------------------
_______________________________________________
jdee-devel mailing list
jdee-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/jdee-devel
Lee Hinman | 18 Aug 23:32 2015

Re: Proposed New Structure (starter for 10)


Re-added the jdee-devel list

Phillip Lord writes:

> Lee Hinman <leehinman <at> fastmail.com> writes:
>> This looks neat to me, and I'm interested in contributing. What's the
>> best place to start with this? (Assuming this is adopted)
>
>
> The roadblock for me at the moment is understanding mvn. If you have
> any time to research this, it would be appreciated. In particular, how
> to add dependencies or plugins without changing the pom.
>
> Phil

So I looked into this briefly, it looks like this can be added to
${user.home}/.m2/settings.xml, specifically, one can specify plugin
groups with:

<pluginGroups>
  <pluginGroup>org.jdee.plugin</pluginGroup>
<pluginGroups>

The docs say: "This element contains a list of pluginGroup elements,
each contains a groupId. The list is searched when a plugin is used and
the groupId is not provided in the command line."

So if we provided a jdee-mvn plugin and added the groupId here, someone
could use

mvn jde:jack-in (or whatever it is called)

And it would search the `org.jdee.plugin` groupId for the plugin.

There is also a "pluginRepositories" element that can be used to add a
repository for downloading plugins, which I could see as being useful
for providing the plugin for download somewhere.

Sources:
- https://maven.apache.org/settings.html#Plugin_Groups
- https://maven.apache.org/settings.html#Plugin_Repositories

--

-- 
;; Lee

------------------------------------------------------------------------------
Lee Hinman | 16 Aug 20:03 2015

Where to contribute?


Hi All,

So, I'd like to contribute to jdee, but with the latest discussion, I'm
slightly confused on where to focus my efforts. I see there are a few
different options:

- jdee master branch (on Github)
- jdee "cask" branch (based on the recent jdee-devel discussion)
- jde-with-clojure-backend (https://github.com/phillord/jde-with-clojure-backend)

Where's the best place to contribute to?

--

-- 
;; Lee

------------------------------------------------------------------------------
Phillip Lord | 14 Aug 18:51 2015
Picon
Picon
Gravatar

Proposed New Structure (starter for 10)


So, I wanted to put some meat onto the bone of my proposed new
structure for JDEE.

It doesn't work yet, of course, but I think that it can in a relatively
short space of time.

https://github.com/phillord/jde-with-clojure-backend

The four components are:

jde -- this will be the Java centric major mode. It will involve NO JVM
interaction and not depend on any of the other parts. The "minimal
viable product" here is a ELPA packaged major mode that is a child of
Java mode and adds no functionality.

jde-interactive (crappy name, sorry) -- a minor mode which will be
active once the JVM (bsh interpreter equivalent) has been started and is
running. In the short term, this will have a dependency on cider, but
eventually this may just become a dependency on nrepl-client.el. I say
may, because, I think quite a bit of the cider functionality (like the
inspector) is JVM centric and entirely relevant.

The MVP here is to use maven inside a project to launch an nrepl, and
then to invoke a call to get the version number of the jde-nrepl
middleware and check that it is consistent with the version of jde-interactive.

jde-nrepl -- this is the nrepl middleware that provides all the backend
functionality, like class look up and the like. The MVP here is to
install some middleware into a nrepl, which returns a version map for
checking my jde-interactive, and which is packaged as a maven dependency
on clojars.

jdee-sample -- this is a sample project. Requirements in the short term
are that the project depend on jde-nrepl and
https://github.com/talios/clojure-maven-plugin to provide the nrepl
functionality we need. Typing "maven jde:nrepl" or equivalent should
result in a nrepl session.

MVP having a packaged jde-interactive that can install, that starts when
we open "App.java" in jdee-sample, and which can then invoke a method of
the class object coming from App.java.

In the long term, I would expect that all four of these would be
separate repos.

That's the idea. The lisp packaging already works (as you can see form
the dist directories that I should not have checked in). Most of the
rest can be stolen from cider.

Thoughts?

Phil

------------------------------------------------------------------------------

Gmane