SourceForge.net | 1 Feb 17:29 2010
Picon
Picon

[ emacs-jabber-Bugs-2943902 ] Respect starttls being required

Bugs item #2943902, was opened at 2010-02-01 16:29
Message generated for change (Tracker Item Submitted) made by legoscia
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=586350&aid=2943902&group_id=88346

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: None
Group: None
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Magnus Henoch (legoscia)
Assigned to: Nobody/Anonymous (nobody)
Summary: Respect starttls being required

Initial Comment:
When using the network connection method (i.e., STARTTLS not supported), and connecting to a server which
requires STARTTLS and supports only the PLAIN mechanism, jabber.el will go ahead and ask the user to send
her password in cleartext anyway. It should notice the <required/> tag, and abort the connection attempt.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=586350&aid=2943902&group_id=88346

------------------------------------------------------------------------------
The Planet: dedicated and managed hosting, cloud storage, colocation
(Continue reading)

SourceForge.net | 12 Feb 09:12 2010
Picon
Picon

[ emacs-jabber-Bugs-2950401 ] Invalid TLS certificate checking

Bugs item #2950401, was opened at 2010-02-12 08:12
Message generated for change (Tracker Item Submitted) made by nobody
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=586350&aid=2950401&group_id=88346

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Connectivity
Group: v0.8.0
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Nobody/Anonymous (nobody)
Summary: Invalid TLS certificate checking

Initial Comment:
Debian bug report (see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=569338):

when connecting via TLS, jabber.el does not check for the correct CN in
the certificate:

  Jabber-ID: bob <at> example.com/Emacs
  DNS:       _xmpp-client._tcp.example.com IN SRV 50 50 5022 jabber.example.org.

jabber.el now looks up the SRV entry and connects to
jabber.example.org.  It then expects the certificate's CN to match
"jabber.example.org", but it should expect "example.com" as documented
(Continue reading)

SourceForge.net | 14 Feb 14:18 2010
Picon
Picon

[ emacs-jabber-Feature Requests-1875920 ] XEP-0202: Entity Time

Feature Requests item #1875920, was opened at 2008-01-21 02:57
Message generated for change (Comment added) made by evg_krsk
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=586353&aid=1875920&group_id=88346

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: XEP support
Group: Git
>Status: Closed
Priority: 5
Private: No
Submitted By: Magnus Henoch (legoscia)
Assigned to: Kirill A. Korinskiy (catap)
Summary: XEP-0202: Entity Time

Initial Comment:
http://www.xmpp.org/extensions/xep-0202.html

jabber.el already supports XEP-0090, the deprecated protocol.  Let's support the new one too/instead.

----------------------------------------------------------------------

Comment By: Evgenii Terechkov (evg_krsk)
Date: 2010-02-14 20:18

Message:
See latest git

(Continue reading)

SourceForge.net | 15 Feb 16:26 2010
Picon
Picon

[ emacs-jabber-Bugs-2836076 ] roster seems to doesnt recognize jids between two servers

Bugs item #2836076, was opened at 2009-08-12 08:00
Message generated for change (Comment added) made by nobody
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=586350&aid=2836076&group_id=88346

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Interface
Group: Git
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Mateusz Ratajski (occulkot)
Assigned to: Nobody/Anonymous (nobody)
Summary: roster seems to doesnt recognize jids between two servers

Initial Comment:
i have two differents account set up:
- one from jabster.pl
- one from gmail.com

i have same jid (from jabber.cc) added on both rosters and after some problems on jabster.pl it cannot
contact with jabber.cc server so it gives me error status with "Remote server not found" error
after i add same contact on gmail everything works fine until i connect myself to both servers on same time

roster seems to doesnt recognize different accounts for same contact and even in gmail account i still have
status error with error status, but i can talk, request etc with this jid.

(Continue reading)


Gmane