Katsumi Yamaoka | 1 Aug 09:35 2005
X-Face

Re: Bug regarding reading sent-mail folder

The old articles can be found in:

http://news.gmane.org/group/gmane.emacs.gnus.general/thread=56470

>>>>> In <m34qae85hy.fsf <at> zeus.intra.softace.dk> Jarl Friis wrote:

> Thanks for your response. It is long time we communicated. I have been
> very busy, yet I haven't solved my problem. Here is some more
> information for you. Thanks for helping me.

I retried it and succeeded in archiving and reading messages
again.  When I think of it now (I'm not quite sure of all,
though), it doesn't seem to be related to the marks nor to the
change you pointed out as follows:

>>>>> In <m3llmk7auy.fsf <at> zeus.intra.softace.dk> Jarl Friis wrote:

> I further figured out that the following lines where removed from
> 5.8.8 to 5.10.6 in nnfolder.el (approx. line 600):
> ----------------------------------------------
> 	;; The group doesn't exist, so we create a new entry for it.
> 	(push (list group (cons 1 0)) nnfolder-group-alist)
> 	(nnfolder-save-active nnfolder-group-alist nnfolder-active-file))
> ----------------------------------------------

In addition, there seems to be no problem in the newsrc entry
for your archive group, except that it suggests there's no
article.

>> (assoc "nnfolder+archive:all" gnus-newsrc-alist)
(Continue reading)

Katsumi Yamaoka | 1 Aug 10:11 2005
X-Face

make-variable-buffer-local in sieve-manage.el

Hi,

In sieve-manage.el, shouldn't `make-variable-buffer-local' used
in several places be replaced with `make-local-variable'?  For
instance:

(defun sieve-manage-interactive-login (buffer loginfunc)
  "Login to server in BUFFER.
LOGINFUNC is passed a username and a password, it should return t if
it where sucessful authenticating itself to the server, nil otherwise.
Returns t if login was successful, nil otherwise."
  (with-current-buffer buffer
    (make-variable-buffer-local 'sieve-manage-username)
    (make-variable-buffer-local 'sieve-manage-password)

David S. Goldberg | 1 Aug 18:01 2005
X-Face
Picon
Picon

insert-buffer vs insert-buffer-substring

After doing a cvs update this morning, I've been unable to use
message-yank-original.  I get the following backtrace:

Debugger entered--Lisp error: (wrong-type-argument integer-or-marker-p nil)
  message-cite-original-without-signature()
  message-yank-original()
  gnus-inews-yank-articles((29067))
  gnus-post-news([...elided...])
  gnus-summary-followup((29067) nil)
  gnus-summary-followup-with-original(nil)
  call-interactively(gnus-summary-followup-with-original)

The problem appears to a bad combination of my use of supercite
(mail-citation-hook is set to sc-cite-original) and the change from
insert-buffer to insert-buffer-substring.  Not sure if it's an XEmacs
issue or not, but in case, 

(emacs-version)^J
XEmacs 21.4 (patch 17) "Jumbo Shrimp" [Lucid] (i686-pc-cygwin, Mule) of Wed Jun  1 2005 on mm117419-pc

Reverting to insert-buffer works, as does setting mail-citation-hook
to nil, but I'd rather not do that.  I often generate replies to one
message but cut/paste text from others and find that sc is the best
tool I can find for getting the citations right as I do so.

Thanks,
--

-- 
Dave Goldberg
david.goldberg6 <at> verizon.net

(Continue reading)

Simon Josefsson | 2 Aug 11:47 2005

Re: make-variable-buffer-local in sieve-manage.el

Katsumi Yamaoka <yamaoka <at> jpl.org> writes:

> Hi,
>
> In sieve-manage.el, shouldn't `make-variable-buffer-local' used
> in several places be replaced with `make-local-variable'?  For
> instance:

Probably, yes.  Please go ahead and make the change.

Katsumi Yamaoka | 2 Aug 12:14 2005
X-Face

Re: make-variable-buffer-local in sieve-manage.el

> Katsumi Yamaoka <yamaoka <at> jpl.org> writes:

>> In sieve-manage.el, shouldn't `make-variable-buffer-local' used
>> in several places be replaced with `make-local-variable'?

>>>>> In <iluoe8ghdra.fsf <at> latte.josefsson.org> Simon Josefsson wrote:

> Probably, yes.  Please go ahead and make the change.

Thanks.  I've done so in the v5-10 branch and the trunk.

David S. Goldberg | 2 Aug 15:14 2005
X-Face
Picon
Picon

Re: insert-buffer vs insert-buffer-substring

>>>>> On Tue, 02 Aug 2005 07:32:44 +0900, Katsumi Yamaoka
>>>>> <yamaoka <at> jpl.org> said:

> I've fixed it just now.  Sorry.

Confirmed.  Thanks!

--

-- 
Dave Goldberg
david.goldberg6 <at> verizon.net

Reiner Steib | 2 Aug 19:57 2005
X-Face

gnus-button-alist: Don't treat " as part MID

Hi,

Gnus treats the trailing quote `"' as part of the MID in case (d) and
(f):

(a) <b4m64uo7ij8.fsf <at> jpl.org>

(b) news:b4m64uo7ij8.fsf <at> jpl.org

(c) <news:b4m64uo7ij8.fsf <at> jpl.org>

(d) "news:b4m64uo7ij8.fsf <at> jpl.org"

(e) <URL:news:b4m64uo7ij8.fsf <at> jpl.org>

(f) "URL:news:b4m64uo7ij8.fsf <at> jpl.org"

AFAICS, `"' can't be part of the domain part, so I suggest apply one
of the following patches.

(1) Minimal change; don't allow `"' ==>  <at> [^>)!;:,\n\t \"]*

--8<---------------cut here---------------start------------->8---
--- gnus-art.el	29 Jul 2005 19:11:46 +0200	6.381.2.46
+++ gnus-art.el	02 Aug 2005 17:23:42 +0200	
 <at>  <at>  -6254,7 +6254,7  <at>  <at> 
 (defcustom gnus-button-alist
   '(("<\\(url:[>\n\t ]*?\\)?\\(nntp\\|news\\):[>\n\t ]*\\([^>\n\t ]* <at> [^>\n\t ]*\\)>"
      0 (>= gnus-button-message-level 0) gnus-button-handle-news 3)
-    ("\\b\\(nntp\\|news\\):\\([^>\n\t ]* <at> [^>)!;:,\n\t ]*\\)" 0 t
(Continue reading)

Russ Allbery | 2 Aug 19:54 2005
Picon

How do I turn off rendering of HTML?

I just upgraded to No and the FAQ information for turning off automatic
display of text/html parts apparently no longer works.  I have:

(custom-set-variables
 '(mm-discouraged-alternatives '("text/html" "text/enriched"))
 '(mm-automatic-display (remove "text/html" mm-automatic-display)))

but w3-mode is still used to render text/html parts when that's the entire
message.  Since w3-mode is painfully slow, this makes sorting through spam
a royal pain.

I've checked with C-h v and mm-automatic-display does not include
text/html.

What's the new magic?

--

-- 
Russ Allbery (rra <at> stanford.edu)             <http://www.eyrie.org/~eagle/>

Russ Allbery | 2 Aug 20:15 2005
Picon

Quoted material manipulation commands

A couple of other things noticed when upgrading to No Gnus....

C-c C-z now trims one fewer blank line.  This is driving me nuts, as it's
destroying my finger memory.  Is there a way to get back to the previous
behavior, or do I need to revert back to my own private implementation of
that feature?

M-RET doesn't appear to reformat the new paragraph any more.  Did I break
something, or was that feature removed?

Also, it no longer correctly handles inserting the whitespace for quoted
text in the form:

>[space][tab]some text some more text
>[space][tab]some text some more text

If I move into the middle of such a paragraph and press M-RET, the first
line of the newly created paragraph after the point starts with just > and
a space, no tab, and the paragraph isn't refilled.

This makes it really difficult to deal with the messages of one of my
regular correspondants.

Thanks in advance for any help!

--

-- 
Russ Allbery (rra <at> stanford.edu)             <http://www.eyrie.org/~eagle/>

Katsumi Yamaoka | 2 Aug 03:05 2005
X-Face

Re: mml.el changes

>>>>> In <m3u0i9mjsh.fsf <at> doze.jochen-kuepper.de> Jochen Küpper wrote:

> With current cvs Gnus I have problems with pgp/mime signed messages.
> See attached message for details.

> ,----
>| GNU Emacs 22.0.50.27 (i686-pc-linux-gnu, GTK+ Version 2.4.14) of 2005-07-31
>| No Gnus v0.4
> `----

> The text of the body is marked as application/octet-stream instead of
> text/plain, as it used to be. Therefore, the message text is not
> visible or only visible as MIME button (application/octet-stream),
> depending on MUA.

> Is there any new configuration necessary or is this simply a bug?

Confirmed.  It's a real problem.  I think it might be necessary
that the mml encoder recognizes the signed (or encrypted) part
as text, though I'm not sure whether it can be done automatically.
Anyway, I'll look into it...


Gmane