Gilbert Harman | 1 May 02:06 2003

Re: tramp failing in new build

Thanks, I somehow missed Kai's suggestion.  Setting process-connection-type
to t corrects the problem (as of today's CVS build).


On 4/29/03 7:37 PM, "Andrew Choi" <akochoi <at>> wrote:

> On 4/25/03 3:17 PM, "Gilbert Harman" <harman <at> Princeton.EDU> wrote:
>> Using today's CVS build in Mac OS 10.2.5, in emacs version,
>> I get the following error message using tramp in a way that was
>> working until today (using a build from a couple of months ago): [...]
> Did you try what Kai suggested?  If so what are the results when you
> did?  Specifically:
>> kai.grossjohann <at> (Kai Gro├čjohann) writes:
>>> Do you still have the old build around?  Did the value of
>>> process-connection-type change?
>>> Does Tramp start to work again if you frob the variable?
> This is very likely the problem because from lisp/ChangeLog:
> 2003-04-14  Andrew Choi  <akochoi <at>>
> * term/mac-win.el: Unconditionally set process-connection-type to nil.
(Continue reading)

Luc Teirlinck | 1 May 04:06 2003

Bootstrapping fails.

Bootstrapping fails.  End of make bootstrap output:

Loading cus-start (source)...
Wrong type argument: integerp, (0 4 3 4)
make[1]: *** [bootstrap-emacs] Error 255
make[1]: Leaving directory `/home/teirllm/CVSemacsdir/emacs/src'
make: *** [bootstrap] Error 2
Richard Stallman | 1 May 05:19 2003

Re: Development package hint in INSTALL for GNU/Linux?

    I've now mentioned the name of the Debian package.  I don't have/know
    Redhat and SuSE, so I can't say about those.

Let's not bother with SuSE.  They develop non-free software,
so let's not give them support.

But let's support Mandrake.  (It may be the same as Red Hat.)
Richard Stallman | 1 May 05:20 2003

Re: Custom question: different default values for different environments?

    The new plan is to require the user to type "/rsh:user <at> host:bla" if
    rsh is to be invoked, and "/remsh:user <at> host:bla" if remsh is to be

I won't argue against it.
Kenichi Handa | 1 May 06:45 2003

Re: utf-translate-cjk-mode question

Sorry for the late response on this matter.

In article <84adej4tmj.fsf <at>>, kai.grossjohann <at> (Kai
Gro├čjohann) writes:
> In my ~/.emacs file, I have this piece of code:

> (when (fboundp 'utf-translate-cjk-mode)
>   (let ((current-language-environment "Chinese-GB"))
>     (utf-translate-cjk-mode 1)))

> I start Emacs.  I open a new file.  I say C-u C-\ chinese-py RET.  I
> then type "nihao" into the buffer.  I say C-x RET f utf-8 RET.  Then
> I try to save the buffer.

> Emacs tells me that it can't encode the Chinese characters, and it
> tried iso-latin-1 and utf-8 as encodings, and now it's suggesting
> gb2312 as the encoding to use.

> Is utf-translate-cjk-mode supposed to enable me to store the file as
> utf-8?

Yes, and this bug is my fault.  My previous change to
find-coding-systems-region-internal was incomplete.  I've
just installed a fix.  Please try again with the latest

> The second question contains the code itself.  I tried to just copy
> and paste it from the original defcustom.  But maybe I did something
> wrong.  After loading all the subst-foo files, there is a let
> statement that binds the symbol `table'.  But after this, nothing is
(Continue reading)

Kenichi Handa | 1 May 08:52 2003

Re: Strange behaviour with dired and UTF8

In article <200304241235.h3OCZdbL023178 <at>>, "Jan D." <jan.h.d <at>> writes:
> Maybe I am doing this wrong, but here is what I try to do.
> My language environment is ISO-8859-1.
> I have a directory that contains files with file names in UTF-8.
> I start dired on that directory.  I want to see the UTF-8 characters
> so I do C-x RET r utf-8.  File names display OK now.

> But when trying to operate on a file, say opening it, I get
> "File no longer exists; type `g' to update Dired buffer"
> It seems that dired does not keep the original file name around, but
> tries to open with the display name representation of the file name.

> When I type g, I loose the UTF-8 coding and files are now displayed
> as ISO-8859-1 again.  Setting buffer coding to UTF-8 does not help.

> Do I have to set file-name-coding-system to UTF-8?  This solves the
> problem, but my file-name-coding-system is really ISO-8859-1, it is
> just this one directory that is UTF-8.

The current Emacs doesn't have a facility to cope with such
a situation well.

How about this?

(1) Make a customizable variable
    file-name-coding-system-alist; the format is the same as

(2) Make the macro ENCODE_FILE and DECODE_FILE to check that
    variable before using file-name-coding-system and
(Continue reading)

Kenichi Handa | 1 May 09:20 2003

Re: Cyrillic vs UTF-8

In article <iluptn9xxp0.fsf <at>>, Simon Josefsson <jas <at>> writes:
> It seems to work, thanks.  Wouldn't it be useful to at least be able
> to customize the fontset?  Requiring use of X resources to get Unicode
> to show up correctly is not user friendly.

Unfortunately, a fontset is not a variable, thus can't be
customized easily.  Another way to modify a fontset is to do
something like this in .emacs.

(set-fontset-font "fontset-default"
		  '("gnu-unifont" . "iso10646-1"))

Ken'ichi HANDA
handa <at>
Kenichi Handa | 1 May 10:10 2003

Re: `set-fontset-font' and ascii characters

In article <87he8kutns.fsf <at>>, Oliver Scholz <alkibiades <at>> writes:
> Is there any special reason why `set-fontset-font' should raise an
> error, if CHARACTER specifies a single byte char? The patch below
> seems to work, but I may be missing something.

Thank you for working on it.

If we change the ASCII font in the fontset of the default
face, I think it should have the same effect as changing the
font of the default face (e.g. changing the font size
results in chaning the frame size).  The reason I inhibitted
changing ASCII font in a fontset is that it seems difficult
to achieve that effect (or at least I didn't know how to do
that when I wrote the code).  Does you change pay attetion
to that?

Ken'ichi HANDA
handa <at>
Kenichi Handa | 1 May 10:27 2003

Re: Cyrillic vs UTF-8

In article <E19A0Ou-0001sm-00 <at>>, Richard Stallman <rms <at>> writes:
>     By the way, all these problems are solved in emacs-unicode.

> Could you report on what work is needed before we
> can release this code?

Dave has compiled the current problems in the file
emacs-unicode/README.unicode.  Some of them (especially
serious ones) are already fixed.

Dave, do you have anything else to add to that file?

I think the most difficult task for releasing that code is
to merge the changes into HEAD.  Emacs-unicode was branched
on 2002-03-01, and since then, there were a lot of changes
in HEAD.

Ken'ichi HANDA
handa <at>

--- README.unicode ---
                                            -*-mode: text; coding: latin-1;-*-

Problems, fixmes and other issues in the emacs-unicode branch

Notes by fx to record various things of variable importance.  handa
needs to check them -- don't take too seriously, especially with
regard to completeness.
(Continue reading)

Martin Jourdan | 1 May 12:31 2003

Mac OS X build fails

I am new to using/building Emacs on MacOS X (although I am not new to 
Emacs in general). I just downloaded the latest Emacs sources from the 
CVS repository, using the instructions from 
<>, and started to build it on my 
MacOS X 10.2.5.

"make bootstrap" fails with the following messages :

./temacs --batch --load loadup bootstrap
Loading loadup.el (source)...
Using load-path (/Users/martin/Documents/Work/x-install/emacs/lisp 
Loading byte-run (source)...
Loading emacs-lisp/backquote (source)...
Loading subr (source)...
Loading version.el (source)...
Loading widget (source)...
Loading custom (source)...
Loading map-ynp (source)...
Loading env (source)...
Loading cus-start (source)...
Wrong type argument: integerp, (0 4 3 4)
make[1]: *** [bootstrap-emacs] Error 255
make: *** [bootstrap] Error 2

Any idea on what causes that?

(Continue reading)