Leo | 17 Dec 18:43 2008
Picon

: (bbdb/gnus-show-sender) still does not work properly

Hi there,

I'd like to report a bug in ':'. Assuming I am browsing a message in
Gnus with both the sender and the CC not in my bbdb db. If I type : ,
bbdb will show a prompt in the echo-area:

  XX XXX is not in the db; add? (y,!,n,s,q,?)

if I type ?, nothing is shown. bbdb then go on and ask me whether I want
to add the contact in CC to db. At this stage even if I type C-g to
quite, the contact in CC is still added.

Cheers,
--

-- 
.:  Leo  :.  [ sdl.web AT gmail.com ]  .: I use Emacs :.

------------------------------------------------------------------------------
SF.Net email is Sponsored by MIX09, March 18-20, 2009 in Las Vegas, Nevada.
The future of the web can't happen without you.  Join us at MIX09 to help
pave the way to the Next Web now. Learn more and register at
http://ad.doubleclick.net/clk;208669438;13503038;i?http://2009.visitmix.com/
_______________________________________________
bbdb-info <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/bbdb-info
BBDB Home Page: http://bbdb.sourceforge.net/

Bill Harris | 28 Dec 17:06 2008

Re: Args out of range: 0, 31 error on move between machines


Bill Harris <bill_harris <at> facilitatedsystems.com> writes:

> FWIW, I figured out that bbdb works okay if Gnus starts okay.  I
> sometimes forget to establish the tunnels I use for Gnus, and that seems
> to confuse bbdb.

After a few more weeks of trial, I've discovered that bbdb works every
other time I start Emacs and Gnus.  That is, if I start Emacs and then
start Gnus, bbdb will fail with the "Args out of range: 0, 31" error.
If I close both and restart Emacs and then Gnus, everything works.  If I
then close Emacs and Gnus and restart both, bbdb will again fail ... and
so forth.

Any ideas what makes bbdb work every other time?  Any state information
that's kept around that might explain the situation?

Thanks,

Bill
--

-- 
Bill Harris                      http://facilitatedsystems.com/weblog/
Facilitated Systems                              Everett, WA 98208 USA
http://facilitatedsystems.com/                  phone: +1 425 337-5541
Leo | 28 Dec 19:41 2008
Picon

Re: Args out of range: 0, 31 error on move between machines

On 2008-12-28 16:06 +0000, Bill Harris wrote:
> Bill Harris <bill_harris <at> facilitatedsystems.com> writes:
>
>> FWIW, I figured out that bbdb works okay if Gnus starts okay.  I
>> sometimes forget to establish the tunnels I use for Gnus, and that seems
>> to confuse bbdb.
>
> After a few more weeks of trial, I've discovered that bbdb works every
> other time I start Emacs and Gnus.  That is, if I start Emacs and then
> start Gnus, bbdb will fail with the "Args out of range: 0, 31" error.
> If I close both and restart Emacs and then Gnus, everything works.  If I
> then close Emacs and Gnus and restart both, bbdb will again fail ... and
> so forth.
>
> Any ideas what makes bbdb work every other time?  Any state information
> that's kept around that might explain the situation?

If a precise recipe to reproduce the bug can be obtained, it will be
much easier to fix it.

I'm also using bbdb from CVS on Emacs GNU Emacs 23.0.60.1
(i386-mingw-nt5.1.2600) of 2008-12-14 on BREPNB. I have not seen this
problem tho.

>
> Thanks,
>
> Bill
> --
> Bill Harris                      http://facilitatedsystems.com/weblog/
(Continue reading)

Bill Harris | 28 Dec 21:29 2008

Re: Args out of range: 0, 31 error on move between machines


Leo <sdl.web <at> gmail.com> writes:

> On 2008-12-28 16:06 +0000, Bill Harris wrote:

>> After a few more weeks of trial, I've discovered that bbdb works every
>> other time I start Emacs and Gnus.  That is, if I start Emacs and then
>> start Gnus, bbdb will fail with the "Args out of range: 0, 31" error.
>> If I close both and restart Emacs and then Gnus, everything works.  If I
>> then close Emacs and Gnus and restart both, bbdb will again fail ... and
>> so forth.

> If a precise recipe to reproduce the bug can be obtained, it will be
> much easier to fix it.

The precise recipe is to close Gnus and Emacs and then to open them
both.  Every other time, it fails.  It doesn't seem to matter if I
reboot in the middle, except that rebooting (and perhaps logging out and
back in, but I'm not sure about that) seems to reset the toggling so
that the next starting of Emacs and Gnus will fail.

AFAICT, simply closing and restarting Gnus isn't sufficient to fix the
problem when it occurs; I have to close both Gnus and Emacs.

> I'm also using bbdb from CVS on Emacs GNU Emacs 23.0.60.1
> (i386-mingw-nt5.1.2600) of 2008-12-14 on BREPNB. I have not seen this
> problem tho.

I'm using Emacs 22.2.1 as modified by Ubuntu (Intrepid) and the version
of Gnus that comes with it (v5.11), along with BBDB 2.35.
(Continue reading)


Gmane