Dr. Gerhard Eber | 10 Aug 10:53 2010
Picon

Problem with AUCTeX installation under Emacs-23.1

I installed AUCTeX 11.86 under emacs-23.1. The configuration worked
straightforward but I cannot start latex (and other executables) from
emacs now. Execution of the same command in a cygwin bash shell works
perfectly. I tried all sorts of workarounds recommended in the web, but
none of them worked. This is the output of my latex command:
---

Running `LaTeX' on `bg' with ``latex  -interaction=nonstopmode "\input" bg.tex''
This is pdfeTeXk, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
 file:line:error style messages enabled.
 %&-line parsing enabled.
entering extended mode
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, bahasa, basque,
bulgarian, catalan, croatian, czech, danish, dutch, esperanto, estonian, finnish, greek, icelandic,
irish, italian, latin, magyar, norsk, polish, portuges, romanian, russian, serbian, slovak, slovene,
spanish, swedish, turkish, ukrainian, nohyphenation, loaded.
! I can't find file `bg.tex'.
<*> \input bg.tex

Please type another input file name
! Emergency stop.
<*> \input bg.tex

No pages of output.
Transcript written on texput.log.

LaTeX exited abnormally with code 1 at Tue Aug 10 10:50:34

---
(Continue reading)

Ralf Angeli | 11 Aug 18:12 2010
Picon

Re: Problem with AUCTeX installation under Emacs-23.1

* Gerhard Eber (2010-08-10) writes:

> I installed AUCTeX 11.86 under emacs-23.1. The configuration worked
> straightforward but I cannot start latex (and other executables) from
> emacs now. Execution of the same command in a cygwin bash shell works
> perfectly.

Does it work if you start Emacs from a Cygwin terminal?

--

-- 
Ralf
Ralf Angeli | 12 Aug 17:37 2010
Picon

Re: Problem with AUCTeX installation under Emacs-23.1

Please keep the mailing list copied!

* Gerhard Eber (2010-08-12) writes:

> Ralf Angeli <angeli <at> caeruleus.net> writes:
>
>> * Gerhard Eber (2010-08-10) writes:
>>
>>> I installed AUCTeX 11.86 under emacs-23.1. The configuration worked
>>> straightforward but I cannot start latex (and other executables) from
>>> emacs now. Execution of the same command in a cygwin bash shell works
>>> perfectly.
>>
>> Does it work if you start Emacs from a Cygwin terminal?
>
> The behaviour is the same from a Cygwin terminal. I checked the
> environment with the command 'env' in emacs and in a bash-shell, I also
> set the most important environment variables in the cygwin shell to the
> values which I found in emacs, but nothing changes.

Hm, perhaps Emacs uses a different shell?  What's the output of
C-h v shell-file-name <RET>
?

--

-- 
Ralf

Gmane