bernie | 1 Jul 01:37 2006
Picon
Picon

Failed Product Load - No module named program.config

I get the subject error when trying to load a new product.  Would appreciate 
any advise.

The relavent portion of the traceback follows:

2006-06-30T18:32:05 INFO(0) program Installing Product
------
2006-06-30T18:32:05 ERROR(200) Zope Could not import Products.tt
Traceback (most recent call last):
  File "C:\Program Files\Plone 2\Zope\lib\python\OFS\Application.py", line 
673, in import_product
    product=__import__(pname, global_dict, global_dict, silly)
  File "C:\Program Files\Plone 2\Data\Products\tt\__init__.py", line 59, in 
?
    from Products.program.config import *
ImportError: No module named program.config
------
2006-06-30T18:32:14 INFO(0) Zope New disk product detected, determining if 
we need to fix up any ZClasses.
------
2006-06-30T18:32:14 INFO(0) Zope Ready to handle requests
------
2006-06-30T18:32:43 PROBLEM(100) Quick Installer Tool:  tt
exceptions.ImportError: No module named program.config
------
2006-06-30T18:32:43 PROBLEM(100) Quick Installer Tool:  tt
exceptions.ImportError: No module named program.config
------
2006-06-30T18:32:43 PROBLEM(100) Quick Installer Tool:  tt
exceptions.ImportError: No module named program.config
(Continue reading)

Martin Aspeli | 1 Jul 01:55 2006
Picon
Picon

Re: Failed Product Load - No module named program.config

bernie wrote:
> I get the subject error when trying to load a new product.  Would appreciate 
> any advise.
> 
> The relavent portion of the traceback follows:
> 
> 2006-06-30T18:32:05 INFO(0) program Installing Product
> ------
> 2006-06-30T18:32:05 ERROR(200) Zope Could not import Products.tt
> Traceback (most recent call last):
>   File "C:\Program Files\Plone 2\Zope\lib\python\OFS\Application.py", line 
> 673, in import_product
>     product=__import__(pname, global_dict, global_dict, silly)
>   File "C:\Program Files\Plone 2\Data\Products\tt\__init__.py", line 59, in 
> ?
>     from Products.program.config import *
> ImportError: No module named program.config

The product 'program' is broken; either you renamed the directory from 
something else to 'program' (which won't work), or the product itself is 
  non-functional from whatever source you got it from.

Martin

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
Rob Miller | 1 Jul 05:56 2006

Re: Question on plone/zope vs ordinary database storage

Bernt Drange wrote:
> I am about to set up new pages for a tango club, and I'm considering
> using plone. On these pages I want to set up a membership database
> where we can store names and addresses for members, handle sign ups
> for courses and generate various reports on course attendance.
> 
> It seems that zope has an advanced object system that makes it
> possible to create this system natively - my question is if this is
> the most practical way to do things, or if I should just do everything
> with an ordinary database, like I'm used to do things, perhaps using
> SOAP or other means of communication between zope/plone and the
> membership database.
> 
> Any advice, please?

if you don't have a compelling reason to use an RDBMS (e.g. needing to 
integrate w/ an existing RDBMS system) you'll almost certainly be happier w/o 
it.  i'd recommend trying to work w/ just the ZODB at first, and if, for some 
reason, you find that it doesn't meet your needs, then you can consider 
switching to an RDBMS.

i'd be quite surprised if it turns out that you need to switch, though.

> I hope to create a system that is easy for other people to take over
> when I retire as web administrator.

the less complexity, the better.  in plone's case, introducing an RDBMS 
introduces complexity.

-r
(Continue reading)

Alexander Limi | 1 Jul 08:15 2006

Re: How do I get a local copy of the plone api on my computer

On Fri, 30 Jun 2006 12:23:48 -0700, Mark Phillips  
<mark@...> wrote:

> How can I get a local copy of the plone api on my computer? I will be
> travelling next week and I won't have access to the Interent?
>
> Is there a portable version of the documents section of the plone site?

Install DocFinderTab, the Plone API is in Plone itself:

http://plone.org/products/docfindertab

--

-- 
_____________________________________________________________________

      Alexander Limi · Chief Architect · Plone Solutions · Norway

  Consulting · Training · Development · http://www.plonesolutions.com
_____________________________________________________________________

       Plone Co-Founder · http://plone.org · Connecting Content
   Plone Foundation · http://plone.org/foundation · Protecting Plone

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
Alexander Limi | 1 Jul 08:20 2006

Re: rss broken on plone 2.1.2

I believe Plone 2.1.3 fixed this.

On Fri, 23 Jun 2006 16:23:11 -0700, Tracy R Reed  
<treed@...> wrote:

>
> I recently installed Plone 2.1.2 at my company as a sort of
> intranet/wiki/blog portal. It has been a big hit and everything is
> working great except for the RSS feed which some people would like to be
> able to use. I have enabled syndication but when I click on the link I
> get this traceback in the error log:
>
> Traceback (innermost last):
>    Module ZPublisher.Publish, line 115, in publish
>    Module ZPublisher.mapply, line 88, in mapply
>    Module ZPublisher.Publish, line 41, in call_object
>    Module Shared.DC.Scripts.Bindings, line 311, in __call__
>    Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
>    Module Products.CMFCore.FSPageTemplate, line 195, in _exec
>    Module Products.CMFCore.FSPageTemplate, line 134, in pt_render
>    Module Products.PageTemplates.PageTemplate, line 104, in pt_render
>     - <FSPageTemplate at /intranet/RSS used for /intranet/index_html>
>    Module TAL.TALInterpreter, line 238, in __call__
>    Module TAL.TALInterpreter, line 281, in interpret
>    Module TAL.TALInterpreter, line 507, in do_setLocal_tal
>    Module Products.PageTemplates.TALES, line 221, in evaluate
>     - URL: file:CMFPlone/skins/plone_templates/RSS.pt
>     - Expression: standard:u'context/rssAllowed'
>     - Names:
>        {'container': <PloneSite at /intranet>,
(Continue reading)

Donna Snow | 1 Jul 09:49 2006
Picon

Second Zope instance on Virtual Server

Hi All,

Situation is this:

My client is currently hosted at zettai.net on a Zope 2.7 instance (no
Plone)..I've been working in a dev environment building a Zope 2.9/Plone 2.5
setup for him so he can incorporate membership capabilites (now that he has over
10,000 readers of his daily newsletter). 

I need to setup a secondary Zope instance (zope 2.9/plone 2.5) on his virtual
server at zettai.net without affecting the zope instance he has currently. I
want to be able to build his site..load his content without taking down what he
has already.. and then we'll redirect dns to his new zope/plone instance. I'm
not even sure how to start. Anyone know of a tutorial for adding a new zope
instance (that isn't necessarily the same version as the one currently on his
virtual server?)

I have root access to the virtual server and know how to add products.. stop and
start zope.. etc. 

Donna M. Snow
C Squared Technologies

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
dieter | 1 Jul 09:58 2006
Picon

Re: ZODB mount points within plone site

Steve Feehan wrote at 2006-6-29 17:02 -0400:
>We would like to have multiple ZODB databases mounted within a plone site. Say:
>
>/plone-site
>/plone-site/one
>/plone-site/two
>
>The idea is that we would like to move the content under one of these
>mount points to another zope server... say from development
>environment to production.

What you plan to do it very risky and brittle:

  The problem you have already encountered is only one instance
  of a more general problem:

     When you mount something which is not self contained
     and expected to interact with the environment (such
     as cataloguing on creation/modification) this
     interaction happens (of course) only in the a single
     (the active) environment.

  To make it concrete for your example:

     When you have mounted subcontent "C" in sites "S1" and "S2", and
     you modify "C" via "S1", then both "S1" and "S2" will
     see the direct change "C" *BUT* only "S1" will have its
     catalog updated, not "S2".

     That's because "S1" nor "C" does not have any knowledge
(Continue reading)

dieter | 1 Jul 10:04 2006
Picon

Re: If user hasn't logged in within 90 days then don't login.

ianripping wrote at 2006-6-30 05:58 -0700:
>This sounds so simple - and it would be using php... but im not.
>
>Can anyone give me a simple instruction on how to change the plone login
>script to check wether the user who is logging in has logged in within the
>last 90 days.

What have you tried? And in what way it failed?

In your original post, you listed a "getLastLogin" method definition.
Does it return the correct last login time?

If it does, where and how do you use it to implement your special
(and in my view a bit doubtful) business logic.
In what way does it fail? Do you get the correct result when
you call your business logic script (hope you use one rather than
inline code in a PageTemplate) separately?

--

-- 
Dieter

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
dieter | 1 Jul 10:09 2006
Picon

Re: Starting Plone on localhost causes username/password prompt

bernie wrote at 2006-6-30 09:16 -0500:
>I am developing a Plone application on a Windows XP localhost using Firefox 
>as my browser.
>
>Sometimes when I start Plone my site opens to the default page as I expect 
>it to.  Other times I am challenged for a user name and password.  The admin 
>user is not accepted so I exit and try again until it opens to my site's 
>default page.
>
>What is causing this behavior?

Difficult to say...

You should check whether the "Unauthorized" comes from Zope
(or from something else). To do this, you
would reconfigure "error_log" not to ignore "Unauthorized" exceptions.
Then, when your error occurs, you would check what the
"error_log" object tells you about the error. If it does not
know anything about it, then the "Unauthorized" is probably done
not by Zope but something else.

Be aware, that a Plone setup may have several "error_log" objects:
one in the Plone instance and one in Zope's "Root folder".
You may need to reconfigure and look into both of them.

--

-- 
Dieter

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
(Continue reading)

dieter | 1 Jul 10:11 2006
Picon

Re: PlonePAS login/cookie problem

Nick Owen wrote at 2006-6-30 14:28 -0400:
>Greetings.  I am trying to install plonepas so i can play with the some of
>the plugin code.  Unfortunately, installing plonepas somehow breaks cookies
>and prevents users from logging in.  I have seen that others have had this
>problem or similar, but this is with a completely new plone site in a
>separate folder.  There is no webserver between zope and the browser.  The
>url is http://localhost:8080/pastest/pastest.  The error is:
>
>"While cookie authentication is disabled, cookie-based login is not
>available."

I do not use PlonePAS and therefore can not give a definitve answer.

However, (purely interpreting the error message) I think
that the message is generated by PlonePAS. It thinks that you
do not have cookie authentication enabled.

If this is right, see how you can enable cookie authentication in
PlonePAS.

--

-- 
Dieter

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

Gmane