Fabio Coatti | 3 Oct 10:18 2006
Picon

Error in new folders scan

I've started booh after some time (and upgrades) of my linux box, and now each 
scan for changes stops with this error:

cova <at> hobbes ~ $ booh
booh-backend --merge-config-onedir '/tmp/boohtemp.13947.0' --dir
'/home/cova/booh/fabiocoatti/fabiocoatti' --for-gui --verbose-level 
2 --comments-format '%t' --info-pipe /tmp/boohpipe.13947.0
/usr/lib/ruby/site_ruby/1.8/gtk2.rb:13:in `init': 
Opzione --merge-config-onedir sconoscuta (RuntimeError)
        from /usr/lib/ruby/site_ruby/1.8/gtk2.rb:13
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/lib/ruby/site_ruby/1.8/booh/booh-lib.rb:32
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/bin/booh-backend:28

It's likely that some upgrade has broken something, but I can't figure what. 

Can someone give some hint?

Many thanks in advance.

--

-- 
Fabio "Cova" Coatti    http://members.ferrara.linux.it/cova     
Ferrara Linux Users Group           http://ferrara.linux.it
(Continue reading)

Guillaume Cottenceau | 3 Oct 11:58 2006
Picon

Re: Error in new folders scan

On 10/3/06, Fabio Coatti <cova <at> ferrara.linux.it> wrote:
> I've started booh after some time (and upgrades) of my linux box, and now each
> scan for changes stops with this error:
>
> cova <at> hobbes ~ $ booh
> booh-backend --merge-config-onedir '/tmp/boohtemp.13947.0' --dir
'/home/cova/booh/fabiocoatti/fabiocoatti' --for-gui --verbose-level
> 2 --comments-format '%t' --info-pipe /tmp/boohpipe.13947.0
> /usr/lib/ruby/site_ruby/1.8/gtk2.rb:13:in `init':
> Opzione --merge-config-onedir sconoscuta (RuntimeError)

Stupid ruby-gnome2-0.15.0 passes all program arguments to gtk. You
need to fix rg2 with the following patch:

http://zarb.org/~gc/t/ruby-gnome2-0.15.0-unbreak-on-args.patch.bz2

--

-- 
Guillaume Cottenceau - http://zarb.org/~gc/

Gmane