George W. Maschke | 13 Jun 15:46 2014
Picon

[jitsi-users] Jitsi TLS Protocol and Cipher Suite

When I call other jit.si users, I see the following details at the top
of the technical call info:

Call information :
Identity : georgemaschke@... (Jabber)
Signalling call transport : TLS TLS protocol : TLSv1
TLS cipher suite : SSL_RSA_WITH_RC4_128_MD5

Is there any reason why TLS 1.2 and a stronger cipher suite with PFS
couldn't be used, for example TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384?

- George Maschke

Attachment (smime.p7s): application/pkcs7-signature, 5073 bytes
_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
Fernando A | 13 Jun 14:00 2014
Picon

[jitsi-users] can't connect to hotmail

Hello everyone,

I installed jitsi first. When I have connected, I obtained next message "you have logged in more once with the same account"
but I have not connected at hotmail.
Any idea how I can fix?
Best regards,
Fernando

_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
Kl Trm | 12 Jun 18:48 2014
Picon

[jitsi-users] (no subject)

what encryption uses Jitsi Meet? Does it use zrtp? Or is like the Video Calling Made Easy - Gruveo encryption?
Thanks.
Jitsi Meet
Join a WebRTC video conference powered by the Jitsi Videobridge
Preview by Yahoo

 
_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
up sv | 12 Jun 16:10 2014
Picon

[jitsi-users] screen sharing on VMware/Hyper-V environment

Hi

I am having trouble testing jitsi's screen share over VM(VMware/Hyper-V) guest OS
environments and like to know if this is an issue or limitation. My testing environment and results
are as follows.

----------------------------------------
[Environment]

- Server side:  openfire + jitsi video-bridge plugin (both latest release)
- Client side :   Windows7Pro SP1 + jitsi (latest release)
- Network:  same IP address segment (no firewalls)

Using Same Client OSs + jitsi client, I've tested screen sharing on following pattern
(DesktopPC means normal PC(no virtual machine))

1)  Desktop PC1 <-> Desktop PC2
2)  Desktop PC1 <-> VM guest2(Vmware/Hyper-V)
3)  VM guest1  <-> VM guest2
           

[Results]

1)   screen sharing OK on both sides.
2)   VM guest2 ->  Desktop PC1 screen sharing is OK
      Desktop PC1 -> VM guest2 sceen sharing is NG ( black screen)
3)    screen sharing NG on both sides (black screen).

#tested over couple VMware/Hyper-V version, but results are the same.

-------------------------------------------

On VM guest environment, it seems

- encoding it's own screen and sending capability works OK
- receiving and decoding capabilty have issues (or limitation)

I suspect  some DirectX(DirectShow/Direct3D) limitation on VMs...

Any clues, suggestion, workaround is appreciated

Best Regards,
Toru HIROSE
_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
Doron Tsur | 12 Jun 14:54 2014

[jitsi-users] Implementing Peer to Peer Chat/video/audio

Hey Jitsi users,

 

This might be the wrong list. If it is I'm sorry. I would publish on the dev list, but I'm not a jitsi developer. I have a few questions:

 

1.       Is there a way to use Jitsi capabilities in peer to peer ?(Jingle)

2.       I saw that Jitsi used to use (or is using) C++ code for video/audio. Does libjitsi has a pure java mode?

3.       Does jitsi have some capabilities to perform remote access? To actually control the other person's computer or is it pure Web-Conference?

4.       WebRTC and jitsi looks really interesting, anywhere I can read up on that?

 

Good Day,

Doron Tsur

 

Doron Tsur | Software Developer | T  +972 (3) 767 3041

Centralized OT Security Management for Distributed SCADA/ICS Networks

 

 

 

 

_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
Gillian "Gus" Andrews | 11 Jun 18:04 2014

[jitsi-users] Contact list and connection bugs in OSX


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Hi all,

Following my mail inquiring how to file bugs, Emil suggested I post the
series of bugs I found in getting Jitsi to run on my Mac here.

I apologize, profoundly, in advance -- this is a LOT to send you at
once, particularly when I haven't participated on this list much before.
As I mentioned before, I work for the Open Internet Tools Project, where
helping improve usability is my job, so I can devote time to testing
this with you. We might also be able to help find more developers who
might be willing to help get these problems taken care of. Hackathons
are one thing we sometimes do :)

I have checked the mailing list for a few of these bugs, but couldn't find
answers. I felt it was a good idea to send them together; many of them
seem related.

Here is what I found, with some recommended solutions. I have
screenshots for these if they would help. All of these bugs were found
when communicating from a Mac running either OS 10.9.x or 10.8.x and the
latest version of Jitsi, communicating to a Linux laptop using Ubuntu
with the latest version of Jitsi.

BUG #1:
In both Mac 10.8 AND 10.9:
Open Add Contact window. Select SIP myaccount@... . I enter the
name of the contact in ID or Number, WITHOUT adding ostel.co at the end.
Jitsi does not pop up an alert warning me this might be a problem or
asking me if I mean  <at> ostel.co .
The contact is added to the list. Mousing over it, I see it is
registered as ContactName@... . When that contact is online,
however, Jitsi does not list them as online, and I cannot put a call
through to that contact.
When I try to initiate a chat, it opens the window and appears to send
text without any indication that the contact is invalid.
When I delete that contact, and add it again as ContactName@...,
Jitsi DOES list them as online when they are online.
I have tried this process in adding two separate contacts, both of whom
were on ostel.co .

THE PROBLEM:
This makes it look to the user as if the ostel.co contact has been added
without any problems, but then it looks as if their contacts are never
online.

RECOMMEND:
1) Separate the workflows for registrarless SIP accounts and registrar
SIP accounts.
2) For ostel.co (and possibly other) registrar SIP accounts, prompt
users to add in the domain name if they only put in ID
OR
Fix the autocomplete that adds the registrar to IDs without registrar,
so that calls can successfully go through.

BUG #2:
In Mac 10.9:
In trying to fix the contact problem in Bug #1, I was able to add a
second account that was ContactName@... . When I did this, each
ContactName@... contact was able to see the chat history of the
other account. I assume it happened because Jitsi was seeing one as
registrarless, even though it had added ostel.co at the end of the ID.
(When I tried to re-create this problem a second time, Jitsi did warn me
that I had two contacts with the same address and wouldn't let me create
the second one. I am not sure how I was able to do it the first time, as
both times I made one account with just ContactName and one with
ContactName@...)

THE PROBLEM:
It is probably not good that two distinct contacts could be added with
the same ID. It is definitely not good that the chat history of one is
displayed for the other.

RECOMMEND:
1) Make sure that the check to see if an address is a duplicate is
functioning correctly. I am assuming that distinguishing between
registrarless and registrar SIP accounts may help with this.
2) Ensure that the chat histories of accounts are indexed correctly.

BUG #3:
In Mac 10.9:
When I deleted the duplicate accounts from Bug #2, then added the
account again to continue my test, the chat history for the deleted
account still appeared.

THE PROBLEM:
In the community of users I work with (human rights activists and
journalists), conversations being stored on a user's machine can be a
matter of life and death if a machine is seized by police, governments,
or criminals. I assume that most of our users will choose not to save
their chat histories as a result, but in case they do, we should protect
their contacts by deleting chat history along with a deleted contact.

RECOMMEND:
When a user deletes a contact, prompt if they would like the chat
history for that contact erased as well.

BUG #4
In Mac 10.9:
I can't find a way to delete chat history. Unclicking "log chat history"
does not do it.

THE PROBLEM:
May be PEBCAC (Problem Exists Between Computer And Chair), i.e. it's my
fault I can't find this ;) However, it should be relatively clear to
users how to do this. Again, for users in sensitive situations, it will
be important to make this an option.

RECOMMEND:
Put a "delete chat history" capability within the chat window.

BUG #5:
In Mac 10.9:
When there are two contacts with the same name, selecting "Remove
Contact" by right-clicking on the contact name sometimes doesn't work.

RECOMMEND:
Not sure what to recommend, as this seems to be a technical problem
rather than usability.

BUG #6
In Mac 10.9:
After multiple times adding and deleting a contact while testing, a SIP
contact appropriately entered as ContactName@... did not appear as
online (grey icon, not green), when the contact confirmed to me in a
side channel that he was in fact online.

RECOMMEND:
Again, a technical problem, I'm not sure what to suggest. Try adding and
removing the same contact as registrarless and registrared multiple
times to re-create.

BUG #6:
In Mac 10.9:
Despite the contact being greyed out in Bug #5, I was still able to
initiate a call to the contact.
The call window popped up. The status registered as "incoming call" on
his end, then "connecting" on both our ends. This took a very long time,
and nothing happened. Then the status changed to "ringing," though the
ring noise did not play.

RECOMMEND: again, a technical problem, I'm not sure what to suggest.

BUG #7:
In Mac 10.9:
Red "hang up" button in call window does not work while calls are
pending, or after incoming call has been accepted. Happens in multiple
calls to this user.

RECOMMEND: again, a technical problem, I'm not sure what to suggest.

BUG #8:
In Mac 10.9:
When receiving a call from this same contact (when his indicator was
green and he was in fact online), green phone button in the "incoming
call" alert pulled up the call window but did not open the voice
channel. Calling beep continued.

RECOMMEND: again, a technical problem, I'm not sure what to suggest.

BUG #9:
In Mac 10.9:
My contact initiated a second call while the first was pending. Rather
than give me a warning or canceling one call, Jitsi made two beeping
noises instead of one.

RECOMMEND:
Don't allow two calls from the same caller; end one to begin another? I
am not sure whether two calls from the same caller is a desired attribute.

BUG #10:
In Mac 10.9:
I was unable to establish an audio connection to the contact above at
any point. His install of Ubuntu seemed to be missing some audio drivers
(only PortAudio was available in his Options), so that may have been the
problem. However, Jitsi did not make it clear to either of us that that
was the problem; the connection simply never appeared to go through.

RECOMMEND:
More-specific messaging about the nature of the problem when a
connection does not go through.

BUG #11:
In Mac 10.8 -- this was with a different contact:
When a call was established, and my webcam was on, user on the other end
(using Ubuntu on a laptop with a built-in camera) heard a constant,
repeated high-pitched beeping noise, sort of like a heart monitor in a
hospital. Likewise, when the other user's webcam was on, I heard the
high-pitched beeping noise.

RECOMMEND:
Not sure if this is supposed to be a feature -- does the beep let you
know the other person can see you because their webcam is on? If it is a
feature, it needs to be clearer how to turn it off. If it is a bug, it
should be dealt with accordingly.

If you'd like my help in confirming these bugs or getting more
information about them, I'm on IRC most weekdays on US East Coast Time
(GMT-4); I'm gusgus in #openitp on freenode, and I've started hanging
out in #jitsi too :)

Regards,
Gus

- -- 
Gillian "Gus" Andrews
Senior Program Associate, Secure User Practices
Open Internet Tools Project
openitp.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.22 (Darwin)
Comment: GPGTools - https://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQEcBAEBCgAGBQJTmH4NAAoJEOrwrs2Zrn53l3UIAI+9/zrUWsG26seIOfYdzRuW
ul2beVdkBuHcJzWNwLtXbHOhReTcrJXUGaI3WXYg8xVRCRkTxleBgJmIvmDz+TBf
DGr51NGADljURV/ed304JCBjopxYzUvQRJ+sSRclzcL8KOoLVI6BHJ9W61craWmJ
TnzeqKGKiGjSgXGputuaR6ezcn2EAejMJ3Y+V+qhCGp+ze8/1Bcbs2vpYx028kCd
hBhUbCH6wPJrJhRbakQrzQsF8q2UOb2wAaIDwwRFe5nnYhuiWl40ZLWJSX+xCgGp
pNy674zr++k/Ur6wvpJmBGEII2m/eK55XZ0bCo+5s4NzsKjliFmhjY7hcGdfgnQ=
=gl56
-----END PGP SIGNATURE-----

_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

Emil Jacobs | 11 Jun 13:16 2014
Picon

[jitsi-users] New and question

Hello everyone,

I'm the usser that opened issues 78, 79 and 80. Sorry for breaking netiquette on that!
I'll be watching this mailinglist with interest. I've currently version 117 deployed on my VPS and it works okay overall.

I do have a question, regarding screensharing: I couldn't find in the installation documentation how to enable this. Could someone point me to some extra documentation regarding this or explain how to enable it?
Regards,

Emil / Q-collective
_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
Cpp | 10 Jun 07:24 2014
Picon

[jitsi-users] Splash screen annoyance

Hi

I have a recent jitsi nightly build installed on Windows 7. I've
configured jitsi to start at windows boot/startup. The thing is that
each and every time I login after booting Jitsi will show its loading
splash screen, and then the main window. Is there a way to make jitsi
not display the splash screen at windows startup?

I'm not asking to get rid of the splash screen, just that it should
only be shown when a user starts jitsi manually, but not when jitsi is
configured to run at boot/login (and it should also start minimized to
tray icon).

Thoughts?

Regards!

_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

rains | 8 Jun 19:46 2014
Picon

Re: [jitsi-users] users Digest, Vol 15, Issue 7

I see this prob. also on Mac, jit.si to jit.si is fine all services available; txt, Audio and vid. But
jabber.org to jit.si even with over-ride default sever shows as off-line permanently. Txt goes but
replies aren't visible or received! Not sure which.

Rains

Sent from my iPhone

> On 07 Jun 2014, at 12:00, users-request@... wrote:
> 
> Send users mailing list submissions to
>    users@...
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    http://lists.jitsi.org/mailman/listinfo/users
> or, via email, send a message with subject or body 'help' to
>    users-request@...
> 
> You can reach the person managing the list at
>    users-owner@...
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of users digest..."
> 
> 
> Today's Topics:
> 
>   1. Problem XMPP service - communicate with another server
>      (Piotr Kiszka)
>   2. Re: Problem XMPP service - communicate with another    server
>      (Emil Ivov)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Fri, 6 Jun 2014 13:36:25 +0200
> From: Piotr Kiszka <piotrkisz@...>
> To: users@...
> Subject: [jitsi-users] Problem XMPP service - communicate with another
>    server
> Message-ID:
>    <CAAkRL1EphkkKGzOR1tgRQfoB5v1u_9acY4p_LV_fm+0mALgc=g@...>
> Content-Type: text/plain; charset="utf-8"
> 
> Hi,
> 
> I am using jit-si XMPP service and I have problem with communicate with
> users of jabber.org. Can't see the statuses, All buddy's are indicated as
> offline (but they shouldn't be). Messages don't go through (in very rare
> cases they do).
> 
> Is this known problem? Maybe this is problem connected to encrypted
> communication between servers?
> 
> Cheers
> vyrly
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.jitsi.org/pipermail/users/attachments/20140606/f05f026d/attachment-0001.html>
> 
> ------------------------------
> 
> Message: 2
> Date: Sat, 7 Jun 2014 01:28:14 +0300
> From: Emil Ivov <emcho@...>
> To: Jitsi Users <users@...>
> Subject: Re: [jitsi-users] Problem XMPP service - communicate with
>    another    server
> Message-ID:
>    <CAPvvaaJuOgtoLrQE5ba7URJ6EzUacP7_QqXZOUvQknujUW2_mQ@...>
> Content-Type: text/plain; charset="utf-8"
> 
> Hey Piotr,
> 
> It is something that is a problem every now and then ... we'll see what we
> can do
> 
> --sent from my mobile
>> On 06 Jun 2014 2:37 PM, "Piotr Kiszka" <piotrkisz@...> wrote:
>> 
>> Hi,
>> 
>> I am using jit-si XMPP service and I have problem with communicate with
>> users of jabber.org. Can't see the statuses, All buddy's are indicated as
>> offline (but they shouldn't be). Messages don't go through (in very rare
>> cases they do).
>> 
>> Is this known problem? Maybe this is problem connected to encrypted
>> communication between servers?
>> 
>> Cheers
>> vyrly
>> 
>> _______________________________________________
>> users mailing list
>> users@...
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.jitsi.org/pipermail/users/attachments/20140607/9eabc890/attachment-0001.html>
> 
> ------------------------------
> 
> _______________________________________________
> users mailing list
> users@...
> http://lists.jitsi.org/mailman/listinfo/users
> 
> 
> End of users Digest, Vol 15, Issue 7
> ************************************
Attachment (smime.p7s): application/pkcs7-signature, 3133 bytes
_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
Piotr Kiszka | 6 Jun 13:36 2014
Picon

[jitsi-users] Problem XMPP service - communicate with another server

Hi,

I am using jit-si XMPP service and I have problem with communicate with users of jabber.org. Can't see the statuses, All buddy's are indicated as offline (but they shouldn't be). Messages don't go through (in very rare cases they do).

Is this known problem? Maybe this is problem connected to encrypted communication between servers?

Cheers
vyrly
_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
Hermann Grell | 6 Jun 08:44 2014
Picon
Picon

[jitsi-users] Jitsi.org website translation

Hi ,
 
is there any plan or activity to translate the Jitsi website into other languages?
I would be willing to help translating.
 
regards,
Hermann
 
_______________________________________________
users mailing list
users@...
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

Gmane