asad ali | 10 Jan 15:27 2012
Picon

cannot create wav file

Hey,

I'm having trouble running the voipong tool successfully. I'm unable to generate *.wav file for the session. I'm using the latest version 2.0 and my o/s is backtrack v5. The voip phone in my case are both cisco 7691 models. I'm not using arp poisoning at the moment I'm just trying to sniff direct calls made to ip phone.

The error msg is given in the screenshot in the link http://postimage.org/image/q4v6pj2rb/. Kindly help me move forward.



regards,
asad

Iqbal | 20 Jun 21:13 2005
Picon

sniffing and changing names of stored files

Hi

I looked into the managemtn console where it displays the NODE1/NODE2 
details, is there anyway i can get these details attached to the 
filename which is stored as opposed to existing file details.

I also seem to have 2 files per recording which I am them combining. 
This is not a problem but I am wondering why i get one file from the 
caller and one from the callee.

Does the raw RTP data contain anyother info which might be useful i only 
wish to record some of my calls and not others and currently all calls 
are going to a pstn gateway, whos IP address I get, but the origination 
IP always seems to be my mediaproxy (SER) which I am using not the node 
which is originating the call.

tks
Iqbal

Torkel Dominique | 13 Jun 00:21 2005
Picon
Picon

problem with calls not removed

Hello Murat,

 

Thanx for a great piece of software! Just what I was looking for..

 

However, I have a problem with calls not being removed from the calllist. The wav files are created and the log says “maximum waiting time [10 secs] has been elapsed…” but when I do calllist from the mgn console the call is still there. Also, after a few calls, new calls are not being detected until I restart the voipong daemon.

I’m running on a RedHat Fedore Core 3 and calling from a I3Micro Vood terminal adapter (SIP) to a Cisco pstn gw. I can provide you with ethereal traces if you like.

 

Another problem occurs when I use the default codec in the Vood, G711 A (PCMA/8000); the output wav seems to be corrupt, only noise is heard… G711 U works find though.

 

Regards,

Torkel

Gabor Esperon | 31 May 04:00 2005

voipong raw format

When voipong is handling a non supported format as G729, 
it leaves the "raw" packet in the output 
directory.... what is the format of that file?

Ramamohan Yeggoni | 22 May 22:48 2005
Picon

Create_wave!

Hi 
Thank you for sharing such a fancy tool.

This tool generates two separate rtp raw payload files for forward and reverse 
directions.Please clarify whether this tool gives single output wave file for 
both directions? 

It seems, in create_wave function, using sox utility the raw payload gets 
converted to wave in separate output wave files. Also, create_wave() function 
does not convert raw payload to wave if the payload type is other than g711 u 
law. please correct me if i am wrong.

In our environment we are using g711 a law codec. I have captured rtp payload 
using winpcap and saved into a file. This raw payload has been converted to 
wave using sox utility. While playing back, one way conversation is clear and 
other way conversation is played back at much slower rate. 
If I save the payload in separate files for forward and reverse directions, 
after convertion to wave, clarity of the both files is good.

If you have any idea on generating single output wave file for both directions 
please let me know.Any help in this regard is highly appreciated.

Thanks and Regards,
Ram

Jonathan Wilson | 27 Apr 17:36 2005
Picon

Re: voipong.conf example.

Fabian Cerro <fcerro <at> ...> writes:

> 
> Hi,
> Can anybody send me one example of voipong.conf file?
> I have installed voipong on redhat fedora and only modified device
> parameter.
> The program is ok but doesn't collect calls.
> Thank in advance,
> 
> Fabian 
> 
> 

Which VoIP client application are you using? If it's kphone then you will need
to   use the development version of voipong. Then the calls were detected but I
still have a problem with the audio encoding. See my earlier posts for my
experiences, it might be helpful in your case too. 

Clement Chen | 21 Apr 11:36 2005
Picon

help! voipong failed to work after 1 call was captured

Hi,
    Thanks a lot for sharing such a fancy tool. I use Linux Fedora core 2.6.11-
1.1240_FC4 with sox 12.17.6 and libpcap-0.8.3-11. I can compile voipong-devel 
successfully. However, when I started voipong, it always detects only the 
first SIP call (g.711 ulaw encoding in my case), and then doesn't work any 
more. The management port is still alive. When I telneted to the management 
port and used "calllist" to check, I found that timer for that call session 
was still counting (But the log said that .wav file was generated successfully 
after the default 10-second timeout for a end-of-call hit). In 
addition, "killsession" always showed me errors and therefore what I could do 
is shutdown and restart voipong.
    BTW, I can't hear correct call conversations in those .wav files. It seems 
that my call conversations are not correctly captured.
    Any comments will be appreciated. Thanks a lot!

Clement.

Murat Balaban | 15 Apr 13:03 2005

Re: Voipong help


Hi, Please try development version. If kphone sends RTP packets
to a fixed IP/port pair; then development version can detect 
those calls. You'll need to specify your ip and catching algorithm
in voipongnets file. Please have a look at it.

In version 1.2 I'll try to design another algorithm which does not
need RTCP traffic but can detect voice just by looking at RTP
packets.

Regards

On Thu, Apr 14, 2005 at 03:21:51PM +0000, Jonathan Wilson wrote:
> Hi,
> 
> I posted on the Voipong mailing list last week but I didn't get a reply. 
> Anyway I read your FAQ again and I think my problem is that kphone does 
> not send the RTCP packets that Voipong is looking for.
> 
> In that case, can you recommend another VoIP client that will definitely 
> work with Voipong? I was going to try SJPhone next, have you tested this 
> one?
> 
> I'm sure you are busy, and I would really be very grateful for your 
> help.  If  you want, maybe I can return the favour by helping you with 
> the documentation for the website? For example, if I get it working 
> myself, then I could write a simple HowTo article for other users.
> 
> Regards,
> 
> Jonathan Wilson

--

-- 
 Duydunuz mu! Turkiye'nin ilk FreeBSD kitabi cikti.
 http://www.acikkod.com/freebsd.php

Jonathan Wilson | 6 Apr 22:40 2005
Picon

can't detect calls

I have installed voipong and I can log in to the management console etc. However
I don't understand how to set it to record calls. When I make a test call (I'm
using kphone on ubuntu hoary), there is nothing in "calllist" or in the log file.

I only made one change to voipong.conf, setting device = eth0. By the way I
don't have any file "voipongclients", do I need something here? What is the
meaning of the "clientlist" parameter? 

Murat Balaban | 17 Mar 15:51 2005

Re: About VoIPong on Suse 9.2


Hi,
See http://www.enderunix.org/voipong/index.php?sect=faq&lang=en Question #3.

If you can send a tcpdump savefile, I can analyze the situation more
precisely.

Regards
Murat

On Thu, Mar 17, 2005 at 09:59:34AM -0400, Rodrigo Frez wrote:
> Hello, along with congratulations to build such a great tool, I would
> like to ask you a few questions... for a long time I use ethereal to
> sniff rtp packets and save as "wav" stream before I find your tool. So
> I've installed on a suse 9.2 machine, succesfully compiled and
> installed, the packets on my network are sended by a cisco catalyst
> switch (port SPAN option). But the utility is not sniffing anything. So
> I tried to use ethereal to findout if it was a problem on the network.
> But no, ethereal work just fine... By the way I run every test as root,.
> So my question is  there any trick on Linux, 
> 
>  
> 
> My system has gcc 3.3.4, libcap 0.8.3-3 and sox 12.17.5-2
> 
>  
> 
> ... By the way the logs doesn't show anything that permits to understand
> what is wrong. I've tested 1.1 and devel version with the same
> results...
> 
>  
> 
> Any kind of help would be great, thanks.....
> 

--

-- 
 Duydunuz mu! Turkiye'nin ilk FreeBSD kitabi cikti.
 http://www.acikkod.com/freebsd.php

Ignacio Bolivar | 17 Mar 06:12 2005
Picon

create_wave: encoding type 2 is not supported yet.

Hi, thanks for such a cool program as VoIPong.

I'm using VoIPong in conjunction with AT&T CallVantage
service which, I believe, uses g726 for normal calls,
or g711 if fax/modem is enabled.

Anyways, right now I'm getting 2 files per call, named
thusly:

session-enc2-G726-32-8KHz-source,destination.raw
session-enc2-G726-32-8KHz-destination,source.raw

After writting to disk, I get message:

create_wave: encoding type 2 is not supported yet.

I thought type 0 is uLaw, type 1 is ALaw, and type 2
is  PCM16.  If not automatically with SOX, if it's
deficient, is there any way to convert with another
utility?  What about borrowing code from other GPL
projects like Tixy's code (
http://home.clara.net/tixy/source/ ) or ip-phone (
http://sourceforge.net/ip-phone/ ) ?

Thank you all for your help.

Igi

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


Gmane