SourceForge.net | 1 Mar 09:11 2009
Picon
Picon

[OpenSIPS-Devel] [ opensips-Bugs-2641453 ] Latest 1.5 trunk Debian packaging "make deb" fails

Bugs item #2641453, was opened at 2009-02-26 14:13
Message generated for change (Comment added) made by cupotka2008
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2641453&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: packaging
Group: trunk
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Alex Massover (cupotka2008)
Assigned to: Bogdan-Andrei Iancu (bogdan_iancu)
Summary: Latest 1.5 trunk Debian packaging "make deb" fails

Initial Comment:
Hi!

Debian packaging ("make deb") fails on latest trunk:

dpatch  apply-all  
applying patch 10_no_lib64_on_64_bits to ./ ... failed.
make[1]: *** [patch-stamp] Error 1
make[1]: Leaving directory `/tmp/opensips_head'
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
make: *** [deb] Error 2

(Continue reading)

SourceForge.net | 1 Mar 15:14 2009
Picon
Picon

[OpenSIPS-Devel] [ opensips-Bugs-2641453 ] Latest 1.5 trunk Debian packaging "make deb" fails

Bugs item #2641453, was opened at 2009-02-26 14:13
Message generated for change (Settings changed) made by bogdan_iancu
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2641453&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: packaging
Group: trunk
>Status: Closed
>Resolution: Fixed
Priority: 5
Private: No
Submitted By: Alex Massover (cupotka2008)
Assigned to: Bogdan-Andrei Iancu (bogdan_iancu)
Summary: Latest 1.5 trunk Debian packaging "make deb" fails

Initial Comment:
Hi!

Debian packaging ("make deb") fails on latest trunk:

dpatch  apply-all  
applying patch 10_no_lib64_on_64_bits to ./ ... failed.
make[1]: *** [patch-stamp] Error 1
make[1]: Leaving directory `/tmp/opensips_head'
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
make: *** [deb] Error 2

(Continue reading)

Di-Shi Sun | 2 Mar 04:09 2009

[OpenSIPS-Devel] SF.net SVN: opensips:[5383] branches/1.4/modules/osp

Revision: 5383
          http://opensips.svn.sourceforge.net/opensips/?rev=5383&view=rev
Author:   di-shi
Date:     2009-03-02 03:09:45 +0000 (Mon, 02 Mar 2009)

Log Message:
-----------
Updated to use OSP Toolkit 3.5.0.

Modified Paths:
--------------
    branches/1.4/modules/osp/orig_transaction.c
    branches/1.4/modules/osp/osptoolkit.c
    branches/1.4/modules/osp/provider.c
    branches/1.4/modules/osp/sipheader.c
    branches/1.4/modules/osp/sipheader.h
    branches/1.4/modules/osp/term_transaction.c
    branches/1.4/modules/osp/usage.c

This was sent by the SourceForge.net collaborative development platform, the world's largest Open
Source development site.
SourceForge.net | 2 Mar 10:14 2009
Picon
Picon

[OpenSIPS-Devel] [ opensips-Bugs-2641464 ] engage_media_proxy failes if called after create_dialog

Bugs item #2641464, was opened at 2009-02-26 14:16
Message generated for change (Comment added) made by dan_pascu
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2641464&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: modules
Group: None
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Thomas Gelf (thomas_gelf)
Assigned to: Nobody/Anonymous (nobody)
Summary: engage_media_proxy failes if called after create_dialog

Initial Comment:
If I correctly understood mediaproxy.c it installs a callback handler __dialog_created, responsible
for setting up the other handlers for this dialog (using dlg_api.register_dlgcb).

However, if you called create_dialog() before, "dialog_created" will not be fired again if you are using engage_media_proxy().

Proposed solution: either add a note to current documentation ("...do NOT use create_dialog when using
engage_media_proxy...") or find a way to catch this situation in EngageMediaProxy (maybe: if dlg
started, immediately register dialog callbacks).

Best regards,
Thomas Gelf
(Continue reading)

Iñaki Baz Castillo | 2 Mar 10:47 2009
Picon

[OpenSIPS-Devel] Error compiling trunk version "make deb-etch"

Hi, after last update I can't compile OpenSIPS by doing "make deb-etch":

-------------------------------------------------------------------
[...]
main.o: In function `cleanup':
/usr/src/opensips-trunk/sources/main.c:336: referencia a `destroy_tls'
sin definir
main.o: In function `main':
/usr/src/opensips-trunk/sources/main.c:1108: referencia a
`pre_init_tls' sin definir
/usr/src/opensips-trunk/sources/main.c:1220: referencia a `init_tls' sin definir
main.o: In function `main_loop':
/usr/src/opensips-trunk/sources/main.c:727: referencia a `tls_init' sin definir
tcp_main.o: In function `tcpconn_rm':
/usr/src/opensips-trunk/sources/tcp_main.c:524: referencia a
`tls_tcpconn_clean' sin definir
tcp_main.o: In function `_tcpconn_rm':
/usr/src/opensips-trunk/sources/tcp_main.c:505: referencia a
`tls_tcpconn_clean' sin definir
tcp_main.o: In function `tcpconn_destroy':
/usr/src/opensips-trunk/sources/tcp_main.c:1008: referencia a
`tls_close' sin definir
tcp_main.o: In function `tcpconn_timeout':
/usr/src/opensips-trunk/sources/tcp_main.c:1391: referencia a
`tls_close' sin definir
/usr/src/opensips-trunk/sources/tcp_main.c:1391: referencia a
`tls_close' sin definir
tcp_main.o: In function `tcpconn_new':
/usr/src/opensips-trunk/sources/tcp_main.c:402: referencia a
`tls_tcpconn_init' sin definir
(Continue reading)

Bogdan-Andrei Iancu | 2 Mar 11:03 2009
Picon

Re: [OpenSIPS-Devel] Error compiling trunk version "make deb-etch"

Hi Iñaki,

I guess you are refering to 1.5. The error are related only yo TLS 
function.....let me check.

Regards,
Bogdan

Iñaki Baz Castillo wrote:
> Hi, after last update I can't compile OpenSIPS by doing "make deb-etch":
>
> -------------------------------------------------------------------
> [...]
> main.o: In function `cleanup':
> /usr/src/opensips-trunk/sources/main.c:336: referencia a `destroy_tls'
> sin definir
> main.o: In function `main':
> /usr/src/opensips-trunk/sources/main.c:1108: referencia a
> `pre_init_tls' sin definir
> /usr/src/opensips-trunk/sources/main.c:1220: referencia a `init_tls' sin definir
> main.o: In function `main_loop':
> /usr/src/opensips-trunk/sources/main.c:727: referencia a `tls_init' sin definir
> tcp_main.o: In function `tcpconn_rm':
> /usr/src/opensips-trunk/sources/tcp_main.c:524: referencia a
> `tls_tcpconn_clean' sin definir
> tcp_main.o: In function `_tcpconn_rm':
> /usr/src/opensips-trunk/sources/tcp_main.c:505: referencia a
> `tls_tcpconn_clean' sin definir
> tcp_main.o: In function `tcpconn_destroy':
> /usr/src/opensips-trunk/sources/tcp_main.c:1008: referencia a
(Continue reading)

Iñaki Baz Castillo | 2 Mar 11:38 2009
Picon

[OpenSIPS-Devel] Error starting OpenSIPS trunk

After removing TLS option from Makefile.defs I compile succesfully the
trunk version (rev 5383) but get this error when starting opensips:

------------------------------------------------------
Not starting opensips: invalid configuration file!

params (0x627420, 128), called from cfg.lex: addstr(800)
params (0x627420, 128), returns address 0x65d098 frag. 0x65d068
(size=128) on 1 -th hit
params (0x627420, 128), called from cfg.lex: addstr(800)
params (0x627420, 128), returns address 0x65d178 frag. 0x65d148
(size=128) on 1 -th hit
params (0x627420, 128), called from cfg.lex: addstr(800)
params (0x627420, 128), returns address 0x65d258 frag. 0x65d228
(size=128) on 1 -th hit
params (0x627420, 12), called from cfg.y: yyparse(1648)
params (0x627420, 16), returns address 0x65d338 frag. 0x65d308
(size=16) on 1 -th hit
params(0x627420, 0x65d178), called from cfg.y: yyparse(1658)
freeing frag. 0x65d148 alloc'ed from cfg.lex: addstr(800)
params(0x627420, 0x65d258), called from cfg.y: yyparse(1658)
freeing frag. 0x65d228 alloc'ed from cfg.lex: addstr(800)
params (0x627420, 12), called from cfg.y: yyparse(475)
params (0x627420, 16), returns address 0x65d258 frag. 0x65d228
(size=16) on 1 -th hit
params (0x627420, 24), called from cfg.y: mk_listen_id(2388)
params (0x627420, 24), returns address 0x65d178 frag. 0x65d148
(size=128) on 1 -th hit
params (0x627420, 32), called from name_alias.c: add_alias(59)
params (0x627420, 32), returns address 0x65d3a8 frag. 0x65d378
(Continue reading)

Iñaki Baz Castillo | 2 Mar 11:39 2009
Picon

Re: [OpenSIPS-Devel] Error compiling trunk version "make deb-etch"

2009/3/2 Bogdan-Andrei Iancu <bogdan <at> voice-system.ro>:
> Hi Iñaki,
>
> I guess you are refering to 1.5.

Hi, I mean the latest rev 5383.

> The error are related only yo TLS
> function.....let me check.

Ok. However, removing TLS I get a different error (posted in other new mail).

Regards.

--

-- 
Iñaki Baz Castillo
<ibc <at> aliax.net>

_______________________________________________
Devel mailing list
Devel <at> lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel
SourceForge.net | 2 Mar 12:31 2009
Picon
Picon

[OpenSIPS-Devel] [ opensips-Support Requests-2617831 ] WARNING: database engine not found - tried 'MYSQL'

Support Requests item #2617831, was opened at 2009-02-19 17:28
Message generated for change (Comment added) made by mysticreporterr
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=1086411&aid=2617831&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Install Problem
Group: None
>Status: Closed
Priority: 5
Private: No
Submitted By: Steve (mysticreporterr)
Assigned to: Nobody/Anonymous (nobody)
Summary: WARNING: database engine not found - tried 'MYSQL'

Initial Comment:
After following the steps on the install document posted on the OpenSips website, building from source on a
Fedora machine, it would appear that it won't start when I run.

Here is command window text:
-----------------------------------
[ sbin]# opensipsctl start
WARNING: database engine not found - tried 'MYSQL'

INFO: Starting OpenSIPS :

ERROR: PID file /var/run/opensips.pid does not exist -- OpenSIPS start failed
-----------------------------------
(Continue reading)

SourceForge.net | 2 Mar 12:34 2009
Picon
Picon

[OpenSIPS-Devel] [ opensips-Support Requests-2617831 ] WARNING: database engine not found - tried 'MYSQL'

Support Requests item #2617831, was opened at 2009-02-19 17:28
Message generated for change (Comment added) made by mysticreporterr
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=1086411&aid=2617831&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Install Problem
Group: None
>Status: Open
Priority: 5
Private: No
Submitted By: Steve (mysticreporterr)
Assigned to: Nobody/Anonymous (nobody)
Summary: WARNING: database engine not found - tried 'MYSQL'

Initial Comment:
After following the steps on the install document posted on the OpenSips website, building from source on a
Fedora machine, it would appear that it won't start when I run.

Here is command window text:
-----------------------------------
[ sbin]# opensipsctl start
WARNING: database engine not found - tried 'MYSQL'

INFO: Starting OpenSIPS :

ERROR: PID file /var/run/opensips.pid does not exist -- OpenSIPS start failed
-----------------------------------
(Continue reading)


Gmane