Andreas Allacher | 1 Mar 11:01 2010
Picon
Picon

FourCC FLV4 used instead of VP62

Hi,

I just found a file using the FourCC code FLV4 and which doesn't play by default. However, by editing the
codecs.conf to include FLV4 to the ffvp6 codec it works.
Maybe this fourcc should be added to it - it shouldn't be a real problem (after all it is more or less a minor adjustment).
To be precisely - according to mkvinfo - it has the following:
(FourCC: FLV4, 0x34564c46)

--

-- 
GMX DSL: Internet, Telefon und Entertainment für nur 19,99 EUR/mtl.!
http://portal.gmx.net/de/go/dsl02
Andreas Allacher | 1 Mar 11:03 2010
Picon
Picon

Re: .mkv files after using mkvpropedit not able to play...

> No, he is still working on svn. Where did you get that idea? I don't
> think anyone said otherwise in this thread? On the contrary he's about
> the only developer who still _does_ do any significant development on
> the svn tree.

I believe someone mentioned it in this "thread".

Regarding your GIT: Wouldn't it at least be good, if it was mentioned on the mplayer site then?
--

-- 
Sicherer, schneller und einfacher. Die aktuellen Internet-Browser -
jetzt kostenlos herunterladen! http://portal.gmx.net/de/go/atbrowser
Andreas Allacher | 1 Mar 11:14 2010
Picon
Picon

Re: FourCC FLV4 used instead of VP62

Of course, I meant that I set the FourCC to VP6F
--

-- 
GRATIS für alle GMX-Mitglieder: Die maxdome Movie-FLAT!
Jetzt freischalten unter http://portal.gmx.net/de/go/maxdome01
Horacio Sanson | 1 Mar 15:25 2010
Picon

Crash when converting Canopus HQ files to a lower fps.

When converting a Canopus HQ file to raw with a lower fps than the
original mencoder segfaults. I tried this with my own samples and with
the sample found at: http://samples.mplayerhq.hu/V-codecs/CUVC/

As long as -ofps is set equal or higher than the source fps there is no
crash but using any lower -ofps segfaults mencoder.

Following is the gdb output:

(gdb) r -v  -nosound  -oac pcm -ovc raw -ofps 12 -of rawvideo -o /media/out_video.yuv /media/canopushq.avi

Starting program: /opt/suj/bin/mencoder -v  -nosound  -oac pcm -ovc raw -ofps 12 -of rawvideo -o
/media/out_video.yuv /media/canopushq.avi
[Thread debugging using libthread_db enabled]                                                                                                                  
MEncoder SVN-r30800-4.4.1 (C) 2000-2010 MPlayer Team                                                                                                           
Warning unknown option vo at line 16                                                                                                                           
Option of: Unknown suboption lavc                                                                                                                              
Warning unknown option of at line 83                                                                                                                           
Configuration: --prefix=/opt/suj --enable-debug=3 --extra-ldflags=-L/opt/suj/lib
--extra-cflags=-I/opt/suj/include                                             
get_path('font/font.desc') -> '/home/ryujin/.mplayer/font/font.desc'                                                                                          
font: can't open file: /home/ryujin/.mplayer/font/font.desc                                                                                                   
font: can't open file: /opt/suj/share/mplayer/font/font.desc                                                                                                   
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay                                                                                                       
[file] File size is 7484838 bytes                                                                                                                              
STREAM: [file] /media/canopushq.avi                                                                                                                     
STREAM: Description: File                                                                                                                                      
STREAM: Author: Albeu                                                                                                                                          
STREAM: Comment: based on the code from ??? (probably Arpi)                                                                                                    
success: format: 0  data: 0x0 - 0x7235a6                                                                                                                       
(Continue reading)

Mehmet Kaplan | 1 Mar 15:33 2010
Picon

Re: question about codec support on windows

sorry there wasn't any reply for the topic and i really need
information about this problem.
also i appreciate any other forum suggestion for finding a reply for my problem.

On Fri, Feb 26, 2010 at 10:07 AM, Mehmet Kaplan <mehmetkpln <at> gmail.com> wrote:
> hi all,
> i'm trying to use mplayer for developing a video player application.
> i know mplayer has a growing codec support. but after i created my
> application i don't want to give a new version of mplayer.exe for new
> codec support. in this situation my application should play media
> files after installing codec into the system (like a codec pack). for
> example in players using directshow you can open a new video file (you
> can't open before) after installing codec of it.
> my question is that, does mplayer have an ability like that on windows
> operating systems?
> on mplayer official page there is an information
> (http://www.mplayerhq.hu/design7/dload.html):
> "On Windows MPlayer will try to use the codecs installed on your
> system. Our packages can save you the hassle of installing every known
> codec and using untested codec versions."
> I couldn't try this situation because mplayer opened every video file I have :)
>
> thanks...
>
Krzysztof Duchnowski | 1 Mar 17:31 2010
Picon

Re: After updating - Faster encode, lower quality

andrew <at> WARnux.com pisze:

>>> I've been using x264 to encode videos now for months.  Encoding a full
>>> length movie used to take about 11 hrs and the quality was splendid.  I
>>> built the latest mplayer/mencoder and x264 a few days ago and now my 
>>> encodes only take about 4 hours but the quality is degraded.  What 
>>> really confuses me is that I didn't change my command line parameters 
>>> at all.
>>>
>>> How is this possible?
>> Did you used CRF mode?
>> If yes then for month now (or two) CRF mode not reflect QP anymore but 
>> instead it is a "Quality factor" and thus considerable good quality 
>> you could achieve is with CRF in 18-21 range.
>>
> Yes, CRF mode.  Was this a change in x264 or a change in mencoder?  
> Anyone know what r number?

I don't use the MEncoder - it is x264 issue thought.

--

-- 
Krzysztof 'DK75' Duchnowski
GetFirefox - http://www.mozilla.com/firefox/
Konfiguracja UTF-8 dla czytników - http://evil.pl/pip/utf/
_______________________________________________
MPlayer-users mailing list
MPlayer-users <at> mplayerhq.hu
https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users
Carl Eugen Hoyos | 1 Mar 18:04 2010
Picon

Re: FourCC FLV4 used instead of VP62

On 2010-03-01 10:01, Andreas Allacher wrote:
> I just found a file using the FourCC code FLV4 and which doesn't play by
> default.

Please upload a sample to ftp://ffmpeg.org/MPlayer/incoming/ (write only) and 
post the name of the new directory you created here.
And perhaps add some information about how the sample was made or where you 
found it  (if you made it yourself, we might consider not to fix it).

Carl Eugen
Koko | 2 Mar 10:42 2010
Picon

mplayer and dual-head (clone) sync question.

Hi all.
I've an intel graphic notebook with dual head setup in clone mode. (LVDS+VGA
on an lcd tv).
I boot using the notebook, next i plug the VGA cable and issue xrandr --auto
which gives me the cloned output via vga.
I use xv video output using overlay adaptor and as expected, one of the two
screens just display a blue box, luckily the blue box appears on the
notebook so i can watch movies on Tv.

What i noticed is that when i watch a video on the notebook panel (VGA off)
i've no problem, but if the cloned output is active, video on the TV is not
always smooth, every bunch of seconds i can clearly see duplicate frames,
the video stops for a (very) little while.

Is it correct to address the issue to the fact that the refresh rates of the
lvds panel and the tv screen slightly differ and somehow mplayer is
syncronizing the frames to the lvds panel instead of the VGA output refresh
rate?
Just in case i am right, what is the right way to tell mplayer to sync to
the right screen (apart of disabling the cloned output of course)?

Thank you
Reimar Döffinger | 2 Mar 19:13 2010
Picon
Picon

Re: mplayer and dual-head (clone) sync question.

On Tue, Mar 02, 2010 at 10:42:44AM +0100, Koko wrote:
> Is it correct to address the issue to the fact that the refresh rates of the
> lvds panel and the tv screen slightly differ and somehow mplayer is
> syncronizing the frames to the lvds panel instead of the VGA output refresh
> rate?

Impossible to know for sure, but usually it is synced to whatever is the primary
screen. I don't know if/how that can be changed except by editing the X config file.
However -vo gl sometimes can sync to any display - though I admit it's unlikely to
work in the cloned case, I've only seen it for xinerama setups.
Kevin DeKorte | 2 Mar 19:49 2010
Picon

Re: mplayer and dual-head (clone) sync question.


On 03/02/2010 11:13 AM, Reimar Döffinger wrote:
> On Tue, Mar 02, 2010 at 10:42:44AM +0100, Koko wrote:
>> Is it correct to address the issue to the fact that the refresh rates of the
>> lvds panel and the tv screen slightly differ and somehow mplayer is
>> syncronizing the frames to the lvds panel instead of the VGA output refresh
>> rate?
> 
> Impossible to know for sure, but usually it is synced to whatever is the primary
> screen. I don't know if/how that can be changed except by editing the X config file.
> However -vo gl sometimes can sync to any display - though I admit it's unlikely to
> work in the cloned case, I've only seen it for xinerama setups.

I talked to the radeon developers about this, and the refresh rates are
tied to the first monitor the window is on. And it depends on the pixel
clock of the display. So not only do you need the same resolution on the
display, you need the same refresh rate. Apparently this can be worked
around in the video driver software, but no one has got around to it yet.

Kevin
--

-- 
Get my public GnuPG key from
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x7D0BD5D1

Gmane