Gianluigi Tiesi | 1 Aug 01:54 2005
Picon

Re: Little bug in asf demuxer

On Wed, Jul 27, 2005 at 03:06:20AM +0200, Diego Biurrun wrote:
> On Sat, Jul 23, 2005 at 01:40:48PM +0200, Gianluigi Tiesi wrote:
> > 
> > Related media: MasterCard.asf (go ahead until almost the end of the clip)
> > 
> > upload on ftp: ftp://mplayerhq.hu/MPlayer/incoming/Mastercard.{asf,txt}
> 
> That file is broken, xine also crashes.  Try this one instead, it works
> flawlessly and has a different md5sum:
> 
> http://mplayerhq.hu/~diego/funny/Mastercard.asf
> 
I really can live also without this video :), but a segfault is not the right
way to handle a broken file (I was suspected about it). Yes, we need a
player not a video file checker but if the fix can be trivial...

Bye

--

-- 
Gianluigi Tiesi <sherpya <at> netfarm.it>
EDP Project Leader
Netfarm S.r.l. - http://www.netfarm.it/
Free Software: http://oss.netfarm.it/
Alexander Strasser | 1 Aug 02:30 2005
Picon
Picon

[PATCH] buildsystem changes for upcoming libavutil

Hi,

  i plan to commit libavutil tommorrow which splits
some of the more generic parts of libavcodec into
a seperate lib.

  Changes to the mplayer buildsystem will be needed
to support latest libavcodec then.

  Attached is a patch to do that. Though it still
is not completely working, it has at least problems
with building mencoder.
  I'll look into it again tonight. But i thought to
better post it here, maybe someone else spots the
problem faster than me.

  Alex (beastd)
Index: configure
===================================================================
RCS file: /cvsroot/mplayer/main/configure,v
retrieving revision 1.1034
diff -u -r1.1034 configure
--- configure	30 Jul 2005 01:07:27 -0000	1.1034
+++ configure	31 Jul 2005 23:29:13 -0000
 <at>  <at>  -5859,6 +5859,13  <at>  <at> 
   _noinputmodules="live.com $_noinputmodules"
 fi
 
(Continue reading)

Rich Felker | 1 Aug 05:13 2005

Re: [PATCH] Fix return types of libvo API

On Mon, Aug 01, 2005 at 12:21:04AM +0200, Reimar Döffinger wrote:
> Hi,
> On Fri, Jul 29, 2005 at 03:36:48AM +0200, Ivo wrote:
> > As stated in an earlier post, the libvo functions that return a value are 
> > declared wrongly. They return uint32_t, but lots of vo's return -1 in 
> > certain functions, or  <= VO_ERROR (<= -1). This patch changes all 
> > declarations and definitions to static int instead of static uint32_t.
> 
> Whether this really is "wrong" or not might be disputable, but it
> certainly is a completely unnecesary use of *int*_t types...

It's wrong because of the signed/unsigned mismatch. Returning -1 from
a function with unsigned return type is broken.

> > I have not seen any ill effects yet, now that the calling code actually gets 
> > negative values for VO_ERROR/NOTIMPL/etc., but there might be. Look out for 
> > them and report back please :)
> 
> I'd actually say wait another day an the commit. You can then join the
> cola-party cause by my filter commits, Alexanders libavutil commit and
> Robertos demuxer commit (or in other words: let's do our worst, so we
> can release pre8 and say we did everything to give our users
> something to test *g*).

:)

Rich
Reimar Döffinger | 1 Aug 11:42 2005
Picon
Picon

Re: [PATCH] Fix return types of libvo API

Hi,
On Sun, Jul 31, 2005 at 11:13:17PM -0400, Rich Felker wrote:
> It's wrong because of the signed/unsigned mismatch. Returning -1 from
> a function with unsigned return type is broken.

Actually IMHO it is just a less ugly way of writing ~0, but like I said
it is disputable :-)
I guess the reason why it was uin32_t is maybe that somebody wanted the
functions to return flags, but since they don't I am (as said before) in
support of this patch.

Greetings,
Reimar Döffinger
Robert Swain | 1 Aug 14:30 2005
Picon

Re: [PATCH] CQMs in x264

On 7/27/05, Robert Swain <robert.swain <at> gmail.com> wrote:
> Has anyone spotted anything wrong in lines 131-157 of the patch? :s

Loren took a look at it and rewrote most of it. It all works now and
looks much nicer. Thanks Loren.

Please find the updated patch attached.

Kind regards,
Robert Swain (superdump)
Attachment (mplayer.x264.cqm.15.diff): application/octet-stream, 7728 bytes
_______________________________________________
MPlayer-dev-eng mailing list
MPlayer-dev-eng <at> mplayerhq.hu
http://mplayerhq.hu/mailman/listinfo/mplayer-dev-eng
Reimar Döffinger | 1 Aug 14:46 2005
Picon
Picon

Re: [PATCH] CQMs in x264

Hi,
On Mon, Aug 01, 2005 at 01:30:09PM +0100, Robert Swain wrote:
> On 7/27/05, Robert Swain <robert.swain <at> gmail.com> wrote:
> > Has anyone spotted anything wrong in lines 131-157 of the patch? :s
> 
> Loren took a look at it and rewrote most of it. It all works now and
> looks much nicer. Thanks Loren.
> 
> Please find the updated patch attached.

The patch contains DOS-linebreaks.
I am also strogly opposed to that macro, most of it can go into the
parse_cqm function, and writing the different error messages four time
really is not that much code/work...

Greetings,
Reimar Döffinger
Guillaume POIRIER | 1 Aug 15:00 2005
Picon

Re: [PATCH] CQMs in x264

Hi,

On 8/1/05, Robert Swain <robert.swain <at> gmail.com> wrote:
> On 7/27/05, Robert Swain <robert.swain <at> gmail.com> wrote:
> > Has anyone spotted anything wrong in lines 131-157 of the patch? :s
> 
> Loren took a look at it and rewrote most of it. It all works now and
> looks much nicer. Thanks Loren.
> 
> Please find the updated patch attached.

The doc part looks OK to me.

Guillaume
--

-- 
I feel sorry for people who don't drink.
When they wake up in the morning, that's
as good as they're going to feel all day.
 -- Frank Sinatra
Guido Guenther | 1 Aug 17:19 2005

[PATCH]: postproc ppc gcc-4.0 build-fixes

Hi,
I need this minor patch to get mplayer CVS from 2005-07-16 to build with
gcc 4.0.1 on linux ppc using altivec opt. Tested with gcc 4.0 and 3.4.
Please apply.
Cheers,
 -- Guido
--- mplayer-1.0-pre7cvs20050716/postproc/swscale_altivec_template.c.agx	2005-07-31
20:58:33.000000000 +0200
+++ mplayer-1.0-pre7cvs20050716/postproc/swscale_altivec_template.c	2005-08-01
15:37:49.000000000 +0200
 <at>  <at>  -27,9 +27,9  <at>  <at> 
 #endif

 static const vector signed int vzero =
-  (const vector signed int)AVV(0, 0, 0, 0);
+  AVV(0, 0, 0, 0);
 static const vector unsigned int altivec_vectorShiftInt19 =
-  (const vector unsigned int)AVV(19, 19, 19, 19);
+  AVV(19, 19, 19, 19);

 static inline void
 altivec_packIntArrayToCharArray(int *val, uint8_t* dest, int dstW) {
--- mplayer-1.0-pre7cvs20050716/postproc/yuv2rgb_altivec.c.agx	2005-08-01 15:38:46.000000000 +0200
+++ mplayer-1.0-pre7cvs20050716/postproc/yuv2rgb_altivec.c	2005-08-01 15:40:06.000000000 +0200
 <at>  <at>  -119,14 +119,14  <at>  <at> 
 */
 static
 const vector unsigned char
(Continue reading)

Attila Kinali | 1 Aug 19:22 2005
Picon

mplayer - contrib directory

Heyo,

---rsync-listing---
contrib/tmp/MPlayer-1.0pre6a-dynamicTTF-1.2.patch
contrib/tmp/MPlayer-1.0pre6a-dynamicTTF-1.2.patch.txt
contrib/tmp/bug-xscale/MPlayer-cvs-arm.tar.bz2
contrib/tmp/bug-xscale/MPlayer-cvs-i686.tar.bz2
contrib/tmp/bug-xscale/MPlayer-patch.diff
contrib/tmp/bug-xscale/arm-debug-trace-log-new.tar.bz2
contrib/tmp/bug-xscale/flashfxp.chm
contrib/tmp/bug-xscale/holeman.h26l
contrib/tmp/bug-xscale/holeman.yuv
contrib/tmp/bug-xscale/holeman2.h264
contrib/tmp/bug-xscale/i686-debug-trace-log-new.tar.bz2
contrib/tmp/bug-xscale/mplayer-arm-trace-log.tar.bz2
contrib/tmp/bug-xscale/mplayer-i686-trace-log.tar.bz2
contrib/tmp/bug-xscale/mplayer_arm_configure.txt
contrib/tmp/bug-xscale/mplayer_i686_configure.txt
contrib/tmp/bug-xscale/new-holeman.h264
contrib/tmp/font.desc_patch/cp1251-arial-18.patch.bz2
contrib/tmp/font.desc_patch/fix_unicode.bz2
contrib/tmp/font.desc_patch/fix_unicode_v1.1.bz2
contrib/tmp/font.desc_patch/koi8-r-arial-18.patch.bz2
contrib/tmp/font.desc_patch/mplayerfonts_win1251_v1.patch.bz2
contrib/tmp/font.desc_patch/readme.txt
contrib/tmp/mplayer-fs-3rdtry.diff
contrib/tmp/mplayer-fs-3rdtry_r3.diff
contrib/tmp/mplayer-fs-3rdtry_r4.diff
contrib/tmp/mplayer-fs-3rdtry_r7.diff
contrib/tmp/mplayer-fs-3rdtry_r9.diff
(Continue reading)

Reimar Döffinger | 1 Aug 20:37 2005
Picon
Picon

Re: [PATCH] set i_bps in demux_audio, other fixes

Hi,
On Sun, Jul 31, 2005 at 06:33:47PM +0200, Reimar D?ffinger wrote:
> On Fri, Jul 29, 2005 at 02:18:50PM +0200, Reimar D?ffinger wrote:
> > the attached patch sets sh_audio->i_bps for MP3 and WAV files, avoiding
> > a division by zero (since the decoder can only set it _after_ the first
> > call to demux_audio_fill_buffer)
> > It also fixes that bug that the format field for MP3 is set according to
> > the last MPEG-Audio like header, instead of the one we decided is the
> > right one (mp3_found).
> > Please comment (and esp. test).
> 
> Comments? Test results? If not I will apply soon!

Applied.

Greetings,
Reimar Döffinger

Gmane