Alex Deucher | 1 May 01:18 2010
Picon

Re: [PATCH] drm/radeon/kms: fix legacy LVDS mode computation

On Fri, Apr 30, 2010 at 12:06 PM, Alex Deucher <alexdeucher <at> gmail.com> wrote:
> On Fri, Apr 30, 2010 at 11:16 AM, Alex Deucher <alexdeucher <at> gmail.com> wrote:
>> On Fri, Apr 30, 2010 at 6:08 AM, Jerome Glisse <jglisse <at> redhat.com> wrote:
>>> From: John Doe <glisse <at> ned.localdomain>
>>>
>>> Compute downscaled mode timing like DDX does on legacy hw.
>>> With this patch it's now possible to use non native laptop
>>> panel resolution. Tested on M7 (7500) laptop.
>>
>> I think I just had the logic reversed previously.  Does the attached
>> patch also fix the issue?  It should fix the avivo scaling problems
>> that were reported as well.
>
> Looks like we need a bit more.  How about this one?

I can confirm that this last one
(0001-drm-radeon-kms-fix-panel-scaling-adjusted-mode-setu.patch) fixes
both avivo and legacy.  Please apply.

Alex

>
> Alex
>
>>
>> Alex
>>
>>
>>>
>>> Cc: <stable <at> kernel.org>
(Continue reading)

bugzilla-daemon | 1 May 01:24 2010

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

https://bugs.freedesktop.org/show_bug.cgi?id=27866

--- Comment #7 from Aidan Marks <aidan <at> cisco.com> 2010-04-30 16:24:38 PDT ---
yes the crash appears gone thank you, however I am seeing a new issue after the
pull.  every now and again there is screen flicker.  it is extremely fast, if
you blink you will miss it.  one time i noticed momentary display of garbage.

--

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
bugzilla-daemon | 1 May 01:32 2010

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

https://bugs.freedesktop.org/show_bug.cgi?id=27866

--- Comment #8 from Alex Deucher <agd5f <at> yahoo.com> 2010-04-30 16:32:52 PDT ---
(In reply to comment #7)
> yes the crash appears gone thank you, however I am seeing a new issue after the
> pull.  every now and again there is screen flicker.  it is extremely fast, if
> you blink you will miss it.  one time i noticed momentary display of garbage.

This happens when the reclocking misses the vblank period.  work is ongoing to
avoid that.

--

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
bugzilla-daemon | 1 May 01:44 2010

[Bug 15166] Changing brightness of backlight freezes kernel with radeon kms enabled.

https://bugzilla.kernel.org/show_bug.cgi?id=15166

--- Comment #43 from Alex Deucher <alexdeucher <at> gmail.com>  2010-04-29 15:56:47 ---
(In reply to comment #42)
> updated Linus' and your git tree
> 
> apply 2 patch on 2.6.34-rc5-git8
> 

Which patches are you referring to?

> 1. diff origin...dave_drm/drm-linus 
> 2. diff origin...dave_drm/drm-radeon-next
> 
> kms work fine

Does an updated tree without the patches also work?

--- Comment #44 from Manuel Ullmann <ullman.bugs <at> gmx.de>  2010-04-30 23:44:09 ---
Created an attachment (id=26191)
 --> (https://bugzilla.kernel.org/attachment.cgi?id=26191)
output from patch -p1 for all three patches

I tested kernel-2.6.34-rc6 from git. The kernel itself has not fixed the hang.

The patches probably do not apply, because the patched files have changed too
much. I attached the output of 'patch'. However it would be great, if you could
adjust them.

The "add accel parameter patch" applies mostly correct, so the radeon.accel=0
(Continue reading)

Alex Buell | 1 May 13:09 2010
Picon

Nouveau / Mesa gets X11 libraries overwritten sometimes

As this has now happened twice in the last two weeks, I thought I'd
write this up.

This morning I came back to my laptop to find it had locked up, even ssh
couldn't gain access to the machine. I rebooted the machine and tried to
start X. X refused to start, so I looked at the logs where it locked up
before I'd even woken up and found the following:

May  1 08:37:16 lithium kernel: __ratelimit: 60 callbacks suppressed
May  1 08:37:16 lithium kernel: X: page allocation failure. order:1,
mode:0x10d0
May  1 08:37:16 lithium kernel: Pid: 11594, comm: X Not tainted
2.6.32-gentoo-r7 #4
May  1 08:37:16 lithium kernel: Call Trace:
May  1 08:37:16 lithium kernel: [<c1050e9f>] ? __alloc_pages_nodemask
+0x439/0x47b
May  1 08:37:16 lithium kernel: [<c106a52e>] ? cache_alloc_refill
+0x240/0x411
May  1 08:37:16 lithium kernel: [<c106a765>] ? __kmalloc+0x66/0x9d
May  1 08:37:16 lithium kernel: [<f91ee2b5>] ? agp_alloc_page_array
+0x22/0x3c [agpgart]
May  1 08:37:16 lithium kernel: [<f91ee330>] ? agp_generic_alloc_user
+0x61/0xc3 [agpgart]
May  1 08:37:16 lithium kernel: [<f91ee45a>] ? agp_allocate_memory
+0x35/0xb3 [agpgart]
May  1 08:37:16 lithium kernel: [<f89e00a6>] ? 0xf89e00a6
May  1 08:37:16 lithium kernel: [<f89e0b9b>] ? ttm_tt_populate
+0x4d/0x382 [ttm]
May  1 08:37:16 lithium kernel: [<f89e0bc6>] ? ttm_tt_populate
+0x78/0x382 [ttm]
(Continue reading)

GhePeU | 1 May 14:42 2010
Picon

Re: [PATCH] drm/radeon/kms: fix tv dac conflict resolver

Il giorno mar, 27/04/2010 alle 18.57 -0400, Alex Deucher ha scritto:
> On Tue, Apr 27, 2010 at 6:24 PM, GhePeU <ghepeu <at> virgilio.it> wrote:
> > Il giorno mar, 27/04/2010 alle 18.11 -0400, Alex Deucher ha scritto:
> >> On Tue, Apr 27, 2010 at 5:30 PM, GhePeU <ghepeu <at> virgilio.it> wrote:
> >> > Il giorno gio, 15/04/2010 alle 13.41 -0400, Alex Deucher ha scritto:
> >> >> >From 837feb147c531219c7315857a6f17e145af8f750 Mon Sep 17 00:00:00 2001
> >> >> From: Alex Deucher <alexdeucher <at> gmail.com>
> >> >> Date: Thu, 15 Apr 2010 13:31:12 -0400
> >> >> Subject: [PATCH] drm/radeon/kms: fix tv dac conflict resolver
> >> >
> >> > Hi,
> >> >
> >> > a few days ago I upgraded to the last 2.6.34 rc kernel and found that with
> >> > KMS both the console and X were using a 800x600 resolution instead of my LCD
> >> > display's native resolution of 1440x900 who was selected by default with
> >> > 2.6.33 and previous kernels.
> >> >
> >> > I tracked the problem to this patch, which causes the same issues also
> >> > when manually applied to 2.6.33: apparently the kms radeon driver
> >> > wrongly detects a TV connected to my card (I don't have one, only a LCD
> >> > display connected to the DVI port) and forces the TV default resolution
> >> > for all the outputs.
> >>
> >> You issue is not related to the patch.  What the patch does is allow
> >> you to use the digital part of DVI plus TV at the same time.  The
> >> analog part of the DVI port and the TV share the same DAC so they
> >> can't be used at the same time.  Prior to the patch, both the TV and
> >> DVI were detected as attached, but the TV was always disabled since it
> >> was wrongly seen as conflicting with the DVI.
> >>
(Continue reading)

bugzilla-daemon | 1 May 18:55 2010

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

https://bugs.freedesktop.org/show_bug.cgi?id=27866

--- Comment #9 from Andrew Randrianasulu <randrik <at> mail.ru> 2010-05-01 09:55:14 PDT ---
It seems i have same issue (with d-r-t up to commit
7a1ffce50373c177d3f6eecce52badc40c90e1dd
Author: Dave Airlie <airlied <at> redhat.com>
Date:   Thu Apr 29 18:37:59 2010 +1000
    drm/radeon/kms: take vram mutex pointer before derefing object. )

May  1 03:47:11 (none) kernel: 41112 pages non-shared
May  1 03:47:11 (none) kernel: [ttm] unable to allocate page.
May  1 03:47:11 (none) kernel: radeon 0000:01:00.0: object_init failed for
(847872, 0x00000002)
May  1 03:47:11 (none) kernel: [drm:radeon_gem_object_create] *ERROR* Failed to
allocate GEM object (847872, 2, 4096, -12)
May  1 05:20:47 (none) kernel: BUG: unable to handle kernel paging request at
00001688
May  1 05:20:47 (none) kernel: IP: [<c1263de0>] mutex_unlock+0x8/0x1b
May  1 05:20:47 (none) kernel: *pde = 00000000
May  1 05:20:47 (none) kernel: Oops: 0002 [#1] SMP
May  1 05:20:47 (none) kernel: last sysfs file:
/sys/devices/platform/w83627hf.656/in8_input
May  1 05:20:47 (none) kernel: Modules linked in: ramzswap(C) lzo_compress
radeon ttm drm_kms_helper drm i2c_algo_bit cfbcopyarea cfbimgblt cfb
fillrect snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss
snd_mixer_oss nfsd lockd nfs_acl auth_rpcgss sunrpc ipv6 tuner_simple
 tuner_types tda9887 usbmouse snd_wavefront usbhid tda8290 snd_cs4236
snd_wss_lib ppdev snd_opl3_lib snd_hwdep snd_via82xx snd_ac97_codec ac97_
bus snd_pcm snd_mpu401 snd_timer saa7134 rtc_cmos snd_page_alloc
snd_mpu401_uart uhci_hcd snd_rawmidi rtc_core ir_common ehci_hcd parport_pc ns
(Continue reading)

bugzilla-daemon | 1 May 18:59 2010

[Bug 27866] d-r-t crashes at radeon_bo_unref() with dynpm=1

https://bugs.freedesktop.org/show_bug.cgi?id=27866

--- Comment #10 from Andrew Randrianasulu <randrik <at> mail.ru> 2010-05-01 09:59:04 PDT ---
Created an attachment (id=35365)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=35365)
my /var/log/syslog

Has some unrelated/old oopses, but anything with 2.6.34-rc5 #34 should be  new
enough ...

--

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
bugzilla-daemon | 1 May 20:09 2010

[Bug 15181] Radeon: *ERROR* Unable to locate a BIOS ROM

https://bugzilla.kernel.org/show_bug.cgi?id=15181

--- Comment #14 from Jérôme Glisse <glisse <at> freedesktop.org>  2010-05-01 18:09:24 ---
Please add a printk at the begining of r700_read_disabled_bios to make sure
this function is use.

--

-- 
Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.
------------------------------------------------------------------------------
--
_______________________________________________
Dri-devel mailing list
Dri-devel <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/dri-devel
bugzilla-daemon | 2 May 01:02 2010

[Bug 27904] r300g segfaults on M56GL

https://bugs.freedesktop.org/show_bug.cgi?id=27904

--- Comment #1 from Marek Olšák <maraeo <at> gmail.com> 2010-05-01 16:02:04 PDT ---
Could you please "make realclean" and rebuild the driver? The line numbers from
the backtrace don't make sense, also the "maxtemps" parameter cannot possibly
be 1, it should be either 32 or 128.

--

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
_______________________________________________
dri-devel mailing list
dri-devel <at> lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

Gmane