SourceForge.net | 1 Nov 16:07 2005
Picon
Picon

[ xdvi-Bugs-1344956 ] segfault with hyperref

Bugs item #1344956, was opened at 2005-11-01 16:07
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1344956&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: None
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Frank Küster (kuesterei)
Assigned to: Nobody/Anonymous (nobody)
Summary: segfault with hyperref

Initial Comment:
See http://bugs.debian.org/336807 and 
http://bugs.debian.org/336783:

From: Robert Hart <enxrah <at> nottingham.ac.uk>

Package: tetex-bin
Version: 3.0-10.1
Severity: normal

I have experience srgfaults with xdvi on a file containing
hyperrefs. The page that causes the crash contains a
(landscape)
(Continue reading)

SourceForge.net | 2 Nov 20:21 2005
Picon
Picon

[ xdvi-Bugs-1188866 ] Crash in htex_prescan_carry_over

Bugs item #1188866, was opened at 2005-04-24 11:18
Message generated for change (Comment added) made by stefanulrich
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1188866&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: hyperref
Group: incorrect behaviour
Status: Open
Resolution: None
>Priority: 9
Submitted By: Felix Gatzemeier (fxg)
Assigned to: Stefan Ulrich (stefanulrich)
Summary: Crash in htex_prescan_carry_over

Initial Comment:
In a dvi file with hyperrefs, xdvi 22.84.9 (from teTeX
3.0) crashes reproducably when displaying a certain
page.  The stack backtrace is:

#0  0x40280c2f in strlen () from /lib/libc.so.6
#1  0x080d5bf4 in xstrdup (s=0x0) at xstrdup.c:27
#2  0x0806c47a in htex_prescan_carry_over (old_page=0,
new_page=1)
    at hypertex.c:442
#3  0x0804fbdc in prescan (fp=0x813b288) at dvi-draw.c:1809
#4  0x08068a5b in redraw_page () at events.c:5134
#5  0x0806908c in do_pages () at events.c:5359
(Continue reading)

SourceForge.net | 2 Nov 20:20 2005
Picon
Picon

[ xdvi-Bugs-1344956 ] segfault with hyperref

Bugs item #1344956, was opened at 2005-11-01 16:07
Message generated for change (Comment added) made by stefanulrich
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1344956&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: None
Group: None
Status: Open
Resolution: None
>Priority: 9
Submitted By: Frank Küster (kuesterei)
>Assigned to: Stefan Ulrich (stefanulrich)
Summary: segfault with hyperref

Initial Comment:
See http://bugs.debian.org/336807 and 
http://bugs.debian.org/336783:

From: Robert Hart <enxrah <at> nottingham.ac.uk>

Package: tetex-bin
Version: 3.0-10.1
Severity: normal

I have experience srgfaults with xdvi on a file containing
hyperrefs. The page that causes the crash contains a
(landscape)
(Continue reading)

SourceForge.net | 19 Nov 21:33 2005
Picon
Picon

[ xdvi-Bugs-1222202 ] X resources are not utilized

Bugs item #1222202, was opened at 2005-06-16 14:23
Message generated for change (Comment added) made by nobody
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1222202&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: X interface
Group: incorrect behaviour
Status: Open
Resolution: None
Priority: 5
Submitted By: E Haywiser (ejh1)
Assigned to: Stefan Ulrich (stefanulrich)
Summary: X resources are not utilized

Initial Comment:
There is a bug in the xdvi wrapper script xdvi-sh
which prevents relevant Xresources from 
being utilized by links to the wrapper script.

I recommend the following change to xdvi-sh:

 <     NAMEOPT='-name xdvi';;
---
>     NAMEOPT="-name $0";;

This would allow links to xdvi-sh to have their
own unique resources.  For example consider:
(Continue reading)

SourceForge.net | 19 Nov 21:43 2005
Picon
Picon

[ xdvi-Bugs-1222202 ] X resources are not utilized

Bugs item #1222202, was opened at 2005-06-16 14:23
Message generated for change (Comment added) made by nobody
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1222202&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: X interface
Group: incorrect behaviour
Status: Open
Resolution: None
Priority: 5
Submitted By: E Haywiser (ejh1)
Assigned to: Stefan Ulrich (stefanulrich)
Summary: X resources are not utilized

Initial Comment:
There is a bug in the xdvi wrapper script xdvi-sh
which prevents relevant Xresources from 
being utilized by links to the wrapper script.

I recommend the following change to xdvi-sh:

 <     NAMEOPT='-name xdvi';;
---
>     NAMEOPT="-name $0";;

This would allow links to xdvi-sh to have their
own unique resources.  For example consider:
(Continue reading)

SourceForge.net | 19 Nov 21:53 2005
Picon
Picon

[ xdvi-Bugs-1222202 ] X resources are not utilized

Bugs item #1222202, was opened at 2005-06-16 23:23
Message generated for change (Comment added) made by stefanulrich
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1222202&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: X interface
Group: incorrect behaviour
Status: Open
Resolution: None
Priority: 5
Submitted By: E Haywiser (ejh1)
Assigned to: Stefan Ulrich (stefanulrich)
Summary: X resources are not utilized

Initial Comment:
There is a bug in the xdvi wrapper script xdvi-sh
which prevents relevant Xresources from 
being utilized by links to the wrapper script.

I recommend the following change to xdvi-sh:

 <     NAMEOPT='-name xdvi';;
---
>     NAMEOPT="-name $0";;

This would allow links to xdvi-sh to have their
own unique resources.  For example consider:
(Continue reading)

SourceForge.net | 19 Nov 22:08 2005
Picon
Picon

[ xdvi-Bugs-1361722 ] xdvik 22.84.9 misbehaves with -name xdvi_xyz

Bugs item #1361722, was opened at 2005-11-19 17:08
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1361722&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: X interface
Group: incorrect behaviour
Status: Open
Resolution: None
Priority: 5
Submitted By: Jim (z-s-d)
Assigned to: Nobody/Anonymous (nobody)
Summary: xdvik 22.84.9 misbehaves with -name xdvi_xyz

Initial Comment:
I have X resources set up so that I can call (for example)
        xdvi -name xdvi_landscape
and get a geometry spec that matches what I want.

When I used xdvik 22.40v under Slackware 10.1 with
    xdvi -paper usr -name xdvi_landscape file.dvi
it worked perfectly. with Slackware 10.2's tetex 3.0's
xdvik version 22.84.9 ( <at> (#)GNU/LessTif Version 2.1
Release 0.93.96, runtime version 2.1)
Libraries: kpathsea version 3.5.4, T1lib version 5.0.1
if I give any -name besides "xdvi", things go to pot.

(Continue reading)

SourceForge.net | 19 Nov 22:25 2005
Picon
Picon

[ xdvi-Bugs-1222202 ] X resources are not utilized

Bugs item #1222202, was opened at 2005-06-16 18:23
Message generated for change (Comment added) made by z-s-d
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1222202&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: X interface
Group: incorrect behaviour
Status: Open
Resolution: None
Priority: 5
Submitted By: E Haywiser (ejh1)
Assigned to: Stefan Ulrich (stefanulrich)
Summary: X resources are not utilized

Initial Comment:
There is a bug in the xdvi wrapper script xdvi-sh
which prevents relevant Xresources from 
being utilized by links to the wrapper script.

I recommend the following change to xdvi-sh:

 <     NAMEOPT='-name xdvi';;
---
>     NAMEOPT="-name $0";;

This would allow links to xdvi-sh to have their
own unique resources.  For example consider:
(Continue reading)

SourceForge.net | 20 Nov 00:02 2005
Picon
Picon

[ xdvi-Bugs-1222202 ] X resources are not utilized

Bugs item #1222202, was opened at 2005-06-16 23:23
Message generated for change (Comment added) made by stefanulrich
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1222202&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: X interface
Group: incorrect behaviour
Status: Open
Resolution: None
Priority: 5
Submitted By: E Haywiser (ejh1)
Assigned to: Stefan Ulrich (stefanulrich)
Summary: X resources are not utilized

Initial Comment:
There is a bug in the xdvi wrapper script xdvi-sh
which prevents relevant Xresources from 
being utilized by links to the wrapper script.

I recommend the following change to xdvi-sh:

 <     NAMEOPT='-name xdvi';;
---
>     NAMEOPT="-name $0";;

This would allow links to xdvi-sh to have their
own unique resources.  For example consider:
(Continue reading)

SourceForge.net | 20 Nov 00:34 2005
Picon
Picon

[ xdvi-Bugs-1361722 ] xdvik 22.84.9 misbehaves with -name xdvi_xyz

Bugs item #1361722, was opened at 2005-11-19 22:08
Message generated for change (Comment added) made by stefanulrich
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=377580&aid=1361722&group_id=23164

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: X interface
Group: incorrect behaviour
Status: Open
Resolution: None
Priority: 5
Submitted By: Jim (z-s-d)
>Assigned to: Stefan Ulrich (stefanulrich)
Summary: xdvik 22.84.9 misbehaves with -name xdvi_xyz

Initial Comment:
I have X resources set up so that I can call (for example)
        xdvi -name xdvi_landscape
and get a geometry spec that matches what I want.

When I used xdvik 22.40v under Slackware 10.1 with
    xdvi -paper usr -name xdvi_landscape file.dvi
it worked perfectly. with Slackware 10.2's tetex 3.0's
xdvik version 22.84.9 ( <at> (#)GNU/LessTif Version 2.1
Release 0.93.96, runtime version 2.1)
Libraries: kpathsea version 3.5.4, T1lib version 5.0.1
if I give any -name besides "xdvi", things go to pot.

(Continue reading)


Gmane