MrMarch1994 . | 9 Oct 00:03 2015

Unable to typeset

Hi there,

I am attempting to use MiKTeX on my personal computer, I have installed
this on my both my desktop and laptop, one running Windows 7 64 bit, the
other running Windows 8 64 bit.
I am unable to typeset any documents, either new documents, or pre-existing
documents that I have created on another computer.

I downloaded the file along with the aux file and synctex.gz file.

I am able to edit the document and also have a pdf displayed (this was also
downloaded), however any changes I make to the document are not replicated
onto the pdf.

When I hit the typeset button, I receive this message in the console output:

*Sorry, but "MiKTeX Configuration Utility" did not succeed.*

*Sorry, but C:\Program Files\MiKTeX 2.9\miktex\bin\x64\texify.exe did not
succeed.*

Along with information on where to locate the logs for each of these which
I will attach in my email.

I received this error on both my Win7 and Win8 machines, I have reinstalled
and made sure that I have the 64 bit versions installed. I was also unable
to locate any information in the FAQ section on the website.

I had a look at the archive and followed some instructions that I found
listed there. I went to the package manager(admin) and synchronized
(Continue reading)

Stefan Pinnow | 9 Oct 12:56 2015
Picon
Picon

Bug in `ltluatex.tex'?

Hi all,

I just updated the packages in MiKTeX and the error message

-----
! Missing number, treated as zero.
<to be read again> 
\relax 
l.140 \newcatcodetable\catcodetable <at> initex
-----

which line is in the `ltluatex.tex' when running LuaTeX on the MWE

% ----- minimal example -----
\documentclass{minimal}
    \usepackage{fontspec}
\begin{document}
    test
\end{document}
% ---------------------------

Can somebody confirm this? Then I would write a bug report.
(When commenting `fontspec' everything works fine.)

Many thanks and best regards,
Stefan

------------------------------------------------------------------------------
_______________________________________________
Q: How can I leave the mailing list?
(Continue reading)

mapfus | 8 Oct 13:58 2015
Picon
Picon

Problems with xelatex/miktex [Errorcode: TeX capacity exceeded, sorry [main memory size=3000000].]

Hey guys!


So i freshly intstalled MiKTeX on my Windows machine (specifics see below) to work on a new project. Usually
I do my Latex on my ubuntu distribution (same machine) but this project requires me to work on Windows. So
next to miktex I also installed TeXstudio. Now a friend of mine helped me to set everything up so it is
exactly the same as everyone else has it working on the project (which is why I have to work on windows in the
first place, to ensure consistency). The problem is that I cannot compile the project or any project for
that matter. I always receive the error message: TeX capacity exceeded, sorry [main memory
size=3000000] Now I already googled this problem but I couldn't find any solutions that would help. A lot
of people suggested to expand the memory size which I did with the following commands (for xelatex,
pdflatex, etc): 


initexmf --edit-config-file=pdflatex


I filled in this:


main_memory=5000000 
extra_mem_bot=5000000 
font_mem_size=5000000 
pool_size=5000000 
buf_size=5000000


And ran this afterwards:


(Continue reading)

Tord Stokke Tryggestad | 6 Oct 22:46 2015
Picon

MiKTeX not running

Hello.

I have been using MiKTeX for quite a while now, but recently reinnstalled
Windows. The installing of MiKTeX went fine, but i have a problem when
using typeset on documents.

When opening an allready written TeX-file, or creating a new one, it opens
fine, and i even get the correct TexWorks pdf. But when trying to run
typeset again i get the following error

"Sorry, but C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\texify.exe did not
succeed.

The log file hopefully contains the information to get MiKTeX going again:

C:/Users/Tord/AppData/Local/MiKTeX/2.9/miktex/log/texify.log

You may want to visit the MiKTeX project page (http://miktex.org), if you

need help."

This is the log

"2015-10-07 09:33:12,525+1300 INFO  texify - running 'initexmf --quiet
--update-fndb' to refresh the file name database
2015-10-07 09:33:12,685+1300 FATAL texify - The operation failed for some
reason.
2015-10-07 09:33:12,685+1300 FATAL texify - Info: C:\Program Files
(x86)\MiKTeX 2.9\miktex\bin\initexmf.exe
2015-10-07 09:33:12,685+1300 FATAL texify - Source:
(Continue reading)

jens-37 | 4 Oct 15:07 2015
Picon

Re: Getting cannot access fndb file error

> 2015-09-17 15:14:22,143-0400 FATAL initexmf - Info:
> C:\Users\jszilagyi\AppData\Local\MiKTeX\2.9\miktex/data/le\5521b48ae3165f8e904714e2c61bbca7.fndb
> 2015-09-17 15:14:22,143-0400 FATAL initexmf - Source: Libraries\MiKTeX\Core\win\winFile.cpp
> 2015-09-17 15:14:22,143-0400 FATAL initexmf - Line: 520
> 2015-09-17 15:14:22,275-0400 INFO  initexmf - starting: MiKTeX Configuration Utility 2.9.5700
(MiKTeX 2.9)
> 2015-09-17 15:14:22,294-0400 FATAL initexmf - Windows API error 32: The process cannot access the file
because it is being used by another process.

Same error here.
I'm using 2.9.5721 on Windows XP 32 Bit.
It happens directly after a clean install with the sample.tex file in TeXworks.
I made sure that I rebooted after installation and had no other instances in the background.

To solve this I stopped TeXworks and ran this manually in a cmd shell:
  initexmf --quiet --update-fndb

Note that I get the same error as before when I run this command manually *and* TeXworks is open.
So it seems to me that TeXworks is the blocking process.
I have no clue why it locks the fndb file.
But once initexmf succeeds to update its fndb TeXworks is able to resume as normal.

I'd suggest the developers to run this command initially once before lauching TeXworks. 

regards
Jens

------------------------------------------------------------------------------
_______________________________________________
Q: How can I leave the mailing list?
(Continue reading)

Norikazu Nakato | 1 Oct 15:52 2015
Picon

Couldn't use luatexja package (documentclass ltjsarticle)

Hi,
I couldn't use luatexja package in MiKTeX.
Is there something I forgotten or package integration defect of MiKTeX ?

(Package luatexja is "Typeset Japanese with Lua(La)TeX" see
http://miktex.org/packages/luatexja )

The source file I wrote is (sample.tex):
> \documentclass{ltjsarticle}
> \begin{document}
> Helo.
> \end{document}

Command line: lualatex --interaction=batchmode sample.tex

I got "sample.log":
> This is LuaTeX, Version beta-0.80.0 (MiKTeX 2.9 64-bit) (rev 5238)  (format=lualatex 2015.9.28)  1 OCT
2015 21:58
> **sample.tex
> (./sample.tex
> LaTeX2e <2015/01/01> patch level 2
> Babel <3.9m> and hyphenation patterns for 69 languages loaded.
>
> ! LaTeX Error: File `ltjsarticle.cls' not found.
>
> Type X to quit or <RETURN> to proceed,
(...snip followings...)

MiKTeX Package Manager shows luatexja is installed.

(Continue reading)

David Allsopp | 28 Sep 15:28 2015

AllowedShellCommands

I would like to configure my MiKTeX installation to allow \write18 to permit
git to be executed without needing to specify --enable-write18 each time I
run the tex driver. The motivation, for anyone interested, is so that an
analysis of \jobname can cause tex to checkout the correct version of other
TeX files automatically from source control.

A look at the sources revealed the AllowShellCommands registry value.
Various hunting through the source code has revealed that I must set the
value for every single TeX driver (i.e. xetex, pdftex, tex are all
separate).

This feature seems to have several limitations:
1. It appears to be undocumented
2. Requiring it be set for each and every single TeX driver is tedious -
instead of reading it from
HKLM/HKCU\Software\MiKTeX.org\MiKTeX\2.9\tex\AllowedShellCommands could it
not be read from the Core key, given that the feature is part of the Core
library?
3. It appears that setting the value in HKCU totally overrides anything
specified in HKLM?
4. It appears that you must include all the default values in the setting
(i.e. they are not added). i.e. the value picked totally replaces all
others.

If someone could confirm that my analysis is correct, I may raise a bug (and
possibly try to code some of the changes). I am thinking that it would be
good if:
1. The setting were properly documented
2. There is a place where it can be set for all TeX drivers
3. There were a way of combining the values, rather than overriding them
(Continue reading)

Rui Moutinho | 23 Sep 15:59 2015
Picon

texify fails when using luatex engine

Hello,

Since the update at 1st September, I am being unable to use
the texify command with luatex engine.

As far as I know, this problem is yet to be discussed here.
I already made a bug report (see http://sourceforge.net/p/miktex/bugs/2396/)

Has anyone having the same issues?
I'm afraid to be the only one... :p
Perhaps, something is wrong with my particular system...

I am open to any suggestions. Thank you!

Best wishes,

Rui Moutinho

------------------------------------------------------------------------------
_______________________________________________
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml

Jason Ashby | 22 Sep 17:05 2015
Picon
Picon

Silent Uninstall MikTex 2.9.5721

We are trying to install and remove  MikTex 2.9.5721 from our computer labs (200 machines) the install works fine

Silent Install : basic-miktex-2.9.5721-x64 --unattended --shared , (this buzzes alnog quite happily :)    )

Silent Uninstall : C:\Program Files\texmf\miktex/bin/internal\copystart_admin.exe" "C:\Program
Files\texmf\miktex\bin\internal\uninstall_admin.exe"  , (fails)

we have tried adding  --unattended , --quiet , --mode unattended and others but each time we get the same
popup (see attached)

how can we silently uninstall the package ?

Jason

: )

Jason Ashby

Computer Systems Administrator
Surrey 4074
School of Computing Science
Simon Fraser University

Tel : 778 782 7574
Fax : 778 782 8116 
Email : jashby <at> sfu.ca

------------------------------------------------------------------------------
(Continue reading)

Vincent Belaïche | 20 Sep 17:35 2015
Picon

environment variable configuration and documentation

Hello Christian,

The documentation of envvars is quite light, see     http://docs.miktex.org/manual/envvars.html

I realized by experimenting that MikTeX TeX engines are an MSYS application, so there are the following
things to note

* either you configure the TEXINPUTS and suchlikes in the MSYS format: 

    /c/Some/path:/c/Some/other/path

* or you configure them in the Dosc format

    c:\Some\path;c:\Some\other\path

In the case that DOS format is used, MikTeX, the bash script wrappers (like texi2pdf.exe) will need to call
some conversion script before calling the script itself).  Here is a script that can do the job:

https://savannah.gnu.org/bugs/download.php?file_id=34935

(In the script the user can tell which format he/she used with some MIKTEX_ENVTYPE envvar.

There are other problems and/or info missing:

* I think that MikTeX always places the current directory first, even though TEXINPUTS specifie
otherwise, I think that this is a MikTeX bug, please feedback,

* Documentation does not give the following information (which I infer, please confirm it)

** Empty dir means: insert here the defaults (ie the root dir configuation)
(Continue reading)

Desiree Cavener | 17 Sep 16:33 2015
Picon

Problem Loading

So I have tried to download this multiple times. I am trying to use it 
for a math equation for a project. Everytime I have downloaded it (I 
have tried on multiple computers) it comes up with this error when I try 
to run my document:
Sorry, but C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\texify.exe did 
not succeed.

The log file hopefully contains the information to get MiKTeX going again:

C:/Users/Pam/AppData/Local/MiKTeX/2.9/miktex/log/texify.log

You may want to visit the MiKTeX project page (http://miktex.org), if you

need help.

PLEASE help me, I cannot figure it out.....

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

------------------------------------------------------------------------------
_______________________________________________
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml


Gmane