Steve Prior | 6 Feb 05:05 2007

Re: Which Java FastAGI implementation has the most "market share"?


Matthew Rubenstein wrote:
> 
> 	The real advantage in choosing an AGI (or CGI or ...) platform/language
> is *reusing* the existing code that already runs on that platform, with

Well of course you should pick whatever AGI implementation matches the 
rest of your environment best.

> minimal porting to the platform in that language. How much does a Java
> application, net/bean, or modern (1.4-6.x) class have to be revised to
> make it work with asterisk-java as FastAGI instead of, say, AGI, CGI,
> commandline, browser JVM, or other execution environment/UI?

I'm not totally sure you're asking the right question here. 
Asterisk-java in combination with Asterisk and in my case Lumenvox is 
just a user interface for whatever application I am developing.  In my 
case it's not even the only user interface I've created for my system 
(which happens to be in Home Automation which uses CORBA to connect the 
pieces together) - I've also got a web interface as well as other 
standalone front ends and even the light switches can be considered part 
of the UI (and therefore non reusable).  Asterisk-java provides you with 
an ordinary JRE environment where you might not be in direct control of 
main() (though you can be if you really want to), but that's similar to 
the other server environments you mentioned (browser JVM is a different 
animal).

So the real question isn't so much how a class needs to be revised for 
asterisk-java, it is does your back end system provide a robust API such 
that you can be dropped naked in the middle of a JRE woods and without 
(Continue reading)

Larry Alkoff | 6 Feb 05:34 2007
Picon

How to access environment variable?

How can I access an environmental variable in Asterisk 1.2.5?

It should be possible according to:
http://www.voip-info.org/wiki/view/Asterisk+variables
which says:

Environment Variables
You may access unix environment variables using the syntax:
    ${ENV(foo)}
${ENV(ASTERISK_PROMPT)}: the current Asterisk CLI prompt.
${ENV(RECORDED_FILE)}: the filename of the last file saved by the Record 
command

I have an environmental variable MYIP which contains my current IP 
address but when I execute exten _4XX the following line only says
'myip is  ' and the rest is blank instead of showing
'myip is   www.xxx.yyy.zzz'

exten => _4XX,n,VERBOSE("myip is  ${ENV(MYIP)}")

Why doesn't it work?

Larry

--

-- 
Larry Alkoff N2LA - Austin TX
Using Thunderbird on Linux
_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

(Continue reading)

Al | 6 Feb 05:37 2007
Picon

Re: Hi Honies! I'm home!

i couldnt agree more with Brian,
i'm sure we'll see more improvement in code and more improvement in asterisk business edition.
Al
 
=====================
I was wondering when this would happen. A lot of successful and prospering
open source company like yours seems to do this.

Much like Google did.   Once a company has grown to a point ---- it's more
valuable to have someone focus on the business from a businessmans
perspective.... working with the monies, departments, board of directors and
strategies while letting the previous guru (Mark) focus on what you always
really have needed to, the code and the product line.

It looks like Danny has a solid background and strong roles of leadership
from adtran.  I love this decision.

Go team Digium.

Brian

On 1/30/07, Mark Spencer <markster <at> digium.com> wrote:
>
> Many of you may have seen the recent announcement about Danny Windham
> coming on as the new CEO of Digium.  This is one of the most exciting
> things to happen to Digium and to Asterisk at large.  When Danny comes on
> board, I will be transitioning to the role of Chief Technical Officer
> (retaining my position of chairman of the board of directors), providing
> strategic vision for the company as well as being able to focus more
> extensively on the community, the customers and the technology.
>
> My sincere hope is that this transition will not only directly benefit the
> Asterisk community and Digium customers, but will allow me to spend much
> more time with the community and with Asterisk, playing a more important
> technical role in our roadmap for both hardware and software.
>
> I'm looking forward to working more with the community and the developers
> to help grow the future of Asterisk even more!
>
> Mark
> _______________________________________________
_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users
Robert DeVries | 6 Feb 06:27 2007
Picon

Having Trouble With Wait Command in Callback Context

I am trying to get called back with a DISA dial tone when I call a trigger number.  I got it to work almost the way I want, this is the callback context:

[callback]

exten=> 501,1,Congestion()
exten=> 501,2,Hangup()
exten =>h,1,System(cp /etc/asterisk/callback.info  /var/spool/asterisk/outgoing)
exten =>h,2,Hangup()

With the above, the call comes into the trigger number, then the call file is copied and executed, I get the DISA dial tone, and can dial just fine.

However, the problem is that the callback is a bit too fast, and sometimes calls back before I can hang up, even if I hang up fast.  I want to program in a pause.  However, when I do the following:

exten=> 501,1,Congestion()
exten=> 501,2,Hangup()
exten =>h,1,wait (10)
exten =>h,2,System(cp /etc/asterisk/callback.info  /var/spool/asterisk/outgoing)
exten =>h,3,Hangup()

the callback never occurs, the execution never gets beyond the wait command.

So, two questions - why does it not execute once I insert the wait command, and how do I get a wait before the call file is run.



_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users
Joseph | 6 Feb 07:42 2007

Inserting a pause with Sipura in between

I've a problem with inserting a "pause" and dialing additional numbers
when going through  Sipura-3000

exten => _12,1,Dial(SIP/4751724 <at> pstn-5,30,D(wwwwww18))

D(wwww) doesn't work as it sends the DTMF tones right after FXS connects
to FXO; though, I want insert a "pause" and send additional numbers
after connection goes through FXO.

Is it possible?
--

-- 
#Joseph
_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users

Andrey Solovjov | 6 Feb 09:36 2007
Picon

Re: format_wav.c:247 update_header: Unable to find our position

Chris Mason (Lists) пишет:
> Tzafrir Cohen wrote:
>
>> Do you rotate Asterisk's logs with the logger or with logrotate?
>>
> I have never addressed this before and never seen this problem before. 
> The issue is causing thousand of log files to be written to the 
> /var/log/asterisk directory, so many that I have to use find to erase 
> them. I believe this is a bug but I don't see many other people report 
> it. I have seen a couple of instances of it, though.
>
This usually happens if one of the log files in /var/log/asterisk is 
more than 2Gb...
_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users

Robert Jenkins | 6 Feb 10:03 2007
Picon

RE: New user question (X100P)

Hi,

I had similar problems with zaptel on a tdm2400.
I found that with the standard make & install, zaptel was being started as a
service but not properly initialising the card.

I disabled the service and added a few bits in rc.local;
rmmod the zaptel modules,
sleep a couple of seconds,
do a 'service zaptel start' to reload everything.

This seems to set things up properly and asterisk can then work with the
card via zaptel.

Robert Jenkins.

> -----Original Message-----
> From: asterisk-users-bounces <at> lists.digium.com 
> [mailto:asterisk-users-bounces <at> lists.digium.com] On Behalf Of 
> Andrew D Kirch
> Sent: 06 February 2007 01:18
> To: Asterisk Users Mailing List - Non-Commercial Discussion
> Subject: Re: [asterisk-users] New user question (X100P)
> 
> Andrew D Kirch wrote:
> > David Ruggles wrote:
> >> I'm trying to set up a simple test box to start developing 
> with Asterisk.
> >>
> >> I've got a Dell GX150 with two X100P cards. I've 
> downloaded, printed 
> >> out and read through most of TFOT. I've also done a lot of 
> Internet 
> >> searching.
> >>
> >> I'm getting this error:
> >> ZT_CHANCONFIG failed on channel 1: No such device or address (6)
> >>
> >> Based on the searching I've done, it seems like the 
> problem must be 
> >> shared IRQ issues. I've gone in the BIOS and disabled everything I 
> >> can but I can't stop the sharing completely. One X100P is 
> shared with 
> >> the built-in video and the other X100P is shared with a serial 
> >> controller. (I disabled both serial
> >> ports)
> >>
> >> My question is this: (in three parts)
> >>
> >> 1) Are my research and assumptions accurate? Does this 
> seem to be an 
> >> IRQ issue?
> >> 2) If I have to build another system to prevent the IRQ 
> problem, can 
> >> anyone recommend hardware (just for a simple test box right now)
> >> 3) Is it worth keeping the X100Ps or should I get a 
> TDM400P like used 
> >> in TFOT, or something else? (again just for testing)
> >>
> >> If there are other things I should check first please let me know!!
> >>
> >> TIA!!!!!
> >>
> >> Thanks,
> >>
> >> David Ruggles
> >> CCNA MCSE (NT) CNA A+
> >> Network Engineer    Safe Data, Inc.
> >> (910) 285-7200    david <at> safedatausa.com
> >>
> >>
> >> _______________________________________________
> >> --Bandwidth and Colocation provided by Easynews.com --
> >>
> >> asterisk-users mailing list
> >> To UNSUBSCRIBE or update options visit:
> >>    http://lists.digium.com/mailman/listinfo/asterisk-users
> > The X100P is going to leave you fairly unsatisfied with 
> your Asterisk 
> > experience.  It lacks an on-card timing interface, and real X100P's 
> > haven't been made in quite awhile (several years).  You may 
> or may not 
> > get caller ID, you may or may not get two way audio.  I know it's a 
> > bit more but you're better off with the TDM.  Good luck!
> > 
> I should note I committed two sins in this post.
> 1. Tzafrir, I didn't see your reply (blame my inability to 
> use my mail reader, and accept my humble apology) 2. the 
> TDM400P comes with installation support from Digium, so you 
> know you're going to be able to get it working correctly.
> 
> -- 
> Andrew D Kirch  |       Abusive Hosts Blocking List      | 
> www.ahbl.org
> Security Admin  |  Summit Open Source Development Group  | 
> www.sosdg.org Key fingerprint = 4106 3338 1F17 1E6F 8FB2  
> 8DFA 1331 7E25 C406 C8D2 
> _______________________________________________
> --Bandwidth and Colocation provided by Easynews.com --
> 
> asterisk-users mailing list
> To UNSUBSCRIBE or update options visit:
>    http://lists.digium.com/mailman/listinfo/asterisk-users
> 

_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users

Torbjörn Abrahamsson | 6 Feb 10:22 2007
Picon

ExtensionStatusEvent

Hi,

After upgrading from 1.2.13 to 1.2.14 it seems that I do not receive any 
ExtensionStatusEvents via the manager API anymore. Anyone else 
experienceing this? Any thing  I need to config?

I diffed 1.2.13- and 1.2.14-versions of manager.c, and found no 
differences, so I presume the problem would be in the part that calls 
manager.c. Unfortunatly I do not know enough of the internals of 
asterisk to know where this is.

I use a SIP-only setup, so presumably it would be chan_sip.c who creates 
the event, but when diffing I could not spot any obvious calls.

BR,
Torbjörn
_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users

Tim Panton | 6 Feb 10:41 2007

Re: Softphone on Linux


On 5 Feb 2007, at 21:46, chester c young wrote:

> Need to deploy between 50 to 300 lightweight Linux - only browser  
> and softphone.

You might want to consider our lightweight java softphone (Corraleta  
SDK) - it can be embedded in
a web page - zero install/config in the client. The UI is in HTML and  
javascript,
so you can get it _exactly_ the way you want it.

>
> Any recomendations?

Clearly I'm biased :-)

Tim Panton

www.mexuar.com
www.westhawk.co.uk/

_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users

Picon

Re: Asterisk H.323, Cisco IOS Gatekeeper(s) intra-zone call routing and TETRA

Stephan,

Ok, I'll re-state the problem...

I have two devices that I want to talk to each other:

1. an Asterisk PBX
2. a Damm Cellular TETRAFLEX digital radio system (www.damm.dk)

both devices are effectively "gateways" because they have many subscribers 
behind them.

The Damm Cellular system controller is based on Windows-XP Embedded and its 
sub-systems used the OpenH323 driver/libraries. Officially Damm supports 
only H.323 connections and only to Innovaphone products such as IP phones 
and ISDN gateways - I want to connect it to VoIP and Asterisk.

The Asterisk box is FC6, Asterisk 1.2.14, ooh323 from 
Asterrisk-Addons-1.2.5 - using ooh323 because the others depend on OpenH323 
libraries which are problematic (see below)

In the Damm Cellular system H.323 configuration use of a H.323 gatekeeper is 
mandatory, not optional :o(

So, how to join the Damm system to an Asterisk box?  Some ASCII art:

                                    192.168.1.0/24
              --------------------------------------------------------
                    |                     |                     |
               192.168.1.7           192.168.1.6           192.168.1.5
                    |                     |                     |
             ----------------      ----------------      ----------------
             | Damm Tetra   |      | Cisco Router |      | Asterisk PBX |
             | (OpenH323)   |      | GateKeeper   |      | (ooh323)     |
             | H323ID=DAMM  |      | Zone=THORCOM |      | H323ID=PABX  |
             | Nos=817XXXX  |      |              |      | Nos=810XXXX  |
             ----------------      ----------------      ----------------

I started on the hope of using the GNU GateKeeper 2.2.5 but ran into lots of 
problems on my Fedora Core 6 box with libraries, incompatibilities, 
compilation errors, the fact that OpenH323 appears deprecated in favour of 
Opal, etc. and in the end gave up and switched to a spare Cisco 2621XM 
router with c2600-jsx-mz.123-22.bin image which includes the Cisco H.323 
Gatekeeper...

The I started reading the documentation and got entirely confused :o( 
Nearly all of Cisco's examples show one gateway connected to one gatekeeper 
in a local zone and may routes to other zones that are 'remote', ie. WAN 
connected and all the traffic flow/examples appeared to be for this.

What I wanted/need is two gateways inside a single zone, and hence 
intra-zone calling (not inter-zone) - confusion continued - because of the 
talk of "technology prefixes" like "1#" and "2#" and "8#" ...

I already have a number plan/dial plan in the form 8EEXXXX where all of our 
Asterisk exchanges have a two-digit exchange number, like "810", "820", 
"867" etc. and we use four-digit extensions like 2001...2999 for phones, 
6XXX for services like voicemail, etc. which makes it easy for work 
collegues, friends and family to all have Asterisk exchanges and perform 
inter-exchange dialling [yup, we have a hub/router asterisk box with loads 
of IAX2 connections and no phones]

I assigned 817XXXX to the Damm TETRA system and my local PBX is already 
810XXXX and is the only "route" to the rest of my 8EEXXXX number plan and to 
the outside world.

I could see how the technology prefix could be used to route calls in the 
H.323 context - for example i could declare Asterisk as technology 1# and 
Tetra as 2# but while it is easy to add a leading 2# to dialled numbers 
leaving the Asterisk box I could find no way to tell either the Damm system 
or Asterisk which technology prefix to register -- this functionality 
appears to be missing.

So, the question was - "how to route calls intra-zone without technology 
prefixes" - back to the problem that there were plenty of examples of cross 
site/inter-zone configurations but little about intra-zone - then last nigh 
I stumbled on the phrase "in the updated version of the 'zone prefix' 
command..." in Cisco IOS documentation, so I went and googled for "cisco ios 
command reference zone prefix" and I think I may have found what I need...

So, I have the Damm system and Asterisk system both registered with the 
Cisco GateKeeper as gateways:

router-h323-gw#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    Flags
--------------- ----- --------------- ----- ---------         ----    -----
192.168.1.5     1720  192.168.1.5     13030 THORCOM           UNKN-GW
    H323-ID: PABX
    H323-ID: ASTERISK
    E164-ID: 100
    Voice Capacity Max.=  Avail.=  Current.= 0
192.168.1.7     1720  192.168.1.7     1085  THORCOM           UNKN-GW
    H323-ID: DAMM
    Voice Capacity Max.=  Avail.=  Current.= 0
Total number of active registrations = 2

I've added the following zone prefixes to the Cisco gatekeeper config:

!
gatekeeper
 zone local THORCOM int.thorcom.com 192.168.1.6
 zone prefix THORCOM 0* gw-priority 5 PABX        ! outside calls to PSTN 
etc
 zone prefix THORCOM 1* gw-priority 5 PABX        ! calls to 
information/operator
 zone prefix THORCOM 2... gw-priority 5 PABX        ! short calls to 
extension numbers
 zone prefix THORCOM 817.... gw-priority 10 DAMM    ! calls to TETRA
 zone prefix THORCOM 8...... gw-priority 5 PABX        ! calls to rest of my 
number plan
 zone prefix THORCOM 9.. gw-priority 10 PABX        ! emergency calls 
911/999
 gw-type-prefix 1#* default-technology
 no shutdown
!

... so I think this should route the calls between the gateways...?

Mike

----- Original Message ----- 
From: "Stephen Bosch" <posting <at> vodacomm.ca>
To: "Michael J. Tubby G8TIC" <mike.tubby <at> thorcom.co.uk>
Sent: Monday, February 05, 2007 7:51 PM
Subject: Re: [asterisk-users] Help sought: Asterisk H.323, Cisco IOS 
Gatekeeper(s) intra-zone call routing and TETRA

> Michael J. Tubby G8TIC wrote:
>> I can see how this be acheived if I had two Gatekeepers and two zones,
>> say one called "tetra" and one called "asterisk" by using zone prefixes
>> and "zone remote" to route between them and putting one of the gateways
>> on each of the Gatekeepers - but this appears to be over-the-top for
>> what I want, ie. two gateways on the same Gatekeeper at the same site,
>> in the same zone, routing calls between them...
>>
>>
>> Can anyone give me a clue where to go next with this?
>
> Oof... that was a lot to process.
>
> It's been a long time since I worked with H.323, but I'd be game to
> paddling about some ideas and see if I can provide any insight. I think
> your system is sufficiently complex that you're not likely to get a
> tonne of response from the list.
>
> I think the most confusing part of your plea is all the Cisco-specific
> stuff at the end. It's still not totally clear what you're trying to do.
> Can you try reframing it?
>
> -Stephen-
> 

_______________________________________________
--Bandwidth and Colocation provided by Easynews.com --

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users


Gmane