Shamus Rask | 1 Nov 02:57 2011
Picon

Re: new installation from Mac OSX Lion

Darrick, Michael, Lonnie:

I was using a video console, and do not have persistent storage installed or configured. My "production" version of AstLinux is based entirely off of a single CF card; no additional cards/sticks present. What I was attempting to do was to try a fresh (brand new) install with Asterisk v1.8 from a new CF card.

I downloaded the i586 beta image (astlinux-1.0-5224-asterisk-1.8.7.1.img, video consol) and it worked! 

My system is based on the Jetway J7F4K1G2E; a VIA C7 based board. The system seemed to hang following POST and a list of the various modules. It would hang after printing the text "SYSLINUX 3.86 0x4da50dc8 EBIOS". This seems to be the beginning of a longer piece of text that I see on the now successful boot of AstLinux v1.0.

Please let me know if there is any further testing I can help with... not an expert but proficient enough to follow instructions and report results!

Do you have any thoughts on when 1.0 will be released?

Thanks again!
   Shamus


----------------------------------------------------------------------

Message: 1
Date: Mon, 31 Oct 2011 15:28:17 +0000
From: Darrick Hartman <dhartman-KitoS0tuyp3MohDmgNdYFA@public.gmane.org>
Subject: Re: [Astlinux-users] new installation from Mac OSX Lion
To: astlinux-users <astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org>
Message-ID:
       <55E7150A40C10E438433B27ABD41DFE70D182FBD-nVT5yx6tYrHe8wdp+rjnUA@public.gmane.orgal>
Content-Type: text/plain; charset="us-ascii"

Shamus,

If you're seeing that rc.modules is read only, you do not have a unionfs partition (which you will need to make changes to that file).

You can try:

     modprobe r8169

To see if that is in-fact, the correct module for that board (I'm pretty sure it is since I have one of the Jetway with a C7).

Also, to be clear, the new runnix-4 files are not usable with the 0.7.x branch at all.  The 1.0.x branch needs a new version of runnix because the version of squashfs changed (and is not backwards compatible).

Darrick

From: Shamus Rask [mailto:shamus <at> srask.ca]
Sent: Monday, October 31, 2011 9:02 AM
To: astlinux-users
Subject: Re: [Astlinux-users] new installation from Mac OSX Lion

I was able to go and purchase a different 4GB CF card yesterday and tried again--same result. This got me thinking that maybe my motherboard was having some sort of other issue with the current release. I downloaded AstLinux 0.7.7 (prior to current RUNNIX release) and tried again... this time, success! I think the culprit is RUNNIX, but have no way to be certain at this point.

That being said, I've run into a new problem. My motherboard uses a RealTek chip for the GigE ports (Jetway mini-ITX board based on VIA C7). Using the VIA C7 image, the Ethernet ports are not initialized. Logging in from the CLI, I see that R8169 is commented out in /etc/rc.modules, but when I try to uncomment I get an error saying the file is read-only.

Two questions:
1. Are the R8169 drivers included in the VIA C7 image?
2. If so, how do I got about modifying files so that the correct drivers are modprobed?

many thanks,
  Shamus





>Shamus,

>

>Yes, the file structure looks good.  The .Trashes and .Spotlight-V100 files>/dirs cause no harm.

>

>Time to try a new CF card.

>

>Lonnie

-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

Message: 2
Date: Mon, 31 Oct 2011 16:33:40 +0100
From: Michael Keuter <lists <at> mksolutions.info>
Subject: Re: [Astlinux-users] new installation from Mac OSX Lion
To: AstLinux Users Mailing List <astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org>
Message-ID: <49C64CCA-2636-4C2C-91C9-9B0367B65C92-T/ftfVuOv1IVmlakO5hAmA@public.gmane.org>
Content-Type: text/plain; charset=iso-8859-1

Am 31.10.2011 um 15:02 schrieb Shamus Rask:

> I was able to go and purchase a different 4GB CF card yesterday and tried again--same result. This got me thinking that maybe my motherboard was having some sort of other issue with the current release. I downloaded AstLinux 0.7.7 (prior to current RUNNIX release) and tried again... this time, success! I think the culprit is RUNNIX, but have no way to be certain at this point.
>
> That being said, I've run into a new problem. My motherboard uses a RealTek chip for the GigE ports (Jetway mini-ITX board based on VIA C7). Using the VIA C7 image, the Ethernet ports are not initialized. Logging in from the CLI, I see that R8169 is commented out in /etc/rc.modules, but when I try to uncomment I get an error saying the file is read-only.
>
> Two questions:
> 1. Are the R8169 drivers included in the VIA C7 image?
> 2. If so, how do I got about modifying files so that the correct drivers are modprobed?
>
> many thanks,
>    Shamus
>
>
> >Shamus,
> >
> >Yes, the file structure looks good.  The .Trashes and .Spotlight-V100 files>/dirs cause no harm.
> >
> >Time to try a new CF card.
> >
> >Lonnie

1.) Yes it is included in the Via C7 image.
2.) Do you have a system with persistent storage already installed (UnionFS)?

http://doc.astlinux.org/userdoc:new-install

Michael

http://www.mksolutions.info








------------------------------

Message: 3
Date: Mon, 31 Oct 2011 10:47:10 -0500
From: Lonnie Abelbeck <lists <at> lonnie.abelbeck.com>
Subject: Re: [Astlinux-users] new installation from Mac OSX Lion
To: AstLinux Users Mailing List <astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org>
Message-ID: <570BF3BA-2822-4CA2-B86F-B0C2B7D5AF13-7Mk/79+iTMGXdHBpF2ONWUEOCMrvLtNR@public.gmane.org>
Content-Type: text/plain; charset=us-ascii

Hi Shamus,

We need to understand what is going on in more detail.  The RUNNIX changes from 0.7.7 to 0.7.8 is very minor and should not effect booting at all, and both are using the same version of syslinux to perform the initial boot.  I don't think it is RUNNIX.

Are you using a video or serial console?  What is exact text where it hangs (with some context), that is very helpful.

What is the Jetway model number of your board and any specific info.

Yes, the VIA C7 image has R8169 drivers, but are not enabled in /etc/rc.modules by default as you stated.


1) Now that you have an extra CF card laying around :-), next try the 1.0-beta beta images, but use the "Generic i586" (or Generic i586 Serial Console) image, not the C7.  Choose your favorite Asterisk version.

Asterisk 1.4.42
http://www.astlinux.org/release/10-svn-5224-asterisk-1442

Asterisk 1.8.7.1
http://www.astlinux.org/release/10-svn-5224-asterisk-1871

Please report your results.


2) Instead of installing the viac7 image of 0.7.10, you could install the geni586 image of 0.7.10 which has the r8169 driver enabled by default.


3) Finally, even with the NIC not enabled, you can still setup persistent storage via the console while using the viac7 image.
--
$ initial-setup status
ok-format /dev/hda

$ initial-setup format combined /dev/hda  (or for a separate partition: format separate /dev/hda 128)

$ reboot

$ initial-setup configure /dev/hda

$ reboot
--
now you can edit the /etc/rc.modules file and enable r8169 .

Lonnie


On Oct 31, 2011, at 9:02 AM, Shamus Rask wrote:

> I was able to go and purchase a different 4GB CF card yesterday and tried again--same result. This got me thinking that maybe my motherboard was having some sort of other issue with the current release. I downloaded AstLinux 0.7.7 (prior to current RUNNIX release) and tried again... this time, success! I think the culprit is RUNNIX, but have no way to be certain at this point.
>
> That being said, I've run into a new problem. My motherboard uses a RealTek chip for the GigE ports (Jetway mini-ITX board based on VIA C7). Using the VIA C7 image, the Ethernet ports are not initialized. Logging in from the CLI, I see that R8169 is commented out in /etc/rc.modules, but when I try to uncomment I get an error saying the file is read-only.
>
> Two questions:
> 1. Are the R8169 drivers included in the VIA C7 image?
> 2. If so, how do I got about modifying files so that the correct drivers are modprobed?
>
> many thanks,
>    Shamus
>
>
> >Shamus,
> >
> >Yes, the file structure looks good.  The .Trashes and .Spotlight-V100 files>/dirs cause no harm.
> >
> >Time to try a new CF card.
> >
> >Lonnie
------------------------------------------------------------------------------
RSA&reg; Conference 2012
Save &#36;700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA&reg; Conference 2012
Save &#36;700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
Oren Yehezkely | 1 Nov 04:15 2011
Picon

New install using SD card not working

Hi,

I am using the instructions in this document http://doc.astlinux.org/userdoc:new-install
to install the image on an SD card.

When I boot from the SD card after performing the dd command, all that I can see is a prompt with blank screen.

What am I missing here?

Can this setting work at all or is it not possible to boot from USB and SD cards?

Thanks,

Oren

------------------------------------------------------------------------------
RSA&reg; Conference 2012
Save &#36;700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA&reg; Conference 2012
Save &#36;700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
Lonnie Abelbeck | 1 Nov 04:45 2011

Re: New install using SD card not working

Oren,

After you created your SD card, does it mount on your PC/Mac ?  Does it show a RUNNIX volume with an "os"
directory ?

If so, then describe what hardware you are using.

Which img.gz board type did you use, geni586 (Generic i586) ?

Which version did you use, 0.7.10 or the 1.0-beta ?

Lonnie

On Oct 31, 2011, at 10:15 PM, Oren Yehezkely wrote:

> Hi,
> 
> I am using the instructions in this document http://doc.astlinux.org/userdoc:new-install
> to install the image on an SD card.
> 
> When I boot from the SD card after performing the dd command, all that I can see is a prompt with blank screen.
> 
> What am I missing here?
> 
> Can this setting work at all or is it not possible to boot from USB and SD cards?
> 
> Thanks,
> 
> Oren

------------------------------------------------------------------------------
RSA&reg; Conference 2012
Save &#36;700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
Oren Yehezkely | 2 Nov 05:27 2011
Picon

Problem booting on VirtualBox

Hello,

I am following the instructions on this page http://doc.astlinux.org/userdoc:tt_virtualbox, which describes (with a little shortfalls) how to convert the IMG file to VDI file and boot it as a virtual machine under VirtualBox.but I had no success doing so.
Every time I try to boot from an existing disk (the VDI file) it fails saying this :
"Failed to open the hard disk /.../astlinux-0.7.10-asterisk-1.8.7.1.vdi.
The medium '/.../astlinux-0.7.10-asterisk-1.8.7.1.vdi' can't be used as the requested device type."

Any suggestion is appreciated.

VirtualBox version is 4.1.2_Ubuntu and it runs on top of Ubuntu 11.10


Thanks,

Oren

------------------------------------------------------------------------------
RSA&#174; Conference 2012
Save $700 by Nov 18
Register now&#33;
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA&#174; Conference 2012
Save $700 by Nov 18
Register now&#33;
http://p.sf.net/sfu/rsa-sfdev2dev1
Oren Yehezkely | 2 Nov 05:50 2011
Picon

Re: Astlinux-users Digest, Vol 64, Issue 1


Lonnie,

Thanks for your reply.

I used the dd command on a Linux (Ubuntu 11.10) machine.
The image is geni586 and the version is 0.7.10.

I am not sure that I understand your question whether it is mountin gor not.
I did not try to mount I only tried to boot from the SD card.

What would I need to do to try to mount it as you suggested?

Thanks,

Oren

------------------------------

Message: 3
Date: Mon, 31 Oct 2011 22:45:09 -0500
From: Lonnie Abelbeck <lists <at> lonnie.abelbeck.com>
Subject: Re: [Astlinux-users] New install using SD card not working
To: AstLinux Users Mailing List <astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org>
Message-ID: <0C5F009B-FF65-4852-B089-889A478D82C3-7Mk/79+iTMGXdHBpF2ONWUEOCMrvLtNR@public.gmane.org>
Content-Type: text/plain; charset=us-ascii

Oren,

After you created your SD card, does it mount on your PC/Mac ?  Does it show a RUNNIX volume with an "os" directory ?

If so, then describe what hardware you are using.

Which img.gz board type did you use, geni586 (Generic i586) ?

Which version did you use, 0.7.10 or the 1.0-beta ?

Lonnie


On Oct 31, 2011, at 10:15 PM, Oren Yehezkely wrote:

> Hi,
>
> I am using the instructions in this document http://doc.astlinux.org/userdoc:new-install
> to install the image on an SD card.
>
> When I boot from the SD card after performing the dd command, all that I can see is a prompt with blank screen.
>
> What am I missing here?
>
> Can this setting work at all or is it not possible to boot from USB and SD cards?
>
> Thanks,
>
> Oren



------------------------------


------------------------------------------------------------------------------
RSA&#174; Conference 2012
Save $700 by Nov 18
Register now&#33;
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA&#174; Conference 2012
Save $700 by Nov 18
Register now&#33;
http://p.sf.net/sfu/rsa-sfdev2dev1
Lonnie Abelbeck | 2 Nov 14:50 2011

Re: New install using SD card not working

Oren,

I asked you to mount the SD card on a PC/Mac (and see RUNNIX volume and "os" directory) so we are sure the SD card
is properly formatted and ready for the next step, since you were having trouble.  After dd'ing the .img
file to the SD card it creates a FAT16 partition that should easily mount on almost any personal computer,
just like a camera SD card.

You never described what hardware you are trying to boot with the SD card.  It must be an x86 board, not ARM, etc.

Lonnie

On Nov 1, 2011, at 11:50 PM, Oren Yehezkely wrote:

> 
> Lonnie,
> 
> Thanks for your reply.
> 
> I used the dd command on a Linux (Ubuntu 11.10) machine.
> The image is geni586 and the version is 0.7.10.
> 
> I am not sure that I understand your question whether it is mountin gor not.
> I did not try to mount I only tried to boot from the SD card.
> 
> What would I need to do to try to mount it as you suggested?
> 
> Thanks,
> 
> Oren 
> 
> ------------------------------
> 
> Message: 3
> Date: Mon, 31 Oct 2011 22:45:09 -0500
> From: Lonnie Abelbeck <lists@...>
> Subject: Re: [Astlinux-users] New install using SD card not working
> To: AstLinux Users Mailing List <astlinux-users@...>
> Message-ID: <0C5F009B-FF65-4852-B089-889A478D82C3@...>
> Content-Type: text/plain; charset=us-ascii
> 
> Oren,
> 
> After you created your SD card, does it mount on your PC/Mac ?  Does it show a RUNNIX volume with an "os"
directory ?
> 
> If so, then describe what hardware you are using.
> 
> Which img.gz board type did you use, geni586 (Generic i586) ?
> 
> Which version did you use, 0.7.10 or the 1.0-beta ?
> 
> Lonnie
> 
> 
> On Oct 31, 2011, at 10:15 PM, Oren Yehezkely wrote:
> 
> > Hi,
> >
> > I am using the instructions in this document http://doc.astlinux.org/userdoc:new-install
> > to install the image on an SD card.
> >
> > When I boot from the SD card after performing the dd command, all that I can see is a prompt with blank screen.
> >
> > What am I missing here?
> >
> > Can this setting work at all or is it not possible to boot from USB and SD cards?
> >
> > Thanks,
> >
> > Oren

------------------------------------------------------------------------------
RSA&#174; Conference 2012
Save $700 by Nov 18
Register now&#33;
http://p.sf.net/sfu/rsa-sfdev2dev1
Fernando Fuentes | 3 Nov 03:52 2011
Picon

AstLinux Server Recommendations (Hardware)

I have AstLinux running solid on a Alix 2D3. I now need to move that setup to a more powerful server. I am in need of a rack mountable system with low power compsumption. I would like it to be smaller than a 1U but not required. I am considering a soekris net5501 http://soekris.com/products/net5501.html 


Any suggestions?

Thank you in advance!
------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
Michael Keuter | 3 Nov 09:39 2011

Re: AstLinux Server Recommendations (Hardware)

The 5501 has the same CPU as the Alix, but 512 MB Ram plus a PCI slot. Otherwise its nearly the same. So you wont get more "power".

Sent from my iPad

Michael

Am 03.11.2011 um 03:52 schrieb Fernando Fuentes <digitaldistro-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>:

I have AstLinux running solid on a Alix 2D3. I now need to move that setup to a more powerful server. I am in need of a rack mountable system with low power compsumption. I would like it to be smaller than a 1U but not required. I am considering a soekris net5501 http://soekris.com/products/net5501.html&nbsp ;

Any suggestions?

Thank you in advance!
------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
_______________________________________________
Astlinux-users mailing list
Astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org
https://lists.sourceforge.net/lists/listinfo/astlinux-users

Donations to supp ort AstLinux are graciously accepted via PayPal to paypal-QwOCKVwDs3fYtjvyW6yDsg@public.gmane.org.
------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
Graziano Brioschi | 3 Nov 10:19 2011
Picon

Re: AstLinux Server Recommendations (Hardware)

Hi Fernando

if you need more CPU power, give a try to OpenVox ICP110: ATOM based, up 2Gb RAM, CF and SATA support. I have installed astlinux 0.7.9 on a Sandisk CF without particolar problems; the only issue is related to its price versus ALIX2D3

Ciao
Graziano

Il 03/11/2011 3.52, Fernando Fuentes ha scritto:
I have AstLinux running solid on a Alix 2D3. I now need to move that setup to a more powerful server. I am in need of a rack mountable system with low power compsumption. I would like it to be smaller than a 1U but not required. I am considering a soekris net5501 http://soekris.com/products/net5501.html 

Any suggestions?

Thank you in advance!


------------------------------------------------------------------------------ RSA(R) Conference 2012 Save $700 by Nov 18 Register now http://p.sf.net/sfu/rsa-sfdev2dev1

_______________________________________________ Astlinux-users mailing list Astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org https://lists.sourceforge.net/lists/listinfo/astlinux-users Donations to support AstLinux are graciously accepted via PayPal to paypal-QwOCKVwDs3fYtjvyW6yDsg@public.gmane.org.

------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
Graziano Brioschi | 3 Nov 10:27 2011
Picon

Re: AstLinux Server Recommendations (Hardware)

Here some URL about Openvox IPC110 embedded mobo and IPPBX kit
http://www.openvox.cn/en/products/embedded-motherboards/ipc110.html
http://www.openvox.cn/en/products/ippbx-kit/ix110.html?page=shop.product_details&flypage=flypage.tpl&product_id=61&category_id=7

graziano

 

Il 03/11/2011 10.19, Graziano Brioschi ha scritto:
Hi Fernando

if you need more CPU power, give a try to OpenVox ICP110: ATOM based, up 2Gb RAM, CF and SATA support. I have installed astlinux 0.7.9 on a Sandisk CF without particolar problems; the only issue is related to its price versus ALIX2D3

Ciao
Graziano

Il 03/11/2011 3.52, Fernando Fuentes ha scritto:
I have AstLinux running solid on a Alix 2D3. I now need to move that setup to a more powerful server. I am in need of a rack mountable system with low power compsumption. I would like it to be smaller than a 1U but not required. I am considering a soekris net5501 http://soekris.com/products/net5501.html 

Any suggestions?

Thank you in advance!


------------------------------------------------------------------------------ RSA(R) Conference 2012 Save $700 by Nov 18 Register now http://p.sf.net/sfu/rsa-sfdev2dev1

_______________________________________________ Astlinux-users mailing list Astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org https://lists.sourceforge.net/lists/listinfo/astlinux-users Donations to support AstLinux are graciously accepted via PayPal to paypal-QwOCKVwDs3fYtjvyW6yDsg@public.gmane.org.



------------------------------------------------------------------------------ RSA(R) Conference 2012 Save $700 by Nov 18 Register now http://p.sf.net/sfu/rsa-sfdev2dev1

_______________________________________________ Astlinux-users mailing list Astlinux-users-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org https://lists.sourceforge.net/lists/listinfo/astlinux-users Donations to support AstLinux are graciously accepted via PayPal to paypal-QwOCKVwDs3fYtjvyW6yDsg@public.gmane.org.

------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1

Gmane