Krämer Kevin | 10 Jul 12:04 2015
Picon

Problem with recovering image

Hello together,

 

I got a problem virtulizing our Proliant 3000 with Unixware 7.

I booted the server with the g4u CD and got the following disks:

 

Ld0 at cac0 unit 0: RAID5 array (70GB)

Ld1 at cac0 unit 1: RAID 1 array (9GB)

 

I used uploaddisk command with ld0 and ld1 at the end for each logical disk.

After this I created a virtual machine on an ESXi 5.5 (with Unixware 7 Support) and added two IDE drives (not SCSI).

After using slurpdisk command to wd0 and wd1 I rebooted the virtual machine and got error loading operating system.

With deploying the image to two SCSI drives I got the same problem.

 

I suspect that it is not supported to recovery the image from a logical disk to a IDE drive – am I right?

 

Do you got any further hints for me, which I could test?

This machine is very important for us and I’ll try anyting to get it virtulized before the disk drives crash.

 

Thank you in advance

 

Kind regards

 

Kevin

 

------------------------------------------------------------------------------
Don't Limit Your Business. Reach for the Cloud.
GigeNET's Cloud Solutions provide you with the tools and support that
you need to offload your IT needs and focus on growing your business.
Configured For All Businesses. Start Your Cloud Today.
https://www.gigenetcloud.com/
_______________________________________________
g4u-help mailing list
g4u-help@...
https://lists.sourceforge.net/lists/listinfo/g4u-help
Henson, Girard | 10 Jul 02:05 2015

Having an issue with G4U

Hi there,

 

Thank you for putting out this tool. Some of the folks here have used it for years to perform local disk clones just fine. However, we are running into an issue when we decided to implement the FTP transfer. We were able to capture the image successfully on to the FTP server, but when we try to write it back to the disk, the connection disconnects at seemingly random intervals. The only errors we get are a 426 error on the server and a 421 on the client if we do a CTRL + C. Is there any guidance you could provide us on how to address this? Does G4U offer some kind of logging mechanism? We’re running some tests with Wireshark but we could use all the input possible. We have tried using both IIS FTP and FileZilla.

 

Girard

 

------------------------------------------------------------------------------
Don't Limit Your Business. Reach for the Cloud.
GigeNET's Cloud Solutions provide you with the tools and support that
you need to offload your IT needs and focus on growing your business.
Configured For All Businesses. Start Your Cloud Today.
https://www.gigenetcloud.com/
_______________________________________________
g4u-help mailing list
g4u-help@...
https://lists.sourceforge.net/lists/listinfo/g4u-help
Mateusz Viste | 14 Mar 10:39 2014

g4u automation - any experience?

Hello list,

I am wondering about using g4u to perform backups of a bunch of PCs. 
These backups would be performed by the users themselves, so I am 
looking after a solution that could be as much automated as possible..

I have read about g4u, and it looks like an astonishing piece of 
open-source software - however, it seems targeted to IT admins. For a 
user, entering the address of a FTP server, providing the name of his 
disk device etc is often black magic (*even* for users that are supposed 
to be professional programmers..).

Anyway, g4u looks really promising, but I'd need to find a way to 
automatize it (for eg. via some kind of custom script). The final goal 
for me would be to have such thing:
  - the user boots g4u from a CD
  - g4u boots, gets an IP over DHCP, and gets a script or config file 
from the DHCP server
  - a simple menu appears, asking to select either "1. backup" or "2. 
restore". then, for the "backup" option:
  - performs a dump of the PC's drive (configured in the script), but 
only up to X GB (let's say, first 128G)
  - pushes the dump to the FTP server (configured in config file), into 
a file that is named after the mac address of the PC
  - once done, halts the PC

Now, I don't see any scripting feature integrated into g4u, but maybe 
I'm missing something. Where should I look? Where would I need to start? 
Have anyone already done similar things?

cheers,
Mateusz

------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
http://p.sf.net/sfu/13534_NeoTech
Colin Ager | 22 Feb 14:16 2014
Picon

re-Problem with g4u 2.5 reading sata disk with vol groups


Hi Hubert Thanks for reply. Just to clarify the situation "dmesg"
does find wd0 and correctly identify it. It only fails when it tries to 
read the partitions. The first sign of trouble is the line:

"wd0: dos partition drive fault"

Then there are several repeats of:

"wd0d device fault reading fsbn 0 (wd0 bn 0; cn 0 tn 0 sn 0),retrying"
followed by

"ixpid0: 0: 0".

It finally gives a last run without the ixped0 line and goes no further.

This drive"wd0" appears to be working normally and I want to make a 
local copy of it on a brand new disk. If g4u makes a bit by bit copy 
does it matter that it can't read the partitions? I don't want to change 
them in any way.

On a different point the only option I can access at start-up of g4u is 
"1" as the timer has already run out when I get there!

Cheers Colin Ager  Norfolk UK

------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk
Colin Ager | 18 Feb 10:44 2014
Picon

Problem with g4u 2.5 reading sata disk with vol groups

I am trying to use g4u 2.5 to clone a sata drive. On an older machine 
with ide disks it has no difficulty finding the disks but with the newer 
machine the disk I want to clone as wd0 is detected plus a second disk 
wd1 as shown by dmesg, but running the disks command gives a repeating 
error message  that it is having problems detecting the partitions.

"wd0d device fault reading fsbn 0 (wd0 bn 0; cn 0 tn 0 sn 0),retrying"

If I try the partition check on this disk I get a similar response, but 
if I try partition check on wd1 it works correctly. Both disks are sata 
types but wd0 has logical volumes on it, while wd1 just has normal 
partitions.

Is it safe to do a copydisk operation in these circumstances to a third 
sata disk that I havn't  yet tried in place of wd1.

wd0 has Fedora16 32b on it while wd1 has win7 64.

Back in 2006 I used g4u 2.2 to clone a disk and sent a donation to you!

Cheers Colin Ager  Norfolk UK

------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk
Hubert Feyrer | 27 Oct 02:04 2013
Picon

Your G4U Opinion: kernel with embedded RAMdisk vs. miniroot?


My dear g4u community,

I've found little time to hack on g4u in the recent past. Yet, I've 
managed to setup my development and test environment for g4u 
(crosscompiling NetBSD from Mac OS X, getting recent Qemu to compile), and 
also got g4u built from recent NetBSD-current sources. As such, take this 
as small sign of life.

Now, while I don't have any plans for large changes, I'd like to bring an 
update with latest drivers and bugfixes from NetBSD.

There's one change that I'm pondering, though: g4u originally came as one 
kernel-file that had an embedded RAM-disk. This was changed in the last 
release to reflect NetBSD's ability to load a RAM-disk from a separate 
file. This change broke the ability to netboot g4u from a single file, and 
required some more effort. There were no real wins for g4u as such.

So, opinion time: keep the RAM-disk as separate file, or move it back into 
the kernel?

Looking forward for your opinions!

  - Hubert

------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from 
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60135991&iu=/4140/ostg.clktrk
Ajax Dahgue | 4 Aug 19:38 2013

FW: Pblm on Dell D620

 

 

Hi,

  I see that there have been problems with Dell hardware.  Was wondering what resolutions there may be.  My Dell Latitude D620 fails at the initial splash: SYSLINUX 4.03 …..Peter Anvin et al.

 

I used Unetbootin to create a bootable usb I could carry in my toolkit.  Can this be made to work?

 

Thanks!

 

- ajax -

------------------------------------------------------------------------------
Get your SQL database under version control now!
Version control is standard for application code, but databases havent 
caught up. So what steps can you take to put your SQL databases under 
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711&iu=/4140/ostg.clktrk
_______________________________________________
g4u-help mailing list
g4u-help@...
https://lists.sourceforge.net/lists/listinfo/g4u-help
Hubert Feyrer | 18 Jun 23:26 2013
Picon

Re: G4U 2.5

Hi Tim,

I'll take the liberty to CC the g4u-help list, as this may come up again:

Am 18.06.2013 um 20:08 schrieb Tim Burks:
   Something about 2.5s netbsd file not like the one before. Ive extracted it from the floppies and uploaded to my pxe server. Doing so with the latest 2.5 file pxe clients cant boot G4U.  I have revered back to the 2.4 netbsd file which works fine. I cant seem to resolve the difference. I do notice that the old netbsd file is 7,487,132 in size and the newer is 6,902,704.
  I notice on your webpage a link for zipped which extracts 3 files but for uncompressed there is only disk one and two links listed.
Maybe Im confused as which set I need.
  As far as the error goes, the boot process stops here: root on md0a dumps on md0b, no file system for md0, cannot mount root error 79,.  After that some usb lines and hangs.

g4u 2.5 changed from a kernel that includes the root filesystem as ram-disk (root on md0a) to a system that just loads the kernel, and then loads the ramdisk with the root filesystem (still at md0a) from an extra file. see the boot.cfg file:

menu=Start g4u:load /miniroot.kmod;boot netbsd

"netbsd" is still the kernel, and "miniroot.kmod" is the root filesystem which gets loaded before the kernel starts.

IIRC it's possible to also do this with PXE. Check this out for documentation on how to do this, which actually doesn't cover NetBSD but g4u :-)


Enjoy!


 - Hubert
------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
g4u-help mailing list
g4u-help@...
https://lists.sourceforge.net/lists/listinfo/g4u-help
Paolo Aglialoro | 12 Nov 00:03 2012
Picon

g4u 2.5 crashes when booting on HP tc4400

Hello,

while I was trying to boot g4u-2.5 from grub2 on my HP laptop, I found that the wifi nic installed crashes the system after that dhcp client strings appear on the screen. Btw considering that I succeeded after long tries to tame g4u iso from grub2, here's how (you could put it in your FAQ, I haven't found the whole story googling the internet):

1. copy g4u-2.5.iso to /boot/iso/
2. add to /boot/grub/40_custom the following lines:

menuentry "g4u 2.5 fromiso" {
        loopback loop /boot/iso/g4u-2.5.iso
        knetbsd     (loop)/netbsd
        knetbsd_module_elf     (loop)/miniroot.kmod
}

3. run the command: update-grub

So, this is the screen output:


wpi0: could not read firmware file
uvm_fault(0xc44176c0, 0x1450000, 1) -> 0xe
fatal page fault in supervisor mode
trap type 6 code 0 eip c02244aa cs 8 eflags 10292 cr2 14502b8 ilevel 6
panic: trap

The operating system has halted
Please press any key to reboot.


Openbsd reports that my wpi0 (at pci2) wireless nic is a "Intel/PRO Wireless 3945ABG" rev 0x02, which is a widespread card.
So, why this crash?
Thanks,
Paolo

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_nov
_______________________________________________
g4u-help mailing list
g4u-help@...
https://lists.sourceforge.net/lists/listinfo/g4u-help
lorezan | 4 Oct 20:28 2012
Picon

g4u-2.5 floppy version: "cannot mount root, error = 79"

Hello,

there's a problem with the g4u-2.5 floppy version, it hangs here:

boot device: <unknown>
root on md0a dumps on md0b
Supported file systems: mfs ffs cd9660
no file system for md0 (dev 0x1100)
cannot mount root, error = 79
root device (default md0a):
use one of: md0[a-p] ne2 wd0[a-p] halt reboot

No choice seems to work, and after the first choice, the keyboard is stuck in
capital letters.

The cdrom 2.5 version works fine in the same condition.

I tested the floppy 2.5-beta1 and 2.4, they produce the same error.
The 2.3 floppy version works fine.

Thanks for your help.

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
Manual GSM | 18 Jun 17:44 2012
Picon

atl1c driver

I have used g4u for years in a university computer room with much content.
Now we have replaced all machines with new ones, and g4u doesn't work anymore, it cannot recognize the nics.

According to Win7: Atheros AR8131 PCI-E Gigabit
According to Ubuntu: atl1c (100 Mb/s)

What I could find out with g4u:
"Attansic Technologis product 0x1063 (ethernet network, revision 0xc0) azt pci2 dev 0 function 0 not configured". (ifconfig -a does not list anything)

What can I do?
I would be grateful for help.

Thank you

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and 
threat landscape has changed and how IT managers can respond. Discussions 
will include endpoint security, mobile security and the latest in malware 
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
g4u-help mailing list
g4u-help@...
https://lists.sourceforge.net/lists/listinfo/g4u-help

Gmane