Massimo Di Pierro | 1 Aug 01:13 2011
Picon

Re: delete buttons not working

do you refer to web2py.com/demo_admin and web2py.com/demo_app ? Yes,
they are in readonly mode.

On Jul 31, 4:23 pm, peter <peterchutchin...@...> wrote:
> I now see that the delete buttons do not work in your live demos, and
> that this is maybe deliberate as you do not want people emptying the
> demo databases. So maybe this is not a bug, but the lack of
> documentation leaves me unclear.
>
> Thanks
> Peter

Matthew | 1 Aug 01:20 2011
Picon

Re: Not getting proper Janrain choices

They were both generated by the new application wizard, then I
modified them. I've copied the relevant portions below (substituting
for secret keys, etc.).

0.py

from gluon.storage import Storage
settings = Storage()

settings.migrate = True
settings.title = 'My New App'
settings.subtitle = 'powered by web2py'
settings.author = 'you'
settings.author_email = 'you@...'
settings.keywords = ''
settings.description = ''
settings.layout_theme = 'Whitelight'
settings.database_uri = 'sqlite://storage.sqlite'
settings.security_key = '14f78e4e-5595-4d88-bcd8-49308acf11b4'
settings.email_server = 'localhost'
settings.email_sender = 'you@...'
settings.email_login = ''
settings.login_method = 'janrain'
settings.login_config = 'domain:api_key'
settings.plugins = []

db.py (abridged)

...

(Continue reading)

boss | 1 Aug 01:36 2011
Picon

Re: voltdb support

Hi Massimo,

the driver can be downloaded from here: http://community.voltdb.com/downloads

the DB only works with stored procedures. I guess the DB could be
defined as usual in web2py and a new dml command could contain the
name of a stored procedure, params, etc... i would love to test.

thank you
sb

On Jul 30, 7:03 pm, Massimo Di Pierro <massimo.dipie...@...>
wrote:
> Can you point is to the driver? Which SQL DB is it most similar to?
> Can you help testing?
>
> On Jul 30, 12:19 pm, boss <abd...@...> wrote:
>
>
>
>
>
>
>
> > hello,
>
> > Would be great to have support for VoltDB . It has a native Python
> > driver as well as a json interface .. very promising DB which is a mix
> > between NoSQL & relational SQL. The database retains the data in RAM
> > or disk partitions and distributes both the data and the SQL engine
(Continue reading)

Anthony | 1 Aug 04:57 2011
Picon

Re: Not getting proper Janrain choices

On Sunday, July 31, 2011 7:20:27 PM UTC-4, Matthew wrote:

0.py

settings.login_config = 'domain:api_key'
 
I think the above is supposed to be your domain and Janrain API key, not the literal string 'domain:api_key' (you input this in the first step of the wizard). However, in this case I don't think it matters, because it appears your code does not actually use this setting (see below).
 
 
db.py (abridged)

...

#########################################################################
## If you need to use OpenID, Facebook, MySpace, Twitter, Linkedin,
etc.
## register with janrain.com, uncomment and customize following
from gluon.contrib.login_methods.rpx_account import RPXAccount
auth.settings.actions_disabled = \
   ['register','change_password','request_reset_password']
auth.settings.login_form = RPXAccount(request,
api_key='xxxxxxxxxxxxxxxxxxxxxx',domain='xxxxxxxxx',
   url = "http://localhost:8888/%s/default/user/login" %
request.application)
 
When using the wizard, you shouldn't need to manually uncomment and fill in the code above. Instead, the following code should be inserted in db.py for you by the wizard:
 
from gluon.contrib.login_methods.rpx_account import RPXAccount
auth.settings.actions_disabled=['register','change_password','request_reset_password']
auth.settings.login_form = RPXAccount(request,
    api_key = settings.login_config.split(':')[-1],
    domain = settings.login_config.split(':')[0],
    url = "http://%s/%s/default/user/login" % (request.env.http_host,request.application))
 
 
Notice this uses settings.login_config to obtain your domain and API key. Does your db.py include this code? If not, what version of web2py are you using?
 
Anthony
 
Bruno Rocha | 1 Aug 05:15 2011
Picon

Re: Delete buttons not working

Hi, you are probably talking about PowerGrid example app.


I made delete buttons read-only, just to avoid loss of the data on examples.

I am writing a better documentation and solving some reported issues, thank you for testing.

I hope next week to release a better version, with support to more datasources, working on GAE and with some documentation.

Thanks.

On Sun, Jul 31, 2011 at 6:12 PM, peter <peterchutchinson-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org> wrote:
Bruno

Thanks a lot for this, it is a very useful tool just as I needed it.

I am using the latest version of web2py, and python 2.5, so I had the
same problems as Tomt had. I commented out the
'with open(path' etc.

I am now finding that the delete buttons do not work on the examples
on which they appear. I discovered that the 'data' functions were not
being called, so the confirmationmodal does not seem to be working.
Using refreshmodal to force the link to the 'data' functions got it
further but then I get a page not found, which is strange as the
details and edit buttons do work fine.

I hope this is useful feedback.

Peter



--



--
Bruno Rocha
[ Aprenda a programar: http://CursoDePython.com.br ]
[ O seu aliado nos cuidados com os animais: http://AnimalSystem.com.br ]
[ Consultoria em desenvolvimento web: http://www.blouweb.com ]

Charles Law | 1 Aug 07:22 2011
Picon

streamer vs stream_file_or_304_or_206

I've noticed that when I stream() files using the streamer I get
content type warnings in chrome:
  Resource interpreted as Document but transferred with MIME type
image/png.
But the static directory, which uses stream_file_or_304_or_206() does
not have this issue.

Should the streamer be returning HTTP status codes?  Should I be doing
this?  Could this be why chrome has an issue?  My controller code
currently looks like this:
  return response.stream(open(path,'rb'),chunk_size=64*1024)

Thanks,
Charles

Andrew | 1 Aug 07:37 2011
Picon

Legacy Tables: Can't Insert rows. Nothing back from db._lastsql

Hello,
I'm experimenting with using legacy tables, and I've created a test
table in MS SQL, inserted some rows(through SQLServer Studio), and I
can now see the rows in a very simple View.

I have tried to Insert rows into this table through the Models
database administration screen, as well as using the Controllers
shell.   db.web2pytest_leg.insert(LoadName='blah', DestinationName =
'blah2', Description = 'blahblah')

This doesn't come back with any errors but doesn't insert anything
either.  There is no feedback on the shell that it did anything.
Another point, which may be a related symptom, is that when I then run
"print db._lastsql"   I just get the command echoed back to me and no
sql.  There are no errors in the log.

my db.py file includes:

db.define_table('web2pytest_leg',
                Field('LoadName', 'string'),
                Field('DestinationName', 'string'),
                Field('Description', 'string'),
                primarykey=['LoadName'],
                migrate=False
                )
I've also tried running with fake_migrate=True for a while too.

Any ideas please.   I've browsed through the forum for a while but I
can't see this issue.   Thanks.

Ramana | 1 Aug 08:09 2011
Picon

Requesting Feedback for Web2py Instant Admin

Dear Web2py users,


I just launched the beta version of Web2py Instant Admin, a (supposedly) django-like admin interface for Web2py applications. The demo is here, documentation is here and source code is here. Since this is my first Web2py project, I don't know how good/bad the quality is. Your feedback will be very valuable for me. Thanks for your time. 

Thanks & Regards,
Ramana.
Hege | 1 Aug 08:59 2011
Picon

Re: response streaming html with images


Those output files are short living objects with tmp names and tmp
dir. Too short living,  to put them to Static. Transformation to html
is specific as there could be more  output files and as far as I
understand, missing images will be requested by browser. So, I will
just alter html to point to specific controler, which will just serve
those files from fixed, yet temporary place.

Thanx for help.

pbreit | 1 Aug 08:57 2011
Picon

Re: Requesting Feedback for Web2py Instant Admin

It looks pretty interesting. Is the idea that it would complement or replace appadmin?


Gmane