Alan G Isaac | 30 Aug 03:37 2013
Picon

status of SimpleParse inclusion?

It seems the new release of Canopy does not include SimpleParse:
   https://www.enthought.com/products/canopy/package-index/

A year or so ago it seemed like you were open to including it.
The author even offered to help if you ran into problems.
What happened?  Does Canopy include a parser generator that
you recommend instead?

Thanks,
Alan Isaac
Sundeep Sivan | 23 Aug 07:29 2013
Picon

Audio processing python

Hi,
I am an M.TECH student. I would like to do speaker recognition (Recognizing perons from their voice). I would like to do my project in Python. So want to know whether Python supports audio processing or not. Kindly Help me.
_______________________________________________
EPD-Users mailing list
EPD-Users <at> enthought.com
https://mail.enthought.com/mailman/listinfo/epd-users
Michael Ellis | 22 Aug 17:06 2013
Picon

Canopy 1.03 on OS X breaks ipython notebook from cmd line ?

I recently upgraded to Canopy 1.03 and made it my default python.  I can open and edit notebooks from the Canopy GUI, but I much prefer working out of a browser (Chrome).   Since the upgrade,  starting the notebook server from the command line yields a page in the browser containing only the Ipython Notebook logo in the upper left corner with no way to access existing notebooks or create new ones.

Here's the terminal output when I start 'ipython notebook'
$ ipython notebook
[NotebookApp] Using existing profile dir: u'/Users/mellis/.ipython/profile_default'
[NotebookApp] Serving notebooks from local directory: /Users/mellis/Google Drive/MidwayProduction
[NotebookApp] The IPython Notebook is running at: http://127.0.0.1:8888/
[NotebookApp] Use Control-C to stop this server and shut down all kernels.

and here's the version info from ipython

$ ipython 
Python 2.7.3 | 64-bit | (default, Jun 14 2013, 18:17:36) 
Type "copyright", "credits" or "license" for more information.

IPython 1.0.dev -- An enhanced Interactive Python.

I'm running OS X Version 10.8.4

Thanks,
Mike Ellis
_______________________________________________
EPD-Users mailing list
EPD-Users <at> enthought.com
https://mail.enthought.com/mailman/listinfo/epd-users
Sturla Molden | 21 Aug 18:13 2013
Picon

Wrong libpython27.a version on 64-bit Canopy for Windows?


I get this linker error:

C:\MinGW64\bin\gcc.exe -shared -s 
build\temp.win-amd64-2.7\Release\test.o 
build\temp.win-amd64-2.7\Release\test.def 
-LC:\Users\sturlamo\AppData\Local\Enthought\Canopy\User\libs 
-LC:\Users\sturlamo\AppData\L
ocal\Enthought\Canopy\User\PCbuild\amd64 -lpython27 -lmsvcr90 -o 
D:\memoryview-test\test.pyd
build\temp.win-amd64-2.7\Release\test.o:test.c:(.text+0x1313d): 
undefined reference to `__imp_Py_InitModule4'
collect2.exe: error: ld returned 1 exit status
error: command 'gcc' failed with exit status 1

This error usually results from trying to link with libraries for 32-bit 
Python. That is, __imp_Py_InitModule4 is renamed __imp_Py_InitModule4_64 
to protect from this.

Since it occurs I assume you have accidentally shipped Canopy with the 
wrong version of the import library for MinGW64.

Regards,
Sturla
Marty Lichtman | 16 Aug 17:48 2013
Picon

Location of Canopy cache on OS X?

Hello.  Can anybody point me to where Canopy keeps cached versions of files that were open in the editor?  (OS X 10.8.4, Canopy 1.0.0.1160)

I had a bunch of files open in the Canopy editor last night from a server mounted as a samba volume, and for some reason they are all blank in the editor this morning, and their size is zero 0 bytes (I checked on the server, it's not just a lost connection).  I will be able to recover them from tape backup, but it will be a lot faster if I can find them locally.

Thanks for your help.

Martin Lichtman

Department of Physics, University of Wisconsin - Madison

_______________________________________________
EPD-Users mailing list
EPD-Users <at> enthought.com
https://mail.enthought.com/mailman/listinfo/epd-users
cpblpublic+enthought | 15 Aug 18:02 2013
Picon

RHEL6 no luck (easy_install; matplotlib)


I am giving Canopy another shot on my 64-core RHEL6 GNU/Linux machine. Thanks 
for the update and maybe strong GNU/Linux support.

This time it installed okay, but I need some packages that seem not to be built 
in. Am I not supposed to use easy_install for those? Here's what happens when I 
try one:

$ source /home/meuser/Enthought/Canopy_64bit/User/bin/activate

$ easy_install gdal
Searching for gdal
Reading http://pypi.python.org/simple/gdal/
Best match: GDAL 1.10.0
Downloading 
https://pypi.python.org/packages/source/G/GDAL/GDAL-1.10.0.tar.gz#md5=d908a070bec2bb86fde1f13d76a552c2
Processing GDAL-1.10.0.tar.gz
Writing /tmp/easy_install-yGAilY/GDAL-1.10.0/setup.cfg
Running GDAL-1.10.0/setup.py -q bdist_egg --dist-dir 
/tmp/easy_install-yGAilY/GDAL-1.10.0/egg-dist-tmp-b5p34E
RuntimeError: module compiled against API version 7 but this version of numpy 
is 6
Traceback (most recent call last):
   File "/home/meuser/Enthought/Canopy_64bit/User/bin/easy_install", line 10, in 
<module>
     sys.exit(main())
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 1920, in main
     with_ei_usage(lambda:
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 1901, in with_ei_usage
     return f()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 1924, in <lambda>
     distclass=DistributionWithoutHelpCommands, **kw
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/core.py", 
line 152, in setup
     dist.run_commands()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/dist.py", 
line 953, in run_commands
     self.run_command(cmd)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/dist.py", 
line 972, in run_command
     cmd_obj.run()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 350, in run
     self.easy_install(spec, not self.no_deps)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 590, in easy_install
     return self.install_item(spec, dist.location, tmpdir, deps)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 620, in install_item
     dists = self.install_eggs(spec, download, tmpdir)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 814, in install_eggs
     return self.build_and_install(setup_script, setup_base)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 1094, in build_and_install
     self.run_setup(setup_script, setup_base, args)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/easy_install.py", 
line 1080, in run_setup
     run_setup(setup_script, args)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/sandbox.py", 
line 30, in run_setup
     lambda: execfile(
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/sandbox.py", 
line 72, in run
     return func()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/sandbox.py", 
line 32, in <lambda>
     {'__file__':setup_script, '__name__':'__main__'}
   File "setup.py", line 301, in <module>
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/core.py", 
line 152, in setup
     dist.run_commands()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/dist.py", 
line 953, in run_commands
     self.run_command(cmd)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/dist.py", 
line 972, in run_command
     cmd_obj.run()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/bdist_egg.py", 
line 172, in run
     self.run_command("egg_info")
   File 
"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/cmd.py", 
line 326, in run_command
     self.distribution.run_command(command)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/dist.py", 
line 972, in run_command
     cmd_obj.run()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/egg_info.py", 
line 179, in run
     self.find_sources()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/egg_info.py", 
line 254, in find_sources
     mm.run()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/egg_info.py", 
line 308, in run
     self.add_defaults()
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/egg_info.py", 
line 332, in add_defaults
     sdist.add_defaults(self)
   File

"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/site-packages/setuptools/command/sdist.py", 
line 191, in add_defaults
     build_ext = self.get_finalized_command('build_ext')
   File 
"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/cmd.py", 
line 312, in get_finalized_command
     cmd_obj.ensure_finalized()
   File 
"/home/meuser/Canopy/appdata/canopy-1.0.3.1262.rh5-x86_64/lib/python2.7/distutils/cmd.py", 
line 109, in ensure_finalized
     self.finalize_options()
   File "setup.py", line 196, in finalize_options
   File "setup.py", line 176, in get_gdal_config
   File "setup.py", line 129, in fetch_config
   File "<string>", line 4, in <module>
__main__.gdal_config_error: [Errno 2] No such file or directory

Similarly, if I try to use ipython:

from pylab import * 
---------------------------------------------------------------------------
RuntimeError                              Traceback (most recent call last)
RuntimeError: module compiled against API version 7 but this version of numpy 
is 6
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)

Anyone know where have I gone wrong?

Thanks,
Chris
Mark Bakker | 9 Aug 14:41 2013
Picon

default size of math equations in Notebook on Windows

Dear List,


I have created some Notebooks that look great in Canopy on my Mac and in webbrowsers on both Mac and Windows, but the equations are terribly tiny in Canopy on a Windows machine. I can change the size by right-clicking on one of the equations and selecting Math Setting -> Scale all math, and then scale the equations by 200%. Then they look nice and are about the same size as the text around. Problem is that this setting is not saved and every time you open a notebook you have to set this setting again.

This really kind of sounds like a bug. The equations in the notebook look fine in a webbrowser, but not in Canopy. And only on Windows. 

Any thoughts?

Thanks a bunch,

Mark
_______________________________________________
EPD-Users mailing list
EPD-Users <at> enthought.com
https://mail.enthought.com/mailman/listinfo/epd-users
Mark Bakker | 31 Jul 23:00 2013
Picon

HELP IPython Notebook slows down to crawl in Canopy

Hello List,


Sorry to bug you again, but when I run an IPython Notebook in Canopy pretty much every time it slows down to a crawl.
I can type one letter, wait half a second, type another letter, etc. 

Anybody else experiencing this? I am working on a Mac with the latest Canopy version.

When I run the notebook in my browser (ipython notebook --pylab-inline), then the same notebook works fine.

I'd like to resolve this, and want to know whether this is a Mac problem or also a Windows problem, as I want to use Canopy to teach 300 students next month.

Thanks,

Mark
_______________________________________________
EPD-Users mailing list
EPD-Users <at> enthought.com
https://mail.enthought.com/mailman/listinfo/epd-users
Mark Bakker | 29 Jul 21:51 2013
Picon

cannot update to matplotlib 1.2.1 on Canopy

Hello List,


Althoguh matplotlib 1.2.1 appears in the list of 'updated packages' in the Canopy package manager, when I click 'update' it does nothing. It keeps saying 1.2.0 is installed and leaves it at that. Any ideas why or how to remedy?

Mark
_______________________________________________
EPD-Users mailing list
EPD-Users <at> enthought.com
https://mail.enthought.com/mailman/listinfo/epd-users
Nicolas SAQUET | 27 Jul 12:54 2013
Picon
Picon

status of wxPython under Canopy

Hi I knew that wxPython was experiencing experimental support within Canopy. Does its support improved?
Status? Thanks in advance.
Best Regards

Nicolas
Mark Bakker | 26 Jul 16:27 2013
Picon

pressing 'set as default' does not make Canopy the default Python

Hello List,


When I go to Preferences in Canopy (1.0.3) on my Mac and
select <set as default> to make Canopy my default Python distribution,
it doesn't work.
When I open a terminal and start Python it will happily start my old EPD version.

Anything else I can do?
Thanks,

Mark
_______________________________________________
EPD-Users mailing list
EPD-Users <at> enthought.com
https://mail.enthought.com/mailman/listinfo/epd-users

Gmane