Picon

API function of libopkg opkg_install_package return error help to resolve issue

Hello,

I have issue with using API of libopkg as following:

What steps will reproduce the problem? 1. Build /pase/opkg-0.2.2/tests/libopkg_test 2. Start /pase/opkg-0.2.2/tests/libopkg_test as libopkg_test install package_name.ipk 3.opkg_install_package return -1 with error ERROR, "Couldn't find package package_name.ipk What is the expected output? What do you see instead? Package supose to be installed. What version of the product are you using? On what operating system? opkg-0.2.2 on YocTo Please provide any additional information below. I tried analyse issue and find out that hash table is not initialized by the package I tried to install.. So when it is suposed to be retrieved from there hash table is empty
Please help to resolve it. I need it as soon as possible for my project. Probably I have to use some previous version without this bug or to install opkg some different way or something else... Thank you ahead...

Regards Alexey

--
You received this message because you are subscribed to the Google Groups "opkg-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opkg-devel+unsubscribe-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
For more options, visit https://groups.google.com/d/optout.

opkg | 2 Sep 10:19 2014

Issue 145 in opkg: API function of libopkg opkg_install_package return error

Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 145 by alex5693...@...: API function of libopkg  
opkg_install_package return error
https://code.google.com/p/opkg/issues/detail?id=145

What steps will reproduce the problem?
1. Build /pase/opkg-0.2.2/tests/libopkg_test
2. Start /pase/opkg-0.2.2/tests/libopkg_test as
libopkg_test install package_name.ipk
3.opkg_install_package return -1 with error ERROR, "Couldn't find package  
package_name.ipk

What is the expected output? What do you see instead?
Package suposed to be installed.

What version of the product are you using? On what operating system?
opkg-0.2.2 on YocTo

Please provide any additional information below.
I tried analyse issue and find out that hash table is not initialized by  
the package I tried to install.. So when it is suposed to be retrieved from  
there hash table is empty

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

Alejandro del Castillo | 26 Aug 18:17 2014
Picon

Opkg limitations vs dpkg

Hello,

I am on the process of evaluating which package manager to use on our embedded controllers. I know dpkg is more feature-rich, but is heavy weight and requires perl, which I would prefer to avoid installing. On the process of the investigation, a few question pop in my mind:

- Is there a document that lists the shortcoming of opkg vs apt/dpkg? 
- Regarding the dependency engines, I believe both use ad-hoc ones. Are there advantages/disadvantages of opkg vs dpkg on it's dependency engine? are there plans to move opkg to an existing solver like libsolv?
- I believe opkg was not actively maintained for a while, then, under the Yocto project umbrella, it is once more maintained and there is a 1.0 release on the horizon. When is 1.0 planned? what would be on it?
- What about digital signing? is there support for it, like in dpkg?

Thanks so much in advance for any information on the matter.

Cheers,

Alejandro del Castillo

--
You received this message because you are subscribed to the Google Groups "opkg-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opkg-devel+unsubscribe-/JYPxA39Uh5TLH3MbocFFw@public.gmane.org.
For more options, visit https://groups.google.com/d/optout.
opkg | 25 Aug 14:53 2014

Issue 144 in opkg: pkg_remove_orphan_dependent does not consider RECOMMENDs

Status: Accepted
Owner: paul.betafive
Labels: Type-Defect Priority-Medium Milestone-0.3

New issue 144 by paul.betafive: pkg_remove_orphan_dependent does not  
consider RECOMMENDs
https://code.google.com/p/opkg/issues/detail?id=144

pkg_remove_orphan_dependent is called during an upgrade to remove packages  
which were previously autoinstalled but are no longer needed. It only  
considers packages which the old package depends on but the new package  
doesn't. It should also consider packages which the old package recommends  
but the new package doesn't. It should not consider suggested packages as  
these are not typically autoinstalled.

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

opkg | 25 Aug 14:23 2014

Re: Issue 142 in opkg: double entries in the info file

Updates:
	Summary: double entries in the info file
	Status: Accepted
	Owner: paul.betafive
	Labels: Milestone-0.3

Comment #1 on issue 142 by paul.betafive: double entries in the info file
https://code.google.com/p/opkg/issues/detail?id=142

The older package probably shouldn't be marked as "install" as that  
indicates that state_want = SW_INSTALL and that opkg wants to install that  
pacakge. I think it should be "unknown" or possibly "deinstall".

I'll look into how state_want is set during a package upgrade after the  
v0.2.3 release unless this is a regression against previous behaviour in  
the v0.2.x series.

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

opkg | 24 Aug 16:32 2014

Issue 143 in opkg: Needs a more detailed error message if an upgarde is not possible

Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 143 by muuscl...@...: Needs a more detailed error
message  
if an upgarde is not possible
https://code.google.com/p/opkg/issues/detail?id=143

What steps will reproduce the problem?
1. the installed package A depends on package B in version 1.0
2. do a upgrade of package A. The new package A needs a package B in  
version 1.1, but package B do not exists in version 1.1

What is the expected output? What do you see instead?
I get an error message, that an upgrade is not possible
I want to see a list of packages, that blocking the upgrade. In this case  
the message should be say, that package B does not exists in version 1.1

What version of the product are you using? On what operating system?
latest 0.2.x on MLD Linux

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

opkg | 23 Aug 14:24 2014

Re: Issue 124 in opkg: Upgrade of a package do not upgrade the depends


Comment #48 on issue 124 by paul.betafive: Upgrade of a package do not  
upgrade the depends
https://code.google.com/p/opkg/issues/detail?id=124

I don't think comments on the issue tracker is the best place to discuss  
this as it isn't related to resolving the original issue. Could you ask  
that on the mailing list instead?

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

opkg | 23 Aug 11:51 2014

Re: Issue 124 in opkg: Upgrade of a package do not upgrade the depends


Comment #47 on issue 124 by muuscl...@...: Upgrade of a package
do  
not upgrade the depends
https://code.google.com/p/opkg/issues/detail?id=124

Now I have a further question to my last problem. Currently I get no  
message, until an upgrade, that tells my witch package blocks an upgrade.  
Is it possible to show a list of packages that blocks an upgrade and is it  
possible to get an option, that allow to force the upgrade with  
uninstalling the blocking packages?

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

opkg | 22 Aug 15:33 2014

Re: Issue 124 in opkg: Upgrade of a package do not upgrade the depends


Comment #46 on issue 124 by muuscl...@...: Upgrade of a package
do  
not upgrade the depends
https://code.google.com/p/opkg/issues/detail?id=124

Thanks, that is the solution fro my problem.

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

opkg | 22 Aug 15:08 2014

Re: Issue 124 in opkg: Upgrade of a package do not upgrade the depends


Comment #45 on issue 124 by paul.betafive: Upgrade of a package do not  
upgrade the depends
https://code.google.com/p/opkg/issues/detail?id=124

opkg parses versions much like dpkg does, so the Debian Policy Manual  
explains this:  
https://www.debian.org/doc/debian-policy/ch-controlfields.html#s-f-Version

So in your example, "1:2014.05.20-2" would be higher than "2014.06.20-1".  
This is because "2014.06.20-1" is interpreted as "0:2014.06.20-1".

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

opkg | 22 Aug 14:55 2014

Re: Issue 124 in opkg: Upgrade of a package do not upgrade the depends


Comment #44 on issue 124 by muuscl...@...: Upgrade of a package
do  
not upgrade the depends
https://code.google.com/p/opkg/issues/detail?id=124

Is there a simple way, to let a package with a small versions number shown  
as a newer one?
e.g.:
the old package has this versions number:
2014.06.20-1
and the new one this:
2014.05.20-2

On debian packages I often se a "1:" or a 2: prefix in versions numbers.  
Does such a prefix prefix has a higher priority than a normal number?
e.g.
than the new versions number will be like this:
1:2014.05.20-2

Does this number has ha higher priority?

--

-- 
You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings


Gmane