dm | 1 Sep 12:43 2011
Picon

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

Hi,

Is there a bug I can track for the breakage in ics?

Using Earlybird 8.0a2 and Lightning 1.1a1pre (aurora nightlies)

Google calendars with gdata provider work but ics on local/network filesystem break them.

ics calendars on remote servers (http) don't break the google calendars, but don't display anything, so
are equally useless!

TIA,

d
Philipp Kewisch | 1 Sep 16:18 2011
Picon

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

I'll update the table later today. I have a WiP patch to fix the ics parser, thats just about finished for a
first version. Performance is still bad though.

Philipp
Stefan Sitter | 1 Sep 18:12 2011
Picon

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

> Is there a bug I can track for the breakage in ics?

https://bugzilla.mozilla.org/show_bug.cgi?id=678343

/Stefan
Philipp Kewisch | 1 Sep 18:21 2011
Picon

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

Thanks to whoever fixed the Versions page, I assume ssitter :)
cheekybuddha | 1 Sep 20:05 2011
Picon

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

Thank you - keep up the great work guys!

d
Peter Lairo | 1 Sep 22:42 2011

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

On Mi. 31.08.2011 23:10, Stefan Sitter wrote:
> Peter Lairo wrote:
>> Do Lighning builds exist that now work with Thunderbird 8 and 9
>> nightlies?
>>
>> The table on the compatibility page[1] *seems* to say so. If not, please
>> make the table *clear*
>>
>> Version Thunderbird Version Mozilla Platform Version Release Date
>> 1.1a1pre 9.0a1 mozilla9 nightly (comm-central)
>> 1.1a1pre 8.0a2 mozilla8 nightly (comm-aurora)
>> 1.0b6pre 7.0b1 mozilla7 not yet available (comm-beta)
>>
>> [1] https://developer.mozilla.org/en/Calendar/Calendar_Versions
>
> Depends on how you define "works". For both Thunderbird builds there
> exist matching Lightning test builds. You can use them for testing. But
> there doesn't exist stable releases that are recommended for daily use.

By "work" I mean: Lightning comm-central and Lightning comm-aurora show 
only "this weeks" events for my Google CalDAV calendars, but it is not 
possible to go "one week forward" or "back". The display either still 
shows "this week's" events or it shows a blank week - I can't remember 
which. The same goes for Month and Day views: blank.

If those bugs were fixed, Lightning would "work" for me.

Is there a bug where I could track when this is fixed? Is it bug 678343?
--

-- 
Regards,
(Continue reading)

Stefan Sitter | 1 Sep 23:33 2011
Picon

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

Peter Lairo wrote:
> By "work" I mean: Lightning comm-central and Lightning comm-aurora
> show only "this weeks" events for my Google CalDAV calendars, but it
> is not possible to go "one week forward" or "back". The display
> either still shows "this week's" events or it shows a blank week - I
> can't remember which. The same goes for Month and Day views: blank.

Any calendar related messages in error console?
Peter Lairo | 5 Sep 23:00 2011

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

On Do. 01.09.2011 23:33, Stefan Sitter wrote:
> Peter Lairo wrote:
>> By "work" I mean: Lightning comm-central and Lightning comm-aurora
>> show only "this weeks" events for my Google CalDAV calendars, but it
>> is not possible to go "one week forward" or "back". The display
>> either still shows "this week's" events or it shows a blank week - I
>> can't remember which. The same goes for Month and Day views: blank.
>
> Any calendar related messages in error console?

Today's comm-central Thunderbird + Lightning still cannot page to other 
weeks in week view nor display events in month view. :-(

There are so many messages in the error console, and some have my 
private data. There seems no way to copy all console errors at once. So, 
here are a *few* examples:

Could not read chrome manifest file 
'C:\Users\Peter\AppData\Roaming\Thunderbird\Profiles\11111111.Peter 
(2011-03)\extensions\de-DE <at> dictionaries.addons.mozilla.org\chrome.manifest'.

Native module at path 
'C:\Users\Peter\AppData\Roaming\Thunderbird\Profiles\1111111.Peter

(2011-03)\extensions\{8620c15f-30dc-4dba-a131-7c5d20cf4a29}\platform\WINNT_x86-msvc\crashme.dll' 
doesn't export symbol `NSModule`.

Error: (new component).QueryInterface is not a function
Source File: resource://gre/modules/XPCOMUtils.jsm
Line: 301
(Continue reading)

Peter Lairo | 5 Sep 23:12 2011

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

On Mi. 31.08.2011 22:30, Peter Lairo wrote:
> Do Lighning builds exist that now work with Thunderbird 8 and 9 nightlies?
>
> The table on the compatibility page[1] *seems* to say so. If not, please
> make the table *clear*
>
> Version Thunderbird Version Mozilla Platform Version Release Date
> 1.1a1pre 9.0a1 mozilla9 nightly (comm-central)
> 1.1a1pre 8.0a2 mozilla8 nightly (comm-aurora)
> 1.0b6pre 7.0b1 mozilla7 not yet available (comm-beta)
>
> [1] https://developer.mozilla.org/en/Calendar/Calendar_Versions

Please add a comment to your table that the following builds don't work:

          ********************Versions********************
Lightning  Thunderbird   Mozilla    Release Date (this isn't a "date"!)
                          Platform
Date
1.1a1pre   9.0a1         mozilla9   nightly (comm-central) *broken*
1.1a1pre   8.0a2         mozilla8   nightly (comm-aurora) *broken*
1.0b6pre   7.0b1         mozilla7   ??? (comm-beta) *broken*

An estimate time-frame when these builds might be working again would be 
helpful.
--

-- 
Regards,
Peter Lairo

Bugs I think are important:
(Continue reading)

Stefan Sitter | 6 Sep 07:10 2011
Picon

Re: Does Lighning now work with Thunderbird 8 and 9 nightlies?

Peter Lairo wrote:
> Error: Components.classes[' <at> mozilla.org/threads/workerfactory;1'] is
> undefined

So it is indeed Bug 678343 that affects you.

I think the other messages are not related to Lightning. Maybe there is 
more broken in Thunderbird or in other extensions you installed.

/Stefan

Gmane