lists | 3 Mar 08:46 2005

(no subject)

Hello All,

I am trying to compile workrave on SUSE 9.3 (still in beta, but I dont
think thats the problem).

amunshi <at> linux:~/workrave-1.6.2> gcc --version
gcc (GCC) 3.3.5 20050117 (prerelease) (SUSE Linux)

amunshi <at> linux:~/workrave-1.6.2> rpm -qa | grep nauti
nautilus-2.9.91-3

./configure went well, I satisfied all the dependencies, and then started
with make. I get the following error. Any clues on whats wrong?

amunshi <at> linux:~/workrave-1.6.2> make
make  all-recursive
make[1]: Entering directory `/home/amunshi/workrave-1.6.2'
Making all in m4
make[2]: Entering directory `/home/amunshi/workrave-1.6.2/m4'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/amunshi/workrave-1.6.2/m4'
Making all in po
make[2]: Entering directory `/home/amunshi/workrave-1.6.2/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/amunshi/workrave-1.6.2/po'
Making all in backend
make[2]: Entering directory `/home/amunshi/workrave-1.6.2/backend'
Making all in src
make[3]: Entering directory `/home/amunshi/workrave-1.6.2/backend/src'
Making all in unix
(Continue reading)

Rob Caelers | 6 Mar 14:51 2005

Re: (no subject)

lists <at> munshi.biz wrote:
> In file included from /opt/gnome/include/libgnome-2.0/libgnome/libgnome.h:29,
>                  from /opt/gnome/include/libgnomeui-2.0/gnome.h:5,
>                  from ../../common/include/nls.h:31,
>                  from Break.cc:24:
> /opt/gnome/include/libgnome-2.0/libgnome/gnome-program.h:35:18: popt.h: No
> such file or directory

It seems that gnome requires libpopt.  Try installing that library.

Groetjes,
   Rob

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
lists | 7 Mar 06:21 2005

Workrave on SUSE 9.3

Greetings,

Thanks for my first query, popt-devel package was missing in my
installation which solved my initial problem.
Now I get the following error, any clues on what is missing.

Amish.

make  all-recursive
make[1]: Entering directory `/home/amunshi/workrave-1.6.2'
Making all in m4
make[2]: Entering directory `/home/amunshi/workrave-1.6.2/m4'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/amunshi/workrave-1.6.2/m4'
Making all in po
make[2]: Entering directory `/home/amunshi/workrave-1.6.2/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/amunshi/workrave-1.6.2/po'
Making all in backend
make[2]: Entering directory `/home/amunshi/workrave-1.6.2/backend'
Making all in src
make[3]: Entering directory `/home/amunshi/workrave-1.6.2/backend/src'
Making all in unix
make[4]: Entering directory `/home/amunshi/workrave-1.6.2/backend/src/unix'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/amunshi/workrave-1.6.2/backend/src/unix'
Making all in win32
make[4]: Entering directory `/home/amunshi/workrave-1.6.2/backend/src/win32'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/amunshi/workrave-1.6.2/backend/src/win32'
(Continue reading)


Gmane