Picon

My Optware fork



Dear all! I know NSLU2-Linux project is basically stalled, but I hope this read will still be interesting for someone still subscribed to the list.
For few months I've been working in my spear time to get up-to-date Optware I could use on my routers. And here it is:
My Optware fork project

I currently maintain two feeds:
-buildroot-armeabi
-buildroot-mipsel

These feeds are firmware-independent and can be used on basically any device running Linux with appropriate architecture. They're both uClibc-0.9.33.2 gcc-4.9.2 binutils-2.25 targets. The ARM feed is soft-float ARM EABI (aka 'armel' in Debian), while MIPS feed is softfloat MIPSEL (mips32r2).
I test the feeds on TomatoUSB ARM and MIPSEL routers myself, buildroot-armeabi has been also confirmed to work with recent dd-wrt. Anything ARM/MIPSEL which is more or less recent should run the feeds fine.

Compared to the original Optware, except being firmware-independent and having modern toolchains, my fork also has numerous packages upgraded, fixed and added. I also got some X11 GTK+-2 and GTK+-3 applications to work.

Bootstraping instructions can be found on the dd-wrt forum:

All the building is being done on my laptop, and the feeds are hosted on my home server. I basically started the whole thing because it is fun, but now it's turning into something useful. What I'm really missing is an appropriate hosting options, since my ISP isn't really fault-proof)) And, of course, I always appreciate any kind of feedback.

Also, if you're an Optware developer, and you're missing the good old days like I do, I'm looking forward to your pull requests))

And I'm open to suggestions in general :) 

--
Best regards,
Alex Potapenko


__._,_.___
Posted by: Alex Potapenko <opotapenko-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>



__,_._,___
Picon

Unable to get Unslung to existing external flash drive



Apologies for the cross-posting... not sure if either of these groups are particularly active any more.

I've had an NSLU2 successfully Unslung for about 7 years (quite the workhorse).  This weekend, I suffered a power outage, and wasn't able to SSH after the Slug came back up.  After some diagnostics, I discovered the IP address had reset to the factory default (192.168.1.77), and although I could access the web interface, I couldn't change the IP settings (kept getting the dreaded "Error: fail to get samba information".)

After poking around, I realized I had this problem...


So... I used telnet to connect to RedBoot (http://www.nslu2-linux.org/wiki/HowTo/TelnetIntoRedBoot), reset/recreated the SysConf area (http://www.nslu2-linux.org/wiki/HowTo/ResetSysConf), and re-flashed using Upslug2 to Unslung 6.10.

After all that, I'm successfully Unslung - but can only boot from internal flash.  I haven't been able to get the system to boot from my existing, 7 year old external flash drive.

What am I missing?  Is there some step I need to do to get the system to again be okay with booting from my external flash drive?  I don't want to start from scratch on a new boot disk, since I've configured this system to work well for my purposes.

Help?


__._,_.___
Posted by: "M.J. Johnson" <threeeyedtoad-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>



__,_._,___
Picon

Need help restoring ssh access



Ok, I did something really dumb last night. I have a pink Pogoplug v2 with Optware on a usb stick that's I've been using as a lan storage device for my music collection for several years. Recently I thought to myself, wouldn't it be great if I could connect to my pogoplug securely over the internet from a remote location (outside the lan) and be able to play my home music files on my remote laptop. The plan was to install sshfs on my Crunchbang laptop so that I could mount my pogoplug music folders remotely. I soon realized that the Dropbear ssh server that is native to my optware doesn't support sshfs. So I would just have to migrate to OpenSSH-server to give me the needed sshfs functionality. I installed openssh with ipkg and set it up to listen for on port 22222 (I didn& #39;t want to expose port 22 to the internet with port forwarding). I cautiously left Dropbear listening on port 22 for the time being while I verified that root and user could both ssh to the pogoplug via the new openssh server on 22222. After making sure that everything worked correctly with openssh I uninstalled Dropbear. Things were going great until I rebooted and realized my major blunder... I had forgotten to add an entry to rc.local or rcS to start the ssh daemon at boot. Ouchies! So, you guessed it, no way to ssh in, and no way to fix the problem! I pulled the usb stick and tried to find an autostart.sh or similar file that runs on boot where I could maybe add the missing "/opt/etc/init.d/S40sshd start" command, but I haven't had any luck so far.

I would greatly appreciate if someone could kindly help me to undo this mess I made! Thanks in advance for any thoughts...8-]

-Stevied




__._,_.___
Posted by: stevedemento-/E1597aS9LQAvxtiuMwx3w@public.gmane.org



__,_._,___
Picon

http://ipkg.nslu2-linux.org/feeds/optware/mbwe-bluering Repo



Hey all,

  Writing as I've had a problem installing Squid3 from the http://ipkg.nslu2-linux.org/feeds/optware/mbwe-bluering repo. This group was listed as the maintainer.

When attempting to install squid3 it installs but then spits out:

Configuring squid3
create default cache and logs dir
/opt/sbin/squid: '/opt/lib/libdl.so.0' is not an ELF executable for ARM
/opt/sbin/squid: can't load library 'libstdc++.so.6'

The libstdc++.so.6 library is available in the repo and is not an issue, however I cannot find libdl.so.0 anywhere.

I've written a more detailed post at: http://tomatousb.org/forum/t-1064237/squid3-from-mbwe-bluering-needs-libdl-so-0

Thank you for your time!


__._,_.___
Posted by: Jack Frost <jackfrost6022-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>



__,_._,___
Picon

USBnotFaund-unslung



Ciao ....
Mi chiamo Alessandro, I living in Italy from Trieste.
Il mio Problema Più grande con NSLU2 (Unslung) E' Che una volta giocato troppo, non rispondono più le porte USB.  come posso ripristinare le porte USB?

**************************************************************************
 Server Name: LKGAB6632
   Version: V-uNSLUng-6.10-beta
   IP Address:
   USB Port 1: Not Installed
   USB Port 2: Not Installed
***************************************************************************
partizionato disco fisso da 38 GB con GPARTED LIVE per provare; NSLU2 preferiva formattare da se prima del danno.
Ma non serve, NSLU2 (uNSLUng) non vede le periferiche, leds off
all'avvio lui lampeggia tutti i leds, senza montare .....
(file: config.bin)
HD1ScanSch=
HD2ScanSch=


Volevo uno script in TELNET per risolvere, è possibile?

(file: config.bin)
*************
config/                                                                                             0000755 0000000 0000000 00000000000 12441070037 011017  5                                                                                                    ustar   root                            root                                                                                                                                                                                                                   config/CGI_ds.conf                                                                                  0000644 0000000 0000000 00000001457 12441070037 012765  0                                                                                                    ustar   root                            root                                                                                                                                                                                                                   [network]
login=yes
ftp_server=yes
ftp_anony=yes
upnp=yes
guest_access=yes
port=80
guest_pass=
bootproto=static
ip_addr=192.168.1.77
netmask=255.255.255.0
gateway=192.168.1.1
dns_server1=
dns_server2=
dns_server3=
disk_server_name=LKGAB6632
default_ip=
default_netmask=
domain_name=
default_time_delay=0
w_d_name=workgroup
msn_enable=yes
code_page=437
wins_enable=no
wins_server=192.168.1.10
hw_addr=00:1D:7E:AB:66:32
default_server_name=LKGAB6632
printer_name=LKGAB6632_p1
dhcp_server=no
telnet_enable=yes
HD1ScanSch=
HD2ScanSch=
[media]
itune=no
itune_name=
itune_port=
itune_share=
itune_path=
upnp_av=no
upnp_name=
upnp_av_share=
upnp_av_path=
music_broad=no
broad_name=
broad_port=1234
broad_share=
broad_path=
play_method=shuffle
[LOG]
fm=
1to=
2to=
3to=
sub=
log=0
not=0
[harddisk]
validhd=0:0
invalidhd=0:0
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
*************

Volevo uno script in TELNET per risolvere, è possibile?
:((



__._,_.___
Posted by: ale.parme <at> yahoo.it



__,_._,___
Picon

To: nslu2 linux k





http://www.lappartementbyalexandre.fr/shg/dtwfhqwtwyihqwvywkagzonyqxiwupwanfcddon.aaaxbmucfdqdpwxyhwmmhhfncznbgxom








lewislewisj <at> ymail.com


__._,_.___
Posted by: "lewislewisj" <lewislewisj-DaQTI0RpDDMAvxtiuMwx3w@public.gmane.org>



__,_._,___
Picon

crontab



I am using slugosBE v5.3


Crontab has to be suid root in order to work.


However, it is just a link to busybox, and making busybox suid root does not seem like a good idea


So is there anyway to make it work (running as root fixes it, obviously, but ordinary users are supposed to be able to use it).



__._,_.___
Posted by: chl-ZHxlAsDvjIFTKUfZBOZdKA@public.gmane.org



__,_._,___
Picon

newgrp



I am using SlugosBE v 5.3, and I cannot find the newgrp program (nor the groups program for that matter). It does not seem to be in busybox, and I cannot identify any likely place in the opkg list.


Where is it (are they)?



__._,_.___
Posted by: chl-ZHxlAsDvjIFTKUfZBOZdKA@public.gmane.org



__,_._,___
Picon

rsync over SSH or NFS



I am using the nslu2 having installed Debian Wheezy on the attached USB hard disk. Everything works well. I use the nslu2 for data backup.

Can anyone help me to decide what kind of connection I should use.
I set up both SSH and NFS server on the nslu2. Both are working.

I supposed NFS to be faster but now I am not shure. It seems to me that rsync may be not faster over NFS than over SSH. I use the nslu2 only on my private network. Security aspects are not relevant.

Any statement is welcome.

Thanks in advance.
Ferdinand

__._,_.___
Posted by: f.gruber-rSp0+0OX1V0@public.gmane.org



__,_._,___
Picon

Bug in File, file_5.12-1_armeb.ipk


I'm using http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/ on
an Asus RT-AC66U and when trying to identify an unmounted file system with

$ file -Ls /dev/sdb1
/dev/sdb1: Linux rev 1.0 ext3 filesystem data, UUID=[...], volume name
"Optware" (needs journal recovery) (large files)
Segmentation fault

the point is not the seg fault, but the
fact that the first line of output is "mystery output" which cannot be
redirected or piped!

$ file -Ls /dev/sdb1 1> out
$ ls -l out
-rw-rw-rw-    1 admin    root             0 Jun 20 20:36 out

$ file -Ls /dev/sdb1 2> out
$ ls -l out
-rw-rw-rw-    1 admin    root            19 Jun 20 20:37 out
$ cat out
Segmentation fault

This is an issue because as far as i know that'd be the only reliable way
to find out the filesystem of an unmounted device (in this context, random
usb key/disk user will plug into router).

If 'file' worked properly it'd be easy to make a super fancy automated
pre-mount script to check any file system...

------------------------------------
Posted by: "Mike Lambert" <mikelambert70@...>
------------------------------------

------------------------------------

Yahoo Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/nslu2-linux/

<*> Your email settings:
    Individual Email | Traditional

<*> To change settings online go to:
    http://groups.yahoo.com/group/nslu2-linux/join
    (Yahoo! ID required)

<*> To change settings via email:
    nslu2-linux-digest@... 
    nslu2-linux-fullfeatured@...

<*> To unsubscribe from this group, send an email to:
    nslu2-linux-unsubscribe@...

<*> Your use of Yahoo Groups is subject to:
    https://info.yahoo.com/legal/us/yahoo/utos/terms/

Picon

librsync outdated



The latest version of librsync in the syno-i686 feeds is librsync 0.9.7, which crashes when attempting to backup large files from a 64bit system to a 32bit system (i.e., the syno-i686).


This was fixed upstream (http://sourceforge.net/p/librsync/patches/8/) and in Debian (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355178) in 2006, but there hasn't been a release since then.


Is there anyone who can apply that patch to the optware feeds?



__._,_.___
Posted by: andy-ysf4btebV0fWJVK4tiyAfA@public.gmane.org



__,_._,___

Gmane