Thieme | 2 Feb 14:34 2008
Picon

Probleme mit Towitoko chipdrive micro

Hallo Insider!

Nachdem, ich lange Zeit mein Towitoko chipdrive micro (seriell) in Verbindung 
mit Gnucash auf meinem Debian Lenny ohne Probleme benutzen konnte, bekam ich 
nach einem Update der Pakete ein Problem. Die HBCI-Karte konnte nicht mehr 
gelesen werden, die LED (Betriebsanzeige) blieb permanent an.

Nach einem Hardwaredefekt war ich gezwungen Debian (wieder Lenny) neu zu 
installieren, seitdem schaffe ich es gar nicht mehr, den Leser zu aktivieren. 
Der Kernel ist noch der Std. aus dem Repo (2.6.23-3-686), libchipcard hat 
Version 4.0.0-4.

Das Hinzufügen des Readers scheitert mit einem Assertion Error:
chipcardd4 addreader --rname tow_usb --dtype tow_ctapi --rtype tow_cdm --rport COM1
chipcardd4: directory_all.c:226: GWEN_Directory_GetPath: Zusicherung »path« 
nicht erfüllt.
Abgebrochen

Die conf-Dateien in /etc/chipcard/[server|client] habe ich bereits mit der 
driver-Angabe probiert, ebenfalls ohne Erfolg.

Ein Aufruf von "chipcardd4 --loglevel info --logtype console" meldet folgende 
für mich harmlos erscheinende Ausgabe:

5:2008/02/02 14-22-28:chipcardd(9023):chipcardd.c:  749: Chipcardd 
v4.0.0.0stable started.
5:2008/02/02 14-22-28:chipcardd(9023):chipcardd.c:  751: LibSYSFS supported.
3:2008/02/02 14-22-28:chipcardd(9024):chipcardd.c:  694: Old PID file existed, 
removed. (Unclean shutdown?)
pandora:/home/pandora# 6:2008/02/02 14-22-28:chipcardd(9025):chipcardd.c:  974: 
(Continue reading)

Martin Preuss | 2 Feb 18:10 2008
Picon
Picon

Re: Probleme mit Towitoko chipdrive micro

Moin,

On Samstag, 2. Februar 2008, Thieme wrote:
[...]
> Das Hinzufügen des Readers scheitert mit einem Assertion Error:
> chipcardd4 addreader --rname tow_usb --dtype tow_ctapi --rtype tow_cdm
> --rport COM1 chipcardd4: directory_all.c:226: GWEN_Directory_GetPath:
> Zusicherung »path« nicht erfüllt.
> Abgebrochen
[...]

Aargh, das ist ein alter Bug, ich dachte, den haette ich gefixed... Ich 
kuemmer mich drum.

Bis dahin kannst Du den Treiber einfach manuell eintragen. Libchipcard liefert 
eine Beispiel-Konfigurationsdatei fuer den Daemon mit 
(/etc/chipcard/server/chipcardd.conf.example), darin findet Du auskommentiert 
einen Eintrag fuer den Chipdrive Micro. Den musst Du fuer Dich anpassen 
(COM-Port) und dann sollte es wieder gehen.

[...]
> supported. 3:2008/02/02 14-22-28:chipcardd(9024):chipcardd.c:  694: Old PID
> file existed, removed. (Unclean shutdown?)
[...]

Da ist wohl vorher der Daemon abgestuerzt.

[...]
> Zusätzlich stellt sich mir die Frage, ob man diese Version von libchipcard
> überhaupt mit Gnucash benutzen kann, ohne es selber kompilieren zu müssen.
(Continue reading)

Micha Lenk | 2 Feb 18:19 2008

Re: Probleme mit Towitoko chipdrive micro

Hallo,

Martin Preuss schrieb:
> Bis dahin kannst Du den Treiber einfach manuell eintragen. Libchipcard liefert 
> eine Beispiel-Konfigurationsdatei fuer den Daemon mit 
> (/etc/chipcard/server/chipcardd.conf.example), darin findet Du auskommentiert 
> einen Eintrag fuer den Chipdrive Micro. Den musst Du fuer Dich anpassen 
> (COM-Port) und dann sollte es wieder gehen.

Die Debian-Pakete installieren diese Beispiel-Konfigurationsdatei nach
/usr/share/doc/libchipcard-data/examples/

Schöne Grüße
  Micha

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
Thieme | 6 Feb 17:41 2008
Picon

Re: Probleme mit Towitoko chipdrive micro

Hallo!

Erst einmal vielen Dank für die schnelle Hilfe.

Zunächst habe ich wie beschrieben den Eintrag in der
/etc/chipcard/server/chipcardd.conf vorgenommen, allerdings ohne Erfolg. Nun
habe ich mit Freude zur Kenntnis genommen, dass inzwischen neue Versionen im
Repository standen - mit denen ich mein Problem aber noch immer nicht lösen konnte.

Offensichtlich wird der Leser nicht erkannt, obwohl die Konfiguration stimmen
sollte:
#> chipcardd3 --loglevel info --logtype console
5:2008/02/06 16-51-02:chipcardd(2896):chipcardd.c:  774: Chipcardd
v3.0.4.0stable started.
5:2008/02/06 16-51-02:chipcardd(2896):chipcardd.c:  776: LibUSB supported.
5:2008/02/06 16-51-02:chipcardd(2896):chipcardd.c:  779: LibSYSFS supported.
3:2008/02/06 16-51-02:chipcardd(2897):chipcardd.c:  719: Old PID file existed,
removed. (Unclean shutdown?)
pandora:/home/pandora# 6:2008/02/06 16-51-02:chipcardd(2898):chipcardd.c: 1004:
Initializing daemon.
6:2008/02/06 16-51-02:chipcardd(2898):chipcardd.c:  460: Trying
"/etc/chipcard3/server/chipcardd3.conf"
6:2008/02/06 16-51-02:chipcardd(2898):chipcardd.c:  466: Using configuration
file [/etc/chipcard3/server/chipcardd3.conf]
6:2008/02/06 16-51-02:chipcardd(2898):chipcardd.c: 1052: Will now initialize server.
6:2008/02/06 16-51-02:chipcardd(2898):cs_init.c:  417: Server role: standAlone
6:2008/02/06 16-51-02:chipcardd(2898):cs_init.c:  426: Autoconfiguration enabled
6:2008/02/06 16-51-02:chipcardd(2898):cs_init.c:  429: Initialising paths
6:2008/02/06 16-51-02:chipcardd(2898):cs_init.c:  436: Initialising IPC manager
6:2008/02/06 16-51-02:chipcardd(2898):devicemanager.c:   91: Initialising device
(Continue reading)

Martin Preuss | 6 Feb 19:58 2008
Picon
Picon

Re: Probleme mit Towitoko chipdrive micro

Moin,

On Mittwoch, 6. Februar 2008, Thieme wrote:
[...]
> Offensichtlich wird der Leser nicht erkannt, obwohl die Konfiguration
> stimmen sollte:
[...]
> 6:2008/02/06 16-51-02:chipcardd(2898):devicemanager.c:   91: Initialising
> device manager
> 6:2008/02/06 16-51-02:chipcardd(2898):devicemanager.c:  221: Adding driver
> "tow_ctapi"
> 6:2008/02/06 16-51-02:chipcardd(2898):devicemanager.c:  235: Adding reader
> "tow1" 6:2008/02/06 16-51-02:chipcardd(2898):devicemanager.c:  249:
[...]

Doch, der Leser wird offensichtlich gefunden, bzw. die Einstellungen dazu in 
der Konfigurationsdatei. Schaue Dir jetzt nochmal die Logs des Lesers an (ich 
glaube in /var/log/chipcard3/server/drivers/*). Was findet sich dort nun?

[...]
> Ein manuelles Hinzufügen des Gerätes wird mit der altbekannten Meldung
> abgebrochen:
>
> #> chipcardd3 addreader --rname tow_usb --dtype tow_ctapi --rtype tow_cdm
> --rport COM1
> chipcardd3: directory_all.c:226: GWEN_Directory_GetPath: Zusicherung »path«
> nicht erfüllt.
> Abgebrochen
[...]

(Continue reading)

Martin Preuss | 7 Feb 15:57 2008
Picon
Picon

Cyberjack 0x100?

Hallo,

ich benoetige ein Rueckmeldungen von Leuten, die einen alten Cyberjack haben, 
der sich bei "lsusb" mit der Zeile

"ID 0c4b:0100 Reiner SCT Kartensysteme GmbH cyberJack e-com/pinpad"

meldet. Ich habe momentan einige Berichte von Leuten mit solchen Geraeten auf 
neuen Rechnern, die mit dem aktuellen Treiber das Geraet nicht zum Laufen 
bekommen.

Bei mir laufen die damit, daher brauche ich unbedingt Rueckmeldungen:
Gibt es hier jemanden, der einen solchen Leser hat und bei dem der Leser auch 
mit dem neuesten Treiber (3.1.0) funktioniert?

Oder gibt es hier Leute, die ebenfalls Probleme mit dem Leser und dieser 
Treiberversion haben?

Gruss
Martin

--

-- 
"Things are only impossible until they're not"

Martin Preuss - http://www.aquamaniac.de/
AqBanking - http://www.aqbanking.de/
LibChipcard - http://www.libchipcard.de/

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
(Continue reading)

Martin Preuss | 8 Feb 01:11 2008
Picon
Picon

Treiber fuer Cyberjack: Downloadseite geaendert - Neuer Treiber

Moin,

zukuenftig hoste ich die Downloads fuer den Cyberjack-Treiber selbst. Neue 
Releases werden also zukuenftig zuerst 
auf "http://www.aquamaniac.de/sites/download/packages.php?package=07&showall=1" 
veroeffentlicht.

Diesen Schritt habe ich vorher auch schon mit meinen anderen Projekten 
vollzogen, weil die Seite bei Sourceforge inzwischen z.T. ueber 200 kleine 
Bildchen und Banner enthaelt, die die Ladezeit unzumutbar verlaengern.

Nachdem Sourceforge bisher auf das entsprechende Ticket nicht reagiert hat, 
bleibt mir nichts anderes ueblich.

Ich habe auch gleich eine neue Version herausgebracht. Neu ist hier, dass man 
nun bei Problemen mit alten Cyberjacks (die sich noch mit der USB ID 0x100 
melden) auf den Kernel-Modus umschalten kann.

Dazu hat das Diagnose-Tool "cyberjack" neue Kommandos erhalten, die das Setzen 
und Loeschen von Flags in der Konfigurationsdatei vereinfachen.

Wenn man nun beispielsweise den Kernelmodus fuer die alten Cyberjacks 
aktivieren will, genuegt das Kommando:

"cyberjack addflags 0x20000".

Aehnlich schaltet man auch das Logging ein und aus:

"cyberjack addflags 0xffff".

(Continue reading)

Thieme | 10 Feb 15:22 2008
Picon

Re: Probleme mit Towitoko chipdrive micro

Hallo!

Da ich auf GnuCash nicht verzichten kann und ich am Ende meines Lateins bin,
muss ich leider weiterhin auf die Hilfe hier in der Mailingliste zurückgreifen.

Dank der Ratschläge bin ich nun etwas weitergekommen: das permanente Leuchten
des Kartenlesers konnte ich auf den pcscd zurückführen. Nun verhält er sich 
wieder völlig still. Leider.

> Schaue Dir jetzt nochmal die Logs des Lesers an (ich 
> glaube in /var/log/chipcard3/server/drivers/*). Was findet sich dort nun?

[...]
5:2008/02/10 15-03-42:driver(3694):driver.c:  348: Starting driver 
"/usr/lib/chipcard3/server/drivers/ctapi" with lowlevel 
"/usr/lib/chipcard3-server/lowlevel/libtowitoko.so"
4:2008/02/10 15-03-42:driver(3694):driver.c:  351: 
chdir(/var/lib/chipcard3/drivers/ctapi): Datei oder Verzeichnis nicht gefunden
3:2008/02/10 15-03-42:driver(3694):driverctapi.c:  113:  Severity: Error Type: 
LIBLOADER Code: Library not found (5)
3:2008/02/10 15-03-42:driver(3694):d_work.c:   29: Network error
3:2008/02/10 15-03-42:driver(3694):d_ipc.c:  203: Error at work
3:2008/02/10 15-03-42:driver(3694):driverctapi.c:  116: Error communicating with 
the server
3:2008/02/10 15-03-42:driver(3694):main.c:   36: Could not start driver
5:2008/02/10 15-03-53:driver(3700):driver.c:  348: Starting driver 
"/usr/lib/chipcard3/server/drivers/ctapi" with lowlevel 
"/usr/lib/chipcard3-server/lowlevel/libtowitoko.so"
4:2008/02/10 15-03-53:driver(3700):driver.c:  351: 
chdir(/var/lib/chipcard3/drivers/ctapi): Datei oder Verzeichnis nicht gefunden
(Continue reading)

Martin Preuss | 11 Feb 17:24 2008
Picon
Picon

Re: Probleme mit Towitoko chipdrive micro

Moin,

On Sonntag, 10. Februar 2008, Thieme wrote:
[...]
> 5:2008/02/10 15-03-42:driver(3694):driver.c:  348: Starting driver
> "/usr/lib/chipcard3/server/drivers/ctapi" with lowlevel
> "/usr/lib/chipcard3-server/lowlevel/libtowitoko.so"
> 4:2008/02/10 15-03-42:driver(3694):driver.c:  351:
> chdir(/var/lib/chipcard3/drivers/ctapi): Datei oder Verzeichnis nicht
> gefunden 3:2008/02/10 15-03-42:driver(3694):driverctapi.c:  113:  Severity:
> Error Type: LIBLOADER Code: Library not found (5)
[...]

Die Fehlermeldung bezieht sich darauf, dass der Treiber nicht gefunden werden 
konnte. Ist vieleicht "/usr/lib/chipcard3-server/lowlevel/libtowitoko.so" ein 
dangling symlink (also ein Symlink, der auf eine nicht existierende Datei 
zeigt)? Was ergibt 
beispielsweise "ls -lh /usr/lib/chipcard3-server/lowlevel"?

Und was "ldd /usr/lib/chipcard3-server/lowlevel/libtowitoko.so"?

Gruss
Martin

--

-- 
"Things are only impossible until they're not"

Martin Preuss - http://www.aquamaniac.de/
AqBanking - http://www.aqbanking.de/
LibChipcard - http://www.libchipcard.de/
(Continue reading)

Thieme | 11 Feb 20:10 2008
Picon

Re: Probleme mit Towitoko chipdrive micro

Hallo!
> beispielsweise "ls -lh /usr/lib/chipcard3-server/lowlevel"?
>
> Und was "ldd /usr/lib/chipcard3-server/lowlevel/libtowitoko.so"?
>   

Wie ich bereits in der letzten Mail erwähnte, ist beides nicht zu 
finden; das Verzeichnis chipcard3-server gibt es hier unter /usr/lib/ 
nicht, stattdessen nur ein chipcard3. Demzufolge lässt sich auch nichts 
finden:

# ls -lh /usr/lib/chipcard3/server/lowlevel/
insgesamt 0
# ldd /usr/lib/chipcard3/server/lowlevel/libtowitoko.so
ldd: /usr/lib/chipcard3/server/lowlevel/libtowitoko.so: Datei oder 
Verzeichnis nicht gefunden

und

# ls -lh /usr/lib/chipcard3-server/lowlevel
ls: /usr/lib/chipcard3-server/lowlevel: Datei oder Verzeichnis nicht 
gefunden
# ldd /usr/lib/chipcard3-server/lowlevel/libtowitoko.so
ldd: /usr/lib/chipcard3-server/lowlevel/libtowitoko.so: Datei oder 
Verzeichnis nicht gefunden

Zur Sicherheit erwähne ich nochmal alle installierten chipcard(3)-Pakete:
libchipcard3c1
libchipcard3-ctapi0
libchipcard3d0
(Continue reading)


Gmane