Vincent Goulet | 1 Aug 18:48 2008
Picon

Re: [R] I install R in Ubuntu with apt-get, But I cannot see help.start() page.why

[Moved from r-help to r-SIG-Debian, where this belongs.]

Le ven. 1 août à 00:50, xiaopeng hu a écrit :

> I install R in Ubuntu with apt-get,But I cannot see help.start()  
> page.why

Errr... I don't think this qualifies as a post that follows the  
posting guide linked at the bottom of this message.

What did you do *exactly* and what does "cannot see" mean? Normally  
help.start() should open the help system"s home page in your default  
browser. Perhaps on another virtual desktop or in a different tab?

Please be more specific if you want us to help you.

---
   Vincent Goulet, Associate Professor
   École d'actuariat
   Université Laval, Québec
   Vincent.Goulet <at> act.ulaval.ca   http://vgoulet.act.ulaval.ca

>
> Thanks
>
> 	[[alternative HTML version deleted]]
>
> ______________________________________________
> R-help <at> r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
(Continue reading)

Gad Abraham | 12 Aug 06:31 2008
Picon
Picon

Conflict between octave3.0-headers and r-base-dev

Hi,

I'm using Ubuntu Hardy i386, and the R 2.7.1 Ubuntu packages from CRAN.

The CRAN r-base-dev package depends on refblas3-dev or atlas3-base-dev, 
but octave3.0-headers depends on libblas-dev. The two blas packages seem 
to conflict, so r-base-dev and octave3.0-headers can't be installed 
together.

Is this a known issue?

Thanks,
Gad

$ sudo apt-get install octave3.0-headers
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
   libblas-dev libfftw3-dev libhdf5-serial-dev liblapack-dev
Suggested packages:
   libhdf5-doc
The following packages will be REMOVED:
   r-base-dev refblas3-dev
The following NEW packages will be installed:
   libblas-dev libfftw3-dev libhdf5-serial-dev liblapack-dev 
octave3.0-headers

--

-- 
Gad Abraham
(Continue reading)

Dirk Eddelbuettel | 12 Aug 14:44 2008
Picon

Re: Conflict between octave3.0-headers and r-base-dev


Gad,

Thanks for the bug report and for using the appropriate list for it.

On 12 August 2008 at 14:31, Gad Abraham wrote:
| Hi,
| 
| I'm using Ubuntu Hardy i386, and the R 2.7.1 Ubuntu packages from CRAN.
| 
| The CRAN r-base-dev package depends on refblas3-dev or atlas3-base-dev, 
| but octave3.0-headers depends on libblas-dev. The two blas packages seem 
| to conflict, so r-base-dev and octave3.0-headers can't be installed 
| together.
| 
| Is this a known issue?

Maybe not, and looks like the Depends for r-base-dev need to be updated to
reflect the newer library names.  Unfortunately, 'everybody' is at Dortmund
this week for UseR but I already mentioned this to Vincent.

On Debian we have 'libblas-dev | libatlas-base-dev, liblapack-dev |
libatlas-base-dev' but that, I think, wasn't possible for Vincent and Ubuntu as the
newer atlas/blas packages had not yet migrated.  I think he can simply stop
changed 'down' to the older refblas choice.

Hope this helps, Dirk

| Thanks,
| Gad
(Continue reading)

Vincent Goulet | 13 Aug 06:27 2008
Picon

Re: Conflict between octave3.0-headers and r-base-dev

Le mar. 12 août à 14:44, Dirk Eddelbuettel a écrit :

>
> Gad,
>
> Thanks for the bug report and for using the appropriate list for it.
>
> On 12 August 2008 at 14:31, Gad Abraham wrote:
> | Hi,
> |
> | I'm using Ubuntu Hardy i386, and the R 2.7.1 Ubuntu packages from  
> CRAN.
> |
> | The CRAN r-base-dev package depends on refblas3-dev or atlas3-base- 
> dev,
> | but octave3.0-headers depends on libblas-dev. The two blas  
> packages seem
> | to conflict, so r-base-dev and octave3.0-headers can't be installed
> | together.
> |
> | Is this a known issue?
>
> Maybe not, and looks like the Depends for r-base-dev need to be  
> updated to
> reflect the newer library names.  Unfortunately, 'everybody' is at  
> Dortmund
> this week for UseR but I already mentioned this to Vincent.
>
> On Debian we have 'libblas-dev | libatlas-base-dev, liblapack-dev |
> libatlas-base-dev' but that, I think, wasn't possible for Vincent  
(Continue reading)

Gad Abraham | 14 Aug 08:17 2008
Picon
Picon

Re: Conflict between octave3.0-headers and r-base-dev

Vincent Goulet wrote:
> Le mar. 12 août à 14:44, Dirk Eddelbuettel a écrit :
> 
>>
>> Gad,
>>
>> Thanks for the bug report and for using the appropriate list for it.
>>
>> On 12 August 2008 at 14:31, Gad Abraham wrote:
>> | Hi,
>> |
>> | I'm using Ubuntu Hardy i386, and the R 2.7.1 Ubuntu packages from CRAN.
>> |
>> | The CRAN r-base-dev package depends on refblas3-dev or atlas3-base-dev,
>> | but octave3.0-headers depends on libblas-dev. The two blas packages 
>> seem
>> | to conflict, so r-base-dev and octave3.0-headers can't be installed
>> | together.
>> |
>> | Is this a known issue?
>>
>> Maybe not, and looks like the Depends for r-base-dev need to be 
>> updated to
>> reflect the newer library names.  Unfortunately, 'everybody' is at 
>> Dortmund
>> this week for UseR but I already mentioned this to Vincent.
>>
>> On Debian we have 'libblas-dev | libatlas-base-dev, liblapack-dev |
>> libatlas-base-dev' but that, I think, wasn't possible for Vincent and 
>> Ubuntu as the
(Continue reading)

Vincent Goulet | 14 Aug 10:06 2008
Picon

Re: Conflict between octave3.0-headers and r-base-dev

Le jeu. 14 août à 08:17, Gad Abraham a écrit :

> Vincent Goulet wrote:
>> Le mar. 12 août à 14:44, Dirk Eddelbuettel a écrit :
>>>
>>> Gad,
>>>
>>> Thanks for the bug report and for using the appropriate list for it.
>>>
>>> On 12 August 2008 at 14:31, Gad Abraham wrote:
>>> | Hi,
>>> |
>>> | I'm using Ubuntu Hardy i386, and the R 2.7.1 Ubuntu packages  
>>> from CRAN.
>>> |
>>> | The CRAN r-base-dev package depends on refblas3-dev or atlas3- 
>>> base-dev,
>>> | but octave3.0-headers depends on libblas-dev. The two blas  
>>> packages seem
>>> | to conflict, so r-base-dev and octave3.0-headers can't be  
>>> installed
>>> | together.
>>> |
>>> | Is this a known issue?
>>>
>>> Maybe not, and looks like the Depends for r-base-dev need to be  
>>> updated to
>>> reflect the newer library names.  Unfortunately, 'everybody' is at  
>>> Dortmund
>>> this week for UseR but I already mentioned this to Vincent.
(Continue reading)

Mark Kimpel | 14 Aug 18:20 2008
Picon

RGBL not compiling with R-devel under Debian Lenny

Some time ago I had difficulty installing RBGL with Ubuntu Hardy on R-2.7.0
and the problem was attributed to an with BGL. I got some very helpful
advice and posted a script to fix the problem by hacking the RGBL source
code:
dateTue, Jan 15, 2008 at 2:16 PMsubjectRe: [R-sig-Debian] trouble installing
building packages from source using R 2.6.0 on Ubuntu Gutsy AMD64mailing
listr-sig-debian.r-project.org The problem is now also occurring since I
switched to Debian Lenny and R-2.6.8 (devel) [see output below]. My first
step would be to download the development version of RGBL but I can't for
the life of me find where to download tarballs of development packages from
CRAN (BioConductor makes this very straightforward for its packages BTW).

So, are other people using bleeding-edge installations having this issue? Is
a fix on the horizon? If it's not within a few months a lot of standard
installations will break. Finally, does anyone know where to find the
development version tarballs of packages (probably a better ? for R-devel
but I"m trying to avoid multiple postings).

Thanks, Mark

* Installing *source* package 'RBGL' ...
untarring boost include tree...
** libs
g++ -I/home/mkimpel/R_HOME/R-devel/R-build/lib64/R/include
-I/usr/local/include   -IboostIncl  -fpic  -g -O2 -c bbc.cpp -o bbc.o
In file included from /usr/include/c++/4.3/ext/hash_set:64,
                 from boostIncl/boost/graph/adjacency_list.hpp:22,
                 from RBGL.hpp:26,
                 from bbc.cpp:1:
/usr/include/c++/4.3/backward/backward_warning.h:32:2: warning: #warning
(Continue reading)

Federico Calboli | 27 Aug 12:19 2008
Picon

r-base-core issue

Hi All,

I cannot upgrade r-base and r-recommended because the latest (latest as in it 
was not listed as 'upgradable' yesterday but today is) r-base-cose is 
2.7.1-2hardy0 not hardy1:

r-base:
   Depends: r-base-core (>=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be installed
   Depends: r-recommended (=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be installed

r-base-core:

r-recommended:
   Depends: r-base-core (>=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be installed

Cheers,

Fede

--

-- 
Federico C. F. Calboli
Department of Epidemiology and Public Health
Imperial College, St Mary's Campus
Norfolk Place, London W2 1PG

Tel  +44 (0)20 7594 1602     Fax (+44) 020 7594 3193

f.calboli [.a.t] imperial.ac.uk
f.calboli [.a.t] gmail.com
(Continue reading)

Michael Rutter | 27 Aug 14:58 2008
Picon

Re: r-base-core issue

Fede,

The hardy0 name on the amd64 packages does not match the hardy1 on the 
generic (any architecture) metapackage r-base.  We will get this 
straightened out and matching packages will likely be on CRAN in the 
next 24 hours or so.

Sorry for the inconvenience,
Michael

Federico Calboli wrote:
> Hi All,
> 
> I cannot upgrade r-base and r-recommended because the latest (latest as 
> in it was not listed as 'upgradable' yesterday but today is) r-base-cose 
> is 2.7.1-2hardy0 not hardy1:
> 
> r-base:
>   Depends: r-base-core (>=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be 
> installed
>   Depends: r-recommended (=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be 
> installed
> 
> r-base-core:
> 
> r-recommended:
>   Depends: r-base-core (>=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be 
> installed
> 
> Cheers,
(Continue reading)

Vincent Goulet | 27 Aug 15:56 2008
Picon

Re: r-base-core issue

Fede,

This is my bad. Updated package are on their way to CRAN now. Please  
report if the issue is fixed or not (perhaps off-list if it's just a  
"yes").

Best

Vincent

Le mer. 27 août à 06:19, Federico Calboli a écrit :

> Hi All,
>
> I cannot upgrade r-base and r-recommended because the latest (latest  
> as in it was not listed as 'upgradable' yesterday but today is) r- 
> base-cose is 2.7.1-2hardy0 not hardy1:
>
> r-base:
>  Depends: r-base-core (>=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be  
> installed
>  Depends: r-recommended (=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be  
> installed
>
> r-base-core:
>
> r-recommended:
>  Depends: r-base-core (>=2.7.2-1hardy1) but 2.7.1-2hardy0 is to be  
> installed
>
(Continue reading)


Gmane