Mauricio Calvao | 24 May 21:15 2016
Picon

RStudio 0.99.902 installation under sid: libgstreamer0.10-0 and libgstreamer-plugins-based0.10-0 missing

Dear r-sig'ers

I use Debian sid (amd64). I downloaded the most recent version of rstudio
.deb from their official site and issued:

dpkg -i rstudio-0.99.902-amd64.deb

to no avail:

dpkg: dependency problems prevent configuration of rstudio:
 rstudio depends on libgstreamer0.10-0; however:
  Package libgstreamer0.10-0 is not installed.
 rstudio depends on libgstreamer-plugins-base0.10-0; however:
  Package libgstreamer-plugins-base0.10-0 is not installed.

It seems newer versions of these packages (1.0-0) are installed, but those
older ones aren't available anymore.
What should be done to have RStudio installed and fully opertional under
Debian sid? I have, of course, installed R debs, from official Debian
repositories, without any issues...

Thanks for any help!

--

-- 
#######################################
Prof. Mauricio Ortiz Calvao
Federal University of Rio de Janeiro
Institute of Physics, P O Box 68528
CEP 21941-972 Rio de Janeiro, RJ
Brazil
(Continue reading)

Atakan Okan | 12 May 14:00 2016

Problem with Install R on Linux Ubuntu 16.04 Xenial Xerus

Hi,

I am running a dual-booted Ubuntu 16.04 from a USB stick and having problems installing R.
I have been following the steps at this site: https://www.datascienceriot.com/how-to-install-r-in-linux-ubuntu-16-04-xenial-xerus/kris/
Below is the the output and the commands from the terminal:

sudo echo "deb http://cran.rstudio.com/bin/linux/ubuntu xenial/" | sudo tee -a /etc/apt/sources.list
[sudo] password for atakan: 
deb http://cran.rstudio.com/bin/linux/ubuntu xenial/

gpg --keyserver keyserver.ubuntu.com --recv-key E084DAB9
gpg: requesting key E084DAB9 from hkp server keyserver.ubuntu.com
gpg: key E084DAB9: "Michael Rutter <marutter <at> gmail.com>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

gpg -a --export E084DAB9 | sudo apt-key add -
OK

sudo apt-get update
Hit:1 http://tr.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://security.ubuntu.com/ubuntu xenial-security InRelease                                        
Hit:3 http://tr.archive.ubuntu.com/ubuntu xenial-updates InRelease                                       
Hit:4 http://tr.archive.ubuntu.com/ubuntu xenial-backports InRelease               
Hit:5 http://cran.rstudio.com/bin/linux/ubuntu xenial/ InRelease             
Reading package lists... Done
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list:57
W: Target Translations (en_US) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list:57
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list:57
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list:58
(Continue reading)

Michael Rutter | 9 May 00:44 2016
Picon

R 3.3.0 for Ubuntu update, c2d4u update: no longer supporting 12.04 Precise Pangolin

Ubuntu and R users:

R 3.3.0 is now available for Ubuntu releases 16.04 (xenial), 15.10 
(wily), and 14.04 (trusty).  Due changes in R 3.3.0 (mainly the need to 
link to the most current zlib library), I can no longer backport R to 
release 12.04 (precise).

I will continue to maintain as many packages as possible for 12.04 on 
the CRAN Ubuntu page, the RRutter PPA, and cran2deb4ubuntu PPA.  If you 
are using 12.04, please consider upgrading to 14.04 or 16.04.

As for cran2deb4ubuntu on 16.04 (xenial), I will start building packages 
this week.  Finals are now over at Penn State, so I have the time needed 
to start this project.

If you have any questions, please contact me.

Thanks,
Michael
Canadian Electronics | 25 Apr 06:20 2016
Picon

Fw: new message

Hello!

You have a new message, please read <http://familyoutlet.ro/warm.php?xnob>

Canadian Electronics

	[[alternative HTML version deleted]]
Luca Braglia | 19 Apr 16:21 2016
Picon

Possible problem with R/X11/libpng on Debian

Dear all,

can you reproduce (on testing or unstable, especially) this 2 line error
which inhibits interactive graphics (to me, tested on 2 debian testing
boxes).

l <at> m740n:~$ R --vanilla
> example(hist)

hist> op <- par(mfrow = c(2, 2))
Error in (function (display = "", width, height, pointsize, gamma, bg,  :
  il modulo X11 non può essere caricato
Inoltre: Warning message:
In (function (display = "", width, height, pointsize, gamma, bg,  :
   unable to load shared object '/usr/lib/R/modules//R_X11.so':
  /usr/lib/x86_64-linux-gnu/libpng12.so.0: version `PNG12_0' not found
  (required by /usr/lib/R/modules//R_X11.so)

which, freely translated from italian, is "module X11 can't be loaded".

Some further details/checks follow (at least for the libpng part):

l <at> m740n:~$ cd /usr/lib/x86_64-linux-gnu/
l <at> m740n:/usr/lib/x86_64-linux-gnu$ file libpng*so* | a bit of manual editing

libpng12.so.0:       symbolic link to libpng.so
libpng.so:           symbolic link to libpng16.so
libpng16.so:         symbolic link to libpng16.so.16.21.0
libpng16.so.16.21.0: ELF 64-bit LSB shared object, x86-64, version 1
(SYSV), dynamically linked,
(Continue reading)

Barnet Wagman | 23 Mar 21:33 2016
Picon

Fwd: Re: r-base installation fails on Ubuntu 14.04


-------- Forwarded Message --------
Subject: 	Re: [R-sig-Debian] r-base installation fails on Ubuntu 14.04
Date: 	Wed, 23 Mar 2016 13:07:44 -0700
From: 	Barnet Wagman <bdwgen <at> gmail.com>
To: 	Dirk Eddelbuettel <edd <at> debian.org>

> Lastly, and please don't take this the wrong way: I think I am helping way
> more people like you who for one reason or other insist on older / frozen
> system like 14.04 but then desire newer software.  Simply running _current_
> Ubuntu and upgrading every six months is IMHO much easier.

Are suggesting upgrading to Ubuntu 15 or just running apt-get upgrade or
apt-get dist-upgrade (which I've done).  Ubuntu 14.04 is the latest LTS
version, which is probably why a lot of people are not going to 15.

PS Inadvertently sent this to Dirk instead of list.  Sorry.

	[[alternative HTML version deleted]]
Barnet Wagman | 23 Mar 17:35 2016
Picon

r-base installation fails on Ubuntu 14.04

I am unable to install R on an up to date (i.e. apt upgraded) Ubuntu 
14.04 system.  According to 
https://cran.r-project.org/bin/linux/ubuntu/README (and many other sources),
R is available for this version of Ubuntu (which is a stable version).

I currently have

    deb https://cran.cnr.berkeley.edu/bin/linux/ubuntu trusty/

in sources.list.  I've tried this with and without

    deb https://  mirrors.rit.edu/ubuntu trusty-backports main
    restricted universe

I've tried installing using apt-get , aptitude, and synaptic. (I have, 
of course, run apt-get update.) All hit problems they cannot resolve 
(listed below).

I'd appreciate any thoughts on this.  I've installed R on many linux 
distributions in the past (suse, redhat, debian, most recently 
elementary os) and never run into anything like this before.   (I'm 
getting desperate enough to consider building R from src, but as I 
recall getting the right libraries installed isn't that easy).

Using apt-get install, I get the error message:

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
(Continue reading)

Ramon Diaz-Uriarte | 22 Mar 13:20 2016
Picon

bzlib, pcre and zlib still needed in rules?

Dear All,

I just

apt-get source r-base-core

and noticed that file "rules" under ./r-base-3.2.4-revised/debian

contains (lines 277 to 279)

--with-system-bzlib			\
--with-system-pcre			\
--with-system-zlib			\

I wonder if these are still necessary and, in fact, when building R alpha
(specifically, R-alpha_2016-03-21_r70361.tar.gz) I get a warning saying
that those options are not recognized.

Best,

R.

--

-- 
Ramon Diaz-Uriarte
Department of Biochemistry, Lab B-25
Facultad de Medicina
Universidad Autónoma de Madrid 
Arzobispo Morcillo, 4
28029 Madrid
Spain
(Continue reading)

Matthew Simpson | 21 Mar 18:10 2016
Picon

Outdated r-base-core when installing on Ubuntu 14.04

I have a chromebook with a fresh minimal install of Ubuntu 14.04 running
through crouton, and I'm trying to install the latest version of R. The
only thing I have done to the system before trying to install R is install
gedit. When I try to install R I get an unmet dependencies error that
complains that the version of r-base-core available isn't new enough.

I followed the instructions at
https://cran.r-project.org/bin/linux/ubuntu/README.html to install R. Here
is precisely what I did:

1) after installing gedit, I added the following two lines to
/etc/apt/sources.list

deb http://cran.wustl.edu/bin/linux/ubuntu trusty/
deb http://ports.ubuntu.com/ubuntu-ports/ trusty-backports main restricted
universe

(Note: I've tried a couple different R mirrors and it doesn't affect
anything as far as I can
tell)

2) Add Michael Rutter's key with

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9

3) Update sources and attempt to install R:

sudo apt-get update
sudo apt-get install r-base

(Continue reading)

Devinder Kaur | 24 Feb 13:02 2016
Picon

randomForest problem

Hi,
I had installed R and rstudio one week age on my machine(x86_64)
having ubuntu 12.04 as an operating system. Everything worked fine.
And then I installed rattlle to build models using R. As in this
process it asks for various packages to be installed like randomForest
etc. But everytime I try to install it, process fails giving a warning
message like "it had a non-zero exit" and a few compiler related
errors as well.
Please guide me through this problem. I would really appreciate any
help from your side!

--

-- 
Devinder Kaur
Jordan Dawe | 23 Feb 01:21 2016

Dependency failures on installing older R packages in Ubuntu

Ive been trying to install the CRAN Ubuntu r-base-3.1.2 package on Ubuntu 14.04, and I keep getting the
following failure:

----------

vagrant <at> default-ubuntu-1404:/etc$ sudo apt-get install r-base=3.1.2-*

Reading package lists... Done

Building dependency tree

Reading state information... Done

Selected version '3.1.2-1trusty0' (CRAN:14.04/trusty [all]) for 'r-base'

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

 r-base : Depends: r-recommended (= 3.1.2-1trusty0) but 3.2.3-6trusty0 is to be installed

          Recommends: r-base-html but it is not going to be installed
(Continue reading)


Gmane