Dirk Eddelbuettel | 19 Mar 23:26 2013
Picon

R port of pymssql


I just came across  

   https://code.google.com/p/pymssql/

Maybe someone wants to run with this and create 'RMSSql' using the DBI
interface?  

The Google Summer of Code framework served us well when Sameer started
RPostgreSQL a few years ago (which I had suggested and mentored).  Now, I am
not volunteering to mentor again (particularly as I, luckily, get by without
having to use mssql).  But in case someone a) needs mssql and b) has some
capacity to (co-)mentor this...

Dirk

--

-- 
Dirk Eddelbuettel | edd@... | http://dirk.eddelbuettel.com

_______________________________________________
R-sig-DB mailing list -- R Special Interest Group
R-sig-DB@...
https://stat.ethz.ch/mailman/listinfo/r-sig-db

Elliot Bernstein | 11 Mar 18:35 2013

Microsoft SQL Server Temp Tables and RODBC

I've noticed that RODBC has some issues with MS SQL Server's syntax for temp tables. For example:

> temp <- data.frame(x = 1:10)
> sqlSave(conn, temp, "#rtemp")
Error in sqlColumns(channel, tablename) :
  '#rtemp': table not found on channel
> sqlQuery(conn, "create table #rtemp (x integer)")
[1] "42S01 2714 [Microsoft][ODBC SQL Server Driver][SQL Server]There is already an object named
'#rtemp' in the database."
[2] "[RODBC] ERROR: Could not SQLExecDirect 'create table #rtemp (x integer)'"
> sqlSave(conn, temp, "#rtemp", append = TRUE)
Error in sqlSave(conn, temp, "#rtemp", append = TRUE) :
  42S01 2714 [Microsoft][ODBC SQL Server Driver][SQL Server]There is already an object named '#rtemp' in
the database.
[RODBC] ERROR: Could not SQLExecDirect 'CREATE TABLE "#rtemp"  ("rownames" varchar(255), "x" int)'
> sqlQuery(conn, "select * from #rtemp")
[1] rownames x
<0 rows> (or 0-length row.names)
> for (i in 1:nrow(temp)) { sqlQuery(conn, sprintf("insert into #rtemp (x) values (%d)", temp$x[i])) }
> sqlQuery(conn, "select * from #rtemp")
   rownames  x
1        NA  1
2        NA  2
3        NA  3
4        NA  4
5        NA  5
6        NA  6
7        NA  7
8        NA  8
9        NA  9
(Continue reading)

Joran Elias | 11 Mar 16:27 2013
Picon

ROracle loads from command line, but not RGUI/RStudio in OSX

I'm having some trouble getting ROracle up and running completely on my
computer (OS X 10.7.5, R 2.15.2).

Compiling ROracle was a little bit of an adventure, but I finally did get
it to compile by mostly following the Linux instructions with some
modifications pieced together from the web. When I run R from the command
line, ROracle loads fine, I can connect to the db and run queries.
Everything works. (I've also installed the Oracle utility sqlplus which
works as well; connecting, querying, etc.)

But if I try to load ROracle from either the R GUI or RStudio, I get this
error:

Loading required package: DBI
Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared object
'/Users/joranelias/Library/R/2.15/library/ROracle/libs/x86_64/ROracle.so':

dlopen(/Users/joranelias/Library/R/2.15/library/ROracle/libs/x86_64/ROracle.so,
6): Library not loaded:
/ade/b/2649109290/oracle/rdbms/lib/libclntsh.dylib.11.1
  Referenced from:
/Users/joranelias/Library/R/2.15/library/ROracle/libs/x86_64/ROracle.so
  Reason: image not found
Error: package/namespace load failed for ‘ROracle’

I examined how the environment variables are set between running R from the
command line and RGUI/RStudio, and noticed some differences, so I tried
making them the same via setting:

(Continue reading)

Paul Bernal | 6 Mar 20:24 2013
Picon

Working with Large sets of Data or even Big Data

Hello everyone,

I managed to connect R with some database tables residing in Microsoft SQL
Server, and I also got R to read the information in. My question is, since
usually, those tables can have 50 thousand or even more records, or even
hundreds of thousands  or millions of records what would be the maximum
amount of records that R is able to read and process or better put, what
would be the maximum amount of rows and columns that R is able to manage
(to perform data mining analysis)?  What would I need to do in order for R
to be able to manage large amounts of data?

Any information regarding this question would be greatly appreciated.

Best regards and have a wonderful day guys,

Paul

	[[alternative HTML version deleted]]

_______________________________________________
R-sig-DB mailing list -- R Special Interest Group
R-sig-DB@...
https://stat.ethz.ch/mailman/listinfo/r-sig-db

Hannes Mühleisen | 24 Feb 11:16 2013
Picon
Picon

MonetDB.R connector

Hello everybody,

We would like to announce the immediate availability of the first native connector for the open source
database MonetDB [1] in R.  The connector is available on CRAN [2] and implements the R DBI [3]. MonetDB is
particularly suited to support statistics due to its column-oriented storage model that allows fast
bulk operations. 

We invite everybody to try this combination and are looking forward to your feedback.

Best,

Hannes Mühleisen

[1] http://www.monetdb.org
[2] http://cran.r-project.org/web/packages/MonetDB.R/index.html
[3] http://cran.r-project.org/web/packages/DBI/index.html
	[[alternative HTML version deleted]]

_______________________________________________
R-sig-DB mailing list -- R Special Interest Group
R-sig-DB@...
https://stat.ethz.ch/mailman/listinfo/r-sig-db
McGehee, Robert | 12 Feb 16:05 2013

PostgreSQL killed on dbDisconnect (RPostgreSQL)

Hi,
Has anyone had an issue where a PostgreSQL connection was forcibly killed (SIGKILL) by RPostgreSQL,
causing a full database crash/recovery/restart? 

This seems to happen about twice a week when a RPostgreSQL connection is closed using dbDisconnect (or when
an R session ends) while other queries are running. The Linux OOM killer is not enabled on this server and I
can find no evidence of hardware problems or any evidence of problems with the PostgreSQL database. This
left me to wonder if there was a problem with the way RPostgreSQL (or R) disconnects that causes the
database crash.

I generally interface with RPostgreSQL inside a function like this:

FUN <- function() {
	conn <- dbConnect(dbDriver("PostgreSQL"), host="xx", user="xx", password="xx", dbname="xx")
	on.exit(dbDisconnect(conn), add=TRUE)
	dbGetQuery("SELECT 1;", conn=conn)
}

I found record of a similar problem with the RpgSQL package here (from 2009):
https://stat.ethz.ch/pipermail/r-help/2009-January/184707.html
which indicates that dbDisconnect() caused a crash under similar circumstances in RpgSQL. However, in
this case there was a crash in R; in my case there is a crash in PostgreSQL (and it's a different package).

Has anyone else had a problem like this with RPostgreSQL or know if it is even possible for RPostgreSQL to
send a SIGKILL signal to a PostgreSQL connection? I'm reluctant to remove dbDisconnect everywhere, as I
don't want zombie connections accumulating. Also, I'm not the only user of the database.

Thanks, Robert

_______________________________________________
(Continue reading)

Jim Porzak | 23 Jan 20:08 2013
Picon

RpgSQL/RJDBC(?) on R15.2(64) Win7 throws can't find .verify.JDBC.result

All, I see:

> options(RpgSQL.user = "tableau", RpgSQL.password = "******",
+         RpgSQL.host = "10.8.0.1", RpgSQL.port = 5432,
+         RpgSQL.JAR = "C:/Drivers/JDBC")
>
> library(RpgSQL)                                  ## Version: 0.1-6
Loading required package: RJDBC           ## Version: 0.2-1
Loading required package: DBI                ## Version: 0.2-5
Loading required package: rJava              ## Version: 0.9-3

> con <- dbConnect(pgSQL(), dbname = "bidata_pg")
Error in .local(drv, ...) : could not find function ".verify.JDBC.result"

The above works just fine with R14.2 & prior versions of PpgSQL & RJDBC.

I noticed H2 user had a similar error which they worked around by
rolling back to RJDBC 0.2-0
I tried hacking a roll-back using files from my 14.2 install but that
didn't work.
I did not see any window binaries for RJDBC 0.2-0

Suggestions?

Jim Porzak
Minted.com
San Francisco, CA
www.linkedin.com/in/jimporzak
use R! Group SF: www.meetup.com/R-Users/

(Continue reading)

norbert hoeller | 3 Dec 13:02 2012
Picon

Re: ROracle 1.1-5 and date fields?

Hi Don,

i ran into the same error.

A post on stackoverflow was inspiring:

http://stackoverflow.com/questions/7678485/oracle-ora-01805-on-oracle-11g-database

So I  upgraded the timezone-version, and now i, too, can read these
pretty dates when using "ROracle"...

In short, what i did, to the good old database [as SYS-user]:

select version from v$timezone_file;
/*
   VERSION
----------
        11
*/
--- so, i upgraded to (the latest) TZ-version 14:
--- You have to be in Migrate-mode to run  dbms_dst.begin_upgrade, so first

shutdown immediate
---- and then
startup migrate;

begin
 dbms_dst.begin_upgrade(new_version => 14);
end;
/
(Continue reading)

Muhammad Abuizzah | 1 Dec 18:54 2012
Picon

RODBC drop work without Error Message

I have a large database on sql Server 2012 Developers edition, some tables are upto 10GB in size,  I have
been connecting fine to the database and extracting info.  
today was the first time I tried to pull 1/2 gb in one query, nothing fancy a query that always worked with
smaller size.

R dropped the work without providing an error message.  I got the "sand clock" running for a couple of
seconds, as if R had stared communication with the database, but 
then nothing. I looked at my windows task manger, and CPU utilization was at zero.

I ran memory.size() function to confirm availability of memory and it read 24 thousand I don't remember the
rest, I have 24GBs of ram on my computer.  the size of the other R objects in memory was around 2GB

Are there any known issues between RODBC and SQLServer?

thanks

_______________________________________________
R-sig-DB mailing list -- R Special Interest Group
R-sig-DB@...
https://stat.ethz.ch/mailman/listinfo/r-sig-db

Marc Schwartz | 1 Dec 16:28 2012

Re: remote connection to an Oracle database - using RODBC

Hi Raff,

Based upon the reply from Actual Tech below, you should definitely remove the XML file name from the Setup
File entry in the driver configuration. 

I did not see an indication in your communication with them below that you specifically mentioned the need
for Kerberos based authentication, which would be a critical omission in the interaction with them, if
so. :-)

From a search this morning, if my read is correct, it would seem that the Kerberos authentication needs to be
supported in the ODBC driver, so that the authentication process is transparent to the calling program
(eg. R/RODBC). Looking through some sites that I found, there are options in the DSN configuration in ODBC
Manager that support Oracle Advanced Security. You may need to confirm the correct settings with your
SysAdmin/DBAdmin for Kerberos on your Oracle server.

1. Go into ODBC Manager and select the DSN configuration for your Oracle server. 

2. On the initial page ("Introduction"), select Continue. 

3. That will bring you to a page where you "Enter the data source name". Be sure that information is correct
and then press Continue.

4. On the next page ("Select the database"), select "Advanced Options".  That will bring up a dialog window
where you can select "Use Oracle Advanced Security". Once you select that, you can then enter the
additional parameters for Encryption and Checksum. Once you do that with the correct parameters, press OK.

5. That should then bring you to a "Conclusion" window. On the bottom of that window will be a Test button,
which you should press. You should then be prompted for  username and password information. Then press OK,
which should then bring up a test results window with information on success/failure. If successful,
then press OK and you will be returned to the Conclusion window and you are done.
(Continue reading)

sasidhar M | 30 Nov 11:40 2012
Picon

oracle database connection issue from R in Linux

Hi,

This is sasi.
I installed R 64 bit and oracle client 64 bit in fedora 17. After R is
working fine. Oracle database also working fine. but problem is, If i try
to connect oracle from R its not connecting.
So, pls guide me how to connect from R to oracle.

how, i tried:--

odbcinst.ini file code is

[ORACLE2]
Description = oracle driver
Driver = /ibexis/app/oracle/product/11.2.0/db_1/lib/libsqora.so.11.1
DontDLClose = 1
FileUsage = 1
UsageCount = 1

I tried in R ...
>library(RODBC)
>con <- odbcConnect("data source name", uid="username", pwd="password")

after this line i got error,

> odbcConnect("india", uid="data_quality", pwd="data_quality")
[1] -1
Warning messages:
1: In odbcDriverConnect("DSN=india;UID=data_quality;PWD=data_quality") :
  [RODBC] ERROR: state 01000, code 0, message [unixODBC][Driver
(Continue reading)


Gmane