John Smith | 1 Nov 21:29 2010
Picon

Install glade package on Windows?

I have successfully installed gtk2hs on Windows, but I can't get the glade package. cabal install glade
complained about 
missing libxml package, so I created a libxml-2.0.pc from the net. Now it complains about Missing C
libraries: xml2, 
pthread. Is it possible to do this on Windows?

------------------------------------------------------------------------------
Nokia and AT&T present the 2010 Calling All Innovators-North America contest
Create new apps & games for the Nokia N8 for consumers in  U.S. and Canada
$10 million total in prizes - $4M cash, 500 devices, nearly $6M in marketing
Develop with Nokia Qt SDK, Web Runtime, or Java and Publish to Ovi Store 
http://p.sf.net/sfu/nokia-dev2dev
Axel Simon | 2 Nov 07:29 2010
Picon

Re: Install glade package on Windows?


On Nov 1, 2010, at 21:29, John Smith wrote:

> I have successfully installed gtk2hs on Windows, but I can't get the  
> glade package. cabal install glade complained about
> missing libxml package, so I created a libxml-2.0.pc from the net.  
> Now it complains about Missing C libraries: xml2,
> pthread. Is it possible to do this on Windows?
>

You need to install C libraries for glade. These would come with the  
corresponding .pc file that tells the cabal file how to use them.

Please ask google. I think somebody has already successfully installed  
glade on Windows.

Cheers,
Axel

------------------------------------------------------------------------------
Nokia and AT&T present the 2010 Calling All Innovators-North America contest
Create new apps & games for the Nokia N8 for consumers in  U.S. and Canada
$10 million total in prizes - $4M cash, 500 devices, nearly $6M in marketing
Develop with Nokia Qt SDK, Web Runtime, or Java and Publish to Ovi Store 
http://p.sf.net/sfu/nokia-dev2dev
John Smith | 2 Nov 08:27 2010
Picon

Re: Install glade package on Windows?

On 02/11/2010 08:29, Axel Simon wrote:
> You need to install C libraries for glade. These would come with the
> corresponding .pc file that tells the cabal file how to use them.
>
> Please ask google. I think somebody has already successfully installed
> glade on Windows.

I have glade installed and running. Is there some kind of devel package that I need? Couldn't find anything
on Google.

------------------------------------------------------------------------------
Nokia and AT&T present the 2010 Calling All Innovators-North America contest
Create new apps & games for the Nokia N8 for consumers in  U.S. and Canada
$10 million total in prizes - $4M cash, 500 devices, nearly $6M in marketing
Develop with Nokia Qt SDK, Web Runtime, or Java and Publish to Ovi Store 
http://p.sf.net/sfu/nokia-dev2dev
Axel Simon | 6 Nov 13:33 2010
Picon

upcoming release

Dear all (who use the darcs repository of Gtk2Hs),

Andy and I would like to release the next version of gtk and it's  
accompanying packages. Before doing so, we would like to migrate the  
darcs repositories of glib, gio, pango, cairo, gtk to darcs version 2.  
This will make it impossible to apply darcs version 1 patches. Thus,  
if you have any patches lying around, please send them to this or the  
gtk-devel list now!

Besides that, it would help a lot of you do a darcs pull on your  
current darcs repository and build the repository in it's current  
state. That would give us some confidence that building works on the  
various platforms.

Cheers,
Axel

------------------------------------------------------------------------------
The Next 800 Companies to Lead America's Growth: New Video Whitepaper
David G. Thomson, author of the best-selling book "Blueprint to a 
Billion" shares his insights and actions to help propel your 
business during the next growth cycle. Listen Now!
http://p.sf.net/sfu/SAP-dev2dev
Andy Stewart | 6 Nov 16:22 2010
Picon

Re: upcoming release

Axel Simon <Axel.Simon <at> in.tum.de> writes:

> Dear all (who use the darcs repository of Gtk2Hs),
>
> Andy and I would like to release the next version of gtk and it's  
> accompanying packages. Before doing so, we would like to migrate the  
> darcs repositories of glib, gio, pango, cairo, gtk to darcs version 2.  
> This will make it impossible to apply darcs version 1 patches. Thus,  
> if you have any patches lying around, please send them to this or the  
> gtk-devel list now!
>
> Besides that, it would help a lot of you do a darcs pull on your  
> current darcs repository and build the repository in it's current  
> state. That would give us some confidence that building works on the  
> various platforms.
Hi all,

code.haskell.org looks down now, if you can't get darcs code from
http://code.haskell.org/gtk2hs 

Please try gtk2hs mirror repository:

   darcs get http://patch-tag.com/r/AndyStewart/gtk2hs-sync-mirror

mirror repository's code is same as gtk2hs main repository.

Any successful feedback are welcome! :)

Thanks,

(Continue reading)

Andy Stewart | 10 Nov 17:42 2010
Picon

Manatee - The Haskell/Gtk+ Integrated Live Environment first

Hi all,

I am proud to announce the release my gtk2hs project : Manatee - The Haskell/Gtk+ Integrated Live
Environment

http://hackage.haskell.org/package/manatee

Screenshots at : http:goo.gl/MkVw
Code at https://patch-tag.com/r/AndyStewart/ beginning with manatee-*

Manatee is Haskell integrated environment written in Haskell.

The goal of the Manatee project is to provide a fast, safe and flexible
integrated environment for haskell hacking.

You can consider it is new environment mix Gnome and Emacs. 
Like Gnome to provide friendly graphics interface and work efficient like Emacs.

Manatee use multi-processes framework, any sub-module running in separate process to protected core
won't crash. So it
minimize your losses when some unexpected exception throw in extension.

Now i have implement below sub-modules in Manatee:

    Editor
    Webkit Browser
    File Manager
    Image Viewer
    IRC Client
    Multimedia Player
(Continue reading)

John Smith | 16 Nov 09:31 2010
Picon

Cannot install Gtk2Hs 0.12 on windows

Cabal install fails with
"setup.exe: gtk-0.12.0: library-dirs: c:/devel/dist/win64/libpng-1.4.3-1/lib doesn't exist or
isn't a directory"
which is true. Should I create such a directory, and what should go in it?

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today
http://p.sf.net/sfu/msIE9-sfdev2dev
Axel Simon | 16 Nov 10:48 2010
Picon

Re: Cannot install Gtk2Hs 0.12 on windows

Hi John,

On 16.11.2010, at 09:31, John Smith wrote:

> Cabal install fails with
> "setup.exe: gtk-0.12.0: library-dirs: c:/devel/dist/win64/ 
> libpng-1.4.3-1/lib doesn't exist or isn't a directory"
> which is true. Should I create such a directory, and what should go  
> in it?
>

The Gtk+ distributions in the past often added paths to libraries that  
don't actually exist. However, it might be that the Gtk+ package  
you've installed is genuinely broken. You could try to create the path  
and see if this fixes the problem. If it does, we probably have to  
talk to the cabal people to filter out paths that don't exist (or we  
have to do it ourselves, both solutions are a pain).

Cheers,
Axel

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today
http://p.sf.net/sfu/msIE9-sfdev2dev
C Gosch | 16 Nov 11:08 2010

Re: Cannot install Gtk2Hs 0.12 on windows

I was having the same problem a while ago. I remember that creating the said directory and copying the PNG library into it fixed the problem for me.

Cheers
Christian

2010/11/16 Axel Simon <Axel.Simon <at> in.tum.de>
Hi John,

On 16.11.2010, at 09:31, John Smith wrote:

> Cabal install fails with
> "setup.exe: gtk-0.12.0: library-dirs: c:/devel/dist/win64/
> libpng-1.4.3-1/lib doesn't exist or isn't a directory"
> which is true. Should I create such a directory, and what should go
> in it?
>

The Gtk+ distributions in the past often added paths to libraries that
don't actually exist. However, it might be that the Gtk+ package
you've installed is genuinely broken. You could try to create the path
and see if this fixes the problem. If it does, we probably have to
talk to the cabal people to filter out paths that don't exist (or we
have to do it ourselves, both solutions are a pain).

Cheers,
Axel


------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today
http://p.sf.net/sfu/msIE9-sfdev2dev
_______________________________________________
Gtk2hs-users mailing list
Gtk2hs-users <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gtk2hs-users

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today
http://p.sf.net/sfu/msIE9-sfdev2dev
_______________________________________________
Gtk2hs-users mailing list
Gtk2hs-users <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gtk2hs-users
John Smith | 16 Nov 11:13 2010
Picon

Re: Cannot install Gtk2Hs 0.12 on windows

Thank you - creating the empty directory, and a couple of rebuilds, has indeed fixed the problem.

Still seems to require the older (2.16) version of Gtk+.

On 16/11/2010 11:48, Axel Simon wrote:
> Hi John,
>
> On 16.11.2010, at 09:31, John Smith wrote:
>
>> Cabal install fails with
>> "setup.exe: gtk-0.12.0: library-dirs: c:/devel/dist/win64/
>> libpng-1.4.3-1/lib doesn't exist or isn't a directory"
>> which is true. Should I create such a directory, and what should go
>> in it?
>>
>
> The Gtk+ distributions in the past often added paths to libraries that
> don't actually exist. However, it might be that the Gtk+ package
> you've installed is genuinely broken. You could try to create the path
> and see if this fixes the problem. If it does, we probably have to
> talk to the cabal people to filter out paths that don't exist (or we
> have to do it ourselves, both solutions are a pain).
>
> Cheers,
> Axel

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today
http://p.sf.net/sfu/msIE9-sfdev2dev

Gmane