Phil Miller | 1 Dec 01:53 2010

Re: KDE 4.5.4 (try #2) uploaded

Ok, lets start with the compile errors:

kde-l10n-el-4.5.4

[ 61%] [ 61%] Generating useraccount.gmo
Generating plasma_containmentactions_contextmenu.gmo
[ 61%] Generating kcm_solid_actions.gmo
[ 61%] Generating plasma_applet_netpanel.gmo
[100%] Built target pofiles
man-kbookmarkmerger.1.docbook:51: parser error : Entity 'ie' not defined
�ου έχουν πρόσβαση σ' αυτή την πληροφορία (&ie;
                                                                               ^
make[2]: *** [docs/kdebase-apps/konqueror/kbookmarkmerger.1] Error 1
make[1]: *** [docs/kdebase-apps/konqueror/CMakeFiles/konqueror-manpage-man-
kbookmarkmerger.dir/all] Error 2
make: *** [all] Error 2
    Aborting...

 
ERROR BUILDING kde-l10n

... I'll keep on digging.
_______________________________________________
release-team mailing list
release-team <at> kde.org
https://mail.kde.org/mailman/listinfo/release-team
Jonathan Riddell | 1 Dec 15:48 2010

Re: KDE 4.5.4 (try #2) uploaded

On Mon, Nov 29, 2010 at 11:19:45PM +0100, Dirk Mueller wrote:
> I just finished uploading the 2nd set of tarballs for KDE 4.5.4. all tarballs 
> have been replaced.kde-l10n is still building.
> 
> Please update to those tarballs. Release is delayed until Thursday.

I get a failure in kdebase-workspace

../../krunner/interfaces/quicksand/qs_matchview.cpp: In member
void QuickSand::QsMatchView::scrollToItem(:
../../krunner/interfaces/quicksand/qs_matchview.cpp:559: error: call
of abs( is ambiguous
/usr/include/c++/4.4/cmath:94: note: candidates are: double
std::abs(double)
/usr/include/c++/4.4/cmath:98: note:                 float
std::abs(float)
/usr/include/c++/4.4/cmath:102: note:                 long double
std::abs(long double)
make[3]: ***
[krunner/CMakeFiles/kdeinit_krunner.dir/interfaces/quicksand/qs_matchview.o]
Error 1
int&)overloaded int)function 

Jonathan
Frank Reininghaus | 1 Dec 16:10 2010

Re: KDE 4.5.4 (try #2) uploaded

Hi,

2010/12/1 Jonathan Riddell <jriddell@...>:
> I get a failure in kdebase-workspace
>
> ../../krunner/interfaces/quicksand/qs_matchview.cpp: In member
> void QuickSand::QsMatchView::scrollToItem(:
> ../../krunner/interfaces/quicksand/qs_matchview.cpp:559: error: call
> of abs( is ambiguous
> /usr/include/c++/4.4/cmath:94: note: candidates are: double
> std::abs(double)
> /usr/include/c++/4.4/cmath:98: note:                 float
> std::abs(float)
> /usr/include/c++/4.4/cmath:102: note:                 long double
> std::abs(long double)
> make[3]: ***
> [krunner/CMakeFiles/kdeinit_krunner.dir/interfaces/quicksand/qs_matchview.o]
> Error 1
> int&)overloaded int)function

fixed in 4.5 branch by

http://websvn.kde.org/?view=revision&revision=1202609

and in trunk by

http://websvn.kde.org/?view=revision&revision=1201800

Cheers,
Frank
(Continue reading)

Albert Astals Cid | 1 Dec 20:55 2010
Picon

Re: KDE 4.5.4 (try #2) uploaded

A Dimecres, 1 de desembre de 2010, Phil Miller va escriure:
> Ok, lets start with the compile errors:
> 
> kde-l10n-el-4.5.4
> 
> [ 61%] [ 61%] Generating useraccount.gmo
> Generating plasma_containmentactions_contextmenu.gmo
> [ 61%] Generating kcm_solid_actions.gmo
> [ 61%] Generating plasma_applet_netpanel.gmo
> [100%] Built target pofiles
> man-kbookmarkmerger.1.docbook:51: parser error : Entity 'ie' not defined
> �ου έχουν πρόσβαση σ' αυτή την πληροφορία (&ie;
>                                                                            
>    ^ make[2]: *** [docs/kdebase-apps/konqueror/kbookmarkmerger.1] Error 1
> make[1]: ***
> [docs/kdebase-apps/konqueror/CMakeFiles/konqueror-manpage-man-
> kbookmarkmerger.dir/all] Error 2
> make: *** [all] Error 2
>     Aborting...
> 
> 
> ERROR BUILDING kde-l10n

Remove that file or update kdelibs/kdoctools/customization/el/user.entities 
from branch

Albert

> 
> ... I'll keep on digging.
(Continue reading)

Dirk Mueller | 2 Dec 10:46 2010
Picon

Re: KDE 4.5.4 (try #2) uploaded

On Wednesday 01 December 2010, Jonathan Riddell wrote:

> > Please update to those tarballs. Release is delayed until Thursday.
> I get a failure in kdebase-workspace

Both reports fixed: 

e1b109db1cc0d7640f06ede0bbcb5aaf  kdebindings-4.5.4.tar.bz2
4a370939977915e12843214d85296de0  kdebase-workspace-4.5.4.tar.bz2

Greetings,
Dirk
Albert Astals Cid | 2 Dec 20:36 2010
Picon

REMINDER: Trunk is frozen for i18n messages

Hi pim-people,

It has come to my attention that since November 11 (when the soft message 
freeze was introduced) there has been a fair amount of new messages and 
messages moving from one catalog to the other inside kdepim/kdepimlibs.

I have to say that this is *not* allowed and you need a special agreement of 
the i18n people (that can be found at kde-i18n-doc@...) to introduce new 
strings or move them from one catalog to another.

What the soft message freeze let's you do is fix typos, but if you do you have 
to mail kde-i18n-doc@... notifying you did the change.

Please keep freezes in mind since it helps all teams work better together if 
we respected them :-)

Thanks,
  Albert
Dirk Mueller | 3 Dec 17:17 2010
Picon

KDE 4.5.85 (KDE 4.6 Beta2) uploaded (try #1)


Hi, 

just finished uploading the first set of KDE 4.6  Beta2 tarballs. Please let me 
know of any compile or other urgent issues. 

Targetted release date is Tuesday next week. 

Thanks,
Dirk
David Faure | 3 Dec 18:32 2010
Picon

Re: can kdebase-4.5.4 depend on kdelibs >= 4.5.4?

On Monday 29 November 2010, Sebastian Kügler wrote:
> I don't recall us accepting API changes after the API freeze (*and* 
> after the subsequent .0 release).

We are definitely adding API to stable branches after .0 releases,
and I wish that we can keep doing that. It's always API needed for bugfixes of 
course, not for new features.

This has always worked that way in KDE (unlike e.g. Qt)

So yes, kdebase-4.5.4 can depend on kdelibs >= 4.5.4.

And I don't see how this prevents distros shipping stable updates.
As I said: it's API needed for bugfixing, all that is needed is proper package 
dependencies so that one cannot upgrade kdebase (or another KDE SC module) 
without upgrading kdelibs first to at least the same version.

--

-- 
David Faure, faure@..., http://www.davidfaure.fr
Sponsored by Nokia to work on KDE, incl. Konqueror (http://www.konqueror.org).
Allen Winter | 4 Dec 02:28 2010
Picon

KDEPIM 4.4.8 Available

Howdy,

Tarballs for kdepim-4.4.8 and kdepim-runtime-4.4.8 have been created 
and will soon be available from a mirror near you, at:

ftp://ftp.kde.org/pub/kde/stable/kdepim-4.4.8/src

md5sums are:

718cc55e334efdd319b0f07279d8105a  kdepim-runtime-4.4.8.tar.bz2
3c8633cd83af08177b685981bfad6d30  kdepim-4.4.8.tar.bz2

As our policy, there are no new messages strings so the existing 4.4.5 translations should work.
Jonathan Riddell | 4 Dec 20:28 2010

Re: KDE 4.5.85 (KDE 4.6 Beta2) uploaded (try #1)

On Fri, Dec 03, 2010 at 05:17:18PM +0100, Dirk Mueller wrote:
> just finished uploading the first set of KDE 4.6  Beta2 tarballs. Please let me 
> know of any compile or other urgent issues. 

One of our packagers found that kdenetwork is broken

Fixed with http://websvn.kde.org/trunk/?rev=1203569&view=rev

Jonathan

Gmane