Max Brazhnikov | 1 Apr 12:54 2012
Picon

[SVN Commit] area51/KDE/japanese/kiten

SVN commit 8098 by makc:

Update plist for KDE 4.8.2

 M  +14 -2     pkg-plist  

_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

FreeBSD bugmaster | 2 Apr 13:07 2012
Picon

Current problem reports assigned to kde <at> FreeBSD.org

Note: to view an individual PR, use:
  http://www.freebsd.org/cgi/query-pr.cgi?pr=(number).

The following is a listing of current problems submitted by FreeBSD users.
These represent problem reports covering all versions including
experimental development code and obsolete releases.

S Tracker      Resp.      Description
--------------------------------------------------------------------------------
o ports/166546 kde        [PATCH] multimedia/qt4-phonon-gst: do not remove a dir
o ports/166271 kde        [PATCH] deskutils/kdepimlibs4 doesn't compile with cla
o ports/165642 kde        x11/kde4: keeps locking the screen.
f ports/165473 kde        devel/qt4-assistant
o ports/165213 kde        devel/cmake: Reinplacement of paths in Modules is bad
o ports/162261 kde        sysutils/k3b-kde4 - fails to compile with ffmpeg-devel
o ports/161317 kde        x11/xde4: KDE 4.6.5 does not prompt for authentication
a ports/160277 kde        [PATCH] databases/akonadi: Make MySQL dependency optio
f ports/158713 kde        Unable to build /usr/ports/multimedia/phonon-xine afte
o ports/156901 kde        [patch] devel/cmake breaks with CC containing spaces
o ports/151154 kde        audio/amarok-kde4 crashes on network activity if ports
o ports/148454 kde        games/freebsd-carddeck-kde4: freebsd's kde card deck d

12 problems total.

_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

(Continue reading)

Max Brazhnikov | 3 Apr 00:18 2012
Picon

[SVN Commit] area51/PORTS/devel

SVN commit 8099 by makc:

Fix plist

 M  +1 -0      kdevelop-kde4/pkg-plist  
 M  +2 -0      kdevelop-pg-qt/pkg-plist  

_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

Alberto Villa | 3 Apr 01:03 2012
Picon

[SVN Commit] area51/PORTS/databases/akonadi

SVN commit 8100 by avilla:

- Update to 1.7.2.
- Update pkg-descr to pet portlint.

 M  +1 -2      Makefile  
 M  +2 -2      distinfo  
 M  +5 -24     pkg-descr  
 M  +1 -1      pkg-plist  

_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

Alberto Villa | 3 Apr 01:33 2012
Picon

Re: akonadi/kdepim

On Tue, Mar 27, 2012 at 1:11 PM, JoaoBR <joao <at> matik.com.br> wrote:
> supposed I do not use nothing from kdepim and delete pim and its libs from
> the system
> then can I delete akonadi/nepomik and related stuff also? also mysql?

If you want to use ports (and avoid troubles):
- you can't remove Akonadi;
- you can't really remove Nepomuk support (it's everywhere), but you
can disable it, just unselect NEPOMUK option in x11/kde4-runtime (this
will avoid you installing databases/virtuoso, which is the only heavy
thing in Nepomuk);
- you can't *yet* remove MySQL, but I'm about to make it optional in Akonadi.
--

-- 
Alberto Villa, FreeBSD committer <avilla <at> FreeBSD.org>
http://people.FreeBSD.org/~avilla
_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

Alberto Villa | 3 Apr 01:37 2012
Picon

Re: Qt 4.8.0 from area51 with clang

On Thu, Mar 22, 2012 at 10:34 AM, Olivier Smedts <olivier <at> gid0.org> wrote:
> Are there any recommendations to compile Qt 4.8.0 (from area51) with
> clang ? I set up my /etc/make.conf as usual for clang, it worked
> perfectly with Qt 4.7 (except qt4-webkit) but now where trying ti
> "portmaster -a" :

Last time I tried, it was working. I will check again when 4.8.1 is ready.
--

-- 
Alberto Villa, FreeBSD committer <avilla <at> FreeBSD.org>
http://people.FreeBSD.org/~avilla
_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

Alberto Villa | 3 Apr 01:39 2012
Picon

Re: Weird build failure with kdenetwork-4.7.4 amd64

On Mon, Mar 12, 2012 at 7:36 PM, Dwayne MacKinnon <dmk <at> ncf.ca> wrote:
> I'm still unable to build kdenetwork-4.7.4. I was wondering if a fix had been
> found, or am I just waiting for 4.8.1 to try again? (Which, while
> inconvenient, is ok. I know you folks are busy.)

Unfortunately we've not been able to understand the problem so far. I
guess I'll have to find some time to inspect it.
--

-- 
Alberto Villa, FreeBSD committer <avilla <at> FreeBSD.org>
http://people.FreeBSD.org/~avilla
_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

Olivier Smedts | 3 Apr 10:18 2012

Re: Qt 4.8.0 from area51 with clang

2012/4/3 Alberto Villa <avilla <at> freebsd.org>:
> On Thu, Mar 22, 2012 at 10:34 AM, Olivier Smedts <olivier <at> gid0.org> wrote:
>> Are there any recommendations to compile Qt 4.8.0 (from area51) with
>> clang ? I set up my /etc/make.conf as usual for clang, it worked
>> perfectly with Qt 4.7 (except qt4-webkit) but now where trying ti
>> "portmaster -a" :
>
> Last time I tried, it was working. I will check again when 4.8.1 is ready.

Thanks. I can also try again with 4.8.1 as soon as you say area51 is
ready for testing :)

--

-- 
Olivier Smedts                                                 _
                                        ASCII ribbon campaign ( )
e-mail: olivier <at> gid0.org        - against HTML email & vCards  X
www: http://www.gid0.org    - against proprietary attachments / \

  "Il y a seulement 10 sortes de gens dans le monde :
  ceux qui comprennent le binaire,
  et ceux qui ne le comprennent pas."
_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information

sindrome | 2 Apr 00:40 2012
Picon

Build problem with kdepim4-runtime

Hi,

I'm running into a problem trying to build the latest version of kdepim4-runtime.  I would be interested to know your thoughts.

Thanks,

-Troy

<KABC::Addressee>() const':

: undefined reference to `Akonadi::Item::payloadBaseV2(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC9AddresseeEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0x44): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::Addressee>::isPolymorphic, KABC::Addressee>::type Akonadi::Item::payloadImpl<KABC::Addressee>() const':

: undefined reference to `Akonadi::Item::ensureMetaTypeId(int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC9AddresseeEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0x55): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::Addressee>::isPolymorphic, KABC::Addressee>::type Akonadi::Item::payloadImpl<KABC::Addressee>() const':

: undefined reference to `Akonadi::Item::payloadBaseV2(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC9AddresseeEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0xc9): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::Addressee>::isPolymorphic, KABC::Addressee>::type Akonadi::Item::payloadImpl<KABC::Addressee>() const':

: undefined reference to `Akonadi::Item::throwPayloadException(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC9AddresseeEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0x140): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::Addressee>::isPolymorphic, KABC::Addressee>::type Akonadi::Item::payloadImpl<KABC::Addressee>() const':

: undefined reference to `Akonadi::Item::throwPayloadException(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item7payloadIN4KABC9AddresseeEEET_v+0x2b): In function `KABC::Addressee Akonadi::Item::payload<KABC::Addressee>() const':

: undefined reference to `Akonadi::Item::throwPayloadException(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC12ContactGroupEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0x44): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::ContactGroup>::isPolymorphic, KABC::ContactGroup>::type Akonadi::Item::payloadImpl<KABC::ContactGroup>() const':

: undefined reference to `Akonadi::Item::ensureMetaTypeId(int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC12ContactGroupEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0x55): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::ContactGroup>::isPolymorphic, KABC::ContactGroup>::type Akonadi::Item::payloadImpl<KABC::ContactGroup>() const':

: undefined reference to `Akonadi::Item::payloadBaseV2(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC12ContactGroupEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0xc9): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::ContactGroup>::isPolymorphic, KABC::ContactGroup>::type Akonadi::Item::payloadImpl<KABC::ContactGroup>() const':

: undefined reference to `Akonadi::Item::throwPayloadException(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item11payloadImplIN4KABC12ContactGroupEEEN5boost12disable_if_cIXsrNS_8Internal12PayloadTraitIT_EE13isPolymorphicES8_E4typeEv+0x140): In function `boost::disable_if_c<Akonadi::Internal::PayloadTrait<KABC::ContactGroup>::isPolymorphic, KABC::ContactGroup>::type Akonadi::Item::payloadImpl<KABC::ContactGroup>() const':

: undefined reference to `Akonadi::Item::throwPayloadException(int, int) const'

CMakeFiles/akonadi_contacts_resource.dir/contactsresource.o(.gnu.linkonce.t._ZNK7Akonadi4Item7payloadIN4KABC12ContactGroupEEET_v+0x2b): In function `KABC::ContactGroup Akonadi::Item::payload<KABC::ContactGroup>() const':

: undefined reference to `Akonadi::Item::throwPayloadException(int, int) const'

*** Error code 1

1 error

*** Error code 2

2 errors

*** Error code 2

1 error

*** Error code 1

 

Stop in /usr/ports/deskutils/kdepim4-runtime.

** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20120313-9420-1a179zd-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=kdepim-runtime-4.4.11.1 UPGRADE_PORT_VER=4.4.11.1 make

** Fix the problem and try again.

** Listing the failed packages (-:ignored / *:skipped / !:failed)

        ! deskutils/kdepim4-runtime (kdepim-runtime-4.4.11.1)   (linker error)


_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information
Alberto Villa | 3 Apr 10:35 2012
Picon

Re: Build problem with kdepim4-runtime

On Mon, Apr 2, 2012 at 12:40 AM, sindrome <sindrome <at> gmail.com> wrote:
> I'm running into a problem trying to build the latest version of
> kdepim4-runtime.  I would be interested to know your thoughts.

Did you try rebuilding Akonadi?
--

-- 
Alberto Villa, FreeBSD committer <avilla <at> FreeBSD.org>
http://people.FreeBSD.org/~avilla
_______________________________________________
kde-freebsd mailing list
kde-freebsd <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-freebsd
See also http://freebsd.kde.org/ for latest information


Gmane