Mark Linimon | 2 May 04:23 2005

Re: ports/80491: Dependency error between packages prebuilt. (fwd)

FYI, this PR affects ports that you maintain, as it deals with conflicts
between multiple ports.

mcl

---------- Forwarded message ----------
Date: Mon, 2 May 2005 02:21:01 GMT
From: Mark Linimon <linimon <at> FreeBSD.org>
To: linimon <at> FreeBSD.org, freebsd-ports-bugs <at> FreeBSD.org, doceng <at> FreeBSD.org
Subject: Re: ports/80491: Dependency error between packages prebuilt.

Synopsis: Dependency error between packages prebuilt.

Responsible-Changed-From-To: freebsd-ports-bugs-≥doceng
Responsible-Changed-By: linimon
Responsible-Changed-When: Mon May 2 02:14:41 GMT 2005
Responsible-Changed-Why: 
Over to maintainters of textproc/docproj-jadetex, since that seems
to be the source of the first conflict mentioned.

Note to submitter: combining two unrelated problems into a single PR
like this makes trying to decide how to handle it quite problematic.
I will go ahead and Cc: the other affected maintainers.

http://www.freebsd.org/cgi/query-pr.cgi?pr=80491
_______________________________________________
freebsd-ports-bugs <at> freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "freebsd-ports-bugs-unsubscribe <at> freebsd.org"
(Continue reading)

Jean-Yves Lefort | 2 May 13:47 2005
Picon

Re: ports/80525: x11-wm/kompmgr doesnt build

Synopsis: x11-wm/kompmgr doesnt build

Responsible-Changed-From-To: freebsd-ports-bugs-≥kde
Responsible-Changed-By: jylefort
Responsible-Changed-When: Mon May 2 11:47:23 GMT 2005
Responsible-Changed-Why: 
Over to maintainers.

http://www.freebsd.org/cgi/query-pr.cgi?pr=80525
Andy Fawcett | 2 May 17:00 2005
Picon

Re: ports/80525: x11-wm/kompmgr doesnt build

The following reply was made to PR ports/80525; it has been noted by GNATS.

From: Andy Fawcett <andy <at> athame.co.uk>
To: bug-followup <at> FreeBSD.org, kosta <at> fillibach.de
Cc:  
Subject: Re: ports/80525: x11-wm/kompmgr doesnt build
Date: Mon, 2 May 2005 17:58:31 +0300

 $ pkg_which /usr/X11R6/include/X11/extensions/Xcomposite.h
 xorg-libraries-6.8.2

 Which X libraries do you have installed?

 A.
Michael Nottebrock | 3 May 16:05 2005
Picon

Re: ports/80525: x11-wm/kompmgr doesnt build

Synopsis: x11-wm/kompmgr doesnt build

State-Changed-From-To: open->feedback
State-Changed-By: lofi
State-Changed-When: Tue May 3 14:05:17 GMT 2005
State-Changed-Why: 
Feedback requested.

http://www.freebsd.org/cgi/query-pr.cgi?pr=80525
Konstantin 'Kosta' Welke | 4 May 00:50 2005
Picon

Re: ports/80525: x11-wm/kompmgr doesnt build

The following reply was made to PR ports/80525; it has been noted by GNATS.

From: "Konstantin 'Kosta' Welke" <kosta <at> fillibach.de>
To: bug-followup <at> freebsd.org, kosta <at> fillibach.de
Cc:  
Subject: Re: ports/80525: x11-wm/kompmgr doesnt build
Date: Thu, 05 May 2005 00:44:14 +0200

 about my xorg-libraries:

 # pkg_which /usr/X11R6/include/X11/extensions/Xcomposite.h
 /usr/X11R6/include/X11/extensions/Xcomposite.h: not found
 # pkg_info | grep xorg-libraries
 xorg-libraries-6.7.0_3 X11 libraries and headers from X.Org

 I will update xorg-libraries and see if the problem persists.

 Kosta
Konstantin 'Kosta' Welke | 4 May 01:20 2005
Picon

Re: ports/80525: x11-wm/kompmgr doesnt build

The following reply was made to PR ports/80525; it has been noted by GNATS.

From: "Konstantin 'Kosta' Welke" <kosta <at> fillibach.de>
To: bug-followup <at> freebsd.org, kosta <at> fillibach.de
Cc:  
Subject: Re: ports/80525: x11-wm/kompmgr doesnt build
Date: Thu, 05 May 2005 01:22:25 +0200

 with an updated xorg-libraries, the problem vanished

 Kosta
Michael Nottebrock | 4 May 07:43 2005
Picon

Re: ports/80525: x11-wm/kompmgr doesnt build

Synopsis: x11-wm/kompmgr doesnt build

State-Changed-From-To: feedback->closed
State-Changed-By: lofi
State-Changed-When: Wed May 4 05:43:01 GMT 2005
State-Changed-Why: 
Submitter reports problem solved.

http://www.freebsd.org/cgi/query-pr.cgi?pr=80525
contiemilio | 4 May 18:25 2005
Picon

Installing kdebase3

Hello all
I am not able to install kdebase3 on a FreeBSD 4.9.
The make install stops after the following messages:

usbdevices.cpp:263: `struct usb_device_info' has no member named `udi_speed'
usbdevices.cpp:264: `USB_SPEED_LOW' undeclared (first use this function)
usbdevices.cpp:264: (Each undeclared identifier is reported only once
usbdevices.cpp:264: for each function it appears in.)
usbdevices.cpp:265: `USB_SPEED_FULL' undeclared (first use this function)
usbdevices.cpp:266: `USB_SPEED_HIGH' undeclared (first use this function)
usbdevices.cpp:264: warning: unreachable code at beginning of switch statement
usbdevices.cpp: In function `static bool USBDevice::parse(QString)':
usbdevices.cpp:301: warning: unused parameter `class QString fname'
gmake[3]: *** [usbdevices.lo] Error 1
gmake[3]: Leaving directory 
`/usr/ports/x11/kdebase3/work/kdebase-3.4.0/kcontrol/usbview'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory 
`/usr/ports/x11/kdebase3/work/kdebase-3.4.0/kcontrol'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/x11/kdebase3/work/kdebase-3.4.0'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/x11/kdebase3.
*** Error code 1

May you help me?

Regards
(Continue reading)

Markus Brueffer | 5 May 17:54 2005
Picon

Re: Installing kdebase3

On Thursday 05 May 2005 13:43, Michael Nottebrock wrote:
> contiemilio <at> virgilio.it wrote:
> > Hello all
> > I am not able to install kdebase3 on a FreeBSD 4.9.
> > The make install stops after the following messages:
> >
> > usbdevices.cpp:263: `struct usb_device_info' has no member named
> > `udi_speed' usbdevices.cpp:264: `USB_SPEED_LOW' undeclared (first use
> > this function)
>
> You'll need at least FreeBSD 4.10-RELEASE, if I read the code right.
> Perhaps Markus (cc'd) can whip up a patch to compensate for the missing
> defines.

The offending field that causes the error was renamed from udi_lowspeed to 
udi_speed before 4.10 as part of preperations for USB2. Unfortunately there 
was no __FreeBSD_version bump for that. The closest I can get is about 4 
weeks.

Please try the attached patch and report back if it works (place it in the 
files directory and retry building kdebase3 if in doubt).

Markus

--

-- 
Markus Brueffer    | GPG-Key: http://people.FreeBSD.org/~markus/markus.asc
markus <at> brueffer.de | FP: 3F9B EBE8 F290 E5CC 1447 8760 D48D 1072 78F8 A8D4
markus <at> FreeBSD.org | FreeBSD: The Power to Serve!
(Continue reading)

Michael Nottebrock | 5 May 13:43 2005
Picon
Picon

Re: Installing kdebase3

contiemilio <at> virgilio.it wrote:
> Hello all
> I am not able to install kdebase3 on a FreeBSD 4.9.
> The make install stops after the following messages:
> 
> usbdevices.cpp:263: `struct usb_device_info' has no member named `udi_speed'
> usbdevices.cpp:264: `USB_SPEED_LOW' undeclared (first use this function)

You'll need at least FreeBSD 4.10-RELEASE, if I read the code right. Perhaps 
Markus (cc'd) can whip up a patch to compensate for the missing defines.

--

-- 
    ,_,   | Michael Nottebrock               | lofi <at> freebsd.org
  (/^ ^\) | FreeBSD - The Power to Serve     | http://www.freebsd.org
    \u/   | K Desktop Environment on FreeBSD | http://freebsd.kde.org

Gmane