Alf Felis | 2 May 23:18 2011
Picon
Picon

Re: Problem with deleted directory

Hi again,

now I tried to delete the digikam4.db file to generate a new one.
This seems to be the only way to delete my missing folder.

But this does NOT work... because many keywords I set are missing after
the generation of the new db file!

If I use the old file, the keywords are ok... and all IPTC and XMP
settings are correct.

How can I generate a new db file?
Any idea?

Regards,

Alf

Am 25.04.2011 22:00, schrieb Alf Felis:
> Hi all,
> 
> I'm using digikam 1.2.0 (linux) and have a problem with a deleted directory.
> 
> The directory has been deleted in the filesystem (not from digikam), but
> digikam always shows this directory as album folder.
> 
> I tried to create a new directory with the same name... digikam now
> shows 2 entries with the same name in list. If I delete one of them with
> digikam, than the directory in the filesystem will be deleted, but only
> one entry in the list. The second entry is always visible.
(Continue reading)

Alf Felis | 2 May 23:21 2011
Picon
Picon

Re: Problem with deleted directory

Hi again,

now I tried to delete the digikam4.db file to generate a new one.
This seems to be the only way to delete my missing folder.

But this does NOT work... because many keywords I set are missing after
the generation of the new db file!

If I use the old file, the keywords are ok... and all IPTC and XMP
settings are correct.

How can I generate a new db file?
Any idea?

Regards,

Alf

Am 25.04.2011 22:00, schrieb Alf Felis:
> Hi all,
> 
> I'm using digikam 1.2.0 (linux) and have a problem with a deleted directory.
> 
> The directory has been deleted in the filesystem (not from digikam), but
> digikam always shows this directory as album folder.
> 
> I tried to create a new directory with the same name... digikam now
> shows 2 entries with the same name in list. If I delete one of them with
> digikam, than the directory in the filesystem will be deleted, but only
> one entry in the list. The second entry is always visible.
(Continue reading)

Tim Jenness | 3 May 00:34 2011
Picon

Re: Problem with deleted directory


Make sure that you write all the tags to the files before trying to regenerate the database.

There is a menu item "Write Metdata To Files" that you run on each album.

Tim

On May 2, 2011, at 11:21 AM, Alf Felis wrote:

> Hi again,
> 
> now I tried to delete the digikam4.db file to generate a new one.
> This seems to be the only way to delete my missing folder.
> 
> But this does NOT work... because many keywords I set are missing after
> the generation of the new db file!
> 
> If I use the old file, the keywords are ok... and all IPTC and XMP
> settings are correct.
> 
> How can I generate a new db file?
> Any idea?
> 
> Regards,
> 
> Alf
> 
> 
> Am 25.04.2011 22:00, schrieb Alf Felis:
>> Hi all,
(Continue reading)

jag59 | 3 May 13:24 2011
Picon

Re: Problem with deleted directory


Tim Jenness wrote:
> 
> Make sure that you write all the tags to the files before trying to
> regenerate the database.
> 
> There is a menu item "Write Metdata To Files" that you run on each album.
> 
> Tim
> 
> On May 2, 2011, at 11:21 AM, Alf Felis wrote:
> 
>> Hi again,
>> 
>> now I tried to delete the digikam4.db file to generate a new one.
>> This seems to be the only way to delete my missing folder.
>> 
>> But this does NOT work... because many keywords I set are missing after
>> the generation of the new db file!
>> 
>> If I use the old file, the keywords are ok... and all IPTC and XMP
>> settings are correct.
>> 
>> How can I generate a new db file?
>> Any idea?
>> 
>> Regards,
>> 
>> Alf
>> 
(Continue reading)

Alf Felis | 3 May 21:37 2011
Picon
Picon

Re: Problem with deleted directory

Thank you for your reply.

In my settings I have set the parameter for writing the metadata to
file. These keywords are all visible in the IPTC/XMP tabs.

But it seems that not all keywords could be found if I delete the DB
file to regenerate the DB from the files.

Sometimes only one of e.g. three keywords can be found.

Is this a known bug?

Regards,

Alf

Am 03.05.2011 13:24, schrieb jag59:
> 
> Tim Jenness wrote:
>>
>> Make sure that you write all the tags to the files before trying to
>> regenerate the database.
>>
>> There is a menu item "Write Metdata To Files" that you run on each album.
>>
>> Tim
>>
>> On May 2, 2011, at 11:21 AM, Alf Felis wrote:
>>
>>> Hi again,
(Continue reading)

upscope | 3 May 23:48 2011
Picon

Digikam 1.9.0 database setup.

I am trying to setup a database with didikam 1.9.0. I want to use the MySQL database I have on localhost. I went into settings Database and set the following:


host name: localhost also tried http://localhost

port 3306 Also tried ports 0, 80.

Schema name: ~/user name/Pictures/digikam4.db

Thumbnails: ~/username/Pictures/thumbnails-digikam.db

username; xxxxxxx

password: XXXXXX

database digikam


Clicked Check DB Connection: Database connection test successful.

kick ok : error while opening the database

digikam will try to automatically reconnect to the database


just hangs trying until I click cancel.

messsage; Failed to open the database.

You cannot use digiKam without a working database. digiKam will attempt to start now, but it will not be functional. Please check the database settings in the configuration menu.

looking at documentation, no mention of database at all, also none on Wiki.

I can log into MySQl and change to the database digikam fro phpmyadmin and commandline. There are no tables. shouldn't digikam creat the tables?

Any help would be appreciated.

Russ

--------------------

openSUSE 11.4 MS1 (2.6.37.6-0.5-desktop)|Platform Version 4.6.2 (4.6.2) "release 3"|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce 8400GS (NVIDIA-Linux-x86_64-270.41.06)

_______________________________________________
Digikam-users mailing list
Digikam-users@...
https://mail.kde.org/mailman/listinfo/digikam-users
Tim Jenness | 4 May 00:44 2011
Picon

Re: Problem with deleted directory


On May 3, 2011, at 9:37 AM, Alf Felis wrote:

> Thank you for your reply.
> 
> In my settings I have set the parameter for writing the metadata to
> file. These keywords are all visible in the IPTC/XMP tabs.
> 
> But it seems that not all keywords could be found if I delete the DB
> file to regenerate the DB from the files.
> 
> Sometimes only one of e.g. three keywords can be found.
> 
> Is this a known bug?
> 

I'm not sure. v1.2 is quite old now (1.9 is current) and it's been a long time since I used that version.

Tim
Alf Felis | 4 May 08:16 2011
Picon
Picon

Re: Problem with deleted directory

Thats right, but I tried Version 1.8 and 1.9 (binary packages) and both
crashes with a segmentation fault on startup :(

Therefore I use 1.2... because this version is included in my linux
distribution (openSuSE 11.3) and seems to work.

Possibly I will try V 1.9 again... but currently I don't have so much
time to find out why the segmentation fault occurs.

Thanks for your support :)

Regards,

Alf

Am 04.05.2011 00:44, schrieb Tim Jenness:
> 
> On May 3, 2011, at 9:37 AM, Alf Felis wrote:
> 
>> Thank you for your reply.
>>
>> In my settings I have set the parameter for writing the metadata to
>> file. These keywords are all visible in the IPTC/XMP tabs.
>>
>> But it seems that not all keywords could be found if I delete the DB
>> file to regenerate the DB from the files.
>>
>> Sometimes only one of e.g. three keywords can be found.
>>
>> Is this a known bug?
>>
> 
> I'm not sure. v1.2 is quite old now (1.9 is current) and it's been a long time since I used that version.
> 
> Tim
> _______________________________________________
> Digikam-users mailing list
> Digikam-users@...
> https://mail.kde.org/mailman/listinfo/digikam-users
> 
Marco Tedaldi | 4 May 07:46 2011
Picon

Re: Digikam 1.9.0 database setup.

On 03.05.2011 23:48, upscope wrote:
> I am trying to setup a database with didikam 1.9.0. I want to use the 
> MySQL database I have on localhost. I went into settings Database and 
> set the following:
> 
>  host name: localhost also tried http://localhost
>  port 3306 Also tried ports 0, 80.
>  Schema name: ~/user name/Pictures/digikam4.db
>  Thumbnails: ~/username/Pictures/thumbnails-digikam.db
>  username;  xxxxxxx
>  password: XXXXXX 
>  database   digikam
> 
> Clicked Check DB Connection: Database connection test successful.
> kick ok : error while opening the database 
> 	     digikam will try to automatically reconnect to the database
> 
> just hangs trying until I click cancel.
>  
>  messsage; Failed to open the database. 
> You cannot use digiKam without a working database. digiKam will attempt 
> to start now, but it will not be functional. Please check the database 
> settings in the configuration menu.
> looking at documentation, no mention of database at all, also none on 
> Wiki.
> I can log into MySQl and change to the database digikam fro phpmyadmin 
> and commandline. There are no tables. shouldn't digikam creat the 
> tables?
> 
Does the user you are using for digikam have the right to create tables
in this database?
And what does the logfile of mysql say?

I don't have access to my installation right now (reverted it to sqlite
anyway, since it won't save image tags to the sql database!). But I
think I've set the "Schema Name" und "Thumbnails" to the databases to
use for the thumbnails and other data /without any slashes and dots in it)

best regards

Marco
Philip Johnsson | 5 May 20:17 2011
Picon

Re: Any interests in Digikam 2.0 packages and digikam PPA?

Digikam 2.0 beta 5 packages are now available for Ubuntu 11.04 (Natty)
on my ppa:philip5/extra PPA. As before install packages digikam2,
kipi-plugins2 and showfoto2 to try out Digikam 2.0 beta5. Remember
that it's still beta software and should not be used for production.

I will upload packages for Ubuntu 10.10 (Maverick) during this
evening. But with Maverick you need three PPAs ppa:philip5/extra,
ppa:philip5/kubuntu-backports and ppa:kubuntu-ppa/backports. Launchpad
have had long build cues the past days after the release of Natty so
it might take some time for the Maverick packages to get built and
ready for users to download.

Happy Digikaming!

/Philip

Gmane