Sam-Network.com | 27 Apr 14:05 2006

KDE does not work properly

Hi

I installed KDE on Cygwin just like it said iin the instructions.
KDE starts up but it can not load the taskbar or anything else. You just 
have a desktop with ''My Computer'' and the trash can on it and you cant 
do anything.

I have no idea what to do now. Please help me.

Thanks

Sam
Andrew Erwin | 27 Apr 04:26 2006
Picon

Problem with KDE

I got KDE going under cygwin. No problem. But when the interface comes up, it tells me basically that nothing can load.
The panel module, etc is appearently not installed?
The only thing I get is icons for Home, System and Trash; none of which can be loaded, because of the missing modules.
What am I doing (or have I done) wrong?
 
thanks,
andrew
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Eric Ho | 17 Apr 09:17 2006
Picon

Applet Problems

Hi,
I am having problems with the kde. It seems that the kicker cant start these three applets:
Desktop Previewer & Pager applet
Taskbar applet
System Tray Applet

I am using the newest cygwin available for download and followed the steps in
http://webdev.cegit.de/snapshots/kde-cygwin/kde/kde3.4/README

What is wrong and what should I do to get them started?
Thanks
Eric

Yahoo! Messenger with Voice. PC-to-Phone calls for ridiculously low rates.
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Rainer Lehrig | 31 Mar 17:08 2006
Picon

Qt4 QSvgRenderer in Qt3 ???

Hello,

SVG graphics is not complete in Qt3.
Would it be thinkable to use the Qt4 QSvgRenderer from within Qt3 ?

PS: I have a commercial License for Qt on Windows and would like to help 
programming.

Best regards:
Rainer Lehrig
http://pvbrowser.org
Vinay Anantharaman | 30 Mar 09:26 2006
Picon

Problems with starting KDE on cygwin

Hi,
    I installed kde as per the instructions: http://webdev.cegit.de/snapshots/kde-cygwin/kde/kde3.4/. I received no error messages however when i attempted to start it through the bash shell. i receive the error "This application has failed to start because cygart_lgpl_2-2.dll was not found. Re-installing the application may fix this problem'. I do not know what cygart_lgpl_2-2.dll is. Is there  cygwin package i need to install?
Thank you very much,
Vinay A.
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Roberto Sica | 5 Mar 23:35 2006
Picon

kde3 problems

i followed the istructions but kde3 after the start says cannot start applet and conqueror cant open modules..
do you have any cue? is something missing in the path?
here is the profile:

# base-files version 3.7-1

# WARNING
#
# IF THIS FILE IS MODIFIED IT WILL NOT BE UPDATED BY THE CYGWIN
# SETUP PROGRAM.  IT BECOMES YOUR RESPONSIBILITY.

# The latest version as installed by the Cygwin Setup program can
# always be found at /etc/defaults/etc/profile

# Some resources...

# Customizing Your Shell: http://www.dsl.org/cookbook/cookbook_5.html#SEC69
# Consistent BackSpace and Delete Configuration:
#   http://www.ibb.net/~anne/keyboard.html
# The Linux Documentation Project: http://www.tldp.org/
# The Linux Cookbook: http://www.tldp.org/LDP/linuxcookbook/html/

# Setup some default paths.  Note that this order will allow user installed
#  software to override 'system' software

# If you wish to change the path for all users, it is recommended you edit
#  /etc/bash.bashrc

# If you wish all future users to have some default setup, it is recommended you
#  edit /etc/skel/.bashrc

# If you wish to change the path on a user by user basis, it is recommended you
#  edit ~/.bashrc

PATH=/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:$PATH
export PATH

MANPATH=/usr/local/man:/usr/share/man:/usr/man:$MANPATH
export MANPATH

INFOPATH=/usr/local/info:/usr/share/info:/usr/info:$INFOPATH
export INFOPATH


#PATH=/usr/bin:/usr/local/bin:/usr/X11R6/bin:/opt/gnome/bin:/opt/kde2/bin:$PATH
#MANPATH=/usr/man:/usr/local/man:/usr/X11R6/man:/opt/gnome/man:/opt/kde2/share/man:$MANPATH
#INFOPATH=/usr/info:/usr/local/info:/opt/gnome/info:$INFOPATH
#KDEDIR=/opt/kde2
DISPLAY=127.0.0.1:0.0

export PATH MANPATH INFOPATH KDEDIR DISPLAY


# Set the user id
USER="`id -un`"
export USER

# Here is how HOME is set, in order of priority, when starting from Windows
#  1) From existing HOME in the Windows environment, translated to a Posix path
#  2) from /etc/passwd, if there is an entry with a non empty directory field
#  3) from HOMEDRIVE/HOMEPATH
#  4) / (root)

# If the home directory doesn't exist, create it.
if [ ! -d "${HOME}" ]; then
 mkdir -p "${HOME}"
 echo "Copying skeleton files."
 echo "These files are for the user to personalise"
 echo "their cygwin experience."
 echo
 echo "These will never be overwritten."
 echo
 cd /etc/skel
 /bin/find . -type f | while read f; do
  fDest=`echo ${f} | sed -e 's/^\.//g'`
  if [ ! -e "${HOME}${fDest}" -a ! -L "${HOME}${fDest}" ]; then
   /usr/bin/install -D -p -v "${f}" "${HOME}/${fDest}"
  fi
 done
fi

chmod 1777 /tmp 2>/dev/null

# Default to unix make mode
MAKE_MODE=unix
export MAKE_MODE

# It is recommended that cvs uses ssh for it's remote shell environment
CVS_RSH=/bin/ssh
export CVS_RSH

# Patches to Cygwin always appreciated ;)
# CVSROOT=:pserver:anoncvs <at> sources.redhat.com:/cvs/src
# export CVSROOT

# Shell dependent settings
case "`echo "_$0" | /usr/bin/tr '[:upper:]' '[:lower:]' | /usr/bin/sed -e 's/^_//'`" in
bash     | -bash     | */bash | \
bash.exe | -bash.exe | */bash.exe )
 # Set a HOSTNAME variable
 HOSTNAME=`hostname`
 export HOSTNAME

 # Set a default prompt of: user <at> host and current_directory
 PS1='\[\e]0;\w\a\]\n\[\e[32m\]\u <at> \h \[\e[33m\]\w\[\e[0m\]\n\$ '
 ;;
ksh*     | -ksh*     | */ksh* | \
ksh*.exe | -ksh*.exe | */ksh*.exe )
 # Set a HOSTNAME variable
 typeset -l HOSTNAME

 # Set a default prompt of: user <at> host and current_directory
 PS1='^[]0;${PWD}^G
^[[32m${USER} <at> ${HOSTNAME} ^[[33m${PWD}^[[0m
$ '
 ;;
zsh*     | -zsh*     | */zsh* | \
zsh*.exe | -zsh*.exe | */zsh*.exe )
 # Set a default prompt of: user <at> host, a command counter, and current_directory
 PS1='(%n <at> %m)[%h] %~ %% '
 
 # Set SHELL if not set
 if [ ! -z "${ZSH_NAME}" -a -z "${SHELL}" ]; then
  SHELL="/bin/zsh"
  export SHELL 
 fi
 ;;
sh     | -sh     | */sh | \
sh.exe | -sh.exe | */sh.exe )
 # Set a simple prompt
 PS1='$ '
 ;;
* )
 # Sorry, this shell has no defaults in /etc/profile,
 #  feel free to add your own.

 # If you have some recommendations for what these defaults
 #  should be, please contact cygwin <at> cygwin.com with the
 #  shell details and what you would like added.

 # Thanks
 
 PS1='$ '
 ;;
esac

export PS1

# Run all of the profile.d scripts
# Note that these are supplied by separate packages
# Ascending alphanumerical order enforced
if [ -d "/etc/profile.d" ]; then
 while read f; do
  if [ -f "${f}" ]; then
   . "${f}"
  fi
 done <<- EOF
 `/bin/find -L /etc/profile.d -type f -iname '*.sh' -or -iname '*.zsh' | LC_ALL=C sort`
 EOF
fi

# Uncomment to use the terminal colours set in DIR_COLOR
# eval "`dircolors -b /etc/DIR_COLORS`"

# Default to removing the write permission for group and other
#  (files normally created with mode 777 become 755; files created with
#  mode 666 become 644)
umask 022

# Define default printer
PRINTER=""
case `uname -s` in
CYGWIN_NT-*)
 PRINTER="`regtool -q get '\user\Software\Microsoft\Windows NT\CurrentVersion\Windows\Device' | sed 's/,.*$//'`"
 ;;
CYGWIN_9?-*)
 PRINTER="`regtool -q get '\config\System\CurrentControlSet\Control\Print\Printers\Default'`"
 ;;
esac
export PRINTER

# Make sure we start in home unless invoked by CHERE
if [ ! -z "${CHERE_INVOKING}" ]; then
  unset CHERE_INVOKING
else
  cd "${HOME}"
fi

# Check to see if mkpasswd/mkgroup needs to be run try and cut down the emails
#   about this on the lists!
# If this message keeps appearing and you are sure it's a mistake (ie, don't
#   email about it!), comment out the test below.
case `id -ng` in
mkpasswd )
  echo "Your group is currently \"mkpasswd\".  This indicates that"
  echo "the /etc/passwd (and possibly /etc/group) files should be rebuilt."
  echo "See the man pages for mkpasswd and mkgroup then, for example, run"
  echo "mkpasswd -l [-d] > /etc/passwd"
  echo "mkgroup  -l [-d] > /etc/group"
  echo "Note that the -d switch is necessary for domain users."
  ;;

mkgroup )
  echo "Your group is currently \"mkgroup\".  This indicates that"
  echo "the /etc/group (and possibly /etc/passwd) files should be rebuilt."
  echo "See the man pages for mkpasswd and mkgroup then, for example, run"
  echo "mkpasswd -l [-d] > /etc/passwd"
  echo "mkgroup  -l [-d] > /etc/group"
  echo "Note that the -d switch is necessary for domain users."
  ;;

mkgroup_l_d )
  echo "Your group name is currently \"mkgroup_l_d\". This indicates that not"
  echo "all domain users and groups are listed in the /etc/passwd and"
  echo "/etc/group files."
  echo "See the man pages for mkpasswd and mkgroup then, for example, run"
  echo "mkpasswd -l -d > /etc/passwd"
  echo "mkgroup  -l -d > /etc/group"
  echo
  echo "This message is only displayed once (unless you recreate /etc/group)"
  echo "and can be safely ignored."

  # only display the above once
  cp -f /etc/group "${HOME}/group.mkgroup_l_d" \
  && ( [ -w /etc/group ] || chmod --silent a+w /etc/group ; )\
  && sed -e 's/^mkgroup_l_d/mkgroup-l-d/' "${HOME}/group.mkgroup_l_d" > /etc/group \
  && chmod --silent --reference=/etc/passwd /etc/group
  rm -f "${HOME}/group.mkgroup_l_d"
  ;;
esac

_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Hemanth Kashinath | 3 Mar 00:27 2006

Cygwin bash shell fails to start after installing KDE3.4


Group,

I cannot start a bash shell on cygwin after following procedures to install 
KDE3.4 and hence can't start KDE with the "startkde" file.
I searched for a "startkde.bat" file to see if I can start KDE from windows 
with no success.

Any help is much appreciated.

Hemanth Kashinath
Hemanth Kashinath | 2 Mar 03:41 2006

Unable to run kde on cygwin


KDE,

I followed all the instructions to install cygwin and KDE on my windows 
system (XP Professional). When I execute I get an error dialog box which has 
the following message:
"This application has failed to start because cygart_lgpl_2-2.dll was not 
found. Re-installing the application may fix this problem."

Can you please help me out with any information?

Thanks,

Hemanth Kashinath
Integration Architect, webMethods
FCS Business Solutions, Inc.
P: 571.224.4536
F: 309.402.8894
E: hkashinath <at> fcs-inc.com
W: www.fcsbusinesssolutions.com
REGAT-BARREL Aurelien | 1 Mar 12:06 2006
Picon

Qt/Win Free - Unofficial patches for Qt4 - manifest

Hi all,
I hope this is the rigth place te speak about "Qt/Win Free - Unofficial patches
for Qt4":
http://sourceforge.net/project/showfiles.php?group_id=49109&package_id=165202

First, thanks for this patch, it's a godd job :-)

I tried to compile Qt in -release -static with it, and, I succeeded. But, in
release + static, it is compiled using -MD = using the CRT as a dll
http://msdn2.microsoft.com/en-us/library/2kzt1wy3(en-US,VS.80).aspx
I changed QMAKE_CFLAGS_RELEASE in qmake.conf in order to compile with -MT, wich
IMO is a better choice for redistribution.
But the compilation quickly fails:

       link /NOLOGO /SUBSYSTEM:CONSOLE /incremental:no /OUT:"..\..\..\bin\moc.e
xe"  <at> C:\DOCUME~1\Aurelien\LOCALS~1\Temp\nm672.tmp
moc.obj : MSIL .netmodule or module compiled with /GL found; restarting link
wit
h /LTCG; add /LTCG to the link command line to improve linker performance
Generating code
Finished generating code
        mt.exe /manifest ..\..\..\bin\moc.exe.manifest
/outputresource:..\..\..\
bin\moc.exe;#2
Microsoft (R) Manifest Tool version 5.2.3790.2014
Copyright (c) Microsoft Corporation 2005.
All rights reserved.

..\..\..\bin\moc.exe.manifest : general error c1010070: Failed to load and
parse
 the manifest. File not found.

This is because the patch always calls mt.exe, and it shouldn't in my case
since when compiling with -MT, no manifest is required so it is not created.
So, I created a patch for your patch :-)
ftp://ftp-developpez.com/arb/qt4/vc++/qt-4.1-patch-release-mt.zip

It patches qmake in order to change its nmake output:

mt.exe /manifest (DESTDIR_TARGET).manifest /outputresource:$(DESTDIR_TARGET);#2

becomes

 <at> if exist $(DESTDIR_TARGET).manifest mt.exe /manifest (DESTDIR_TARGET).manifest
/outputresource:$(DESTDIR_TARGET);#2

it also patches qmake/Makefile.win32-msvc2005 in order to compile it with -MT
too.
Files modified by my patch:
http://arb.developpez.com/qt4/vc++/compilation/msvc_nmake.cpp
http://arb.developpez.com/qt4/vc++/compilation/qmake.conf
http://arb.developpez.com/qt4/vc++/compilation/Makefile.win32-msvc2005

Note that I also compile with -GL in release.
http://msdn2.microsoft.com/en-us/library/0zza0de8(en-US,VS.80).aspx

But this point can be discussed.

Hope it helps.

PS: I wrote a french article about this, if there are some french here:
http://arb.developpez.com/qt4/vc++/compilation/

	

	
		
___________________________________________________________________________ 
Nouveau : téléphonez moins cher avec Yahoo! Messenger ! Découvez les tarifs exceptionnels pour
appeler la France et l'international.
Téléchargez sur http://fr.messenger.yahoo.com
Ralf Habacker | 16 Feb 10:58 2006
Picon

Re: Problem: Applet could not be loaded

PerfectDark schrieb:
>> PerfectDark schrieb:
>>     
>>> Hello!
>>>
>>> I am a developer from Russia and now I try to use KDE on cygwin. Native OS is WinXP SP2.
>>> I installed KDE 3.4.1 as described in README, and it seems installed well, but when I start KDE with script
>>> #!/bin/bash
>>> /usr/sbin/cygserver &
>>> export CYGWIN=server
>>> export DISPLAY=127.0.0.1:0.0
>>> export SHELL=/bin/bash
>>> xwin -fullscreen -noreset &
>>> xwinclip &
>>> xhost +
>>> /opt/kde3.4/bin/startkde
>>> kdeinit_shutdown
>>> taskkill /IM xwin
>>> taskkill /IM xwinclip
>>> taskkill /IM cygserver
>>> #-----------------------END------------------
>>> it loads and the end of loading appear error messages such as
>>> "The Desktop Previewer & Pager Applet could not be loaded.
>>> Please check your installation"
>>> 2nd message:
>>> "The Taskbar Applet ....."
>>> 3rd message:
>>> "The System Tray Applet ...."
>>>
>>> I tried to start KDE in debug log, and very strange errors appeared (logs situated in attached zip file).
>>>
>>> Please, help me.
>>>
>>> Regards,
>>>         Alexander
>>>       
>> It was reported, that a buggy cygwin dll results in such errors. Please 
>> try an older or newer version of the cygwin package. If this helps, 
>> please let me know.
>>
>> Ralf
>>
>>
>>     
>
>
> Thank for you advice!!!
> Now it really works (but some new bugs appeared)! I downloaded cygwin1.dll (1005.18.0.0 version), but
bash.exe and something others applications such as sed.exe, rm.exe, ls.exe could not found entries for
something necessary(?) functions - "getline", "strtoupmax" (May be I should rebase it? - Which entry
point should be used?)...
> Used dll situated in attached files.
> It version really does not contain "getline" function, but cygwin1.dll 1.19.4 does.
> And I can't beliewe - newest version of cygwin1.dll (1005.19.0.0 or 1.5.19-cr-0x5ef) contains bug
(what???) which does not allow to load applets (and some KDE controls (or packages?) such as built-in
KHTML, Text Viewer, and some another controls) - seems all drowning in dll' hell, as microsoft warned :)
>
>   
There are three different approaches to fix this problem:

1. The related applications are build with recent cygwin dll. If you 
revert this apps to older version which does not require the new symbols 
it will work.
2. Perform some research to find where the cygwin behavior had changed 
between the two releases (you may inspect the cygwin changelog at 
http://cygwin.com/cgi-bin/cvsweb.cgi/src/winsup/cygwin/ChangeLog?cvsroot=src) 
and
    1. if this is a cygwin problem send a patch or bug report with a 
reproducable testcase to the cygwin mailing list, so that further cygwin 
dlls will work or
    2. if no reason is so find, someone may recompile kde with newest 
cygwin library and release an updated binary release

Ralf
PerfectDark | 16 Feb 10:05 2006
Picon

Fw: Problem: Applet could not be loaded

--- Forwarded message --
From: PerfectDark <PerfectDark <at> yandex.ru>
To:  <kde-cygwin <at> kde.org>
Date: 15.02.06 15:54
Subject: Problem: Applet could not be loaded

Hello!

I am a developer from Russia and now I try to use KDE on cygwin. Native OS is WinXP SP2.
I installed KDE 3.4.1 as described in README, and it seems installed well, but when I start KDE with script
#!/bin/bash
/usr/sbin/cygserver &
export CYGWIN=server
export DISPLAY=127.0.0.1:0.0
export SHELL=/bin/bash
xwin -fullscreen -noreset &
xwinclip &
xhost +
/opt/kde3.4/bin/startkde
kdeinit_shutdown
taskkill /IM xwin
taskkill /IM xwinclip
taskkill /IM cygserver
#-----------------------END------------------
it loads and the end of loading appear error messages such as
"The Desktop Previewer & Pager Applet could not be loaded.
Please check your installation"
2nd message:
"The Taskbar Applet ....."
3rd message:
"The System Tray Applet ...."

I tried to start KDE in debug log, and very strange errors appeared (logs situated in attached zip file).

Please, help me.

Regards,
        Alexander

--- End of forwarded message --
---------------------------------------------------

Hello!

Now I found solution to that problem. Seems newest versions of cygwin1.dll contains bug which does not
allow to load required applets and packages (such as Desktop applet, Taskbar, Text Viewer, KHTML module
and several others). When I replaced newest cygwin1.dll to older version (1.5.18) kde loaded without any
troubles, but several applications (bash, sed, rm, ls and others...) could not found entry point to
function "getline" (actually, cygwin1.dll v1.5.18 does not contain those function, although
cygwin1.dll v1.5.19.4 does)
How I can fix new problem?

Best Regards,
             Alexander Shabanov
Picon
From: PerfectDark <PerfectDark <at> yandex.ru>
Subject: Problem: Applet could not be loaded
Date: 2006-02-15 12:54:41 GMT
Hello!

I am a developer from Russia and now I try to use KDE on cygwin. Native OS is WinXP SP2.
I installed KDE 3.4.1 as described in README, and it seems installed well, but when I start KDE with script
#!/bin/bash
/usr/sbin/cygserver &
export CYGWIN=server
export DISPLAY=127.0.0.1:0.0
export SHELL=/bin/bash
xwin -fullscreen -noreset &
xwinclip &
xhost +
/opt/kde3.4/bin/startkde
kdeinit_shutdown
taskkill /IM xwin
taskkill /IM xwinclip
taskkill /IM cygserver
#-----------------------END------------------
it loads and the end of loading appear error messages such as
"The Desktop Previewer & Pager Applet could not be loaded.
Please check your installation"
2nd message:
"The Taskbar Applet ....."
3rd message:
"The System Tray Applet ...."

I tried to start KDE in debug log, and very strange errors appeared (logs situated in attached zip file).

Please, help me.

Regards,
        Alexander
Attachment (debug_startkde_logs.zip): application/zip, 4535 bytes
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin

Gmane