Douglas Allen | 29 Jan 22:34 2007
Picon

It works for me

Hey all,

   I just thought that you might like to know that this non hacker got kde-cygwin to work on my Windows XP. So if I can do it, so can you.
I'm a neo at best with Linux command line so I just copied and pasted the commands from the web page <at> here
to a bash window. It didn't work at first for me either so I double checked to see if I had all the prerequired components from the cygwin setup program. I also used freedownloadmanager.org site explorer to get some of the big ones. The setup will see the bz2 if you have it in the right place so the site explorer helped me to figure out where they go in my installers directory. It sure would be nice if someone could write a little utility to just gather what is needed to get things working. I still don't know where the ones I downloaded from the bash were first located before I unzipped them. I also found that I had a few still missing but K Desktop came up anyway. I am getting the rest now as I write this. The one thing that I need now is to somehow get firefox in there because konquerer won't work with any google personalized pages. I wanted to write in gmail there but google says no way for that browser. Perhaps someone developing for google will work on that someday.
  Does anyone know how to make firefox work in this kde-cygwin desktop?

_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Waldo, Paul | 26 Jan 20:49 2007

Some initial problems

Hi all,

I'm an avid KDE user under Linux at home, but I'm forced to use Windows
at work.  I was very happy to find that KDE under Cygwin is available!
I have it up and running, but I have a few issues I was hoping to get
some help with:

- things that require root access are problematic:
sh-3.2$ kdesu
kdesu: ERROR: User root does not exist

- Starting up programs from the K menu is very slow.  I see in
TaskManager that kdeinit runs full-bore for many seconds before the
program appears

- Sound does not work.  When I run "startkde" I see this in the output:
Could not find 'artswrapper' executable.  Do I need to run esd in
Windows to get sound?

- Only a few styles are available, and I see this in the startup
messages:
Conflict in /usr/lib/kde3/plugins/styles/light.dll:
  Plugin uses incompatible Qt library (3.3.6)!
Conflict in /usr/lib/kde3/plugins/styles/highcolor.dll:
  Plugin uses incompatible Qt library (3.3.6)!
Conflict in /usr/lib/kde3/plugins/styles/highcontrast.dll:
  Plugin uses incompatible Qt library (3.3.6)!
Conflict in /usr/lib/kde3/plugins/styles/keramik.dll:
  Plugin uses incompatible Qt library (3.3.6)!
Conflict in /usr/lib/kde3/plugins/styles/kthemestyle.dll:
  Plugin uses incompatible Qt library (3.3.6)!
Conflict in /usr/lib/kde3/plugins/styles/scheck.dll:
  Plugin uses incompatible Qt library (3.3.6)!
Conflict in /usr/lib/kde3/plugins/styles/plastik.dll:
  Plugin uses incompatible Qt library (3.3.6)!

- The only way to access the KDE Settings is via expanding menus from
the K menu.  I don't see a Control Panel-type application that stays
open and contains all of the settings icons.

Any help with these issues would be greatly appreciated.  Thanks in
advance!

Paul
====================
This email/fax message is for the sole use of the intended
recipient(s) and may contain confidential and privileged information.
Any unauthorized review, use, disclosure or distribution of this
email/fax is prohibited. If you are not the intended recipient, please
destroy all paper and electronic copies of the original message.
Tim Schumacher | 17 Jan 16:23 2007
Picon

Problems with KDE

Hi.

I have big problems with my the KDE I want to use with cygwin.
I used the Windows installer for KDE 3.1.1. When I run the created batchfile ("Start KDE Desktop(full)")
the KDE splash screen appears and the desktop is loaded. But instead of any panels I get the following error message:

The application KDE Panel (kicker) crashed and caused the signal 11 (SIGSEGV)

Could you please tell me how I can solve this problem.

Kind Regards
Tim
______________________________________________________________________
XXL-Speicher, PC-Virenschutz, Spartarife & mehr: Nur im WEB.DE Club!		
Jetzt gratis testen! http://freemail.web.de/home/landingpad/?mc=021130
iBedir | 10 Jan 19:59 2007
Picon

errol installing kile on cygwin

I have followed the guide on your page:

http://webdev.cegit.de/snapshots/kde-cygwin/kde/kde3.4/

and KDE runs fine. I am now trying to install Kile but when I run the ./configure I \
get this error:

you need to install kdelibs first.

If you did install kdelibs, then the Qt version that is picked up by
this configure is not the same version you used to compile kdelibs.
The Qt Plugin installed by kdelibs is *ONLY* loadable if its the
same Qt version, compiled with the same compiler and the same Qt
configuration settings.

Hope you can help!
Thank you,
Islam
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
johnny semiono | 3 Jan 18:49 2007
Picon

Don't work!

Index of /snapshots/kde-cygwin/kde/kde3.4 is downloaded.
Don't work! :(
Why?
I use biggest pakage of cygwin 2,50 GB content!
What need more to added here??
?
Attachment (1XWin.log): application/octet-stream, 4648 bytes
Attachment (2XWin.log): application/octet-stream, 889 bytes
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Jon Evans | 29 Dec 23:33 2006
Picon

Unable to startkde

I've followed the guide here
http://webdev.cegit.de/snapshots/kde-cygwin/kde/kde3.4/

The X server starts in full screen but bombs out trying to get kde
running.   I get an error message in cygwin console:-
/opt/kde3.4/bin/startkde: line 79:
/opt/kde3.4/home/share/config/startupconfig
No such file or directory

Regards,
echo6
Iqbal Javid | 17 Dec 18:21 2006
Picon
Picon

KDE 3.1.4 installation on Cygwin -- Suggestions

I have installed Cygwin and  KDE 3.1.4 packages on Windows XP system.  I followed the setup process explained
with the KDE 3.1.4 release.  The steps are given here:
1. install required cygwin packages.
2. download the packages and unpack them into the cygwin root
3. rebase all dll's to avoid cygwin remap problem
<before running rebaseall make sure, that no cygwin process is running>

1. create file list

find /opt/qt/3.3 /opt/kde3.4 -name '*.dll' >/tmp/files.lst

2. close *ALL* cygwin processes

3. open a windows command shell (cmd.exe) from Start/Run and goto cygwin installation root

cd c:\cygwin
bin\ash bin/rebaseall -b 0x61000000 -v -T tmp/files.lst

4. start kde

1. display only kicker (uses Xwin multiwindow mode)

at first create a simple startscript

cat >~/startkde
export DISPLAY=127.0.0.1:0
/usr/sbin/cygserver &
export CYGWIN=server
export DISPLAY=127.0.0.1:0
xwin -multiwindow -clipboard &
xhost +
export SHELL=/bin/bash
kdeinit +kicker &

[press ENTER, then CTRL-D]

chmod a+x ~/startkde

no you can start kde with

~/startkde &

stop kde - run

kdeinit_shutdown

then close the bash window
 

When I execute the startkde script, following output messages are generated.
Can someone explain the reason for the startkde failure and suggest steps to correctly
setup the KDE?. Thanks in advance.


/home/RootUser/startkde: line 2:
: command not found
/home/RootUser/startkde: line 5:
: command not found
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 6.8.99.901-4

Contact: cygwin-xfree <at> cygwin.com

XWin was started with the following command line:

xwin -multiwindow -clipboard

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
winDetectSupportedEngines - Windows NT/2000/XP
xhost: unable to open display "127.0.0.1:0
"
winDetectSupportedEngines - DirectDraw installed
winDetectSupportedEngines - DirectDraw4 installed
winDetectSupportedEngines - Returning, supported engines 00000007
winSetEngine - Multi Window or Rootless => ShadowGDI
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 1280 height: 1024 depth: 32
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
/home/RootUser/startkde: line 8:
: command not found
winInitMultiWindowWM - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Hello
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of shared memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409)
(--) Using preset keyboard for "English (USA)" (409), type "4"
Rules = "xorg" Model = "pc105" Layout = "us" Variant = "(null)" Options = "(null)"
(--) 3 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
winPointerWarpCursor - Discarding first warp: 640 512
winInitMultiWindowWM - pthread_mutex_lock () returned.
winInitMultiWindowWM - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - pthread_mutex_lock () returned.
winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
winProcEstablishConnection - Hello
winInitClipboard ()
winClipboardProc - Hello
DetectUnicodeSupport - Windows NT/2000/XP
winClipboardProc - DISPLAY=127.0.0.1:0.0
winProcEstablishConnection - winInitClipboard returned.
winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the display.
winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the display.
winClipboardProc - XOpenDisplay () returned and successfully opened the display.
winProcSetSelectionOwner - Clipboard not yet started, aborting.
winProcSetSelectionOwner - Clipboard not yet started, aborting.
+ Exit 127 ~/startkde

Javid

_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Hylke Donker | 26 Nov 13:09 2006
Picon

Problems compiling Q...

Hello,
Today i've installed Dev-Cpp 4.9.9.2 and QT WIN Free 3.3-2006-11-24.
I get the following compiling errors from:
configure-mingw.bat -static

[..]
g++ -c -mthreads -w -O2 -fexceptions -frtti -DQT_THREAD_SUPPORT -DQT_ACCESSIBILI
TY_SUPPORT -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DUNICODE -DQT_THREAD_SUPPORT -DQT_
NO_CUPS -DQT_NO_NIS -DQT_NO_STYLE_MAC -DQT_NO_STYLE_AQUA -DQT_NO_STYLE_WINDOWSXP
 -DQT_NO_STYLE_POCKETPC -I"tmp" -I"3rdparty\libmng" -I"3rdparty\libjpeg" -I"3rdp
arty\libpng" -I"3rdparty\zlib" -I"C:\Source\qt-3\include" -I"." -I"tmp\moc\relea
se-static-mt" -I"C:\Source\qt-3\mkspecs\win32-g++" -o tmp\obj\release-static-mt\
qdesktopwidget_win.o kernel\qdesktopwidget_win.cpp
kernel\/qwidget.h: In copy constructor `QSingleDesktopWidget::QSingleDesktopWidg
et(const QSingleDesktopWidget&)':
kernel\/qwidget.h:696: error: `QWidget::QWidget(const QWidget&)' is private
kernel\qdesktopwidget_win.cpp:167: error: within this context
mingw32-make[2]: *** [tmp\obj\release-static-mt\qdesktopwidget_win.o] Error 1
mingw32-make[2]: Leaving directory `C:/Source/qt-3/src'
mingw32-make[1]: *** [sub-src] Error 2
mingw32-make[1]: Leaving directory `C:/Source/qt-3'
mingw32-make: *** [init] Error 2
C:\Source\qt-3>

I hope you can fix this simple syntax error.
Hylke
Khader Nayati | 16 Oct 18:19 2006
Picon

Please help me!

Hello I saw ur website and I would like to contribute to ur website. I would like to work in the customer support area.
 
Expecting your reply
 
Regards
 
MAK
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
haig.krikorian | 4 Oct 22:10 2006

Help in configuiring KDE

I have sucessfully downloaded, installed, configured, and can execute cygwin & bring up the KDE 3.4 desktop.
 
I have downloaded and extracted the KDE games to "C:\cygwin\opt\kde3\bin"
 
How do I get the games to appear in the menu selection for example just after  "Editors" on the desktop menu ?  
 
Do I need to add a soft-link from C:\cygwin\opt\kde3.4\bin to "C:\cygwin\opt\kde3\bin" ?
 
How do I get the games to execute from the file manager?
 
- Thanks
 
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin
Serge Kouthon | 21 Sep 18:16 2006
Picon

kde 3.4 startup problem

When I try to launch startkde in cygwin using the following script :
 
   #!/bin/bash
   /usr/sbin/cygserver &
   export CYGWIN=server
   export SHELL=/bin/bash
   xwin -fullscreen -noreset &
   xwinclip &
   xhost +
   /opt/kde3.4/bin/startkde
   kdeinit_shutdown
   taskkill /IM xwin
   taskkill /IM xwinclip
   taskkill /IM cygserver
 
A black screen appear containing a single popu windows with the text :
could not start kstartupconfig check your installation
 
I also obtain the following messages on the shell window:
 
 
 

$ ./startkde
./startkde: line 6: xwinclip: command not found
cygserver: Initialization complete.  Waiting for requests.
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 6.8.99.901-4

Contact: cygwin-xfree <at> cygwin.com

XWin was started with the following command line:

xwin -fullscreen -noreset

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
winDetectSupportedEngines - Windows NT/2000/XP
winDetectSupportedEngines - DirectDraw installed
winDetectSupportedEngines - DirectDraw4 installed
winDetectSupportedEngines - Returning, supported engines 00000007
winSetEngine - Using Shadow DirectDraw NonLocking
winAdjustVideoModeShadowDDNL - Using Windows display depth of 32 bits per pixel
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "0000100C" (0000100c)
(--) Using preset keyboard for "French (Switzerland)" (100c), type "4"
Rules = "xorg" Model = "pc105" Layout = "fr_CH" Variant = "(null)" Options = "(n
ull)"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Can't find file "pc/fr_CH" for symbols include
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
(--) 3 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from li
st!
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from
list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from li
st!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from
 list!
winPointerWarpCursor - Discarding first warp: 800 600
winProcEstablishConnection - Hello
winProcEstablishConnection - Clipboard is not enabled, returning.
access control disabled, clients can connect from any host

 

Any idea ?



--
Serge Kouthon
Rue du Maupas 11
1004 Lausanne
_______________________________________________
kde-cygwin mailing list
kde-cygwin <at> kde.org
https://mail.kde.org/mailman/listinfo/kde-cygwin

Gmane