Liu Shaohui (JIRA | 2 Sep 13:43 2014
Picon

[jira] [Created] (HBASE-11877) Make TableSplit more readable

Liu Shaohui created HBASE-11877:
-----------------------------------

             Summary: Make TableSplit more readable
                 Key: HBASE-11877
                 URL: https://issues.apache.org/jira/browse/HBASE-11877
             Project: HBase
          Issue Type: Improvement
            Reporter: Liu Shaohui
            Priority: Minor

When debugging MR jobs reading from hbase table, it's import to figure out which region a map task is reading from.
But the table split object is hard to read.
eg:
{code}
2014-09-01 20:58:39,783 INFO [main] org.apache.hadoop.mapred.MapTask: Processing split: lg-hadoop-prc-st40.bj:,0
{code}

We should make it more readable.

--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Lars Hofhansl (JIRA | 2 Sep 06:51 2014
Picon

[jira] [Created] (HBASE-11876) RegionScanner.nextRaw(...) should update metrics

Lars Hofhansl created HBASE-11876:
-------------------------------------

             Summary: RegionScanner.nextRaw(...) should update metrics
                 Key: HBASE-11876
                 URL: https://issues.apache.org/jira/browse/HBASE-11876
             Project: HBase
          Issue Type: Bug
    Affects Versions: 0.98.6
            Reporter: Lars Hofhansl

I added the RegionScanner.nextRaw(...) to allow "smart" client to avoid some of the default work that
HBase is doing, such as {start|stop}RegionOperation and synchronized(scanner) for each row.

Metrics should follow the same approach. Collecting them per row is expensive and a caller should have the
option to collect those later or to avoid collecting them completely.

We can also save some cycles in RSRcpServices.scan(...) if we updated the metric only once/batch instead
of each row.

--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

James Taylor | 2 Sep 03:23 2014
Picon

[ANNOUNCE] Apache Phoenix 3.1 and 4.1 released

Hello everyone,

On behalf of the Apache Phoenix [1] project, a SQL database on top of
HBase, I'm pleased to announce the immediate availability of our 3.1
and 4.1 releases [2].

These include many bug fixes along with support for nested/derived
tables, tracing, and local indexing. For details of the release,
please see our announcement [3].

Regards,
The Apache Phoenix team

[1] http://phoenix.apache.org/
[2] http://phoenix.apache.org/download.html
[3] https://blogs.apache.org/phoenix/entry/announcing_phoenix_3_1_and

ayache khettar (JIRA | 1 Sep 18:49 2014
Picon

[jira] [Created] (HBASE-11875) Referencing external package com/google/protobuf/ inside hbase-protcol module won't work in OSGI environment

ayache khettar created HBASE-11875:
--------------------------------------

             Summary: Referencing external package com/google/protobuf/ inside hbase-protcol module won't work in
OSGI environment
                 Key: HBASE-11875
                 URL: https://issues.apache.org/jira/browse/HBASE-11875
             Project: HBase
          Issue Type: Improvement
          Components: Protobufs
    Affects Versions: 0.98.6
         Environment: OSGI container
            Reporter: ayache khettar

Hi

HbaseZeroCopyByteString class isn't accessible in OSGI based environment. The reason is that it ends up
in a separate route package within an OSGI bundle. As such the class isn't viewable by the classLoader.

I understand that the hbase-module isn't an osgi bundle, but there is another project which makes use of
this module to generate an osgi bundle for the OSGI container:
https://github.com/apache/servicemix4-bundles/tree/trunk/hbase-0.98.0-hadoop2. If you get
hold of the binary or source artefact from maven, unzip the jar and you will see the structure of the project:
com/google/ (classes defined in this package are not visible by the classLoader).
org/apache/hbase

I understand the reason of having a foreign package cause goggle base class defines package level methods.
It would be nice to work out another way of extending google protobuf classes.

Regards,
(Continue reading)

Anoop Sam John (JIRA | 1 Sep 14:47 2014
Picon

[jira] [Created] (HBASE-11874) Support Cell to be passed to StoreFile.Writer rather than KeyValue

Anoop Sam John created HBASE-11874:
--------------------------------------

             Summary: Support Cell to be passed to StoreFile.Writer rather than KeyValue
                 Key: HBASE-11874
                 URL: https://issues.apache.org/jira/browse/HBASE-11874
             Project: HBase
          Issue Type: Sub-task
            Reporter: Anoop Sam John
            Assignee: Anoop Sam John

This is the in write path and touches StoreFile.Writer,  HFileWriter , HFileDataBlockEncoder and
different DataBlockEncoder impl.
We will have to avoid KV#getBuffer() KV#getKeyOffset/Length() calls.

--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Guo Ruijing (JIRA | 1 Sep 09:36 2014
Picon

[jira] [Created] (HBASE-11873) Hbase Version CLI enhancement

Guo Ruijing created HBASE-11873:
-----------------------------------

             Summary: Hbase Version CLI enhancement
                 Key: HBASE-11873
                 URL: https://issues.apache.org/jira/browse/HBASE-11873
             Project: HBase
          Issue Type: Improvement
          Components: build
            Reporter: Guo Ruijing
            Priority: Minor

Hbase Version CLI enhancements:

1) include source code checksum.
2) change "Subversion" to "Source code repository"

Existing implementation:

hadoop <at> localhost p4_wspaces]$ hbase version
2014-09-01 03:29:40,773 INFO  [main] util.VersionInfo: HBase 0.98.1-hadoop2
2014-09-01 03:29:40,773 INFO  [main] util.VersionInfo: Subversion <...>
2014-09-01 03:29:40,773 INFO  [main] util.VersionInfo: Compiled by <...>

Expected implematation:

hadoop <at> localhost p4_wspaces]$ hbase version
2014-09-01 03:29:40,773 INFO  [main] util.VersionInfo: HBase 0.98.1-hadoop2
2014-09-01 03:29:40,773 INFO  [main] util.VersionInfo: Source code repository <...>   <<< change
"Subversion" to "Source code repository"
(Continue reading)

Anoop Sam John (JIRA | 1 Sep 09:03 2014
Picon

[jira] [Created] (HBASE-11872) Avoid usage of KeyValueUtil#ensureKeyValue from Compactor

Anoop Sam John created HBASE-11872:
--------------------------------------

             Summary: Avoid usage of KeyValueUtil#ensureKeyValue from Compactor
                 Key: HBASE-11872
                 URL: https://issues.apache.org/jira/browse/HBASE-11872
             Project: HBase
          Issue Type: Sub-task
            Reporter: Anoop Sam John
            Assignee: Anoop Sam John

--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Kashif Jawed Siddiqui | 1 Sep 08:28 2014

Re: Thrift client authentication skipped for HBase thrift server

Hi All,

As per current implementation done for https://issues.apache.org/jira/i#browse/HBASE-11349  && 
https://issues.apache.org/jira/i#browse/HBASE-11474 ,

The authentication mechanism using  Kerberos principal for Thrift server with HBase is perfectly fine.

But for clients communicating to HBase via thrift server does not handle the security mechanism.

Any unauthenticated client can access HBase via thrift server. The thrift sever can act as a backdoor entry
for skipping the security & authentication.

It will be better if thrift clients can also be authenticated through some mechanism like Kerberos or IP restriction,etc

Let us discuss on mechanism for thrift client authentication that can be implemented.

***************************************************************************************
This e-mail and attachments contain confidential information from HUAWEI, which is intended only for the
person or entity whose address is listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction, or dissemination) by
persons other than the intended recipient's) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or email immediately and delete it!

Anoop Sam John (JIRA | 1 Sep 08:06 2014
Picon

[jira] [Created] (HBASE-11871) Avoid usage of KeyValueUtil#ensureKeyValue

Anoop Sam John created HBASE-11871:
--------------------------------------

             Summary: Avoid usage of KeyValueUtil#ensureKeyValue
                 Key: HBASE-11871
                 URL: https://issues.apache.org/jira/browse/HBASE-11871
             Project: HBase
          Issue Type: Improvement
          Components: regionserver
            Reporter: Anoop Sam John
            Assignee: Anoop Sam John

Now we try to use diff impls of Cells (other than KV) in server side for optimizations. (HBASE-11870  is one
like this) Having code  KeyValueUtil#ensureKeyValue can be dangerous as it recreate the Cell and do
buffer copy. This is an umbrella issue.  Will raise small sub tasks in specific areas and tackle this.

--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Anoop Sam John (JIRA | 1 Sep 08:04 2014
Picon

[jira] [Created] (HBASE-11870) Optimization : Avoid copy of key and value for tags addition in AC and VC

Anoop Sam John created HBASE-11870:
--------------------------------------

             Summary: Optimization : Avoid copy of key and value for tags addition in AC and VC
                 Key: HBASE-11870
                 URL: https://issues.apache.org/jira/browse/HBASE-11870
             Project: HBase
          Issue Type: Improvement
          Components: Performance, security
    Affects Versions: 0.98.0
            Reporter: Anoop Sam John
            Assignee: Anoop Sam John

In AC and VC we have to add the per cell ACL tags/ visibility tags to Cells. We get KeyValue objects and which
need one backing array with key,value and tags. So in order to add a tag we have to recreate buffer the and
copy the entire key , value and tags.  We can avoid this
Create a new Cell impl which wraps the original Cell and fro the non tag parts just refer this old buffer.
This will contain a byte[] state for the tags part.
Also we have to ensure we deal with Cells n write path not KV.

--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Liu Shaohui (JIRA | 1 Sep 06:26 2014
Picon

[jira] [Created] (HBASE-11869) Support snapshot owner

Liu Shaohui created HBASE-11869:
-----------------------------------

             Summary: Support snapshot owner
                 Key: HBASE-11869
                 URL: https://issues.apache.org/jira/browse/HBASE-11869
             Project: HBase
          Issue Type: Improvement
            Reporter: Liu Shaohui
            Assignee: Liu Shaohui
            Priority: Minor

In current codebase, the table snapshot operations only can be done by the global admin , not by  the table admin.

There is a multi-tenant hbase cluster, each table has different snapshot policies, eg: do snapshot per
week, or snapshot after the new data are imported. 
We want to release the snapshot permission to each table admin.

According to [~mbertozzi]'s suggestion, we implement the snapshot own feature.

* The user with table admin permission can create snapshot and the owner of this snapshot is this user.
* The owner of snapshot can delete and restore the snapshot.
* Only the user with global admin permission can clone a snapshot, for this operation creates a new table.

--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


Gmane