Jan Schneider | 19 Mar 14:35 2007

MIMP H3 (1.0.1) (final)

The Horde Team is pleased to announce the final release of the MIMP Webmail
Client version H3 (1.0.1).

MIMP (Mobile IMP) is a project to create a version of IMP suitable for mobile
devices such as WAP phones or PDAs. Basic IMP functionality is implemented
including mailbox viewing and paging, viewing messages, deleting, replying,
forwarding, and composing new messages.

Major changes compared to the MIMP version H3 (1.0) are:
    * Added Catalan, Dutch and Portuguese translations.
    * Updated Finnish and German translations.

The full list of changes (from version H3 (1.0)) can be viewed here:

http://cvs.horde.org/diff.php/mimp/docs/CHANGES?r1=1.46.2.1&r2=1.46.2.6&ty=h

The MIMP H3 (1.0.1) distribution is available from the following locations:

    ftp://ftp.horde.org/pub/mimp/mimp-h3-1.0.1.tar.gz
    http://ftp.horde.org/pub/mimp/mimp-h3-1.0.1.tar.gz

Patches against version H3 (1.0) are available at:

    ftp://ftp.horde.org/pub/mimp/patches/patch-mimp-h3-1.0-h3-1.0.1.gz
    http://ftp.horde.org/pub/mimp/patches/patch-mimp-h3-1.0-h3-1.0.1.gz

Or, for quicker access, download from your nearest mirror:

    http://www.horde.org/mirrors.php

(Continue reading)

Markus Krause | 26 Oct 22:01 2006
Picon

no read permissions for mimp

hi all,

i am setting up several latest horde modules for evaluation, one of it  
is mimp. for several days it worked perfect, but now i got the  
following error message in the horde.log file:

HORDE [notice] [mimp] Login success for krause [84.56.31.142] to  
{localhost:5143} [on line 89 of "/srv/www/horde/mimp/redirect.php"]
Oct 26 20:53:54 HORDE [debug] [] SQL Query by  
DataTree_sql::_buildParentIds(): SELECT datatree_id, datatree_parents  
FROM horde_datatree WHERE datatree_name = ? AND group_uid = ? ORDER BY  
datatree_id [on line 261 of "/srv/www/horde/lib/Horde/DataTree/sql.php"]
Oct 26 20:53:54 HORDE [debug] [] SQL Query by DataTree_sql::_load():  
SELECT c.datatree_id, c.datatree_name, c.datatree_parents,  
c.datatree_order FROM horde_datatree c WHERE c.group_uid =  
'horde.perms'  [on line 130 of  
"/srv/www/horde/lib/Horde/DataTree/sql.php"]
Oct 26 20:53:54 HORDE [debug] [] User  does not have READ permission  
for mimp [on line 770 of "/srv/www/horde/lib/Horde/Registry.php"]

i tried to login as admin user, so i did not expect to have no  
permissions ... futhermore it work a few days ago, in the mean time i  
changed different things in the horde installation but actually  
nothing connected to mimp (as far as i know, which, of course may be  
wrong ;-)).

where do i set permissions for mimp? in the menu administration ->  
permissions i can only see gollem.

thanks in advance for any hints!
(Continue reading)

Volker Then | 23 Oct 16:28 2006

mimp-HEAD redirects to IMP after login

Hi folks,

I changed Horde's authentication driver from "composite" to pure LDAP,  
since mimp no longer needs this configuration (see  
http://wiki.horde.org/MIMPHowTo).

After a login with Opera Mini the correct welcome screen appears. But  
when clicking on the "Mobile Mail" link I'm redirected to imp's inbox  
screen instead of mimp.

Should this be submitted to bugs.horde.org?

Bye

Volker

--

-- 
mimp mailing list - Join the hunt: http://horde.org/bounties/#mimp
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: mimp-unsubscribe <at> lists.horde.org

Volker Then | 23 Oct 16:10 2006

mimp-HEAD cannot send messages

Hi,

mimp does not send composed messages anymore. Clicking on the "Send"  
button reloads the compose screen instead of sending the message.

(I'm using the latest HEAD version (horde, imp, turba, mimp) and LDAP  
as authentication and preferences backend.)

Any idea?

Thanks.

Volker

--

-- 
mimp mailing list - Join the hunt: http://horde.org/bounties/#mimp
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: mimp-unsubscribe <at> lists.horde.org

Markus Krause | 19 Oct 13:43 2006
Picon

options->mobil mail shows mimp login

Hi all,

i set up MIMP H3 1.0 with current Horde (and some other modules), also  
configured
login in horde/config/conf.php as suggested in  
http://wiki.horde.org/MIMPHowTo, which works fine.

But logging in using a standard non-mobile browser and selecting  
"Options -> Mobile Mail" just leeds me to the MIMP login page  
(starting with "Welcome to Mobile Mail") and prompting for username  
and password. After entering the values, i only see the inbox, no  
options.

Ticket 1636 (http://bugs.horde.org/ticket/?id=1636) states that the  
extra login is still unsolved (with which i could live somehow) but i  
do not get to the page to set mimp options and did not find a ticket  
for this.

Any suggestions for solving this are appreciated!

Thanks!
    Markus

--

-- 
Markus Krause                                   email: krause <at> biochem.mpg.de
Mogli-Soft: Support for Mac OS X, Webmail/Horde, LDAP, RADIUS
by order of the Computing Center of the Max-Planck-Institute of Biochemistry
Tel.: 089 - 89 40 85 99                         Fax.: 089 - 89 40 85 98

----------------------------------------------------------------------
(Continue reading)

Massimiliano Rossi | 18 Oct 12:57 2006
Picon

MIMP problem

Dear all,

I have a horde installation with
horde, imp, turba, kronolith, ingo
and all run fine.
The user authentication is throught imp.
I put mimp in my configuration:
I put the change present in wiki in horde/config/conf.php.
I'm configuring mimp with web interface.
The problem is:
with my qtek 9090, if I use "pocket internet explorer" I can't login in mimp
but if i use "pocket opera" I log in without problem.
Thanks in advance.

Best Regards

--

-- 
mimp mailing list - Join the hunt: http://horde.org/bounties/#mimp
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: mimp-unsubscribe <at> lists.horde.org

John H. Bennett III | 11 Oct 05:42 2006

login errors with mimp 1.0

Hello,

I am running the current stable versions of Horde and am trying to get mimp
to run.  Whenever I log into mimp, I get these errors in my log.

Oct 10 22:36:32 www HORDE[5862]: [mimp] Login success for user1 <at> testing.com
[10.10.10.125] to {localhost:143} [on line 89 of
"/home/httpd/html/horde/mimp/redirect.php"]
Oct 10 22:36:32 www HORDE[5862]: PHP Warning:  fwrite(): 74 is not a valid
stream resource in /home/httpd/html/horde/mimp/lib/IMAP/Client.php on line
172
Oct 10 22:36:32 www HORDE[5862]: PHP Warning:  fgets(): 74 is not a valid
stream resource in /home/httpd/html/horde/mimp/lib/IMAP/Client.php on line
225
Oct 10 22:36:32 www HORDE[5862]: PHP Notice:  Undefined offset:  1 in
/home/httpd/html/horde/mimp/lib/IMAP/Client.php on line 256
Oct 10 22:36:32 www HORDE[5862]: PHP Warning:  fclose(): 74 is not a valid
stream resource in /home/httpd/html/horde/mimp/lib/IMAP/Client.php on line
495

I"ve tried updating my Pear modules and searching the 'net, but couldn't
find a solution.  I would appreciate any help.  If I need to give more
information, please let me know what you need.

Thanks,

John Bennett

--

-- 
mimp mailing list - Join the hunt: http://horde.org/bounties/#mimp
(Continue reading)

Manuel Rodríguez Salgado | 18 Sep 14:37 2006
Picon

Auth to mimp

Hi,

i have installed mimp 1.0 with horde 3.1.1 and IMP 4.1.1. I have the
authentication default with imp and i want to access directly, with a
URL to mimp for authenticate my users. How can i do it ??

I have tested the "MIMP HowTo" but it not run correctly with several
browser mobile.

thanks for your help.
--

-- 
mimp mailing list - Join the hunt: http://horde.org/bounties/#mimp
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: mimp-unsubscribe <at> lists.horde.org

Alex Kuretz | 23 Aug 15:40 2006

Duplicate paths in Login and Delete URLs

Hello,

I'm new to Horde/Imp/Mimp, but have them all mostly working quite well on my server. Thanks to all the
developers that put their time into this product, I'm enjoying it so far.

The issue I'm seeing, is that duplicate paths appear when I log into Mimp and when I delete a message, 
resulting in 404 errors. The URL looks like this:
http://www.server.com/horde/index.php?url=http%3A%2F%2Fwww.server.com%2Fhorde%2Fmimp%2Findex.php%2Fhorde%2Fmimp%2Findex.php%3Fnocache%3D5310v7zf1jsw

Notice the "?url=http://www.server.com/horde/mimp/index.php/horde/mimp/index.php" redundant
path? I only see this when initially logging in, and when deleting (or undeleting) messages. I am able to
view, reply, and compose messages successfully. I see this behavior both in IE and on my Motorola e816
phone running the Novarra browser.

The closest bug I see might be #1634. Has anyone else seen this behavior?

I am using the composite authentication driver with a browser switch, as described in the wiki.

Thanks,
Alex

--

-- 
mimp mailing list - Join the hunt: http://horde.org/bounties/#mimp
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: mimp-unsubscribe <at> lists.horde.org

Eligijus Rackauskas | 3 Aug 11:08 2006
Picon

MIMP doesn't work properly

Hi, 

I have some problems with MIMP:    MIMP do not work with smart phones.

I installed 
  a.. Horde: 3.1.1 
  b.. Imp: H3 (4.1.1) 
  c.. Mimp: H3 (1.0-cvs) 
IMP works fine.

MIMP works only with browsers fine, but I can't check mailbox from smart phones or from WAP emulator
(tagtag.com). 
With smart phone or with WAP emulator I can open only MIMP's login screen. When I try to login, emulator
writes "Invalid WML code".

Horde error_log show warnings (when I use WAP emulator):

fwrite(): 89 is not a valid stream resource in /mimp/lib/IMAP/Client.php on line 172
fgets(): 89 is not a valid stream resource in /mimp/lib/IMAP/Client.php on line 225
Undefined offset:  1 in mimp/lib/IMAP/Client.php on line 256
fclose(): 89 is not a valid stream resource in mimp/lib/IMAP/Client.php on line 495
fwrite(): 89 is not a valid stream resource in mimp/lib/IMAP/Client.php on line 172
fgets(): 89 is not a valid stream resource in mimp/lib/IMAP/Client.php on line 225
Undefined offset:  1 in mimp/lib/IMAP/Client.php on line 256
fclose(): 89 is not a valid stream resource in mimp/lib/IMAP/Client.php on line 495

Almost same errors come when I use browser...

P.S the code from http://wiki.horde.org/MIMPHowTo is added into horde config.php file. 
--

-- 
(Continue reading)

Rod Morison | 25 Jul 23:55 2006

mimp "Page cannot be displayed" on phone

I'm a longtime horde admin/user, but first time I've tried mimp. I've  
tested from a browser, and the backend servers are all setup: I can  
login and view mimp mail.

When I try to bring up the site (webmail.morison.biz/mimp) with my  
smart phone (Motorola Razor, Cingular network) the phone browser says  
"Page cannot be displayed". I see the request come into apache (access  
log appended).

I'm hoping this is an easy newbie config question...any suggestions  
are appreciated.

Rod

66.102.186.15 - - [25/Jul/2006:14:52:06 -0700] "GET /mimp/ HTTP/1.1"  
302 - "-" "MOT-V3/0E.41.C3R MIB/2.2.1 Profile/MIDP-2.0  
Configuration/CLDC-1.0 UP.Link/6.3.0.0.0"
66.102.186.15 - - [25/Jul/2006:14:52:08 -0700] "GET  
/login.php?url=%2Fmimp%2Findex.php&nosidebar=1 HTTP/1.1" 302 - "-"  
"MOT-V3/0E.41.C3R MIB/2.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.0  
UP.Link/6.3.0.0.0"
66.102.186.15 - - [25/Jul/2006:14:52:10 -0700] "GET  
/imp/login.php?url=%2Fmimp%2Findex.php HTTP/1.1" 200 7466 "-"  
"MOT-V3/0E.41.C3R MIB/2.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.0  
UP.Link/6.3.0.0.0"
66.102.186.15 - - [25/Jul/2006:14:52:14 -0700] "GET /themes/screen.css  
HTTP/1.1" 200 11071 "-" "MOT-V3/0E.41.C3R MIB/2.2.1 Profile/MIDP-2.0  
Configuration/CLDC-1.0 UP.Link/6.3.0.0.0"
66.102.186.15 - - [25/Jul/2006:14:52:14 -0700] "GET  
/themes/bluewhite/screen.css HTTP/1.1" 200 2903 "-" "MOT-V3/0E.41.C3R  
(Continue reading)


Gmane