Rob Brandt | 1 Jan 02:16 2003
Picon

Newbie installation help

Hello;

I trying to do a horde/imp installation on my own server in
preperation for a new position I am taking at an organization that
uses an older version.  My own server runs YellowDogLinux, apache,
php 4.2.2, mysql, postfix and courier-imap.  I have installed the
latest stable releases from the noarch RPMs of both Horde and IMP.
 I've run the mysql_create.sql script and the database is created.

Frankly I'm lost.  I have heard horror stories about trying to get
it installed, and I'm beginning to see why.  I'm sure it's rather
obvious when you know what you're doing, but I don't know how
Horde works and have no idea what to do with the configuration
files.  I've made an attempt at setting the preferences in
horde.php at their simplest options but when I try to access Horde
at http://myserver.com/horde/ I get an error message as:

Fatal error:  Call to undefined function:  _() in
/var/www/html/horde/templates/index/notconfigured.inc on line 4

Which isn't very descriptive.

Where do I go from here?

Rob

--

-- 
IMP mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: imp-unsubscribe <at> lists.horde.org
(Continue reading)

S.P.Vimala | 1 Jan 12:40 2003
Picon

None

Hi,
         My config  with

	horde-2.1-3
	imp-3.1-2
	kronolith-1.0-2
	turba-1.1-2
                     gives me the following problem. I had enabled imp
support for authentication and set all the horde and imp configurations in
the config directory. If i try loading test.php from ../horde/test.php and
../imp/test.php the pages are displayed correctly. But when i load

http://localserver.domain/horde  the page is displayed blank and the
source gives the following info

<b>Fatal error</b>:  Call to undefined function:  _() in
<b>/usr/local/apache/htdocs/horde/templates/index/notconfigured.inc</b> on
line <b>4</b><br />

I had compiled php with --with-gettext --with-mysql support.

      I i run anyother php scripts it runs fine but here alone i dod'nt
understand what is the problem. Can anybody give me anysuggestions?

-kellogy

--

-- 
IMP mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: imp-unsubscribe <at> lists.horde.org
(Continue reading)

René Lund Jensen | 1 Jan 16:37 2003
Picon

Re: Newbie installation help

Rob Brandt wrote:

[snip]

> Where do I go from here?
> 

[snip]

You could go to the faq:

http://www.horde.org/faq/admin/trouble/index.php#t44

... or search the list archives...
this question is about the most asked on this list.

René Jensen

--

-- 
IMP mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: imp-unsubscribe <at> lists.horde.org

Rob Brandt | 1 Jan 12:41 2003
Picon

Re: Newbie installation help

OK, got it.  At 1 am I failed to notice the "_" before the "()" in
the error message, and it now makes sense.  I'll recompile php
with gettext support.

Thanks

> Rob Brandt wrote:
>
> [snip]
>
>> Where do I go from here?
>>
>
> [snip]
>
> You could go to the faq:
>
> http://www.horde.org/faq/admin/trouble/index.php#t44
>
> ... or search the list archives...
> this question is about the most asked on this list.
>
> René Jensen

--

-- 
IMP mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: imp-unsubscribe <at> lists.horde.org

(Continue reading)

Paulo Salvado | 1 Jan 21:35 2003
Picon

Permission problems?

Hello,

I have installed horde and imp and it runs great.
Recently I added turba and am having problems
accessing the address-book. When I click on the
address-book link in imp I get a "Forbidden You don't
have permission to access /horde/turba/ on this
server." but if I add an index.php to the
end,address-book comes up. The same thing happens when
I click the mail button in the address book I get a
"Forbidden You don't have permission to access
/horde/imp/ on this server." I append the index.php to
the end and I get back to my mail box. Is this
something that horde/imp is doing or is it apache?
Thank you for helping out a noob.

Take care,
Paulo

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

--

-- 
IMP mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: imp-unsubscribe <at> lists.horde.org

(Continue reading)

Kevin G. Hammond | 1 Jan 21:49 2003

IMP/Horde usability

Much thanks goes out to Parag Godkar for his excellent post on howto
install horde/imp via RPM's on RedHat 8. Twice in the past I tried to
get imp working via tarballs to no avail. Previously I devoted a good
twenty to thirty hours trying to get the combination of horde, php,
apache, mysql to all like each other. Following Parag's post, it took me
less than an hour to get imp up and running without one glitch!!!! One
note to his post though, you still need to follow the configuration
sections of the horde and imp installs. Here is a Google link to his

post:

http://groups.google.com/groups?q=redhat+8+group:mailing.www.horde-imp&s
<http://groups.google.com/groups?q=redhat+8+group:mailing.www.horde-imp&
s> 

tart=10&hl=en&lr=&ie=UTF-8&selm=apt34k%242vt1%241%40FreeBSD.csie.NCTU.ed

u.tw&rnum=15

To the developers, for whatever reason, the installation instructions
are very complicated. I am definitely not a UNIX guru, but I am a Linux
admin. I have performed many functions from ./configure, make, make
install to disaster recovery of a live server including migrating passwd
files, mail stores, websites with data collecting cgi scripts. I prefer
RedHat out of the box solutions and RPM's to tarballs. My experience is
that most tarballs won't work out of the box, and usually 15 minutes of
google searches is required to figure out what was missing from the
documentation. This is very true for horde/imp. Take note of the above
post and consider a quick up and running howto.

(Continue reading)

Rob Brandt | 1 Jan 16:04 2003
Picon

Re: Newbie installation help

I've made much progress in getting horde installed.  Currently,
I'm stuck trying to login.  When I enter a user name and password
then click Log In, I just get returned back to the login page.  No
errors or other information.

Here's a list of what I've done, not sure what's relevent and not.

* Got fatal error on _(); recompiling php with gettext support
solved this.

* Got error message that configuration files were missing. 
Knowing this was NOT the case, I surmised a user permission
problem.  I run apache as 'nobody'.  I changed the group
permissions on these files from apache to nobody and solved the
problem.

* Got fatal error with missing phptype.  After further massaging
of horde.php, I elminated the problem with the following settings
(with passwords omitted):

$conf['auth']['driver'] = 'sql';

$conf['auth']['params'] = array();

$conf['auth']['params']['phptype'] = 'mysql';
$conf['auth']['params']['hostspec'] = 'localhost';
$conf['auth']['params']['username'] = 'horde';
$conf['auth']['params']['password'] = (omitted);
$conf['auth']['params']['database'] = 'horde';
$conf['auth']['params']['table'] = 'horde_users';
(Continue reading)

Ryan Gallagher | 2 Jan 00:21 2003

Re: Feature Request: Mark as unseen on individual message

Unfortunately, No... 

Just throwing the idea out there for posterity.

Happy new year (if it's your new year).
--Ryan

Quoting Adrian Walters <adrian <at> na.dhs.org>:

> Do you already have something like this in place on your site?
> 
> Sounds like a good idea...
> 
> Quoting Ryan Gallagher <ryan <at> studiesabroad.com>:
> 
> | How bout user based prefs to include specific features in the message view
> | (the
> | ones they commonly use) as links from the full drop-down list of actions. 
> | These
> | could be viewed sort of as "hot-clicks", and if key support is robust
> | enough,
> | even hot keys.
> | 
> | --Ryan
> | 
> | Quoting Adrian Walters <adrian <at> na.dhs.org>:
> | 
> | > First off I think IMP is an awsome product, kudos to all the work
> everyone
> | 
(Continue reading)

Joe Burks | 2 Jan 00:32 2003

Possible problem with virtual host and IMP 3.1 or Horde 2.1 or maybe with me :)

About 3 weeks ago I got IMP set up on my server and it worked flawlessly... 
until today...  It is trying to bring up the maintenance page so I can 
archive all my received email, but is generating the url for the account 
maintenance page wrong.  Here's a run down on my setup:

Apache 2.0.43, PHP 4.2.3, IMP 3.1, Horde 2.1

I created a DNS entry called webmail.wavicle.org
I created an apache virtual host entry for webmail.wavicle.org that points 
to my imp installation directory
Inside horde/config/registry.php:
   I changed the horde webroot to 'http://www.wavicle.org/horde'
   I changed the imp webroot to ''

* Note that the horde webroot is a full path.  If the horde webroot is not 
a full path, there are attempted accesses to 'webmail.wavicle.org/horde' 
which doesn't exist, this creates a problem with the style sheets at a minimum.

Again, this set up has worked, flawlessly, for weeks.  Today, I can't get 
to webmail.  After logging in, I'm getting a 404 error.  The webmail error 
log contains:

[Wed Jan 01 13:53:37 2003] [error] [client 64.166.42.132] File does not 
exist: /web/htdocs/horde/imp/http:, referer: 
http://webmail.wavicle.org/login.php?Horde=[session]

and the access log contains:

64.166.42.132 - - [01/Jan/2003:13:53:37 -0800] "GET

(Continue reading)

Jon Knepher | 2 Jan 00:54 2003

AccessKeys for widgets


I like having access keys defined for almost all the widgets.  I implemented a 
test case for the message view.  

I created a new library function to create the entire widget, allowing 
conditional reusing of the access keys for the widget.  I them modified just 
the navbar template.

If everyone likes this, I will make more patches to add accesskeys all 
over the place...  :)

Thanks.

Jon

Attachment (widget.diff): text/diff, 12 KiB

--

-- 
IMP mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: imp-unsubscribe <at> lists.horde.org

Gmane