Picon
Picon

"Standard Platform" ?

Ive been trying to use MCSim on both windows and Mac OS (Leopard), and have run in to quirks related to the compilation that prompt the following question:

What is thestandard platform that MCSim development is being done on ? Im assuming by posing this question that the build scripts and tools are all designed for a certain Linux or Unix platform and that a build will run clean on such a platform.

Ive been unsuccessful at finding good help in build MCSim for Mac OS, and am attempting to create a virtual machine running a linux distro, so that I can at least have a reference installation to refer to as I work through what it takes to build for Mac.

Thanks in advance for any help you can give me.

Tim Hansell

Henry M. Jackson Foundation

711 HPW/RHPB

2729 R St, Bldg 837

Wright-Patterson AFB, OH 45433-5707

Phone: (937) 255-4332

E-Mail: Timothy.Hansell <at> WPAFB.AF.MIL

Attachment (smime.p7s): application/x-pkcs7-signature, 7003 bytes
_______________________________________________
Help-mcsim mailing list
Help-mcsim <at> gnu.org
http://lists.gnu.org/mailman/listinfo/help-mcsim
Bill Harris | 12 May 04:12 2009

Re: Fwd: questions about MCSim

Cindy,

It's good to see another MCSim user in the Pacific Northwest!  Enjoy
your modeling!

If it's of any use, I created a quick reference card for MCSim that
includes some of its newer features.  You can find it along with a
presentation I made two and a half years ago in Portland at
http://facilitatedsystems.com/links.html#sd

As to your question, I use J (http://www.jsoftware.com/) as my scripting
language, and I've written J scripts to assemble simulation files
programmatically, run the model, and produce graphs.  That worked quite
nicely.  

For a simple example, see http://www.adaptistration.com/?p=1185.  While
that article doesn't contain the scripts, it does show the results.  For
example (as I recall), I had a script that picked percentage ranges for
the three key parameters, assembled a simulation file, ran the
simulation, and plotted and saved the table of eight graphs or the stick
plot you can see.

Bill
--

-- 
Bill Harris                      http://facilitatedsystems.com/weblog/
Facilitated Systems                              Everett, WA 98208 USA
http://facilitatedsystems.com/                  phone: +1 425 337-5541
Zhenhong Li | 14 Apr 21:26 2009
Picon

Fwd: questions about MCSim


Hello,

I am a PhD student at Oregon Health & Science University. I am using MCSim to do my modeling work for hormone
profiles in Fathead Minnows. The question I would like to ask is about "vectors". 

According to MCSim manual, vectors should be defined as <variable-name>'['<integer>']'. Can I define
the <integer> as a variable? I mean, for example, I would like to use a 'n' to replace the <integer>; then in
the first run, I define n=10 (the vector has a length of 10), and in the second run I define n=7 (the vector has
a length of 7), as so on. Then, for different runs, the length of the vector varies.

I tried several times, it seems that the present program does not accept it. Would you please give me any
suggestion? Can I modify the program a little bit to add this function in? and how? Thank you very much!

Best!

Cindy
Frederic Y. Bois | 3 Mar 09:32 2009
Picon

GNU MCSim version 5.3.1 release

Version 5.3.1 of GNU MCSim is now available from
http://www.gnu.org/software/mcsim/.
It fixes some problems with OptimalDesign();

Frederic Bois
Frédéric BOIS | 12 Jan 09:16 2009
Picon

GNU MCSim version 5.3.0 release

Version 5.3.0 of GNU MCSim is now available from
http://www.gnu.org/software/mcsim/.

Frederic Bois
Frederic Y. Bois | 8 Sep 10:10 2008
Picon

new mcsim users list : mcsim-info

A new public list "Info-mcsim" has been set up to provide general announcements
on MCSim.
Frederic Y. Bois | 25 Mar 15:02 2008
Picon

http://www.gnu.org/software/mcsim/

The official MCSim web page can now be found at 
http://www.gnu.org/software/mcsim/
The old page point to there now.

F. Bois
Frederic Bois | 3 Mar 17:53 2008
Picon

MCSim source code is now under CVS access on GNU Savannah

All the source code of MCSim is now accessible online via CVS on GNU Savannah.
You can fetch the latest code (almost!) as well as past versions.
You can also envision contributing to the project ;^)...
Just go to http://cvs.savannah.gnu.org/viewvc/mcsim/?root=mcsim
(for help go to https://savannah.gnu.org/cvs/?group=mcsim)
From now on maintenance an diffusion of the software will be made via Savannah.

F. Bois
Frederic Y. Bois | 29 Jan 16:55 2008
Picon

MCSim version 5.2.beta available

The version 5.2.beta of MCSim is now available at http://fredomatic.free.fr
This is a technical upgrade before porting to the GNU official development 
platform.
Frederic Y. Bois | 29 Nov 09:52 2007
Picon

Installation problems for libmcsim.so

From anonymous MCSim User:
Question: Installation Problem for libmcsim.so
Date: Tue, 20 Nov 2007

Hi,

I tried to install MCSim on my Red Hat Enterprise Linux WS vs.4 
(64-bit Intel EM64T) 
and kept getting the following error message:

make[1]: Entering directory `Programs/mcsim/sim'
Linking libmcsim.so...
/usr/bin/ld: /tmp/cckVUj.o: relocation R_X86_64_32 against `a local
symbol' can not be used when making a shared object; recompile with -fPIC
/tmp/cckVUj.o: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [libmcsim.so] Error 1

I edited a line in sim/Makefile by adding -fPIC to the LFLAGS line:

LFLAGS = -lgsl -lgslcblas -lm -fPIC

It did solve my problem, but when I ran further with the example 
(mcsim.perc) and got another error message: 

$ ./mcsim.perc
./mcsim.perc: error while loading shared libraries: libgsl.so.0: cannot 
open shared object file: No such file or directory

What should I do?

-----------
Answer: 

Gsl library problem: in most systems it is installed in /usr/local/lib. 

First, do you have the "-L /usr/local/lib" option set in CLFLAGS? 

Another potential cause is that you may not have registered libgsl 
and libgslcblas 
with the kernel when you installed them. One way to check is to do 
"ldd /usr/lib/libmcsim.so" (or whatever the path for libmcsim.so is). 
You should get something like:
        linux-gate.so.1 =>  (0xffffe000)
        libgsl.so.0 => /usr/local/lib/libgsl.so.0 (0x4003c000)
        libgslcblas.so.0 => /usr/local/lib/libgslcblas.so.0 (0x401a2000)
        libm.so.6 => /lib/tls/libm.so.6 (0x401d4000)
        libc.so.6 => /lib/tls/libc.so.6 (0x401f6000)
        /lib/ld-linux.so.2 (0x80000000)
You can see that it knows where to find libgsl.so. 

Another way to check is "/sbin/ldconfig -p | grep gsl". 
You should get something
like:
        libgslcblas.so.0 (libc6) => /usr/local/lib/libgslcblas.so.0
        libgslcblas.so (libc6) => /usr/local/lib/libgslcblas.so
        libgsl.so.0 (libc6) => /usr/local/lib/libgsl.so.0
        libgsl.so (libc6) => /usr/local/lib/libgsl.so
which shows that the pointers are setup ok. 

If you don't see gsl when you run "/sbin/ldconfig -p" then run 
"/sbin/ldconfig /usr/local/lib"
(see man ldconfig). 
That should update the repertory of libraries (redo "/sbin/ldconfig -p" 
to be sure).

F. Bois
Setzer.Woodrow | 18 Sep 18:04 2007
Picon

mcsim using MinGW on Windows XP


I am about to embark on compiling and setting up mcsim to use mingw on
Windows XP.  I did this a long time ago with a much earlier version of
mcsim, but I gather others have already done this with the current
version-- would you be willing to share what I need to do?
Thanks!

R. Woodrow Setzer, Ph. D.
National Center for Computational Toxicology
US Environmental Protection Agency
Mail Drop B205-01/US EPA/RTP, NC 27711
Ph: (919) 541-0128    Fax: (919) 541-1194

Gmane