Chris Sidiropoulos | 1 Jan 16:35 2008
Picon

problems with gdb

Dear Sir/Madam,

I loaded the windows version( ie windows XP)  
gnat-gpl-2007-2-pentium-mingw32msv-bin.exe. I installed it successfully. 
However, I get problems when I use the GDB to create breakpoints in my 
code.

The errors are as follows:

file c:/ada_training/lovelace/1/compute_case.exe
(gdb)
(gdb) break compute_case.adb:19
(gdb) No source file named compute_case.adb.

The Problem is , it simply can't find the source code. I also played 
around withe GDB command lines but with no success.

Please let me know if you have any hint of where I can fix or patch the 
problems above.

Best Regards

Chris Sidiropoulos
Mike Frysinger | 2 Jan 00:04 2008
Picon

Re: problems with gdb

On Tuesday 01 January 2008, Chris Sidiropoulos wrote:
> I loaded the windows version( ie windows XP)
> gnat-gpl-2007-2-pentium-mingw32msv-bin.exe.

ok, but this list is about libtool, not gdb.  please consult the gdb homepage 
to find the correct list.
http://sourceware.org/gdb
-mike
_______________________________________________
Bug-libtool mailing list
Bug-libtool <at> gnu.org
http://lists.gnu.org/mailman/listinfo/bug-libtool
Ralf Wildenhues | 2 Jan 20:20 2008
Picon
Picon

Re: lib/progname.c

[ Cc:ing bug-libtool ]

Hello Bruno, Paul, all,

* Bruno Haible wrote on Sat, Dec 29, 2007 at 05:36:01PM CET:
> Paul Eggert wrote:
> > I do have a bit of trouble reading the code, though.
> > It doesn't seem to match the comment: e.g., it strips a leading "lt-"
> > even when there's no "/.libs/".
> 
> When I look at ltmain.sh it seems that an 'lt-program' or 'lt-program.exe'
> can also be generated outside the .libs directory. But I cannot tell under
> which conditions this happens. Can some libtool guru throw some light on
> this?

Can you point to what makes it look like this, and which Libtool version?
Because I think that an lt-program* outside [._]libs/ would be a bug.
Are you hinting at this line?

      { file=\`ls -1dt \"\$progdir/\$program\" \"\$progdir/../\$program\" 2>/dev/null | ${SED} 1q\`; \\

I think that's a leftover bug made unnecessary by the changes from
1999-02-22, but I haven't looked closely yet.  ;-)

Thanks, and a Happy New Year,
Ralf

Rainer Tammer | 8 Jan 17:03 2008
Picon

Re: support AIX 6.1 in config.rpath

Hello,

Ralf Wildenhues wrote:
> Hello Rainer,
>
> please post whatever Libtool testsuite log of AIX 6.1 you have to
> <bug-libtool <at> gnu.org>.  
No problem. Is there a size limitation to the post ??
> I will look into some of the issues, but it
> is very important to have a public archive of these: that way others
> can help, too, and yet others who find the same issues can avoid
> sending a duplicate report because a web search finds this for them.
>
> If you can do another testsuite run with
>   ./configure LDFLAGS=-Wl,-brtl
>
>   
OK here are the results of the testsuite (with the pathc to 
tests/runpath-in-lalib.at):

command:

export LDFLAGS=-Wl,-brtl
export CC=cc_r
export CXX=xlC_r
gmake -k check VERBOSE=yes

restult:

## ------------------------ ##
(Continue reading)

Ralf Wildenhues | 8 Jan 21:34 2008
Picon
Picon

Re: support AIX 6.1 in config.rpath

Hello Rainer,

* Rainer Tammer wrote on Tue, Jan 08, 2008 at 05:03:30PM CET:
> Ralf Wildenhues wrote:
>>
>> please post whatever Libtool testsuite log of AIX 6.1 you have to
>> <bug-libtool <at> gnu.org>.  
> No problem. Is there a size limitation to the post ??

Yes, there is.  For large outputs, use gzip or bzip2.  In case the
message size exceeds the limit, the list moderator will act accordingly
(and yes, I will typically let your message through ;-).

>> If you can do another testsuite run with
>>   ./configure LDFLAGS=-Wl,-brtl
>>   
> OK here are the results of the testsuite (with the pathc to  
> tests/runpath-in-lalib.at):
>
> command:
>
> export LDFLAGS=-Wl,-brtl
> export CC=cc_r
> export CXX=xlC_r
> gmake -k check VERBOSE=yes

Cool, many thanks.

> ## ------------- ##
> ## Test results. ##
(Continue reading)

Rainer Tammer | 9 Jan 12:25 2008
Picon

build check in AIX 5.2 / 5.3 / 6.1

Hello,
I have checked the following libtool versions on several AIX versions:

1. branch-1.5-20080108-cvs

on AIX 5.2, 5.3, 6.1

result:

AIX 5.2 / branch-1.5 / OK
AIX 5.3 / branch-1.5 / OK
AIX 6.1 / branch-1.5 / OK

2. HEAD-20080108-cvs

on AIX 5.3, 6.1

result:

AIX 5.3 / HEAD / testsuite OK, FAIL: tests/mdemo-exec.test (3 times)
AIX 6.1 / HEAD / testsuite OK, FAIL: tests/mdemo-exec.test (3 times)

The detailed test results are in the attached archive.

All test were conducted with IBM C/C++ compilers.

If you like me to perforce some tests with gcc then I can try that too..

Bye
  Rainer
(Continue reading)

Ralf Wildenhues | 9 Jan 20:52 2008
Picon
Picon

Re: build check in AIX 5.2 / 5.3 / 6.1

Hello Rainer,

* Rainer Tammer wrote on Wed, Jan 09, 2008 at 12:25:03PM CET:
> I have checked the following libtool versions on several AIX versions:
>
> 1. branch-1.5-20080108-cvs
>
> on AIX 5.2, 5.3, 6.1
>
> result:
>
> AIX 5.2 / branch-1.5 / OK
> AIX 5.3 / branch-1.5 / OK
> AIX 6.1 / branch-1.5 / OK
>
> 2. HEAD-20080108-cvs
>
> on AIX 5.3, 6.1
>
> result:
>
> AIX 5.3 / HEAD / testsuite OK, FAIL: tests/mdemo-exec.test (3 times)
> AIX 6.1 / HEAD / testsuite OK, FAIL: tests/mdemo-exec.test (3 times)
>
>
> The detailed test results are in the attached archive.
>
> All test were conducted with IBM C/C++ compilers.

And all tests were done with runtimelinking enabled (-brtl).  It'd be
(Continue reading)

Ralf Wildenhues | 9 Jan 20:54 2008
Picon
Picon

Re: build check in AIX 5.2 / 5.3 / 6.1

* Rainer Tammer wrote on Wed, Jan 09, 2008 at 12:25:03PM CET:
[ branch-1.5-20080108-cvs/check.log ]
> creating libmlib.la (cd .libs && rm -f libmlib.la && ln -s ../libmlib.la libmlib.la) cc_r
-qlanglvl=extc89 -DPACKAGE_NAME=\"mdemo\" -DPACKAGE_TARNAME=\"mdemo\"
-DPACKAGE_VERSION=\"0.1\" -DPACKAGE_STRING=\"mdemo\ 0.1\"
-DPACKAGE_BUGREPORT=\"bug-libtool <at> gnu.org\" -DPACKAGE=\"mdemo\" -DVERSION=\"0.1\"
-DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1
-DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1
-DHAVE_DLFCN_H=1 -DHAVE_MATH_H=1 -I. -I./../libltdl    -g -c main.c
> "main.c", line 195.7: 1506-068 (W) Operation between types "char*" and "int" is not allowed.

While we're at it, let's fix that buglet, and a couple of other ones I
found.  Applied to branch-1-5 (HEAD is fixed already).

Cheers,
Ralf

2008-01-09  Ralf Wildenhues  <Ralf.Wildenhues <at> gmx.de>

	* mdemo/main.c: Include string.h, for strrchr.
	Report by Rainer Tammer.
	* f77demo/cprogram.c: Include stdio.h, for printf.
	* f77demo/fooc.c: Likewise.

Index: f77demo/cprogram.c
===================================================================
RCS file: /cvsroot/libtool/libtool/f77demo/Attic/cprogram.c,v
retrieving revision 1.1.2.1
diff -u -r1.1.2.1 cprogram.c
--- f77demo/cprogram.c	22 Apr 2005 09:05:43 -0000	1.1.2.1
(Continue reading)

Rainer Tammer | 10 Jan 08:51 2008
Picon

Re: build check in AIX 5.2 / 5.3 / 6.1

Hello,

Ralf Wildenhues wrote:
> Hello Rainer,
>
> * Rainer Tammer wrote on Wed, Jan 09, 2008 at 12:25:03PM CET:
>   
>> I have checked the following libtool versions on several AIX versions:
>>
>> 1. branch-1.5-20080108-cvs
>>
>> on AIX 5.2, 5.3, 6.1
>>
>> result:
>>
>> AIX 5.2 / branch-1.5 / OK
>> AIX 5.3 / branch-1.5 / OK
>> AIX 6.1 / branch-1.5 / OK
>>
>> 2. HEAD-20080108-cvs
>>
>> on AIX 5.3, 6.1
>>
>> result:
>>
>> AIX 5.3 / HEAD / testsuite OK, FAIL: tests/mdemo-exec.test (3 times)
>> AIX 6.1 / HEAD / testsuite OK, FAIL: tests/mdemo-exec.test (3 times)
>>
>>
>> The detailed test results are in the attached archive.
(Continue reading)

Rainer Tammer | 10 Jan 09:39 2008
Picon

Re: build check in AIX 5.2 / 5.3 / 6.1 - gcc/g++

Hello Ralf,

>> If you like me to perforce some tests with gcc then I can try that too..
>>     
>
> Yes, that would be great.  The systems I test on currently don't have
> g++ or gfortran (or gcj) installed, so if you could test
>   ./configure CC=gcc CXX=g++ FC=gfortran F77=gfortran
>
>   
branch-1.5
=======

With gcc 4.0.0 I need to include:

libltdl/ltdl.c
#include <sys/access.h>

R_OK is undefined

gmake[2]: Entering directory 
`/daten/source/libtool/libtool-1.5.24a-cvs-gcc/libltdl'
/bin/sh ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.     
-g -O2 -c -o ltdl.lo ltdl.c
 gcc -DHAVE_CONFIG_H -I. -g -O2 -c ltdl.c  -DPIC -o .libs/ltdl.o
ltdl.c: In function 'find_handle_callback':
ltdl.c:2808: error: 'R_OK' undeclared (first use in this function)
ltdl.c:2808: error: (Each undeclared identifier is reported only once
ltdl.c:2808: error: for each function it appears in.)

(Continue reading)


Gmane