Dick Porter | 2 Jun 12:22 2010

Patch for bug 464464

Hi all

A while ago I added a patch to bugzilla
(https://bugzilla.novell.com/show_bug.cgi?id=464464) to fix the issue
with underscores in text boxes.  Is there any chance it can be committed
for 2.6?

- Dick

_______________________________________________
Mono-winforms-list maillist  -  Mono-winforms-list <at> lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-winforms-list

Paul | 6 Jun 12:05 2010
Picon

RichTextBox problem

Hi,

Bit of an odd one here which I'm not sure if it's a mono issue, a .NET
issue or a problem with OOo exporting RTF.

If I create a file in OpenOffice and save out as RTF, I can load it
happily into a RichTextBox and the fonts, font size and colours are
quite happily kept.

If I create a formula in OOo equation editor and save that out as an
RTF, this will load into the RichTextBox, but nothing shows up. Is this
a limitation in RichTextBox or an issue with OOo which needs to be
reported? I've not tried to export a formula from Word.

TTFN

Paul
--

-- 
Biggles was quietly reading his favourite book when Algy burst through
the door. Distracted for a moment, Biggles surveyed what had happened
and turned a page. "Algy old man" he said, clearing his throat, "use the
handle next time..." - Taken from "Biggles combs his Hair"
_______________________________________________
Mono-winforms-list maillist  -  Mono-winforms-list <at> lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-winforms-list
nodoid | 7 Jun 00:21 2010
Picon

Not sure if this is a mono issue, openoffice issue or is just not going to work!


Hi,

I have a RichTextBox. If I create a file in OpenOffice and save it out as
RTF, it imports happily into the control, with all of the fonts and sizes
and colours and justifications completely intact.

However, if I create an equation using the OOo Equation editor and export
that, it isn't imported or if it is, doesn't show.

Is this a problem with OOo RTF output, the RichTextBox, mono or is it
designed not to take it? If it's an OOo problem, could someone with Word try
and create a formula, export as RTF and bring it into a RichTextBox? I can
then eliminate .NET and file a BZ against OOo.

TTFN

Paul
--

-- 
View this message in context: http://mono.1490590.n4.nabble.com/Not-sure-if-this-is-a-mono-issue-openoffice-issue-or-is-just-not-going-to-work-tp2245322p2245322.html
Sent from the Mono - WinForms mailing list archive at Nabble.com.
_______________________________________________
Mono-winforms-list maillist  -  Mono-winforms-list <at> lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-winforms-list

Andy Theuninck | 7 Jun 21:31 2010
Picon

Having trouble finding adequate documentation

Is there any better documentation out there than this (ideally a
serachable one...)?
http://www.go-mono.com/docs/

I'm trying to port a Windows .NET app to mono. It compiles but I'm
getting weird run time bugs. For instance, right now I'm getting
incorrect values from WebBrowser.Document.Window.Frames. However, the
above documentation doesn't seem to give any info on Mono's
implementation of WebBrowser or HtmlDocument or HtmlWindow.

I understand that not every part of winforms is implemented, but is
there a reference anywhere stating what does and does not work?
_______________________________________________
Mono-winforms-list maillist  -  Mono-winforms-list <at> lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-winforms-list

pfj | 8 Jun 14:25 2010
Picon

Re: Not sure if this is a mono issue, openoffice issue or is just not going to work!


Hi,

Looks like OOo is to blame here. Wrote the same equation using Word2003,
export as RTF and up it pops...

Have to put that into BZ...

TTFN

Paul
--

-- 
View this message in context: http://mono.1490590.n4.nabble.com/Not-sure-if-this-is-a-mono-issue-openoffice-issue-or-is-just-not-going-to-work-tp2245322p2247292.html
Sent from the Mono - WinForms mailing list archive at Nabble.com.
_______________________________________________
Mono-winforms-list maillist  -  Mono-winforms-list <at> lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-winforms-list

Rafael Teixeira | 8 Jun 16:21 2010
Picon

Re: Having trouble finding adequate documentation

For what is implemented or not you can check the Class Status Pages:
http://go-mono.com/status/
Bear in mind that Mono's WebBrowser implementation is based on
Gecko(Firefox) and someday Webkit(Chrome), so it's internal may differ
a lot from MS's which wraps IE.

Hope it helps,

Rafael "Monoman" Teixeira
---------------------------------------
"To be creative means to be in love with life. You can be creative
only if you love life enough that you want to enhance its beauty, you
want to bring a little more music to it, a little more poetry to it, a
little more dance to it."
Osho

On Mon, Jun 7, 2010 at 4:31 PM, Andy Theuninck <gohanman <at> gmail.com> wrote:
> Is there any better documentation out there than this (ideally a
> serachable one...)?
> http://www.go-mono.com/docs/
>
> I'm trying to port a Windows .NET app to mono. It compiles but I'm
> getting weird run time bugs. For instance, right now I'm getting
> incorrect values from WebBrowser.Document.Window.Frames. However, the
> above documentation doesn't seem to give any info on Mono's
> implementation of WebBrowser or HtmlDocument or HtmlWindow.
>
> I understand that not every part of winforms is implemented, but is
> there a reference anywhere stating what does and does not work?
> _______________________________________________
(Continue reading)

Andy Theuninck | 8 Jun 16:29 2010
Picon

Re: Having trouble finding adequate documentation

Thanks, that's very much what I'm looking for. If all the requisite
classes are listed there and the properties I'm accessing all have
checkmarks, yet the values I'm getting are wrong, would it be fair to
say I have to dig into libgluezilla or webkit-sharp to fix the
problem?

On Tue, Jun 8, 2010 at 9:21 AM, Rafael Teixeira <monoman <at> gmail.com> wrote:
> For what is implemented or not you can check the Class Status Pages:
> http://go-mono.com/status/
> Bear in mind that Mono's WebBrowser implementation is based on
> Gecko(Firefox) and someday Webkit(Chrome), so it's internal may differ
> a lot from MS's which wraps IE.
>
> Hope it helps,
>
> Rafael "Monoman" Teixeira
> ---------------------------------------
> "To be creative means to be in love with life. You can be creative
> only if you love life enough that you want to enhance its beauty, you
> want to bring a little more music to it, a little more poetry to it, a
> little more dance to it."
> Osho
>
>
>
> On Mon, Jun 7, 2010 at 4:31 PM, Andy Theuninck <gohanman <at> gmail.com> wrote:
>> Is there any better documentation out there than this (ideally a
>> serachable one...)?
>> http://www.go-mono.com/docs/
>>
(Continue reading)

Rafael Teixeira | 8 Jun 16:56 2010
Picon

Re: Having trouble finding adequate documentation

Or simply open a bug case, with the shortest code that may reproduce
the problem. But going deeper and sending patches, make progress go
faster and benefit all.

Thanks,

Rafael "Monoman" Teixeira
---------------------------------------
"To be creative means to be in love with life. You can be creative
only if you love life enough that you want to enhance its beauty, you
want to bring a little more music to it, a little more poetry to it, a
little more dance to it."
Osho

On Tue, Jun 8, 2010 at 11:29 AM, Andy Theuninck <gohanman <at> gmail.com> wrote:
> Thanks, that's very much what I'm looking for. If all the requisite
> classes are listed there and the properties I'm accessing all have
> checkmarks, yet the values I'm getting are wrong, would it be fair to
> say I have to dig into libgluezilla or webkit-sharp to fix the
> problem?
>
> On Tue, Jun 8, 2010 at 9:21 AM, Rafael Teixeira <monoman <at> gmail.com> wrote:
>> For what is implemented or not you can check the Class Status Pages:
>> http://go-mono.com/status/
>> Bear in mind that Mono's WebBrowser implementation is based on
>> Gecko(Firefox) and someday Webkit(Chrome), so it's internal may differ
>> a lot from MS's which wraps IE.
>>
>> Hope it helps,
>>
(Continue reading)

fulano2040 | 9 Jun 21:20 2010
Picon

RichTextBox = Problems!!!


Ok the first problem that I found was that the selection made with the mouse
doesn't update the selection lenght variable so if one tries to get the
current selected font or color it just returns null
I found that there are several references to this variable but not that much
so I just got rid of all the references to this var and instead used
SelectionLength method and it worked.

Now I'm having formatting issues.
I trying to fix this issues but its kind of hard doing it because I don't
really understand the desing behind the RTB and text controls

One example is that there are empty tags that are useful to set formating
properties when no text is selected but for me this is useless because
theres is a caret tag and the format should be applied to the caret if
nothing is selected and when something is typed it should inherit the
caret's current format.
If the caret is move it should get the current position format.
In this way the memory usage is improved and less code is needed reducing
the desing complexity

Its been a couple of weeks since I'm trying to understand the design. I hope
someone here could shed some light about this and at the end we will end up
with a bug free RTB

I also found that  RTB's code coverage is not very good because all the test
pass with out errors even with this issues.
--

-- 
View this message in context: http://mono.1490590.n4.nabble.com/RichTextBox-Problems-tp2249359p2249359.html
Sent from the Mono - WinForms mailing list archive at Nabble.com.
(Continue reading)

Eric Schaefer | 11 Jun 08:12 2010

Default Menu Font

Hi List,

is it possible to configure the default winforms font for menus? The
current font on my system (ubuntu 10.04) does not support german
umlauts. I changed the forms default font for the form content
(this.Font) but that does not affect the menu font.

Regards,
Eric
_______________________________________________
Mono-winforms-list maillist  -  Mono-winforms-list <at> lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-winforms-list


Gmane